Add a few patches that were in f16 but not in rawhide
This commit is contained in:
parent
8ffa0afd4c
commit
bc12142e94
11
block-stray-block-put-after-teardown.patch
Normal file
11
block-stray-block-put-after-teardown.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- linux-2.6.39.noarch/block/elevator.c~ 2011-08-09 10:07:41.532774872 -0400
|
||||||
|
+++ linux-2.6.39.noarch/block/elevator.c 2011-08-09 10:07:56.131724173 -0400
|
||||||
|
@@ -815,7 +815,7 @@ void elv_completed_request(struct reques
|
||||||
|
*/
|
||||||
|
if (blk_account_rq(rq)) {
|
||||||
|
q->in_flight[rq_is_sync(rq)]--;
|
||||||
|
- if ((rq->cmd_flags & REQ_SORTED) &&
|
||||||
|
+ if ((rq->cmd_flags & REQ_SORTED) && e->ops &&
|
||||||
|
e->ops->elevator_completed_req_fn)
|
||||||
|
e->ops->elevator_completed_req_fn(q, rq);
|
||||||
|
}
|
22
efi-dont-map-boot-services-on-32bit.patch
Normal file
22
efi-dont-map-boot-services-on-32bit.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff --git a/arch/x86/platform/efi/efi.c b/arch/x86/platform/efi/efi.c
|
||||||
|
index 3ae4128..ff7dc70 100644
|
||||||
|
--- a/arch/x86/platform/efi/efi.c
|
||||||
|
+++ b/arch/x86/platform/efi/efi.c
|
||||||
|
@@ -659,10 +659,13 @@ void __init efi_enter_virtual_mode(void)
|
||||||
|
|
||||||
|
for (p = memmap.map; p < memmap.map_end; p += memmap.desc_size) {
|
||||||
|
md = p;
|
||||||
|
- if (!(md->attribute & EFI_MEMORY_RUNTIME) &&
|
||||||
|
- md->type != EFI_BOOT_SERVICES_CODE &&
|
||||||
|
- md->type != EFI_BOOT_SERVICES_DATA)
|
||||||
|
- continue;
|
||||||
|
+ if (!(md->attribute & EFI_MEMORY_RUNTIME)) {
|
||||||
|
+#ifdef CONFIG_X86_64
|
||||||
|
+ if (md->type != EFI_BOOT_SERVICES_CODE &&
|
||||||
|
+ md->type != EFI_BOOT_SERVICES_DATA)
|
||||||
|
+#endif
|
||||||
|
+ continue;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
size = md->num_pages << EFI_PAGE_SHIFT;
|
||||||
|
end = md->phys_addr + size;
|
12
kernel.spec
12
kernel.spec
@ -650,6 +650,7 @@ Patch800: linux-2.6-crash-driver.patch
|
|||||||
|
|
||||||
# virt + ksm patches
|
# virt + ksm patches
|
||||||
Patch1555: fix_xen_guest_on_old_EC2.patch
|
Patch1555: fix_xen_guest_on_old_EC2.patch
|
||||||
|
Patch1556: xen-blkfront-name-adjust.patch
|
||||||
|
|
||||||
# DRM
|
# DRM
|
||||||
|
|
||||||
@ -687,6 +688,9 @@ Patch12022: fix-cdc-ncm-dma-stack-vars.patch
|
|||||||
Patch12023: ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
Patch12023: ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
||||||
Patch12024: epoll-fix-spurious-lockdep-warnings.patch
|
Patch12024: epoll-fix-spurious-lockdep-warnings.patch
|
||||||
Patch12025: rcu-avoid-just-onlined-cpu-resched.patch
|
Patch12025: rcu-avoid-just-onlined-cpu-resched.patch
|
||||||
|
Patch12026: block-stray-block-put-after-teardown.patch
|
||||||
|
Patch12027: usb-add-quirk-for-logitech-webcams.patch
|
||||||
|
|
||||||
|
|
||||||
# Runtime power management
|
# Runtime power management
|
||||||
Patch12203: linux-2.6-usb-pci-autosuspend.patch
|
Patch12203: linux-2.6-usb-pci-autosuspend.patch
|
||||||
@ -695,6 +699,8 @@ Patch12205: runtime_pm_fixups.patch
|
|||||||
|
|
||||||
Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
||||||
|
|
||||||
|
Patch13003: efi-dont-map-boot-services-on-32bit.patch
|
||||||
|
|
||||||
Patch20000: utrace.patch
|
Patch20000: utrace.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1233,6 +1239,7 @@ ApplyPatch linux-2.6-e1000-ich9-montevina.patch
|
|||||||
|
|
||||||
# Assorted Virt Fixes
|
# Assorted Virt Fixes
|
||||||
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
||||||
|
ApplyPatch xen-blkfront-name-adjust.patch
|
||||||
|
|
||||||
# DRM core
|
# DRM core
|
||||||
|
|
||||||
@ -1264,6 +1271,8 @@ ApplyPatch fix-cdc-ncm-dma-stack-vars.patch
|
|||||||
ApplyPatch ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
ApplyPatch ums-realtek-driver-uses-stack-memory-for-DMA.patch
|
||||||
ApplyPatch epoll-fix-spurious-lockdep-warnings.patch
|
ApplyPatch epoll-fix-spurious-lockdep-warnings.patch
|
||||||
ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
||||||
|
ApplyPatch block-stray-block-put-after-teardown.patch
|
||||||
|
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
||||||
|
|
||||||
# Runtime PM
|
# Runtime PM
|
||||||
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
||||||
@ -1274,6 +1283,8 @@ ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
|||||||
# rhbz#605888
|
# rhbz#605888
|
||||||
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
||||||
|
|
||||||
|
ApplyPatch efi-dont-map-boot-services-on-32bit.patch
|
||||||
|
|
||||||
# utrace.
|
# utrace.
|
||||||
ApplyPatch utrace.patch
|
ApplyPatch utrace.patch
|
||||||
|
|
||||||
@ -1902,6 +1913,7 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Tue Aug 16 2011 Josh Boyer <jwboyer@redhat.com>
|
* Tue Aug 16 2011 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Bring ARM config changes from David Marlin forward
|
- Bring ARM config changes from David Marlin forward
|
||||||
|
- Sync a handful of patches from f16
|
||||||
|
|
||||||
* Mon Aug 15 2011 Josh Boyer <jwboyer@redhat.com>
|
* Mon Aug 15 2011 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Linux-3.1-rc2
|
- Linux-3.1-rc2
|
||||||
|
30
usb-add-quirk-for-logitech-webcams.patch
Normal file
30
usb-add-quirk-for-logitech-webcams.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
commit a218e3649310bd2ee0e8b7ec6353ab029d020289
|
||||||
|
Author: Oliver Neukum <oliver@neukum.org>
|
||||||
|
Date: Tue Aug 9 08:12:37 2011 -0400
|
||||||
|
|
||||||
|
USB: quirk for Logitech C250, C270, and C310 webcams
|
||||||
|
|
||||||
|
This need for this was shown by the new PM code
|
||||||
|
|
||||||
|
Signed-off-by: Oliver Neukum <oneukum@suse.de>
|
||||||
|
|
||||||
|
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
|
||||||
|
index 81ce6a8..5114281 100644
|
||||||
|
--- a/drivers/usb/core/quirks.c
|
||||||
|
+++ b/drivers/usb/core/quirks.c
|
||||||
|
@@ -41,6 +41,15 @@ static const struct usb_device_id usb_quirk_list[] = {
|
||||||
|
/* Logitech Harmony 700-series */
|
||||||
|
{ USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },
|
||||||
|
|
||||||
|
+ /* Logitech Webcam C250 */
|
||||||
|
+ { USB_DEVICE(0x046d, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
|
+
|
||||||
|
+ /* Logitech Webcam C310 */
|
||||||
|
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
|
+
|
||||||
|
+ /* Logitech Webcam C270 */
|
||||||
|
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
|
+
|
||||||
|
/* Philips PSC805 audio device */
|
||||||
|
{ USB_DEVICE(0x0471, 0x0155), .driver_info = USB_QUIRK_RESET_RESUME },
|
||||||
|
|
30
xen-blkfront-name-adjust.patch
Normal file
30
xen-blkfront-name-adjust.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
commit 196cfe2ae8fcdc03b3c7d627e7dfe8c0ce7229f9
|
||||||
|
Author: Stefan Bader <stefan.bader@canonical.com>
|
||||||
|
Date: Thu Jul 14 15:30:22 2011 +0200
|
||||||
|
|
||||||
|
xen-blkfront: Drop name and minor adjustments for emulated scsi devices
|
||||||
|
|
||||||
|
These were intended to avoid the namespace clash when representing
|
||||||
|
emulated IDE and SCSI devices. However that seems to confuse users
|
||||||
|
more than expected (a disk defined as sda becomes xvde).
|
||||||
|
So for now go back to the scheme which does no adjustments. This
|
||||||
|
will break when mixing IDE and SCSI names in the configuration of
|
||||||
|
guests but should be by now expected.
|
||||||
|
|
||||||
|
Acked-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
|
||||||
|
Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
|
||||||
|
Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
|
||||||
|
|
||||||
|
--- linux-2.6.39.noarch/drivers/block/xen-blkfront.c~ 2011-08-11 11:54:25.656150889 -0400
|
||||||
|
+++ linux-2.6.39.noarch/drivers/block/xen-blkfront.c 2011-08-11 11:54:54.573046334 -0400
|
||||||
|
@@ -123,8 +123,8 @@ static DEFINE_SPINLOCK(minor_lock);
|
||||||
|
#define BLKIF_MINOR_EXT(dev) ((dev)&(~EXTENDED))
|
||||||
|
#define EMULATED_HD_DISK_MINOR_OFFSET (0)
|
||||||
|
#define EMULATED_HD_DISK_NAME_OFFSET (EMULATED_HD_DISK_MINOR_OFFSET / 256)
|
||||||
|
-#define EMULATED_SD_DISK_MINOR_OFFSET (EMULATED_HD_DISK_MINOR_OFFSET + (4 * 16))
|
||||||
|
-#define EMULATED_SD_DISK_NAME_OFFSET (EMULATED_HD_DISK_NAME_OFFSET + 4)
|
||||||
|
+#define EMULATED_SD_DISK_MINOR_OFFSET (0)
|
||||||
|
+#define EMULATED_SD_DISK_NAME_OFFSET (EMULATED_SD_DISK_MINOR_OFFSET / 256)
|
||||||
|
|
||||||
|
#define DEV_NAME "xvd" /* name in /dev */
|
||||||
|
|
Loading…
Reference in New Issue
Block a user