add patch to fix UDOO boot hang
This commit is contained in:
parent
c2f4ac7cf6
commit
b98ae2eee3
@ -0,0 +1,41 @@
|
||||
From patchwork Thu Jan 18 12:34:18 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: ARM: dts: imx6qdl-udoo: Disable usbh1 to avoid kernel hang
|
||||
From: Fabio Estevam <fabio.estevam@nxp.com>
|
||||
X-Patchwork-Id: 10173115
|
||||
Message-Id: <1516278858-15464-1-git-send-email-fabio.estevam@nxp.com>
|
||||
To: <shawnguo@kernel.org>
|
||||
Cc: maggu2810@gmail.com, peter.chen@nxp.com, mail@maciej.szmigiero.name,
|
||||
Fabio Estevam <fabio.estevam@nxp.com>, linux-arm-kernel@lists.infradead.org
|
||||
Date: Thu, 18 Jan 2018 10:34:18 -0200
|
||||
|
||||
Currently the kernel hangs when USB Host1 is enabled due to the lack of
|
||||
support for controlling the USB hub clock and GPIO reset line.
|
||||
|
||||
Peter Chen has made several attempts to fix this problem, but his series
|
||||
has not been applied yet, so better disable USB host1 for now to avoid
|
||||
the kernel hang.
|
||||
|
||||
Signed-off-by: Fabio Estevam <fabio.estevam@nxp.com>
|
||||
Acked-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
|
||||
Tested-by: Markus Rathgeb <maggu2810@gmail.com>
|
||||
---
|
||||
arch/arm/boot/dts/imx6qdl-udoo.dtsi | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/imx6qdl-udoo.dtsi b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
||||
index 4161b7d..1f0b9f6 100644
|
||||
--- a/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
||||
+++ b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
||||
@@ -274,7 +274,8 @@
|
||||
pinctrl-0 = <&pinctrl_usbh>;
|
||||
vbus-supply = <®_usb_h1_vbus>;
|
||||
clocks = <&clks IMX6QDL_CLK_CKO>;
|
||||
- status = "okay";
|
||||
+ /* currently USB support causes a kernel hang. Disable it for now */
|
||||
+ status = "disabled";
|
||||
};
|
||||
|
||||
&usdhc3 {
|
18
kernel.spec
18
kernel.spec
@ -567,6 +567,7 @@ Patch210: disable-i8042-check-on-apple-mac.patch
|
||||
Patch211: drm-i915-hush-check-crtc-state.patch
|
||||
|
||||
# 300 - ARM patches
|
||||
Patch300: arm64-Add-option-of-13-for-FORCE_MAX_ZONEORDER.patch
|
||||
|
||||
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
||||
Patch301: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
||||
@ -578,23 +579,24 @@ Patch302: arm-revert-mmc-omap_hsmmc-Use-dma_request_chan-for-reque.patch
|
||||
Patch303: ARM-tegra-usb-no-reset.patch
|
||||
|
||||
# https://www.spinics.net/lists/arm-kernel/msg554183.html
|
||||
Patch305: arm-imx6-hummingboard2.patch
|
||||
Patch304: arm-imx6-hummingboard2.patch
|
||||
|
||||
Patch306: arm64-Add-option-of-13-for-FORCE_MAX_ZONEORDER.patch
|
||||
|
||||
Patch307: arm64-Revert-allwinner-a64-pine64-Use-dcdc1-regulato.patch
|
||||
Patch305: arm64-Revert-allwinner-a64-pine64-Use-dcdc1-regulato.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/9820417/
|
||||
Patch310: qcom-msm89xx-fixes.patch
|
||||
Patch306: qcom-msm89xx-fixes.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10173115/
|
||||
Patch307: arm-dts-imx6qdl-udoo-Disable-usbh1-to-avoid-kernel-hang.patch
|
||||
|
||||
# Fix USB on the RPi https://patchwork.kernel.org/patch/9879371/
|
||||
Patch321: bcm283x-dma-mapping-skip-USB-devices-when-configuring-DMA-during-probe.patch
|
||||
Patch308: bcm283x-dma-mapping-skip-USB-devices-when-configuring-DMA-during-probe.patch
|
||||
|
||||
# https://git.kernel.org/pub/scm/linux/kernel/git/ardb/linux.git/log/?h=synquacer-netsec
|
||||
Patch332: arm64-socionext-96b-enablement.patch
|
||||
Patch330: arm64-socionext-96b-enablement.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10149775/ MMC support for Synquacer
|
||||
Patch333: arm64-mmc-sdhci_f_sdh30-add-ACPI-support.patch
|
||||
Patch331: arm64-mmc-sdhci_f_sdh30-add-ACPI-support.patch
|
||||
|
||||
# 400 - IBM (ppc/s390x) patches
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user