Linux v3.18-rc3-61-ga1cff6e25e6e
This commit is contained in:
parent
8a5a8ea38a
commit
b90522aeef
15
kernel.spec
15
kernel.spec
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 3
|
%define rcrev 3
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -616,14 +616,13 @@ Patch26058: asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
|||||||
#rhbz 1111138
|
#rhbz 1111138
|
||||||
Patch26059: i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
Patch26059: i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
||||||
|
|
||||||
#rhbz 1157327
|
|
||||||
Patch26062: quirk-for-Lenovo-Yoga-3-no-rfkill-switch.patch
|
|
||||||
|
|
||||||
#rhbz 1158204 1157157
|
#rhbz 1158204 1157157
|
||||||
Patch26063: x86-microcode-AMD-Fix-early-ucode-loading-on-32-bit.patch
|
Patch26063: x86-microcode-AMD-Fix-early-ucode-loading-on-32-bit.patch
|
||||||
|
|
||||||
Patch26064: Input-add-driver-for-the-Goodix-touchpanel.patch
|
Patch26064: Input-add-driver-for-the-Goodix-touchpanel.patch
|
||||||
|
|
||||||
|
Patch26065: sched-Remove-lockdep-check-in-sched_move_task.patch
|
||||||
|
|
||||||
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
||||||
Patch30000: kernel-arm64.patch
|
Patch30000: kernel-arm64.patch
|
||||||
|
|
||||||
@ -1349,14 +1348,13 @@ ApplyPatch asus-nb-wmi-Add-wapf4-quirk-for-the-X550VB.patch
|
|||||||
#rhbz 1111138
|
#rhbz 1111138
|
||||||
ApplyPatch i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
ApplyPatch i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
|
||||||
|
|
||||||
#rhbz 1157327
|
|
||||||
ApplyPatch quirk-for-Lenovo-Yoga-3-no-rfkill-switch.patch
|
|
||||||
|
|
||||||
#rhbz 1158204 1157157
|
#rhbz 1158204 1157157
|
||||||
ApplyPatch x86-microcode-AMD-Fix-early-ucode-loading-on-32-bit.patch
|
ApplyPatch x86-microcode-AMD-Fix-early-ucode-loading-on-32-bit.patch
|
||||||
|
|
||||||
ApplyPatch Input-add-driver-for-the-Goodix-touchpanel.patch
|
ApplyPatch Input-add-driver-for-the-Goodix-touchpanel.patch
|
||||||
|
|
||||||
|
ApplyPatch sched-Remove-lockdep-check-in-sched_move_task.patch
|
||||||
|
|
||||||
%if 0%{?aarch64patches}
|
%if 0%{?aarch64patches}
|
||||||
ApplyPatch kernel-arm64.patch
|
ApplyPatch kernel-arm64.patch
|
||||||
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
||||||
@ -2225,6 +2223,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 05 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc3.git2.1
|
||||||
|
- Linux v3.18-rc3-61-ga1cff6e25e6e
|
||||||
|
|
||||||
* Tue Nov 04 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc3.git1.1
|
* Tue Nov 04 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc3.git1.1
|
||||||
- Linux v3.18-rc3-31-g980d0d51b1c9
|
- Linux v3.18-rc3-31-g980d0d51b1c9
|
||||||
- Reenable debugging options.
|
- Reenable debugging options.
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From: Stephan Mueller <smueller@chronox.de>
|
|
||||||
Date: Mon, 27 Oct 2014 04:09:50 +0100
|
|
||||||
Subject: [PATCH] quirk for Lenovo Yoga 3: no rfkill switch
|
|
||||||
|
|
||||||
The Yoga 3 does not contain any physical rfkill switch. Therefore
|
|
||||||
disable the rfkill switch identically to the Yoga 2 approach.
|
|
||||||
|
|
||||||
Signed-off-by: Stephan Mueller <smueller@chronox.de>
|
|
||||||
---
|
|
||||||
drivers/platform/x86/ideapad-laptop.c | 7 +++++++
|
|
||||||
1 file changed, 7 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/platform/x86/ideapad-laptop.c b/drivers/platform/x86/ideapad-laptop.c
|
|
||||||
index 02152de135b5..ed494f37c40f 100644
|
|
||||||
--- a/drivers/platform/x86/ideapad-laptop.c
|
|
||||||
+++ b/drivers/platform/x86/ideapad-laptop.c
|
|
||||||
@@ -837,6 +837,13 @@ static const struct dmi_system_id no_hw_rfkill_list[] = {
|
|
||||||
DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Yoga 2"),
|
|
||||||
},
|
|
||||||
},
|
|
||||||
+ {
|
|
||||||
+ .ident = "Lenovo Yoga 3 Pro 1370",
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo YOGA 3 Pro-1370"),
|
|
||||||
+ },
|
|
||||||
+ },
|
|
||||||
{}
|
|
||||||
};
|
|
||||||
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
@ -14,10 +14,10 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|||||||
1 file changed, 10 insertions(+)
|
1 file changed, 10 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/platform/x86/samsung-laptop.c b/drivers/platform/x86/samsung-laptop.c
|
diff --git a/drivers/platform/x86/samsung-laptop.c b/drivers/platform/x86/samsung-laptop.c
|
||||||
index 5a5966512277..0d7954e0fc74 100644
|
index ff765d8e1a09..864290243e46 100644
|
||||||
--- a/drivers/platform/x86/samsung-laptop.c
|
--- a/drivers/platform/x86/samsung-laptop.c
|
||||||
+++ b/drivers/platform/x86/samsung-laptop.c
|
+++ b/drivers/platform/x86/samsung-laptop.c
|
||||||
@@ -1568,6 +1568,16 @@ static struct dmi_system_id __initdata samsung_dmi_table[] = {
|
@@ -1578,6 +1578,16 @@ static struct dmi_system_id __initdata samsung_dmi_table[] = {
|
||||||
},
|
},
|
||||||
.driver_data = &samsung_np740u3e,
|
.driver_data = &samsung_np740u3e,
|
||||||
},
|
},
|
||||||
|
49
sched-Remove-lockdep-check-in-sched_move_task.patch
Normal file
49
sched-Remove-lockdep-check-in-sched_move_task.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
From: Kirill Tkhai <ktkhai@parallels.com>
|
||||||
|
Date: Tue, 28 Oct 2014 08:24:34 +0300
|
||||||
|
Subject: [PATCH] sched: Remove lockdep check in sched_move_task()
|
||||||
|
|
||||||
|
sched_move_task() is the only interface to change sched_task_group:
|
||||||
|
cpu_cgrp_subsys methods and autogroup_move_group() use it.
|
||||||
|
|
||||||
|
Everything is synchronized by task_rq_lock(), so cpu_cgroup_attach()
|
||||||
|
is ordered with other users of sched_move_task(). This means we do no
|
||||||
|
need RCU here: if we've dereferenced a tg here, the .attach method
|
||||||
|
hasn't been called for it yet.
|
||||||
|
|
||||||
|
Thus, we should pass "true" to task_css_check() to silence lockdep
|
||||||
|
warnings.
|
||||||
|
|
||||||
|
Fixes: eeb61e53ea19 ("sched: Fix race between task_group and sched_task_group")
|
||||||
|
Reported-by: Oleg Nesterov <oleg@redhat.com>
|
||||||
|
Reported-by: Fengguang Wu <fengguang.wu@intel.com>
|
||||||
|
Signed-off-by: Kirill Tkhai <ktkhai@parallels.com>
|
||||||
|
Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
|
||||||
|
Cc: Linus Torvalds <torvalds@linux-foundation.org>
|
||||||
|
Link: http://lkml.kernel.org/r/1414473874.8574.2.camel@tkhai
|
||||||
|
Signed-off-by: Ingo Molnar <mingo@kernel.org>
|
||||||
|
---
|
||||||
|
kernel/sched/core.c | 8 ++++++--
|
||||||
|
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/kernel/sched/core.c b/kernel/sched/core.c
|
||||||
|
index 240157c13ddc..6841fb46eb07 100644
|
||||||
|
--- a/kernel/sched/core.c
|
||||||
|
+++ b/kernel/sched/core.c
|
||||||
|
@@ -7444,8 +7444,12 @@ void sched_move_task(struct task_struct *tsk)
|
||||||
|
if (unlikely(running))
|
||||||
|
put_prev_task(rq, tsk);
|
||||||
|
|
||||||
|
- tg = container_of(task_css_check(tsk, cpu_cgrp_id,
|
||||||
|
- lockdep_is_held(&tsk->sighand->siglock)),
|
||||||
|
+ /*
|
||||||
|
+ * All callers are synchronized by task_rq_lock(); we do not use RCU
|
||||||
|
+ * which is pointless here. Thus, we pass "true" to task_css_check()
|
||||||
|
+ * to prevent lockdep warnings.
|
||||||
|
+ */
|
||||||
|
+ tg = container_of(task_css_check(tsk, cpu_cgrp_id, true),
|
||||||
|
struct task_group, css);
|
||||||
|
tg = autogroup_task_group(tsk, tg);
|
||||||
|
tsk->sched_task_group = tg;
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
fb30d0f29214d75cddd2faa94f73d5cf linux-3.17.tar.xz
|
fb30d0f29214d75cddd2faa94f73d5cf linux-3.17.tar.xz
|
||||||
159e969cbc27201d8e2fa0f609dc722f perf-man-3.17.tar.gz
|
159e969cbc27201d8e2fa0f609dc722f perf-man-3.17.tar.gz
|
||||||
84109345d207976c0a899b1d29bfeddd patch-3.18-rc3.xz
|
84109345d207976c0a899b1d29bfeddd patch-3.18-rc3.xz
|
||||||
77acf9ad443db84a8c4757f812f456e6 patch-3.18-rc3-git1.xz
|
256ba5418e5d6246fca7f9cb7d9ebfd4 patch-3.18-rc3-git2.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user