Revert vdso_install patch for aarch64 which breaks build
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
49998f8a0d
commit
b8e77e8fe2
48
0001-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
Normal file
48
0001-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
From 8d75785a814241587802655cc33e384230744f0c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stephen Boyd <swboyd@chromium.org>
|
||||||
|
Date: Mon, 17 Aug 2020 18:49:50 -0700
|
||||||
|
Subject: Revert [PATCH] ARM64: vdso32: Install vdso32 from vdso_install
|
||||||
|
|
||||||
|
Add the 32-bit vdso Makefile to the vdso_install rule so that 'make
|
||||||
|
vdso_install' installs the 32-bit compat vdso when it is compiled.
|
||||||
|
|
||||||
|
Fixes: a7f71a2c8903 ("arm64: compat: Add vDSO")
|
||||||
|
Signed-off-by: Stephen Boyd <swboyd@chromium.org>
|
||||||
|
Reviewed-by: Vincenzo Frascino <vincenzo.frascino@arm.com>
|
||||||
|
Acked-by: Will Deacon <will@kernel.org>
|
||||||
|
Cc: Vincenzo Frascino <vincenzo.frascino@arm.com>
|
||||||
|
Link: https://lore.kernel.org/r/20200818014950.42492-1-swboyd@chromium.org
|
||||||
|
Signed-off-by: Catalin Marinas <catalin.marinas@arm.com>
|
||||||
|
---
|
||||||
|
arch/arm64/Makefile | 1 -
|
||||||
|
arch/arm64/kernel/vdso32/Makefile | 2 +-
|
||||||
|
2 files changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
|
||||||
|
index 55bc8546d9c7..b45f0124cc16 100644
|
||||||
|
--- a/arch/arm64/Makefile
|
||||||
|
+++ b/arch/arm64/Makefile
|
||||||
|
@@ -165,7 +165,6 @@ zinstall install:
|
||||||
|
PHONY += vdso_install
|
||||||
|
vdso_install:
|
||||||
|
$(Q)$(MAKE) $(build)=arch/arm64/kernel/vdso $@
|
||||||
|
- $(Q)$(MAKE) $(build)=arch/arm64/kernel/vdso32 $@
|
||||||
|
|
||||||
|
# We use MRPROPER_FILES and CLEAN_FILES now
|
||||||
|
archclean:
|
||||||
|
diff --git a/arch/arm64/kernel/vdso32/Makefile b/arch/arm64/kernel/vdso32/Makefile
|
||||||
|
index 5139a5f19256..d6adb4677c25 100644
|
||||||
|
--- a/arch/arm64/kernel/vdso32/Makefile
|
||||||
|
+++ b/arch/arm64/kernel/vdso32/Makefile
|
||||||
|
@@ -208,7 +208,7 @@ quiet_cmd_vdsosym = VDSOSYM $@
|
||||||
|
cmd_vdsosym = $(NM) $< | $(gen-vdsosym) | LC_ALL=C sort > $@
|
||||||
|
|
||||||
|
# Install commands for the unstripped file
|
||||||
|
-quiet_cmd_vdso_install = INSTALL32 $@
|
||||||
|
+quiet_cmd_vdso_install = INSTALL $@
|
||||||
|
cmd_vdso_install = cp $(obj)/$@.dbg $(MODLIB)/vdso/vdso32.so
|
||||||
|
|
||||||
|
vdso.so: $(obj)/vdso.so.dbg
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
@ -790,6 +790,9 @@ Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
|||||||
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
|
|
||||||
|
#Temporary build fix
|
||||||
|
Patch75: 0001-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# empty final patch to facilitate testing of kernel patches
|
# empty final patch to facilitate testing of kernel patches
|
||||||
@ -1365,6 +1368,7 @@ ApplyOptionalPatch 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
|||||||
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
|
ApplyOptionalPatch 0001-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user