kernel-5.9.0-0.rc3.1
* Mon Aug 31 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc3.1] - v5.9-rc3 rebase - Updated changelog for the release based on 1127b219ce94 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
5c2e3ce22c
commit
b41e8da84d
@ -100,7 +100,7 @@ Signed-off-by: Philipp Rudo <prudo@redhat.com>
|
|||||||
create mode 100644 kernel/rh_taint.c
|
create mode 100644 kernel/rh_taint.c
|
||||||
|
|
||||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||||
index 500def620d8f..c352ecdfcb43 100644
|
index c25b8e41c0ea..c3dd56bf044f 100644
|
||||||
--- a/include/linux/kernel.h
|
--- a/include/linux/kernel.h
|
||||||
+++ b/include/linux/kernel.h
|
+++ b/include/linux/kernel.h
|
||||||
@@ -1037,4 +1037,19 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
@@ -1037,4 +1037,19 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 83033334b565..824e2caf4067 100644
|
index 983e704d720b..7fdaaa5d20a4 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -497,7 +497,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
@@ -497,7 +497,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||||
|
@ -51,7 +51,7 @@ index a1a012702915..b57e6dd6d7ef 100644
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||||
index c93ba7fc65da..2803ec062a16 100644
|
index 156d1e44d9f7..e355907f5d6c 100644
|
||||||
--- a/include/linux/kernel.h
|
--- a/include/linux/kernel.h
|
||||||
+++ b/include/linux/kernel.h
|
+++ b/include/linux/kernel.h
|
||||||
@@ -1057,7 +1057,7 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
@@ -1057,7 +1057,7 @@ static inline void ftrace_dump(enum ftrace_dump_mode oops_dump_mode) { }
|
||||||
|
@ -24,7 +24,7 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|||||||
2 files changed, 32 insertions(+), 1 deletion(-)
|
2 files changed, 32 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||||
index c352ecdfcb43..8d3eaa27b082 100644
|
index c3dd56bf044f..f14f238dc36a 100644
|
||||||
--- a/include/linux/kernel.h
|
--- a/include/linux/kernel.h
|
||||||
+++ b/include/linux/kernel.h
|
+++ b/include/linux/kernel.h
|
||||||
@@ -602,7 +602,24 @@ extern enum system_states {
|
@@ -602,7 +602,24 @@ extern enum system_states {
|
||||||
|
@ -53,7 +53,7 @@ index a1068742a6df..aba9439caec9 100644
|
|||||||
[USB] Default USB device authorization:
|
[USB] Default USB device authorization:
|
||||||
(default -1 = authorized except for wireless USB,
|
(default -1 = authorized except for wireless USB,
|
||||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||||
index 8d3eaa27b082..c93ba7fc65da 100644
|
index f14f238dc36a..156d1e44d9f7 100644
|
||||||
--- a/include/linux/kernel.h
|
--- a/include/linux/kernel.h
|
||||||
+++ b/include/linux/kernel.h
|
+++ b/include/linux/kernel.h
|
||||||
@@ -617,7 +617,7 @@ extern enum system_states {
|
@@ -617,7 +617,7 @@ extern enum system_states {
|
||||||
|
@ -23,7 +23,7 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
|
||||||
index 2803ec062a16..6753f8e17dfe 100644
|
index e355907f5d6c..7a7a47665771 100644
|
||||||
--- a/include/linux/kernel.h
|
--- a/include/linux/kernel.h
|
||||||
+++ b/include/linux/kernel.h
|
+++ b/include/linux/kernel.h
|
||||||
@@ -612,7 +612,7 @@ extern enum system_states {
|
@@ -612,7 +612,7 @@ extern enum system_states {
|
||||||
|
@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
|
|||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index f21168154160..83033334b565 100644
|
index ff5e0731d26d..983e704d720b 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -1249,7 +1249,13 @@ endef
|
@@ -1249,7 +1249,13 @@ endef
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From 8d75785a814241587802655cc33e384230744f0c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Boyd <swboyd@chromium.org>
|
|
||||||
Date: Mon, 17 Aug 2020 18:49:50 -0700
|
|
||||||
Subject: Revert [PATCH] ARM64: vdso32: Install vdso32 from vdso_install
|
|
||||||
|
|
||||||
Add the 32-bit vdso Makefile to the vdso_install rule so that 'make
|
|
||||||
vdso_install' installs the 32-bit compat vdso when it is compiled.
|
|
||||||
|
|
||||||
Fixes: a7f71a2c8903 ("arm64: compat: Add vDSO")
|
|
||||||
Signed-off-by: Stephen Boyd <swboyd@chromium.org>
|
|
||||||
Reviewed-by: Vincenzo Frascino <vincenzo.frascino@arm.com>
|
|
||||||
Acked-by: Will Deacon <will@kernel.org>
|
|
||||||
Cc: Vincenzo Frascino <vincenzo.frascino@arm.com>
|
|
||||||
Link: https://lore.kernel.org/r/20200818014950.42492-1-swboyd@chromium.org
|
|
||||||
Signed-off-by: Catalin Marinas <catalin.marinas@arm.com>
|
|
||||||
---
|
|
||||||
arch/arm64/Makefile | 1 -
|
|
||||||
arch/arm64/kernel/vdso32/Makefile | 2 +-
|
|
||||||
2 files changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
|
|
||||||
index 55bc8546d9c7..b45f0124cc16 100644
|
|
||||||
--- a/arch/arm64/Makefile
|
|
||||||
+++ b/arch/arm64/Makefile
|
|
||||||
@@ -165,7 +165,6 @@ zinstall install:
|
|
||||||
PHONY += vdso_install
|
|
||||||
vdso_install:
|
|
||||||
$(Q)$(MAKE) $(build)=arch/arm64/kernel/vdso $@
|
|
||||||
- $(Q)$(MAKE) $(build)=arch/arm64/kernel/vdso32 $@
|
|
||||||
|
|
||||||
# We use MRPROPER_FILES and CLEAN_FILES now
|
|
||||||
archclean:
|
|
||||||
diff --git a/arch/arm64/kernel/vdso32/Makefile b/arch/arm64/kernel/vdso32/Makefile
|
|
||||||
index 5139a5f19256..d6adb4677c25 100644
|
|
||||||
--- a/arch/arm64/kernel/vdso32/Makefile
|
|
||||||
+++ b/arch/arm64/kernel/vdso32/Makefile
|
|
||||||
@@ -208,7 +208,7 @@ quiet_cmd_vdsosym = VDSOSYM $@
|
|
||||||
cmd_vdsosym = $(NM) $< | $(gen-vdsosym) | LC_ALL=C sort > $@
|
|
||||||
|
|
||||||
# Install commands for the unstripped file
|
|
||||||
-quiet_cmd_vdso_install = INSTALL32 $@
|
|
||||||
+quiet_cmd_vdso_install = INSTALL $@
|
|
||||||
cmd_vdso_install = cp $(obj)/$@.dbg $(MODLIB)/vdso/vdso32.so
|
|
||||||
|
|
||||||
vdso.so: $(obj)/vdso.so.dbg
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -11,4 +11,4 @@
|
|||||||
|
|
||||||
driverdirs="atm auxdisplay bcma bluetooth firewire fmc fpga infiniband isdn leds media memstick message mmc mtd nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
driverdirs="atm auxdisplay bcma bluetooth firewire fmc fpga infiniband isdn leds media memstick message mmc mtd nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
||||||
|
|
||||||
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr chtls rnbd-client rnbd-server mlx5_vdpa"
|
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr chtls rnbd-client rnbd-server"
|
||||||
|
@ -5011,6 +5011,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4036,6 +4036,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -4992,6 +4992,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4018,6 +4018,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -5118,6 +5118,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
@ -8041,7 +8042,7 @@ CONFIG_VIDEO_SUNXI_CEDRUS=m
|
|||||||
CONFIG_VIDEO_SUNXI=y
|
CONFIG_VIDEO_SUNXI=y
|
||||||
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
||||||
CONFIG_VIDEO_TEGRA=m
|
CONFIG_VIDEO_TEGRA=m
|
||||||
# CONFIG_VIDEO_TI_CAL is not set
|
CONFIG_VIDEO_TI_CAL=m
|
||||||
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
||||||
CONFIG_VIDEO_TI_VPE=m
|
CONFIG_VIDEO_TI_VPE=m
|
||||||
CONFIG_VIDEO_TM6000_ALSA=m
|
CONFIG_VIDEO_TM6000_ALSA=m
|
||||||
|
@ -5100,6 +5100,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
@ -8021,7 +8022,7 @@ CONFIG_VIDEO_SUNXI_CEDRUS=m
|
|||||||
CONFIG_VIDEO_SUNXI=y
|
CONFIG_VIDEO_SUNXI=y
|
||||||
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
||||||
CONFIG_VIDEO_TEGRA=m
|
CONFIG_VIDEO_TEGRA=m
|
||||||
# CONFIG_VIDEO_TI_CAL is not set
|
CONFIG_VIDEO_TI_CAL=m
|
||||||
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
||||||
CONFIG_VIDEO_TI_VPE=m
|
CONFIG_VIDEO_TI_VPE=m
|
||||||
CONFIG_VIDEO_TM6000_ALSA=m
|
CONFIG_VIDEO_TM6000_ALSA=m
|
||||||
|
@ -4987,6 +4987,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
@ -7768,7 +7769,7 @@ CONFIG_VIDEO_SUNXI_CEDRUS=m
|
|||||||
CONFIG_VIDEO_SUNXI=y
|
CONFIG_VIDEO_SUNXI=y
|
||||||
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
||||||
CONFIG_VIDEO_TEGRA=m
|
CONFIG_VIDEO_TEGRA=m
|
||||||
# CONFIG_VIDEO_TI_CAL is not set
|
CONFIG_VIDEO_TI_CAL=m
|
||||||
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
||||||
CONFIG_VIDEO_TI_VPE=m
|
CONFIG_VIDEO_TI_VPE=m
|
||||||
CONFIG_VIDEO_TM6000_ALSA=m
|
CONFIG_VIDEO_TM6000_ALSA=m
|
||||||
|
@ -4969,6 +4969,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
@ -7748,7 +7749,7 @@ CONFIG_VIDEO_SUNXI_CEDRUS=m
|
|||||||
CONFIG_VIDEO_SUNXI=y
|
CONFIG_VIDEO_SUNXI=y
|
||||||
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
CONFIG_VIDEO_TEGRA_HDMI_CEC=m
|
||||||
CONFIG_VIDEO_TEGRA=m
|
CONFIG_VIDEO_TEGRA=m
|
||||||
# CONFIG_VIDEO_TI_CAL is not set
|
CONFIG_VIDEO_TI_CAL=m
|
||||||
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
# CONFIG_VIDEO_TI_VPE_DEBUG is not set
|
||||||
CONFIG_VIDEO_TI_VPE=m
|
CONFIG_VIDEO_TI_VPE=m
|
||||||
CONFIG_VIDEO_TM6000_ALSA=m
|
CONFIG_VIDEO_TM6000_ALSA=m
|
||||||
|
@ -4578,6 +4578,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4559,6 +4559,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4250,6 +4250,7 @@ CONFIG_PPC_MEM_KEYS=y
|
|||||||
# CONFIG_PPC_MEMTRACE is not set
|
# CONFIG_PPC_MEMTRACE is not set
|
||||||
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
||||||
CONFIG_PPC_POWERNV=y
|
CONFIG_PPC_POWERNV=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
CONFIG_PPC_PSERIES=y
|
CONFIG_PPC_PSERIES=y
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
|
@ -3880,6 +3880,7 @@ CONFIG_PPC_MEM_KEYS=y
|
|||||||
# CONFIG_PPC_MEMTRACE is not set
|
# CONFIG_PPC_MEMTRACE is not set
|
||||||
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
||||||
CONFIG_PPC_POWERNV=y
|
CONFIG_PPC_POWERNV=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
CONFIG_PPC_PSERIES=y
|
CONFIG_PPC_PSERIES=y
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
|
@ -4230,6 +4230,7 @@ CONFIG_PPC_MEM_KEYS=y
|
|||||||
# CONFIG_PPC_MEMTRACE is not set
|
# CONFIG_PPC_MEMTRACE is not set
|
||||||
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
||||||
CONFIG_PPC_POWERNV=y
|
CONFIG_PPC_POWERNV=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
CONFIG_PPC_PSERIES=y
|
CONFIG_PPC_PSERIES=y
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
|
@ -3864,6 +3864,7 @@ CONFIG_PPC_MEM_KEYS=y
|
|||||||
# CONFIG_PPC_MEMTRACE is not set
|
# CONFIG_PPC_MEMTRACE is not set
|
||||||
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
CONFIG_PPC_OF_BOOT_TRAMPOLINE=y
|
||||||
CONFIG_PPC_POWERNV=y
|
CONFIG_PPC_POWERNV=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
CONFIG_PPC_PSERIES=y
|
CONFIG_PPC_PSERIES=y
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
|
@ -4191,6 +4191,7 @@ CONFIG_POWERCAP=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -3825,6 +3825,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -4171,6 +4171,7 @@ CONFIG_POWERCAP=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -3809,6 +3809,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -3832,6 +3832,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -4616,6 +4616,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4054,6 +4054,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
@ -4597,6 +4597,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_PTDUMP is not set
|
# CONFIG_PPC_PTDUMP is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
|
@ -4036,6 +4036,7 @@ CONFIG_POWER_RESET=y
|
|||||||
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
# CONFIG_POWER_SUPPLY_DEBUG is not set
|
||||||
CONFIG_POWER_SUPPLY_HWMON=y
|
CONFIG_POWER_SUPPLY_HWMON=y
|
||||||
CONFIG_POWER_SUPPLY=y
|
CONFIG_POWER_SUPPLY=y
|
||||||
|
# CONFIG_PPC_PROT_SAO_LPAR is not set
|
||||||
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
# CONFIG_PPC_QUEUED_SPINLOCKS is not set
|
||||||
CONFIG_PPDEV=m
|
CONFIG_PPDEV=m
|
||||||
CONFIG_PPP_ASYNC=m
|
CONFIG_PPP_ASYNC=m
|
||||||
|
29
kernel.spec
29
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1.
|
# For a stable, released kernel, released_kernel should be 1.
|
||||||
%global released_kernel 0
|
%global released_kernel 0
|
||||||
|
|
||||||
%global distro_build 0.rc2.20200827git15bc20c6af4c.1
|
%global distro_build 0.rc3.1
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define rpmversion 5.9.0
|
%define rpmversion 5.9.0
|
||||||
%define pkgrelease 0.rc2.20200827git15bc20c6af4c.1
|
%define pkgrelease 0.rc3.1
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 9
|
%define patchlevel 9
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc2.20200827git15bc20c6af4c.1%{?buildid}%{?dist}
|
%define specrelease 0.rc3.1%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -166,7 +166,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
# The kernel tarball/base version
|
# The kernel tarball/base version
|
||||||
%define kversion 5.9
|
%define kversion 5.9
|
||||||
@ -567,7 +567,7 @@ BuildRequires: asciidoc
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-20200827git15bc20c6af4c.tar.xz
|
Source0: linux-5.9-rc3.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -789,7 +789,6 @@ Patch71: 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
|||||||
Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
Patch75: 0001-revert-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1285,8 +1284,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-20200827git15bc20c6af4c -c
|
%setup -q -n kernel-5.9-rc3 -c
|
||||||
mv linux-20200827git15bc20c6af4c linux-%{KVERREL}
|
mv linux-5.9-rc3 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -1366,7 +1365,6 @@ ApplyOptionalPatch 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
|||||||
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||||
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
|
||||||
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
|
||||||
ApplyOptionalPatch 0001-revert-ARM64-vdso32-Install-vdso32-from-vdso_install.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -2795,6 +2793,19 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 31 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc3.1]
|
||||||
|
- v5.9-rc3 rebase
|
||||||
|
- Updated changelog for the release based on 1127b219ce94 (Fedora Kernel Team)
|
||||||
|
|
||||||
|
* Sun Aug 30 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.20200830git1127b219ce94.1]
|
||||||
|
- 1127b219ce94 rebase
|
||||||
|
- Updated changelog for the release based on 4d41ead6ead9 (Fedora Kernel Team)
|
||||||
|
|
||||||
|
* Sat Aug 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.20200829git4d41ead6ead9.1]
|
||||||
|
- 4d41ead6ead9 rebase
|
||||||
|
- mod-sign.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||||
|
- Updated changelog for the release based on 15bc20c6af4c (Fedora Kernel Team)
|
||||||
|
|
||||||
* Thu Aug 27 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.20200827git15bc20c6af4c.1]
|
* Thu Aug 27 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc2.20200827git15bc20c6af4c.1]
|
||||||
- 15bc20c6af4c rebase
|
- 15bc20c6af4c rebase
|
||||||
- Updated changelog for the release based on 2ac69819ba9e (Fedora Kernel Team)
|
- Updated changelog for the release based on 2ac69819ba9e (Fedora Kernel Team)
|
||||||
|
@ -13,9 +13,9 @@ MODSECKEY=$1
|
|||||||
MODPUBKEY=$2
|
MODPUBKEY=$2
|
||||||
moddir=$3
|
moddir=$3
|
||||||
|
|
||||||
modules=`find $moddir -type f -name '*.ko'`
|
modules=$(find "$moddir" -type f -name '*.ko')
|
||||||
|
|
||||||
NPROC=`nproc`
|
NPROC=$(nproc)
|
||||||
[ -z "$NPROC" ] && NPROC=1
|
[ -z "$NPROC" ] && NPROC=1
|
||||||
|
|
||||||
# NB: this loop runs 2000+ iterations. Try to be fast.
|
# NB: this loop runs 2000+ iterations. Try to be fast.
|
||||||
@ -27,7 +27,7 @@ done
|
|||||||
" DUMMYARG0 # xargs appends ARG1 ARG2..., which go into $mod in for loop.
|
" DUMMYARG0 # xargs appends ARG1 ARG2..., which go into $mod in for loop.
|
||||||
|
|
||||||
RANDOMMOD=$(echo "$modules" | sort -R | head -n 1)
|
RANDOMMOD=$(echo "$modules" | sort -R | head -n 1)
|
||||||
if [ "~Module signature appended~" != "$(tail -c 28 $RANDOMMOD)" ]; then
|
if [ "~Module signature appended~" != "$(tail -c 28 "$RANDOMMOD")" ]; then
|
||||||
echo "*****************************"
|
echo "*****************************"
|
||||||
echo "*** Modules are unsigned! ***"
|
echo "*** Modules are unsigned! ***"
|
||||||
echo "*****************************"
|
echo "*****************************"
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-20200827git15bc20c6af4c.tar.xz) = 6ef0bb8b2091261ae6e2adf1d2c996e560656905caa0b4c08d15dfcf2ba7372bee70f8130a14ab466bc394180f0d1ea32a58cb0bc5da9522012c98ee59383728
|
SHA512 (linux-5.9-rc3.tar.xz) = 2e03e9a24d87c4cd7017e37ecdf00c9f60fc2c7dcf0f2f206329b496d73a851e6521141561029643fc6975342bcaf4ec7071453c36708298ef52c7fd1fad46a3
|
||||||
SHA512 (kernel-abi-whitelists-5.9.0-0.rc2.20200827git15bc20c6af4c.1.tar.bz2) = b70ef3341b198ee18cc9f9ebdd44615401f1e423d4ae16c2400b8a92065d6bc3fa6a68b586f30d9fa47508047b541ed943e5a6b3368c90e46475f5a210bf4e04
|
SHA512 (kernel-abi-whitelists-5.9.0-0.rc3.1.tar.bz2) = e63350f5fceccddf80e7d61dc4d04438fcc721e2f9e01e2a9a86ce46849a97f48f52a6b0a3ab43cec8984007ac3476ff0c34b0e9702ec92b47eb407891b1a50e
|
||||||
SHA512 (kernel-kabi-dw-5.9.0-0.rc2.20200827git15bc20c6af4c.1.tar.bz2) = 670ee96926fff5ec35382be34b075d67de9de50b875905792244d4e3c1f838683254f5a3a13335a88e4e93496d126750d23b08977c64efabbb21817b4d9eaef7
|
SHA512 (kernel-kabi-dw-5.9.0-0.rc3.1.tar.bz2) = 70532f17e25ed57c1256b4af7bbb60f02713f3ddc07111a737fe85bf713665883ae9acab610bbcfea8fbbfd5638b72306d6b4c1fae93f91c4e7150a652593744
|
||||||
|
Loading…
Reference in New Issue
Block a user