update to 2.6.37-rc5-git5
This commit is contained in:
parent
1f623e9fd5
commit
b3c92af657
2
.gitignore
vendored
2
.gitignore
vendored
@ -4,4 +4,4 @@ clog
|
|||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
/patch-2.6.37-rc5.bz2
|
/patch-2.6.37-rc5.bz2
|
||||||
/patch-2.6.37-rc5-git2.bz2
|
/patch-2.6.37-rc5-git5.bz2
|
||||||
|
@ -4380,6 +4380,7 @@ CONFIG_BLK_DEV_DRBD=m
|
|||||||
|
|
||||||
# CONFIG_MDIO_GPIO is not set
|
# CONFIG_MDIO_GPIO is not set
|
||||||
# CONFIG_KEYBOARD_GPIO is not set
|
# CONFIG_KEYBOARD_GPIO is not set
|
||||||
|
# CONFIG_KEYBOARD_GPIO_POLLED is not set
|
||||||
# CONFIG_MOUSE_GPIO is not set
|
# CONFIG_MOUSE_GPIO is not set
|
||||||
# CONFIG_I2C_GPIO is not set
|
# CONFIG_I2C_GPIO is not set
|
||||||
# CONFIG_DEBUG_GPIO is not set
|
# CONFIG_DEBUG_GPIO is not set
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 5
|
%define rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 5
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -712,8 +712,6 @@ Patch12411: mm-vmstat-use-a-single-setter-function-and-callback-for-adjusting-pe
|
|||||||
# rhbz#650934
|
# rhbz#650934
|
||||||
Patch12420: sched-cure-more-NO_HZ-load-average-woes.patch
|
Patch12420: sched-cure-more-NO_HZ-load-average-woes.patch
|
||||||
|
|
||||||
Patch12421: orinoco-initialise-priv_hw-before-assigning-the-interrupt.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||||
@ -1316,9 +1314,6 @@ ApplyPatch mm-vmstat-use-a-single-setter-function-and-callback-for-adjusting-per
|
|||||||
# rhbz#650934
|
# rhbz#650934
|
||||||
ApplyPatch sched-cure-more-NO_HZ-load-average-woes.patch
|
ApplyPatch sched-cure-more-NO_HZ-load-average-woes.patch
|
||||||
|
|
||||||
# rhbz657864
|
|
||||||
ApplyPatch orinoco-initialise-priv_hw-before-assigning-the-interrupt.patch
|
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1932,6 +1927,9 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 15 2010 Kyle McMartin <kyle@redhat.com> 2.6.37-0.rc5.git5.1
|
||||||
|
- 2.6.37-rc5-git5
|
||||||
|
|
||||||
* Fri Dec 10 2010 Kyle McMartin <kyle@redhat.com>
|
* Fri Dec 10 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
- Another patch from mjg59: Set _OSC supported field correctly (#638912)
|
- Another patch from mjg59: Set _OSC supported field correctly (#638912)
|
||||||
|
|
||||||
|
@ -1,91 +0,0 @@
|
|||||||
From 17f1e34b178ffc0111d768f48a86b58fd0c88c56 Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Kilroy <kilroyd@googlemail.com>
|
|
||||||
Date: Tue, 7 Dec 2010 18:50:42 +0000
|
|
||||||
Subject: [PATCH] orinoco: initialise priv->hw before assigning the interrupt
|
|
||||||
|
|
||||||
The interrupt handler takes a lock - but since commit bcad6e80f3f this
|
|
||||||
lock goes through an indirection specified in the hermes_t structure.
|
|
||||||
We must therefore initialise the structure before setting up the
|
|
||||||
interrupt handler.
|
|
||||||
|
|
||||||
Fix orinoco_cs and spectrum_cs
|
|
||||||
|
|
||||||
<https://bugzilla.kernel.org/show_bug.cgi?id=23932>
|
|
||||||
|
|
||||||
Bisected by: Matt Domsch <Matt_Domsch@dell.com>
|
|
||||||
Signed-off by: David Kilroy <kilroyd@googlemail.com>
|
|
||||||
Cc: stable@kernel.org
|
|
||||||
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
|
||||||
---
|
|
||||||
drivers/net/wireless/orinoco/orinoco_cs.c | 14 +++++++-------
|
|
||||||
drivers/net/wireless/orinoco/spectrum_cs.c | 14 +++++++-------
|
|
||||||
2 files changed, 14 insertions(+), 14 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/net/wireless/orinoco/orinoco_cs.c b/drivers/net/wireless/orinoco/orinoco_cs.c
|
|
||||||
index 71b3d68..32954c4 100644
|
|
||||||
--- a/drivers/net/wireless/orinoco/orinoco_cs.c
|
|
||||||
+++ b/drivers/net/wireless/orinoco/orinoco_cs.c
|
|
||||||
@@ -151,20 +151,20 @@ orinoco_cs_config(struct pcmcia_device *link)
|
|
||||||
goto failed;
|
|
||||||
}
|
|
||||||
|
|
||||||
- ret = pcmcia_request_irq(link, orinoco_interrupt);
|
|
||||||
- if (ret)
|
|
||||||
- goto failed;
|
|
||||||
-
|
|
||||||
- /* We initialize the hermes structure before completing PCMCIA
|
|
||||||
- * configuration just in case the interrupt handler gets
|
|
||||||
- * called. */
|
|
||||||
mem = ioport_map(link->resource[0]->start,
|
|
||||||
resource_size(link->resource[0]));
|
|
||||||
if (!mem)
|
|
||||||
goto failed;
|
|
||||||
|
|
||||||
+ /* We initialize the hermes structure before completing PCMCIA
|
|
||||||
+ * configuration just in case the interrupt handler gets
|
|
||||||
+ * called. */
|
|
||||||
hermes_struct_init(hw, mem, HERMES_16BIT_REGSPACING);
|
|
||||||
|
|
||||||
+ ret = pcmcia_request_irq(link, orinoco_interrupt);
|
|
||||||
+ if (ret)
|
|
||||||
+ goto failed;
|
|
||||||
+
|
|
||||||
ret = pcmcia_enable_device(link);
|
|
||||||
if (ret)
|
|
||||||
goto failed;
|
|
||||||
diff --git a/drivers/net/wireless/orinoco/spectrum_cs.c b/drivers/net/wireless/orinoco/spectrum_cs.c
|
|
||||||
index fb859a5..db34c28 100644
|
|
||||||
--- a/drivers/net/wireless/orinoco/spectrum_cs.c
|
|
||||||
+++ b/drivers/net/wireless/orinoco/spectrum_cs.c
|
|
||||||
@@ -214,21 +214,21 @@ spectrum_cs_config(struct pcmcia_device *link)
|
|
||||||
goto failed;
|
|
||||||
}
|
|
||||||
|
|
||||||
- ret = pcmcia_request_irq(link, orinoco_interrupt);
|
|
||||||
- if (ret)
|
|
||||||
- goto failed;
|
|
||||||
-
|
|
||||||
- /* We initialize the hermes structure before completing PCMCIA
|
|
||||||
- * configuration just in case the interrupt handler gets
|
|
||||||
- * called. */
|
|
||||||
mem = ioport_map(link->resource[0]->start,
|
|
||||||
resource_size(link->resource[0]));
|
|
||||||
if (!mem)
|
|
||||||
goto failed;
|
|
||||||
|
|
||||||
+ /* We initialize the hermes structure before completing PCMCIA
|
|
||||||
+ * configuration just in case the interrupt handler gets
|
|
||||||
+ * called. */
|
|
||||||
hermes_struct_init(hw, mem, HERMES_16BIT_REGSPACING);
|
|
||||||
hw->eeprom_pda = true;
|
|
||||||
|
|
||||||
+ ret = pcmcia_request_irq(link, orinoco_interrupt);
|
|
||||||
+ if (ret)
|
|
||||||
+ goto failed;
|
|
||||||
+
|
|
||||||
ret = pcmcia_enable_device(link);
|
|
||||||
if (ret)
|
|
||||||
goto failed;
|
|
||||||
--
|
|
||||||
1.7.3.3
|
|
||||||
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
||||||
a84cf559615b5168ec1d5591841601ed patch-2.6.37-rc5.bz2
|
a84cf559615b5168ec1d5591841601ed patch-2.6.37-rc5.bz2
|
||||||
dbc90858467e28b39539ad6d3415a956 patch-2.6.37-rc5-git2.bz2
|
8e0b899768fd82d227ddc8c9e6d6d220 patch-2.6.37-rc5-git5.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user