Linux v3.14-4227-g3e75c6de1ac3
This commit is contained in:
parent
9ed75fbd4f
commit
afe319c502
34
arm64-Fix-duplicated-Kconfig-entries-again.patch
Normal file
34
arm64-Fix-duplicated-Kconfig-entries-again.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From a5574be3731095703675ad08b6f5e9697b361ffe Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
Date: Wed, 2 Apr 2014 10:14:43 -0400
|
||||||
|
Subject: [PATCH] arm64: Fix duplicated Kconfig entries again
|
||||||
|
|
||||||
|
Commit 74397174989e5f70 attempted to clean up the power management options
|
||||||
|
for arm64, but when things were merged it didn't fully take effect. Fix
|
||||||
|
it again.
|
||||||
|
|
||||||
|
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
---
|
||||||
|
arch/arm64/Kconfig | 6 ------
|
||||||
|
1 file changed, 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||||
|
index 07aa3556952c..8033b9b8a2df 100644
|
||||||
|
--- a/arch/arm64/Kconfig
|
||||||
|
+++ b/arch/arm64/Kconfig
|
||||||
|
@@ -321,12 +321,6 @@ menu "CPU Power Management"
|
||||||
|
|
||||||
|
source "drivers/cpuidle/Kconfig"
|
||||||
|
|
||||||
|
-source "drivers/cpufreq/Kconfig"
|
||||||
|
-
|
||||||
|
-endmenu
|
||||||
|
-
|
||||||
|
-menu "Power management options"
|
||||||
|
-
|
||||||
|
source "kernel/power/Kconfig"
|
||||||
|
|
||||||
|
source "drivers/cpufreq/Kconfig"
|
||||||
|
--
|
||||||
|
1.8.5.3
|
||||||
|
|
@ -73,6 +73,7 @@ CONFIG_VM_EVENT_COUNTERS=y
|
|||||||
# CONFIG_MDIO_BUS_MUX_GPIO is not set
|
# CONFIG_MDIO_BUS_MUX_GPIO is not set
|
||||||
# CONFIG_MDIO_BUS_MUX_MMIOREG is not set
|
# CONFIG_MDIO_BUS_MUX_MMIOREG is not set
|
||||||
|
|
||||||
|
|
||||||
# busted build for various reasons
|
# busted build for various reasons
|
||||||
# uses pci_* for some reason to allocate DMA buffers
|
# uses pci_* for some reason to allocate DMA buffers
|
||||||
# CONFIG_DVB_B2C2_FLEXCOP_USB is not set
|
# CONFIG_DVB_B2C2_FLEXCOP_USB is not set
|
||||||
@ -85,3 +86,4 @@ CONFIG_POWER_RESET_XGENE=y
|
|||||||
CONFIG_COMMON_CLK_XGENE=y
|
CONFIG_COMMON_CLK_XGENE=y
|
||||||
|
|
||||||
CONFIG_AHCI_XGENE=m
|
CONFIG_AHCI_XGENE=m
|
||||||
|
CONFIG_PHY_XGENE=m
|
||||||
|
@ -277,6 +277,9 @@ CONFIG_RADIO_WL128X=m
|
|||||||
|
|
||||||
CONFIG_OMAP_REMOTEPROC=m
|
CONFIG_OMAP_REMOTEPROC=m
|
||||||
|
|
||||||
|
CONFIG_OMAP_CONTROL_PHY=m
|
||||||
|
CONFIG_TI_PIPE3=m
|
||||||
|
|
||||||
# CONFIG_TIDSPBRIDGE is not set
|
# CONFIG_TIDSPBRIDGE is not set
|
||||||
# CONFIG_TIDSPBRIDGE_MEMPOOL_SIZE=0x600000
|
# CONFIG_TIDSPBRIDGE_MEMPOOL_SIZE=0x600000
|
||||||
# CONFIG_TIDSPBRIDGE_DEBUG is not set
|
# CONFIG_TIDSPBRIDGE_DEBUG is not set
|
||||||
|
@ -169,6 +169,7 @@ CONFIG_STMMAC_PLATFORM=y
|
|||||||
CONFIG_DWMAC_SUNXI=y
|
CONFIG_DWMAC_SUNXI=y
|
||||||
CONFIG_EEPROM_SUNXI_SID=m
|
CONFIG_EEPROM_SUNXI_SID=m
|
||||||
CONFIG_RTC_DRV_SUNXI=m
|
CONFIG_RTC_DRV_SUNXI=m
|
||||||
|
CONFIG_PHY_SUN4I_USB=m
|
||||||
|
|
||||||
CONFIG_REGMAP=y
|
CONFIG_REGMAP=y
|
||||||
CONFIG_REGMAP_I2C=m
|
CONFIG_REGMAP_I2C=m
|
||||||
|
@ -1523,6 +1523,8 @@ CONFIG_SMSC_PHY=m
|
|||||||
CONFIG_STE10XP=m
|
CONFIG_STE10XP=m
|
||||||
CONFIG_VITESSE_PHY=m
|
CONFIG_VITESSE_PHY=m
|
||||||
CONFIG_MICREL_PHY=m
|
CONFIG_MICREL_PHY=m
|
||||||
|
# CONFIG_OMAP_CONTROL_PHY is not set
|
||||||
|
# CONFIG_PHY_SAMSUNG_USB2 is not set
|
||||||
|
|
||||||
CONFIG_MII=m
|
CONFIG_MII=m
|
||||||
CONFIG_NET_CORE=y
|
CONFIG_NET_CORE=y
|
||||||
|
15
kernel.spec
15
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 4
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -648,6 +648,11 @@ Patch25052: net-xen-netback-disable-rogue-vif-in-kthread-context.patch
|
|||||||
#CVE-2014-2678 rhbz 1083274 1083280
|
#CVE-2014-2678 rhbz 1083274 1083280
|
||||||
Patch25054: rds-prevent-dereference-of-a-NULL-device-in-rds_iw_laddr_check.patch
|
Patch25054: rds-prevent-dereference-of-a-NULL-device-in-rds_iw_laddr_check.patch
|
||||||
|
|
||||||
|
Patch25055: net-enic-include-irq.h-for-irqreturn_t-definitions.patch
|
||||||
|
Patch25056: net-bnx2x-include-irq.h-for-irqreturn_t-definitions.patch
|
||||||
|
Patch25057: net-qlcnic-include-irq.h-for-irq-definitions.patch
|
||||||
|
Patch25058: arm64-Fix-duplicated-Kconfig-entries-again.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1301,6 +1306,11 @@ ApplyPatch net-xen-netback-disable-rogue-vif-in-kthread-context.patch
|
|||||||
#CVE-2014-2678 rhbz 1083274 1083280
|
#CVE-2014-2678 rhbz 1083274 1083280
|
||||||
ApplyPatch rds-prevent-dereference-of-a-NULL-device-in-rds_iw_laddr_check.patch
|
ApplyPatch rds-prevent-dereference-of-a-NULL-device-in-rds_iw_laddr_check.patch
|
||||||
|
|
||||||
|
ApplyPatch net-enic-include-irq.h-for-irqreturn_t-definitions.patch
|
||||||
|
ApplyPatch net-bnx2x-include-irq.h-for-irqreturn_t-definitions.patch
|
||||||
|
ApplyPatch net-qlcnic-include-irq.h-for-irq-definitions.patch
|
||||||
|
ApplyPatch arm64-Fix-duplicated-Kconfig-entries-again.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2080,6 +2090,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 02 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc0.git4.1
|
||||||
|
- Linux v3.14-4227-g3e75c6de1ac3
|
||||||
|
|
||||||
* Wed Apr 02 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc0.git3.1
|
* Wed Apr 02 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc0.git3.1
|
||||||
- Linux v3.14-3893-gc12e69c6aaf7
|
- Linux v3.14-3893-gc12e69c6aaf7
|
||||||
|
|
||||||
|
38
net-bnx2x-include-irq.h-for-irqreturn_t-definitions.patch
Normal file
38
net-bnx2x-include-irq.h-for-irqreturn_t-definitions.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From b6580f8eea4993bc5cbd903c705db0155919fbad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
Date: Wed, 2 Apr 2014 10:08:03 -0400
|
||||||
|
Subject: [PATCH] net: bnx2x: include irq.h for irqreturn_t definitions
|
||||||
|
|
||||||
|
The bnx2x driver fails to build on ARM with:
|
||||||
|
|
||||||
|
In file included from drivers/net/ethernet/broadcom/bnx2x/bnx2x_link.c:28:0:
|
||||||
|
drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h:243:1: error: unknown type name 'irqreturn_t'
|
||||||
|
irqreturn_t bnx2x_msix_sp_int(int irq, void *dev_instance);
|
||||||
|
^
|
||||||
|
drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h:251:1: error: unknown type name 'irqreturn_t'
|
||||||
|
irqreturn_t bnx2x_interrupt(int irq, void *dev_instance);
|
||||||
|
^
|
||||||
|
|
||||||
|
Nothing in bnx2x_link.c or bnx2x_cmn.h is explicitly including the irq
|
||||||
|
definitions, so we add an include of linux/irq.h to pick them up.
|
||||||
|
|
||||||
|
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
---
|
||||||
|
drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h
|
||||||
|
index a89a40f88c25..384025605948 100644
|
||||||
|
--- a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h
|
||||||
|
+++ b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.h
|
||||||
|
@@ -21,6 +21,7 @@
|
||||||
|
#include <linux/pci.h>
|
||||||
|
#include <linux/netdevice.h>
|
||||||
|
#include <linux/etherdevice.h>
|
||||||
|
+#include <linux/irq.h>
|
||||||
|
|
||||||
|
#include "bnx2x.h"
|
||||||
|
#include "bnx2x_sriov.h"
|
||||||
|
--
|
||||||
|
1.8.5.3
|
||||||
|
|
35
net-enic-include-irq.h-for-irqreturn_t-definitions.patch
Normal file
35
net-enic-include-irq.h-for-irqreturn_t-definitions.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From aaed30ef3df1c0679c57da27c268a518921f1ed8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
Date: Wed, 2 Apr 2014 09:23:17 -0400
|
||||||
|
Subject: [PATCH] net: enic: include irq.h for irqreturn_t definitions
|
||||||
|
|
||||||
|
The enic driver fails to build on ARM with:
|
||||||
|
|
||||||
|
In file included from drivers/net/ethernet/cisco/enic/enic_res.c:40:0:
|
||||||
|
drivers/net/ethernet/cisco/enic/enic.h:48:2: error: expected specifier-qualifier-list before 'irqreturn_t'
|
||||||
|
irqreturn_t (*isr)(int, void *);
|
||||||
|
^
|
||||||
|
|
||||||
|
Nothing in the driver is explicitly including the irq definitions, so we add
|
||||||
|
an include of linux/irq.h to pick them up.
|
||||||
|
|
||||||
|
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
---
|
||||||
|
drivers/net/ethernet/cisco/enic/enic.h | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/net/ethernet/cisco/enic/enic.h b/drivers/net/ethernet/cisco/enic/enic.h
|
||||||
|
index e9f7c656ddda..e35c8e0202ad 100644
|
||||||
|
--- a/drivers/net/ethernet/cisco/enic/enic.h
|
||||||
|
+++ b/drivers/net/ethernet/cisco/enic/enic.h
|
||||||
|
@@ -29,6 +29,7 @@
|
||||||
|
#include "vnic_stats.h"
|
||||||
|
#include "vnic_nic.h"
|
||||||
|
#include "vnic_rss.h"
|
||||||
|
+#include <linux/irq.h>
|
||||||
|
|
||||||
|
#define DRV_NAME "enic"
|
||||||
|
#define DRV_DESCRIPTION "Cisco VIC Ethernet NIC Driver"
|
||||||
|
--
|
||||||
|
1.8.5.3
|
||||||
|
|
36
net-qlcnic-include-irq.h-for-irq-definitions.patch
Normal file
36
net-qlcnic-include-irq.h-for-irq-definitions.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From 0115d51042e99a35c3bf83a01b9e776dedea7bdb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
Date: Wed, 2 Apr 2014 10:48:37 -0400
|
||||||
|
Subject: [PATCH] net: qlcnic: include irq.h for irq definitions
|
||||||
|
|
||||||
|
The qlcnic driver fails to build on ARM with errors like:
|
||||||
|
|
||||||
|
In file included from drivers/net/ethernet/qlogic/qlcnic/qlcnic.h:36:0,
|
||||||
|
from drivers/net/ethernet/qlogic/qlcnic/qlcnic_hw.c:8:
|
||||||
|
drivers/net/ethernet/qlogic/qlcnic/qlcnic_83xx_hw.h:585:1: error: unknown type name 'irqreturn_t'
|
||||||
|
irqreturn_t qlcnic_83xx_clear_legacy_intr(struct qlcnic_adapter *);
|
||||||
|
^
|
||||||
|
|
||||||
|
Nothing in the driver is explicitly including the irq definitions, so we
|
||||||
|
add an include of linux/irq.h to pick them up.
|
||||||
|
|
||||||
|
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
---
|
||||||
|
drivers/net/ethernet/qlogic/qlcnic/qlcnic.h | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/net/ethernet/qlogic/qlcnic/qlcnic.h b/drivers/net/ethernet/qlogic/qlcnic/qlcnic.h
|
||||||
|
index f19f81cde134..cbc897e6bb8f 100644
|
||||||
|
--- a/drivers/net/ethernet/qlogic/qlcnic/qlcnic.h
|
||||||
|
+++ b/drivers/net/ethernet/qlogic/qlcnic/qlcnic.h
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
#include <linux/ethtool.h>
|
||||||
|
#include <linux/mii.h>
|
||||||
|
#include <linux/timer.h>
|
||||||
|
+#include <linux/irq.h>
|
||||||
|
|
||||||
|
#include <linux/vmalloc.h>
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.5.3
|
||||||
|
|
Loading…
Reference in New Issue
Block a user