v3.6-8559-ge9eca4d
This commit is contained in:
parent
393a84a43a
commit
ad887f5270
@ -1,15 +0,0 @@
|
|||||||
diff --git a/sound/pci/Kconfig b/sound/pci/Kconfig
|
|
||||||
index ff3af6e..f99fa25 100644
|
|
||||||
--- a/sound/pci/Kconfig
|
|
||||||
+++ b/sound/pci/Kconfig
|
|
||||||
@@ -2,8 +2,8 @@
|
|
||||||
|
|
||||||
config SND_TEA575X
|
|
||||||
tristate
|
|
||||||
- depends on SND_FM801_TEA575X_BOOL || SND_ES1968_RADIO || RADIO_SF16FMR2 || RADIO_MAXIRADIO
|
|
||||||
- default SND_FM801 || SND_ES1968 || RADIO_SF16FMR2 || RADIO_MAXIRADIO
|
|
||||||
+ depends on SND_FM801_TEA575X_BOOL || SND_ES1968_RADIO || RADIO_SF16FMR2 || RADIO_MAXIRADIO || RADIO_SHARK
|
|
||||||
+ default SND_FM801 || SND_ES1968 || RADIO_SF16FMR2 || RADIO_MAXIRADIO || RADIO_SHARK
|
|
||||||
|
|
||||||
menuconfig SND_PCI
|
|
||||||
bool "PCI sound devices"
|
|
@ -1,39 +0,0 @@
|
|||||||
read_current_timer is used in the get_cycles() function when
|
|
||||||
ARM_ARCH_TIMER is set, and that function can be inlined into
|
|
||||||
driver modules, so we should export the function to avoid
|
|
||||||
errors like
|
|
||||||
|
|
||||||
ERROR: "read_current_timer" [drivers/video/udlfb.ko] undefined!
|
|
||||||
ERROR: "read_current_timer" [crypto/tcrypt.ko] undefined!
|
|
||||||
|
|
||||||
Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>
|
|
||||||
Cc: Shinya Kuribayashi <shinya.kuribayashi.px@xxxxxxxxxxx>
|
|
||||||
Cc: Stephen Boyd <sboyd@xxxxxxxxxxxxxx>
|
|
||||||
Cc: Will Deacon <will.deacon@xxxxxxx>
|
|
||||||
Cc: Russell King <rmk+kernel@xxxxxxxxxxxxxxxx>
|
|
||||||
---
|
|
||||||
arch/arm/kernel/arch_timer.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/arch/arm/kernel/arch_timer.c b/arch/arm/kernel/arch_timer.c
|
|
||||||
index cf25880..6327d1f 100644
|
|
||||||
--- a/arch/arm/kernel/arch_timer.c
|
|
||||||
+++ b/arch/arm/kernel/arch_timer.c
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#include <linux/device.h>
|
|
||||||
#include <linux/smp.h>
|
|
||||||
#include <linux/cpu.h>
|
|
||||||
+#include <linux/export.h>
|
|
||||||
#include <linux/jiffies.h>
|
|
||||||
#include <linux/clockchips.h>
|
|
||||||
#include <linux/interrupt.h>
|
|
||||||
@@ -232,6 +233,7 @@ int read_current_timer(unsigned long *timer_val)
|
|
||||||
*timer_val = arch_counter_get_cntpct();
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
+EXPORT_SYMBOL_GPL(read_current_timer);
|
|
||||||
|
|
||||||
static struct clocksource clocksource_counter = {
|
|
||||||
.name = "arch_sys_counter",
|
|
||||||
--
|
|
||||||
1.7.10
|
|
12
kernel.spec
12
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 5
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -725,8 +725,7 @@ Patch14010: lis3-improve-handling-of-null-rate.patch
|
|||||||
|
|
||||||
|
|
||||||
# ARM
|
# ARM
|
||||||
Patch21000: arm-read_current_timer.patch
|
|
||||||
Patch21002: arm-fix_radio_shark.patch
|
|
||||||
# OMAP
|
# OMAP
|
||||||
|
|
||||||
# ARM tegra
|
# ARM tegra
|
||||||
@ -1326,8 +1325,6 @@ ApplyPatch vmbugon-warnon.patch
|
|||||||
#
|
#
|
||||||
# ARM
|
# ARM
|
||||||
#
|
#
|
||||||
ApplyPatch arm-read_current_timer.patch
|
|
||||||
ApplyPatch arm-fix_radio_shark.patch
|
|
||||||
ApplyPatch arm-tegra-nvec-kconfig.patch
|
ApplyPatch arm-tegra-nvec-kconfig.patch
|
||||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
ApplyPatch arm-tegra-sdhci-module-fix.patch
|
ApplyPatch arm-tegra-sdhci-module-fix.patch
|
||||||
@ -2314,6 +2311,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 08 2012 Justin M. Forbes <jforbes@redhat.com>
|
||||||
|
- v3.6-8559-ge9eca4d
|
||||||
|
|
||||||
* Sat Oct 06 2012 Josh Boyer <jwboyer@redhat.com>
|
* Sat Oct 06 2012 Josh Boyer <jwboyer@redhat.com>
|
||||||
- secure boot modsign depends on CONFIG_MODULE_SIG not CONFIG_MODULES
|
- secure boot modsign depends on CONFIG_MODULE_SIG not CONFIG_MODULES
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user