Add fix from linux-next for mvebu Armada 8K macbin boot regression
This commit is contained in:
parent
70ef9fe7fb
commit
ac8c6dca51
70
arm64-dts-marvell-armada-cp110-fix-hang.patch
Normal file
70
arm64-dts-marvell-armada-cp110-fix-hang.patch
Normal file
@ -0,0 +1,70 @@
|
||||
From f43194c1447c9536efb0859c2f3f46f6bf2b9154 Mon Sep 17 00:00:00 2001
|
||||
From: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
Date: Wed, 25 Apr 2018 20:19:47 +0200
|
||||
Subject: ARM64: dts: marvell: armada-cp110: Add mg_core_clk for ethernet node
|
||||
|
||||
Marvell PPv2.2 controller present on CP-110 need the extra "mg_core_clk"
|
||||
clock to avoid system hangs when powering some network interfaces up.
|
||||
|
||||
This issue appeared after a recent clock rework on Armada 7K/8K platforms.
|
||||
|
||||
This commit adds the new clock and updates the documentation accordingly.
|
||||
|
||||
[gregory.clement: use the real first commit to fix and add the cc:stable
|
||||
flag]
|
||||
Fixes: e3af9f7c6ece ("RM64: dts: marvell: armada-cp110: Fix clock resources for various node")
|
||||
Cc: <stable@vger.kernel.org>
|
||||
Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
|
||||
---
|
||||
Documentation/devicetree/bindings/net/marvell-pp2.txt | 9 +++++----
|
||||
arch/arm64/boot/dts/marvell/armada-cp110.dtsi | 5 +++--
|
||||
2 files changed, 8 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/Documentation/devicetree/bindings/net/marvell-pp2.txt b/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
||||
index 1814fa1..fc019df 100644
|
||||
--- a/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
||||
+++ b/Documentation/devicetree/bindings/net/marvell-pp2.txt
|
||||
@@ -21,9 +21,10 @@ Required properties:
|
||||
- main controller clock (for both armada-375-pp2 and armada-7k-pp2)
|
||||
- GOP clock (for both armada-375-pp2 and armada-7k-pp2)
|
||||
- MG clock (only for armada-7k-pp2)
|
||||
+ - MG Core clock (only for armada-7k-pp2)
|
||||
- AXI clock (only for armada-7k-pp2)
|
||||
-- clock-names: names of used clocks, must be "pp_clk", "gop_clk", "mg_clk"
|
||||
- and "axi_clk" (the 2 latter only for armada-7k-pp2).
|
||||
+- clock-names: names of used clocks, must be "pp_clk", "gop_clk", "mg_clk",
|
||||
+ "mg_core_clk" and "axi_clk" (the 3 latter only for armada-7k-pp2).
|
||||
|
||||
The ethernet ports are represented by subnodes. At least one port is
|
||||
required.
|
||||
@@ -80,8 +81,8 @@ cpm_ethernet: ethernet@0 {
|
||||
compatible = "marvell,armada-7k-pp22";
|
||||
reg = <0x0 0x100000>, <0x129000 0xb000>;
|
||||
clocks = <&cpm_syscon0 1 3>, <&cpm_syscon0 1 9>,
|
||||
- <&cpm_syscon0 1 5>, <&cpm_syscon0 1 18>;
|
||||
- clock-names = "pp_clk", "gop_clk", "gp_clk", "axi_clk";
|
||||
+ <&cpm_syscon0 1 5>, <&cpm_syscon0 1 6>, <&cpm_syscon0 1 18>;
|
||||
+ clock-names = "pp_clk", "gop_clk", "mg_clk", "mg_core_clk", "axi_clk";
|
||||
|
||||
eth0: eth0 {
|
||||
interrupts = <ICU_GRP_NSR 39 IRQ_TYPE_LEVEL_HIGH>,
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-cp110.dtsi b/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
||||
index ca22f9d..ed2f123 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-cp110.dtsi
|
||||
@@ -38,9 +38,10 @@
|
||||
compatible = "marvell,armada-7k-pp22";
|
||||
reg = <0x0 0x100000>, <0x129000 0xb000>;
|
||||
clocks = <&CP110_LABEL(clk) 1 3>, <&CP110_LABEL(clk) 1 9>,
|
||||
- <&CP110_LABEL(clk) 1 5>, <&CP110_LABEL(clk) 1 18>;
|
||||
+ <&CP110_LABEL(clk) 1 5>, <&CP110_LABEL(clk) 1 6>,
|
||||
+ <&CP110_LABEL(clk) 1 18>;
|
||||
clock-names = "pp_clk", "gop_clk",
|
||||
- "mg_clk", "axi_clk";
|
||||
+ "mg_clk", "mg_core_clk", "axi_clk";
|
||||
marvell,system-controller = <&CP110_LABEL(syscon0)>;
|
||||
status = "disabled";
|
||||
dma-coherent;
|
||||
--
|
||||
cgit v1.1
|
34
kernel.spec
34
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 1.arm1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -567,41 +567,42 @@ Patch300: arm64-Add-option-of-13-for-FORCE_MAX_ZONEORDER.patch
|
||||
|
||||
# http://www.spinics.net/lists/linux-tegra/msg26029.html
|
||||
Patch301: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
|
||||
|
||||
# http://patchwork.ozlabs.org/patch/587554/
|
||||
Patch302: ARM-tegra-usb-no-reset.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10351797/
|
||||
Patch303: ACPI-scan-Fix-regression-related-to-X-Gene-UARTs.patch
|
||||
# rhbz 1574718
|
||||
Patch304: ACPI-irq-Workaround-firmware-issue-on-X-Gene-based-m400.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/9820417/
|
||||
Patch303: qcom-msm89xx-fixes.patch
|
||||
Patch305: qcom-msm89xx-fixes.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10173115/
|
||||
Patch304: arm-dts-imx6qdl-udoo-Disable-usbh1-to-avoid-kernel-hang.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10351797/
|
||||
Patch305: ACPI-scan-Fix-regression-related-to-X-Gene-UARTs.patch
|
||||
Patch306: arm-dts-imx6qdl-udoo-Disable-usbh1-to-avoid-kernel-hang.patch
|
||||
|
||||
# https://marc.info/?l=linux-kernel&m=152328880417846&w=2
|
||||
Patch308: arm64-thunderx-crypto-zip-fixes.patch
|
||||
Patch307: arm64-thunderx-crypto-zip-fixes.patch
|
||||
|
||||
# https://www.spinics.net/lists/linux-crypto/msg32725.html
|
||||
Patch309: crypto-testmgr-Allow-different-compression-results.patch
|
||||
Patch308: crypto-testmgr-Allow-different-compression-results.patch
|
||||
|
||||
Patch310: arm-tegra-fix-nouveau-crash.patch
|
||||
Patch309: arm-tegra-fix-nouveau-crash.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10346089/
|
||||
Patch311: arm-dts-Add-am335x-pocketbeagle.patch
|
||||
Patch310: arm-dts-Add-am335x-pocketbeagle.patch
|
||||
|
||||
# https://www.spinics.net/lists/linux-tegra/msg32920.html
|
||||
Patch312: arm-tegra-USB-driver-dependency-fix.patch
|
||||
Patch311: arm-tegra-USB-driver-dependency-fix.patch
|
||||
|
||||
# rhbz 1574718
|
||||
Patch313: ACPI-irq-Workaround-firmware-issue-on-X-Gene-based-m400.patch
|
||||
# In linux-next, due in stable
|
||||
Patch312: arm64-dts-marvell-armada-cp110-fix-hang.patch
|
||||
|
||||
# https://patchwork.kernel.org/patch/10354521/
|
||||
# https://patchwork.kernel.org/patch/10354187/
|
||||
# https://patchwork.kernel.org/patch/10306793/
|
||||
# https://patchwork.kernel.org/patch/10133165/
|
||||
Patch315: mvebu-a37xx-fixes.patch
|
||||
Patch313: mvebu-a37xx-fixes.patch
|
||||
|
||||
Patch324: bcm283x-clk-audio-fixes.patch
|
||||
|
||||
@ -1875,6 +1876,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Thu May 10 2018 Peter Robinson <pbrobinson@fedoraproject.org>
|
||||
- Add fix from linux-next for mvebu Armada 8K macbin boot regression
|
||||
|
||||
* Thu May 10 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.17.0-0.rc4.git3.1
|
||||
- Linux v4.17-rc4-38-g008464a9360e
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user