Linux v3.9-9409-g8665218
This commit is contained in:
parent
deb816ab2a
commit
a93604a9ba
@ -0,0 +1,56 @@
|
|||||||
|
From 883e2c26855e19e19bfb985221ae5a09db26a1c4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@obiwan.gha.chartermi.net>
|
||||||
|
Date: Fri, 3 May 2013 17:10:32 -0400
|
||||||
|
Subject: [PATCH] Revert "drm/i915: revert eDP bpp clamping code changes"
|
||||||
|
|
||||||
|
This reverts commit 57c219633275c7e7413f8bc7be250dc092887458.
|
||||||
|
---
|
||||||
|
drivers/gpu/drm/i915/intel_dp.c | 18 ++++--------------
|
||||||
|
1 file changed, 4 insertions(+), 14 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
index fb2fbc1..e0ee2ca 100644
|
||||||
|
--- a/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
+++ b/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
@@ -702,6 +702,9 @@ intel_dp_compute_config(struct intel_encoder *encoder,
|
||||||
|
/* Walk through all bpp values. Luckily they're all nicely spaced with 2
|
||||||
|
* bpc in between. */
|
||||||
|
bpp = min_t(int, 8*3, pipe_config->pipe_bpp);
|
||||||
|
+ if (is_edp(intel_dp) && dev_priv->edp.bpp)
|
||||||
|
+ bpp = min_t(int, bpp, dev_priv->edp.bpp);
|
||||||
|
+
|
||||||
|
for (; bpp >= 6*3; bpp -= 2*3) {
|
||||||
|
mode_rate = intel_dp_link_required(target_clock, bpp);
|
||||||
|
|
||||||
|
@@ -739,6 +742,7 @@ found:
|
||||||
|
intel_dp->link_bw = bws[clock];
|
||||||
|
intel_dp->lane_count = lane_count;
|
||||||
|
adjusted_mode->clock = drm_dp_bw_code_to_link_rate(intel_dp->link_bw);
|
||||||
|
+ pipe_config->pipe_bpp = bpp;
|
||||||
|
pipe_config->pixel_target_clock = target_clock;
|
||||||
|
|
||||||
|
DRM_DEBUG_KMS("DP link bw %02x lane count %d clock %d bpp %d\n",
|
||||||
|
@@ -751,20 +755,6 @@ found:
|
||||||
|
target_clock, adjusted_mode->clock,
|
||||||
|
&pipe_config->dp_m_n);
|
||||||
|
|
||||||
|
- /*
|
||||||
|
- * XXX: We have a strange regression where using the vbt edp bpp value
|
||||||
|
- * for the link bw computation results in black screens, the panel only
|
||||||
|
- * works when we do the computation at the usual 24bpp (but still
|
||||||
|
- * requires us to use 18bpp). Until that's fully debugged, stay
|
||||||
|
- * bug-for-bug compatible with the old code.
|
||||||
|
- */
|
||||||
|
- if (is_edp(intel_dp) && dev_priv->edp.bpp) {
|
||||||
|
- DRM_DEBUG_KMS("clamping display bpc (was %d) to eDP (%d)\n",
|
||||||
|
- bpp, dev_priv->edp.bpp);
|
||||||
|
- bpp = min_t(int, bpp, dev_priv->edp.bpp);
|
||||||
|
- }
|
||||||
|
- pipe_config->pipe_bpp = bpp;
|
||||||
|
-
|
||||||
|
return true;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.2.1
|
||||||
|
|
@ -37,6 +37,7 @@ CONFIG_ARM_ARCH_TIMER=y
|
|||||||
CONFIG_ARCH_HAS_TICK_BROADCAST=y
|
CONFIG_ARCH_HAS_TICK_BROADCAST=y
|
||||||
CONFIG_ALWAYS_USE_PERSISTENT_CLOCK=y
|
CONFIG_ALWAYS_USE_PERSISTENT_CLOCK=y
|
||||||
|
|
||||||
|
# CONFIG_MCPM is not set
|
||||||
# CONFIG_OABI_COMPAT is not set
|
# CONFIG_OABI_COMPAT is not set
|
||||||
# CONFIG_FPE_NWFPE is not set
|
# CONFIG_FPE_NWFPE is not set
|
||||||
# CONFIG_FPE_FASTFPE is not set
|
# CONFIG_FPE_FASTFPE is not set
|
||||||
|
@ -4623,6 +4623,7 @@ CONFIG_RCU_CPU_STALL_TIMEOUT=60
|
|||||||
# CONFIG_RCU_TORTURE_TEST is not set
|
# CONFIG_RCU_TORTURE_TEST is not set
|
||||||
# CONFIG_RCU_TRACE is not set
|
# CONFIG_RCU_TRACE is not set
|
||||||
# CONFIG_RCU_CPU_STALL_INFO is not set
|
# CONFIG_RCU_CPU_STALL_INFO is not set
|
||||||
|
# CONFIG_RCU_USER_QS is not set
|
||||||
CONFIG_SPARSE_RCU_POINTER=y
|
CONFIG_SPARSE_RCU_POINTER=y
|
||||||
|
|
||||||
CONFIG_KSM=y
|
CONFIG_KSM=y
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 14
|
%define gitrev 15
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -736,6 +736,9 @@ Patch23006: fix-child-thread-introspection.patch
|
|||||||
|
|
||||||
Patch25014: blkcg-fix-scheduling-while-atomic-in-blk_queue_bypass_start.patch
|
Patch25014: blkcg-fix-scheduling-while-atomic-in-blk_queue_bypass_start.patch
|
||||||
|
|
||||||
|
# Fix i915 on Macbook Pro 10,2 machines
|
||||||
|
Patch25015: 0001-Revert-drm-i915-revert-eDP-bpp-clamping-code-changes.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1418,6 +1421,9 @@ ApplyPatch fix-child-thread-introspection.patch
|
|||||||
|
|
||||||
ApplyPatch blkcg-fix-scheduling-while-atomic-in-blk_queue_bypass_start.patch
|
ApplyPatch blkcg-fix-scheduling-while-atomic-in-blk_queue_bypass_start.patch
|
||||||
|
|
||||||
|
# Fix i915 on Macbook Pro 10,2 machines
|
||||||
|
ApplyPatch 0001-Revert-drm-i915-revert-eDP-bpp-clamping-code-changes.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2243,6 +2249,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 03 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git15.1
|
||||||
|
- Linux v3.9-9409-g8665218
|
||||||
|
|
||||||
* Fri May 03 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git14.1
|
* Fri May 03 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git14.1
|
||||||
- Linux v3.9-8933-gce85722
|
- Linux v3.9-8933-gce85722
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user