Linux v5.5-rc1
This commit is contained in:
parent
492eb2410f
commit
a508a8e468
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
b0d4beaa5a4b7d31070c41c2e50740304a3f1138
|
||||
e42617b825f8073569da76dc4510bfa019b1c35a
|
||||
|
@ -4842,6 +4842,7 @@ CONFIG_QCOM_L2_PMU=y
|
||||
CONFIG_QCOM_L3_PMU=y
|
||||
CONFIG_QCOM_LLCC=m
|
||||
CONFIG_QCOM_MDT_LOADER=m
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_Q6V5_ADSP=m
|
||||
CONFIG_QCOM_Q6V5_MSS=m
|
||||
|
@ -4821,6 +4821,7 @@ CONFIG_QCOM_L2_PMU=y
|
||||
CONFIG_QCOM_L3_PMU=y
|
||||
CONFIG_QCOM_LLCC=m
|
||||
CONFIG_QCOM_MDT_LOADER=m
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_Q6V5_ADSP=m
|
||||
CONFIG_QCOM_Q6V5_MSS=m
|
||||
|
@ -4929,6 +4929,7 @@ CONFIG_QCOM_HFPLL=m
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QCOM_IOMMU=y
|
||||
# CONFIG_QCOM_LLCC is not set
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_PM8XXX_XOADC=m
|
||||
CONFIG_QCOM_PM=y
|
||||
|
@ -4909,6 +4909,7 @@ CONFIG_QCOM_HFPLL=m
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
CONFIG_QCOM_IOMMU=y
|
||||
# CONFIG_QCOM_LLCC is not set
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_PM8XXX_XOADC=m
|
||||
CONFIG_QCOM_PM=y
|
||||
|
@ -4737,6 +4737,7 @@ CONFIG_QCOM_HFPLL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
# CONFIG_QCOM_LLCC is not set
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_PM8XXX_XOADC=m
|
||||
CONFIG_QCOM_RMTFS_MEM=m
|
||||
|
@ -4717,6 +4717,7 @@ CONFIG_QCOM_HFPLL=m
|
||||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_QCOM_HIDMA_MGMT is not set
|
||||
# CONFIG_QCOM_LLCC is not set
|
||||
CONFIG_QCOM_OCMEM=m
|
||||
CONFIG_QCOM_PDC=y
|
||||
CONFIG_QCOM_PM8XXX_XOADC=m
|
||||
CONFIG_QCOM_RMTFS_MEM=m
|
||||
|
10
kernel.spec
10
kernel.spec
@ -102,9 +102,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 0
|
||||
%global rcrev 1
|
||||
# The git snapshot level
|
||||
%define gitrev 7
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 5.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -852,6 +852,9 @@ Patch526: libertas-Fix-two-buffer-overflows-at-parsing-bss-descriptor.patch
|
||||
# CVE-2019-14901 rhbz 1773519 1776184
|
||||
Patch527: mwifiex-Fix-heap-overflow-in-mmwifiex_process_tdls_action_frame.patch
|
||||
|
||||
# Test fix for PPC build
|
||||
Patch528: netfilter_ppc_fix.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -2887,6 +2890,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Dec 09 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.5.0-0.rc1.git0.1
|
||||
- Linux v5.5-rc1
|
||||
|
||||
* Mon Dec 09 2019 Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
- Disable debugging options.
|
||||
|
||||
|
69
netfilter_ppc_fix.patch
Normal file
69
netfilter_ppc_fix.patch
Normal file
@ -0,0 +1,69 @@
|
||||
From: Pablo Neira Ayuso <pablo () netfilter ! org>
|
||||
Date: Sat, 07 Dec 2019 17:38:05 +0000
|
||||
To: netfilter-devel
|
||||
Subject: Re: [PATCH] netfilter: nf_flow_table_offload: Correct memcpy size for flow_overload_mangle
|
||||
|
||||
I'm attaching a tentative patch to address this problem.
|
||||
|
||||
Thanks.
|
||||
|
||||
diff --git a/net/netfilter/nf_flow_table_offload.c b/net/netfilter/nf_flow_table_offload.c
|
||||
index c54c9a6cc981..3d6b2bea9a63 100644
|
||||
--- a/net/netfilter/nf_flow_table_offload.c
|
||||
+++ b/net/netfilter/nf_flow_table_offload.c
|
||||
@@ -326,23 +326,23 @@ static void flow_offload_port_snat(struct net *net,
|
||||
struct nf_flow_rule *flow_rule)
|
||||
{
|
||||
struct flow_action_entry *entry = flow_action_entry_next(flow_rule);
|
||||
- u32 mask = ~htonl(0xffff0000);
|
||||
- __be16 port;
|
||||
+ u32 mask = ~htonl(0xffff0000), port;
|
||||
u32 offset;
|
||||
|
||||
switch (dir) {
|
||||
case FLOW_OFFLOAD_DIR_ORIGINAL:
|
||||
- port = flow->tuplehash[FLOW_OFFLOAD_DIR_REPLY].tuple.dst_port;
|
||||
+ port = ntohs(flow->tuplehash[FLOW_OFFLOAD_DIR_REPLY].tuple.dst_port);
|
||||
offset = 0; /* offsetof(struct tcphdr, source); */
|
||||
break;
|
||||
case FLOW_OFFLOAD_DIR_REPLY:
|
||||
- port = flow->tuplehash[FLOW_OFFLOAD_DIR_ORIGINAL].tuple.src_port;
|
||||
+ port = ntohs(flow->tuplehash[FLOW_OFFLOAD_DIR_ORIGINAL].tuple.src_port);
|
||||
offset = 0; /* offsetof(struct tcphdr, dest); */
|
||||
break;
|
||||
default:
|
||||
break;
|
||||
}
|
||||
|
||||
+ port = htonl(port << 16);
|
||||
flow_offload_mangle(entry, flow_offload_l4proto(flow), offset,
|
||||
(u8 *)&port, (u8 *)&mask);
|
||||
}
|
||||
@@ -353,23 +353,23 @@ static void flow_offload_port_dnat(struct net *net,
|
||||
struct nf_flow_rule *flow_rule)
|
||||
{
|
||||
struct flow_action_entry *entry = flow_action_entry_next(flow_rule);
|
||||
- u32 mask = ~htonl(0xffff);
|
||||
- __be16 port;
|
||||
+ u32 mask = ~htonl(0xffff), port;
|
||||
u32 offset;
|
||||
|
||||
switch (dir) {
|
||||
case FLOW_OFFLOAD_DIR_ORIGINAL:
|
||||
- port = flow->tuplehash[FLOW_OFFLOAD_DIR_REPLY].tuple.dst_port;
|
||||
+ port = ntohs(flow->tuplehash[FLOW_OFFLOAD_DIR_REPLY].tuple.dst_port);
|
||||
offset = 0; /* offsetof(struct tcphdr, source); */
|
||||
break;
|
||||
case FLOW_OFFLOAD_DIR_REPLY:
|
||||
- port = flow->tuplehash[FLOW_OFFLOAD_DIR_ORIGINAL].tuple.src_port;
|
||||
+ port = ntohs(flow->tuplehash[FLOW_OFFLOAD_DIR_ORIGINAL].tuple.src_port);
|
||||
offset = 0; /* offsetof(struct tcphdr, dest); */
|
||||
break;
|
||||
default:
|
||||
break;
|
||||
}
|
||||
|
||||
+ port = htonl(port);
|
||||
flow_offload_mangle(entry, flow_offload_l4proto(flow), offset,
|
||||
(u8 *)&port, (u8 *)&mask);
|
||||
}
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (linux-5.4.tar.xz) = 9f60f77e8ab972b9438ac648bed17551c8491d6585a5e85f694b2eaa4c623fbc61eb18419b2656b6795eac5deec0edaa04547fc6723fbda52256bd7f3486898f
|
||||
SHA512 (patch-5.4-git7.xz) = 915f14ae30e7d7dc238ac8f90e95ceba5c56c9c356e7d88bfbc9acaf61b0d34347a10ebdd9d0fa6a91ca8715efdc5c1f41406dae2a986d79c9236d696f29c89b
|
||||
SHA512 (patch-5.5-rc1.xz) = 151d993746f5947827617468b79541f8376502f9ad2285b675f4e4464dfd427e5874a2a9976af1fa9867ac1728c9fda13cad85ac810e12b1fc039a9b2ee5a174
|
||||
|
Loading…
Reference in New Issue
Block a user