kernel-5.17-0.rc8.551acdc3c3d2.124
* Fri Mar 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc8.551acdc3c3d2.124] - redhat/Makefile: Reorganize variables (Prarit Bhargava) - redhat/Makefile: Add some descriptions (Prarit Bhargava) - redhat/Makefile: Move SNAPSHOT check (Prarit Bhargava) - redhat/Makefile: Deprecate BREW_FLAGS, KOJI_FLAGS, and TEST_FLAGS (Prarit Bhargava) - redhat/genspec.sh: Rework RPMVERSION variable (Prarit Bhargava) - redhat/Makefile: Remove dead comment (Prarit Bhargava) - redhat/Makefile: Cleanup KABI* variables. (Prarit Bhargava) - redhat/Makefile.variables: Default RHGITCOMMIT to HEAD (Prarit Bhargava) - redhat/scripts/create-tarball.sh: Use Makefile TARBALL variable (Prarit Bhargava) - redhat/Makefile: Remove extra DIST_BRANCH (Prarit Bhargava) - redhat/Makefile: Remove STAMP_VERSION (Prarit Bhargava) - redhat/Makefile: Move NO_CONFIGCHECKS to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move RHJOBS to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move RHGIT* variables to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move PREBUILD_GIT_ONLY to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move BUILD to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move BUILD_FLAGS to Makefile.variables. (Prarit Bhargava) - redhat/Makefile: Move BUILD_PROFILE to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Move BUILD_TARGET and BUILD_SCRATCH_TARGET to Makefile.variables (Prarit Bhargava) - redhat/Makefile: Remove RHPRODUCT variable (Prarit Bhargava) - redhat/Makefile: Cleanup DISTRO variable (Prarit Bhargava) - redhat/Makefile: Move HEAD to Makefile.variables. (Prarit Bhargava) - redhat: Combine Makefile and Makefile.common (Prarit Bhargava) - redhat/koji/Makefile: Decouple koji Makefile from Makefile.common (Prarit Bhargava) - mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
dab93b00b0
commit
a2b528f09e
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 124
|
||||
RHEL_RELEASE = 125
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,5 +1,5 @@
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/764959c3db54fee825430eb2764be7f127419dd9
|
||||
764959c3db54fee825430eb2764be7f127419dd9 mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/66cfe6e6431fe582aebf6beb00fc57f156616bad
|
||||
66cfe6e6431fe582aebf6beb00fc57f156616bad mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
|
||||
|
||||
"https://gitlab.com/cki-project/kernel-ark/-/commit"/4f79b3c547b8e3dbc014058a8adffe0fe8cd5e4b
|
||||
4f79b3c547b8e3dbc014058a8adffe0fe8cd5e4b objtool: check: give big enough buffer for pv_ops
|
||||
|
17
kernel.spec
17
kernel.spec
@ -87,7 +87,7 @@ Summary: The Linux kernel
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc8.20220316git56e337f2cf13.124
|
||||
%global distro_build 0.rc8.20220318git551acdc3c3d2.125
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -132,13 +132,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.17.0
|
||||
%define patchversion 5.17
|
||||
%define pkgrelease 0.rc8.20220316git56e337f2cf13.124
|
||||
%define pkgrelease 0.rc8.20220318git551acdc3c3d2.125
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 17
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc8.20220316git56e337f2cf13.124%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc8.20220318git551acdc3c3d2.125%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -695,7 +695,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.17-rc8-3-g56e337f2cf13.tar.xz
|
||||
Source0: linux-5.17-rc8-45-g551acdc3c3d2.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1391,8 +1391,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.17-rc8-3-g56e337f2cf13 -c
|
||||
mv linux-5.17-rc8-3-g56e337f2cf13 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.17-rc8-45-g551acdc3c3d2 -c
|
||||
mv linux-5.17-rc8-45-g551acdc3c3d2 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -3019,7 +3019,7 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed Mar 16 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc8.56e337f2cf13.123]
|
||||
* Fri Mar 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc8.551acdc3c3d2.124]
|
||||
- redhat/Makefile: Reorganize variables (Prarit Bhargava)
|
||||
- redhat/Makefile: Add some descriptions (Prarit Bhargava)
|
||||
- redhat/Makefile: Move SNAPSHOT check (Prarit Bhargava)
|
||||
@ -3046,6 +3046,9 @@ fi
|
||||
- redhat/koji/Makefile: Decouple koji Makefile from Makefile.common (Prarit Bhargava)
|
||||
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
|
||||
|
||||
* Fri Mar 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc8.551acdc3c3d2.124]
|
||||
- Set CONFIG_SND_SOC_SOF_MT8195 for Fedora and turn on VDPA_SIM_BLOCK (Justin M. Forbes)
|
||||
|
||||
* Wed Mar 16 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc8.56e337f2cf13.123]
|
||||
- Add asus_wmi_sensors modules to filters for Fedora (Justin M. Forbes)
|
||||
- redhat: spec: trigger dracut when modules are installed separately (Jan Stancek)
|
||||
|
@ -547,7 +547,7 @@ index c68e694fca26..146cba5ae5bc 100644
|
||||
return ctx.rc;
|
||||
}
|
||||
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
|
||||
index 1331756d4cfc..4b5257f5e2c4 100644
|
||||
index 8b2e5ef15559..ac0291ef0838 100644
|
||||
--- a/drivers/acpi/scan.c
|
||||
+++ b/drivers/acpi/scan.c
|
||||
@@ -1769,6 +1769,15 @@ static bool acpi_device_enumeration_by_parent(struct acpi_device *device)
|
||||
@ -852,7 +852,7 @@ index c02ff25dd477..d860f8eb9a81 100644
|
||||
obj-$(CONFIG_EFI_RCI2_TABLE) += rci2-table.o
|
||||
obj-$(CONFIG_EFI_EMBEDDED_FIRMWARE) += embedded-firmware.o
|
||||
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
||||
index 7de3f5b6e8d0..95b1c35b347c 100644
|
||||
index 5502e176d51b..93b61ca552d6 100644
|
||||
--- a/drivers/firmware/efi/efi.c
|
||||
+++ b/drivers/firmware/efi/efi.c
|
||||
@@ -31,6 +31,7 @@
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.17-rc8-3-g56e337f2cf13.tar.xz) = 35241db1e9705bc09f329376e9004371c6f9c3e0ec532a2f96fd541cbd020c6d8cbfbe896a9c455388e17478ba1d5a4ef40a189d7cb8d2f2a33e302daeddf1cf
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc8.20220316git56e337f2cf13.124.tar.bz2) = 1edfff7bbe764c1eaa67c0349861354b27b94ccf3583ba8d53177ad31edf0aa335200ed762d963c060ea98031f7038e072d399d1bab1bbdacd88643b48c69481
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc8.20220316git56e337f2cf13.124.tar.bz2) = ea0e9474021efe7b734ad2d2ba7c2e87f6e8abf52397d27d2957574a0d06ad7fbc9245b01a9892f694936365e15482b1be089a73f0e2cacaea3605873ea571c8
|
||||
SHA512 (linux-5.17-rc8-45-g551acdc3c3d2.tar.xz) = f58b06f1ce92ecd57381e14df3df5448df7b4e344fa42605b407ed1df0a164318f3130235445c0fb1947498b6eef120075e01c285d79ed549c56840ad2d1e5ac
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc8.20220318git551acdc3c3d2.125.tar.bz2) = 1d0b9c5a4241e620f85788b08e443a0db56aff517a848fa51178eeb0c7e2b03db8c72ac97fca04a220296b83db4a1b53c4fae074bd6c14f61e409f16bc5a65ea
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc8.20220318git551acdc3c3d2.125.tar.bz2) = dd7e6ee3e33ec59620bfcdf00d932d6c1953cd5add9926e6f932c8ad200f12912e12ef16fedd3a199dd3b8c8e00371e44c6aaa3c90686080c3c1acfb1e9d4320
|
||||
|
Loading…
Reference in New Issue
Block a user