Linux v3.15-rc1-12-g55101e2d6ce1
- Reenable debugging options.
This commit is contained in:
parent
a5276fd60e
commit
a21141dbca
@ -1,38 +0,0 @@
|
|||||||
Bugzilla: 1085016
|
|
||||||
Upstream-status: Queued for 3.15
|
|
||||||
|
|
||||||
From 5678de3f15010b9022ee45673f33bcfc71d47b60 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Paolo Bonzini <pbonzini@redhat.com>
|
|
||||||
Date: Fri, 28 Mar 2014 20:41:50 +0100
|
|
||||||
Subject: KVM: ioapic: fix assignment of ioapic->rtc_status.pending_eoi
|
|
||||||
(CVE-2014-0155)
|
|
||||||
|
|
||||||
QE reported that they got the BUG_ON in ioapic_service to trigger.
|
|
||||||
I cannot reproduce it, but there are two reasons why this could happen.
|
|
||||||
|
|
||||||
The less likely but also easiest one, is when kvm_irq_delivery_to_apic
|
|
||||||
does not deliver to any APIC and returns -1.
|
|
||||||
|
|
||||||
Because irqe.shorthand == 0, the kvm_for_each_vcpu loop in that
|
|
||||||
function is never reached. However, you can target the similar loop in
|
|
||||||
kvm_irq_delivery_to_apic_fast; just program a zero logical destination
|
|
||||||
address into the IOAPIC, or an out-of-range physical destination address.
|
|
||||||
|
|
||||||
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/virt/kvm/ioapic.c b/virt/kvm/ioapic.c
|
|
||||||
index d4b6015..d98d107 100644
|
|
||||||
--- a/virt/kvm/ioapic.c
|
|
||||||
+++ b/virt/kvm/ioapic.c
|
|
||||||
@@ -356,7 +356,7 @@ static int ioapic_service(struct kvm_ioapic *ioapic, int irq, bool line_status)
|
|
||||||
BUG_ON(ioapic->rtc_status.pending_eoi != 0);
|
|
||||||
ret = kvm_irq_delivery_to_apic(ioapic->kvm, NULL, &irqe,
|
|
||||||
ioapic->rtc_status.dest_map);
|
|
||||||
- ioapic->rtc_status.pending_eoi = ret;
|
|
||||||
+ ioapic->rtc_status.pending_eoi = (ret < 0 ? 0 : ret);
|
|
||||||
} else
|
|
||||||
ret = kvm_irq_delivery_to_apic(ioapic->kvm, NULL, &irqe, NULL);
|
|
||||||
|
|
||||||
--
|
|
||||||
cgit v0.10.1
|
|
||||||
|
|
@ -1680,13 +1680,13 @@ CONFIG_B43_SDIO=y
|
|||||||
CONFIG_B43_BCMA=y
|
CONFIG_B43_BCMA=y
|
||||||
# CONFIG_B43_BCMA_EXTRA is not set
|
# CONFIG_B43_BCMA_EXTRA is not set
|
||||||
CONFIG_B43_BCMA_PIO=y
|
CONFIG_B43_BCMA_PIO=y
|
||||||
# CONFIG_B43_DEBUG is not set
|
CONFIG_B43_DEBUG=y
|
||||||
CONFIG_B43_PHY_LP=y
|
CONFIG_B43_PHY_LP=y
|
||||||
CONFIG_B43_PHY_N=y
|
CONFIG_B43_PHY_N=y
|
||||||
CONFIG_B43_PHY_HT=y
|
CONFIG_B43_PHY_HT=y
|
||||||
# CONFIG_B43_FORCE_PIO is not set
|
# CONFIG_B43_FORCE_PIO is not set
|
||||||
CONFIG_B43LEGACY=m
|
CONFIG_B43LEGACY=m
|
||||||
# CONFIG_B43LEGACY_DEBUG is not set
|
CONFIG_B43LEGACY_DEBUG=y
|
||||||
CONFIG_B43LEGACY_DMA=y
|
CONFIG_B43LEGACY_DMA=y
|
||||||
CONFIG_B43LEGACY_PIO=y
|
CONFIG_B43LEGACY_PIO=y
|
||||||
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
|
CONFIG_B43LEGACY_DMA_AND_PIO_MODE=y
|
||||||
@ -3542,7 +3542,7 @@ CONFIG_USB_STORAGE_REALTEK=m
|
|||||||
CONFIG_REALTEK_AUTOPM=y
|
CONFIG_REALTEK_AUTOPM=y
|
||||||
CONFIG_USB_STORAGE_ENE_UB6250=m
|
CONFIG_USB_STORAGE_ENE_UB6250=m
|
||||||
# CONFIG_USB_LIBUSUAL is not set
|
# CONFIG_USB_LIBUSUAL is not set
|
||||||
# CONFIG_USB_UAS is not set
|
CONFIG_USB_UAS=m
|
||||||
|
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -4618,7 +4618,7 @@ CONFIG_PM_DEBUG=y
|
|||||||
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
|
# CONFIG_DPM_WATCHDOG is not set # revisit this in debug
|
||||||
CONFIG_PM_TRACE=y
|
CONFIG_PM_TRACE=y
|
||||||
CONFIG_PM_TRACE_RTC=y
|
CONFIG_PM_TRACE_RTC=y
|
||||||
# CONFIG_PM_TEST_SUSPEND is not set
|
CONFIG_PM_TEST_SUSPEND=y
|
||||||
CONFIG_PM_RUNTIME=y
|
CONFIG_PM_RUNTIME=y
|
||||||
# CONFIG_PM_OPP is not set
|
# CONFIG_PM_OPP is not set
|
||||||
# CONFIG_PM_AUTOSLEEP is not set
|
# CONFIG_PM_AUTOSLEEP is not set
|
||||||
|
116
config-nodebug
116
config-nodebug
@ -2,100 +2,100 @@ CONFIG_SND_VERBOSE_PRINTK=y
|
|||||||
CONFIG_SND_DEBUG=y
|
CONFIG_SND_DEBUG=y
|
||||||
CONFIG_SND_PCM_XRUN_DEBUG=y
|
CONFIG_SND_PCM_XRUN_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_ATOMIC_SLEEP is not set
|
CONFIG_DEBUG_ATOMIC_SLEEP=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_MUTEXES is not set
|
CONFIG_DEBUG_MUTEXES=y
|
||||||
# CONFIG_DEBUG_WW_MUTEX_SLOWPATH is not set
|
CONFIG_DEBUG_WW_MUTEX_SLOWPATH=y
|
||||||
# CONFIG_DEBUG_RT_MUTEXES is not set
|
CONFIG_DEBUG_RT_MUTEXES=y
|
||||||
# CONFIG_DEBUG_LOCK_ALLOC is not set
|
CONFIG_DEBUG_LOCK_ALLOC=y
|
||||||
# CONFIG_LOCK_TORTURE_TEST is not set
|
CONFIG_LOCK_TORTURE_TEST=m
|
||||||
# CONFIG_PROVE_LOCKING is not set
|
CONFIG_PROVE_LOCKING=y
|
||||||
# CONFIG_DEBUG_SPINLOCK is not set
|
CONFIG_DEBUG_SPINLOCK=y
|
||||||
# CONFIG_PROVE_RCU is not set
|
CONFIG_PROVE_RCU=y
|
||||||
# CONFIG_PROVE_RCU_REPEATEDLY is not set
|
# CONFIG_PROVE_RCU_REPEATEDLY is not set
|
||||||
# CONFIG_DEBUG_PER_CPU_MAPS is not set
|
CONFIG_DEBUG_PER_CPU_MAPS=y
|
||||||
CONFIG_CPUMASK_OFFSTACK=y
|
CONFIG_CPUMASK_OFFSTACK=y
|
||||||
|
|
||||||
# CONFIG_CPU_NOTIFIER_ERROR_INJECT is not set
|
CONFIG_CPU_NOTIFIER_ERROR_INJECT=m
|
||||||
|
|
||||||
# CONFIG_FAULT_INJECTION is not set
|
CONFIG_FAULT_INJECTION=y
|
||||||
# CONFIG_FAILSLAB is not set
|
CONFIG_FAILSLAB=y
|
||||||
# CONFIG_FAIL_PAGE_ALLOC is not set
|
CONFIG_FAIL_PAGE_ALLOC=y
|
||||||
# CONFIG_FAIL_MAKE_REQUEST is not set
|
CONFIG_FAIL_MAKE_REQUEST=y
|
||||||
# CONFIG_FAULT_INJECTION_DEBUG_FS is not set
|
CONFIG_FAULT_INJECTION_DEBUG_FS=y
|
||||||
# CONFIG_FAULT_INJECTION_STACKTRACE_FILTER is not set
|
CONFIG_FAULT_INJECTION_STACKTRACE_FILTER=y
|
||||||
# CONFIG_FAIL_IO_TIMEOUT is not set
|
CONFIG_FAIL_IO_TIMEOUT=y
|
||||||
# CONFIG_FAIL_MMC_REQUEST is not set
|
CONFIG_FAIL_MMC_REQUEST=y
|
||||||
|
|
||||||
# CONFIG_LOCK_STAT is not set
|
CONFIG_LOCK_STAT=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_STACK_USAGE is not set
|
CONFIG_DEBUG_STACK_USAGE=y
|
||||||
|
|
||||||
# CONFIG_ACPI_DEBUG is not set
|
CONFIG_ACPI_DEBUG=y
|
||||||
# CONFIG_ACPI_DEBUG_FUNC_TRACE is not set
|
# CONFIG_ACPI_DEBUG_FUNC_TRACE is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_SG is not set
|
CONFIG_DEBUG_SG=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_PAGEALLOC is not set
|
# CONFIG_DEBUG_PAGEALLOC is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_WRITECOUNT is not set
|
CONFIG_DEBUG_WRITECOUNT=y
|
||||||
# CONFIG_DEBUG_OBJECTS is not set
|
CONFIG_DEBUG_OBJECTS=y
|
||||||
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
|
# CONFIG_DEBUG_OBJECTS_SELFTEST is not set
|
||||||
# CONFIG_DEBUG_OBJECTS_FREE is not set
|
CONFIG_DEBUG_OBJECTS_FREE=y
|
||||||
# CONFIG_DEBUG_OBJECTS_TIMERS is not set
|
CONFIG_DEBUG_OBJECTS_TIMERS=y
|
||||||
# CONFIG_DEBUG_OBJECTS_RCU_HEAD is not set
|
CONFIG_DEBUG_OBJECTS_RCU_HEAD=y
|
||||||
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
|
CONFIG_DEBUG_OBJECTS_ENABLE_DEFAULT=1
|
||||||
|
|
||||||
# CONFIG_X86_PTDUMP is not set
|
CONFIG_X86_PTDUMP=y
|
||||||
# CONFIG_EFI_PGT_DUMP is not set
|
CONFIG_EFI_PGT_DUMP=y
|
||||||
|
|
||||||
# CONFIG_CAN_DEBUG_DEVICES is not set
|
CONFIG_CAN_DEBUG_DEVICES=y
|
||||||
|
|
||||||
# CONFIG_MODULE_FORCE_UNLOAD is not set
|
CONFIG_MODULE_FORCE_UNLOAD=y
|
||||||
|
|
||||||
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
|
CONFIG_SYSCTL_SYSCALL_CHECK=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_NOTIFIERS is not set
|
CONFIG_DEBUG_NOTIFIERS=y
|
||||||
|
|
||||||
# CONFIG_DMA_API_DEBUG is not set
|
CONFIG_DMA_API_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_MMIOTRACE is not set
|
CONFIG_MMIOTRACE=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_CREDENTIALS is not set
|
CONFIG_DEBUG_CREDENTIALS=y
|
||||||
|
|
||||||
# off in both production debug and nodebug builds,
|
# off in both production debug and nodebug builds,
|
||||||
# on in rawhide nodebug builds
|
# on in rawhide nodebug builds
|
||||||
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
|
CONFIG_DEBUG_FORCE_WEAK_PER_CPU=y
|
||||||
|
|
||||||
# CONFIG_EXT4_DEBUG is not set
|
CONFIG_EXT4_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_XFS_WARN is not set
|
# CONFIG_XFS_WARN is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set
|
CONFIG_DEBUG_PERF_USE_VMALLOC=y
|
||||||
|
|
||||||
# CONFIG_JBD2_DEBUG is not set
|
CONFIG_JBD2_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_NFSD_FAULT_INJECTION is not set
|
CONFIG_NFSD_FAULT_INJECTION=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_BLK_CGROUP is not set
|
CONFIG_DEBUG_BLK_CGROUP=y
|
||||||
|
|
||||||
# CONFIG_DRBD_FAULT_INJECTION is not set
|
CONFIG_DRBD_FAULT_INJECTION=y
|
||||||
|
|
||||||
# CONFIG_ATH_DEBUG is not set
|
CONFIG_ATH_DEBUG=y
|
||||||
# CONFIG_CARL9170_DEBUGFS is not set
|
CONFIG_CARL9170_DEBUGFS=y
|
||||||
# CONFIG_IWLWIFI_DEVICE_TRACING is not set
|
CONFIG_IWLWIFI_DEVICE_TRACING=y
|
||||||
|
|
||||||
# CONFIG_RTLWIFI_DEBUG is not set
|
# CONFIG_RTLWIFI_DEBUG is not set
|
||||||
|
|
||||||
# CONFIG_DEBUG_OBJECTS_WORK is not set
|
CONFIG_DEBUG_OBJECTS_WORK=y
|
||||||
|
|
||||||
# CONFIG_DMADEVICES_DEBUG is not set
|
CONFIG_DMADEVICES_DEBUG=y
|
||||||
# CONFIG_DMADEVICES_VDEBUG is not set
|
CONFIG_DMADEVICES_VDEBUG=y
|
||||||
|
|
||||||
CONFIG_PM_ADVANCED_DEBUG=y
|
CONFIG_PM_ADVANCED_DEBUG=y
|
||||||
|
|
||||||
# CONFIG_CEPH_LIB_PRETTYDEBUG is not set
|
CONFIG_CEPH_LIB_PRETTYDEBUG=y
|
||||||
# CONFIG_QUOTA_DEBUG is not set
|
CONFIG_QUOTA_DEBUG=y
|
||||||
|
|
||||||
CONFIG_PCI_DEFAULT_USE_CRS=y
|
CONFIG_PCI_DEFAULT_USE_CRS=y
|
||||||
|
|
||||||
@ -103,18 +103,18 @@ CONFIG_KGDB_KDB=y
|
|||||||
CONFIG_KDB_KEYBOARD=y
|
CONFIG_KDB_KEYBOARD=y
|
||||||
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
|
CONFIG_KDB_CONTINUE_CATASTROPHIC=0
|
||||||
|
|
||||||
# CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER is not set
|
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
||||||
# CONFIG_PERCPU_TEST is not set
|
# CONFIG_PERCPU_TEST is not set
|
||||||
# CONFIG_TEST_LIST_SORT is not set
|
CONFIG_TEST_LIST_SORT=y
|
||||||
# CONFIG_TEST_STRING_HELPERS is not set
|
# CONFIG_TEST_STRING_HELPERS is not set
|
||||||
|
|
||||||
# CONFIG_DETECT_HUNG_TASK is not set
|
CONFIG_DETECT_HUNG_TASK=y
|
||||||
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
||||||
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
||||||
|
|
||||||
# CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK is not set
|
CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_KMEMLEAK is not set
|
CONFIG_DEBUG_KMEMLEAK=y
|
||||||
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
|
CONFIG_DEBUG_KMEMLEAK_EARLY_LOG_SIZE=1024
|
||||||
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
|
# CONFIG_DEBUG_KMEMLEAK_TEST is not set
|
||||||
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
||||||
@ -125,7 +125,7 @@ CONFIG_DEBUG_KMEMLEAK_DEFAULT_OFF=y
|
|||||||
|
|
||||||
# CONFIG_SPI_DEBUG is not set
|
# CONFIG_SPI_DEBUG is not set
|
||||||
|
|
||||||
# CONFIG_X86_DEBUG_STATIC_CPU_HAS is not set
|
CONFIG_X86_DEBUG_STATIC_CPU_HAS=y
|
||||||
|
|
||||||
# CONFIG_SCHEDSTATS is not set
|
# CONFIG_SCHEDSTATS is not set
|
||||||
# CONFIG_LATENCYTOP is not set
|
# CONFIG_LATENCYTOP is not set
|
||||||
|
@ -336,7 +336,7 @@ CONFIG_SP5100_TCO=m
|
|||||||
|
|
||||||
# CONFIG_MEMTEST is not set
|
# CONFIG_MEMTEST is not set
|
||||||
# CONFIG_DEBUG_TLBFLUSH is not set
|
# CONFIG_DEBUG_TLBFLUSH is not set
|
||||||
# CONFIG_MAXSMP is not set
|
CONFIG_MAXSMP=y
|
||||||
|
|
||||||
|
|
||||||
CONFIG_HP_ILO=m
|
CONFIG_HP_ILO=m
|
||||||
|
14
kernel.spec
14
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -122,7 +122,7 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||||
# and 0 for rawhide (all kernels are debug kernels).
|
# and 0 for rawhide (all kernels are debug kernels).
|
||||||
# See also 'make debug' and 'make release'.
|
# See also 'make debug' and 'make release'.
|
||||||
%define debugbuildsenabled 1
|
%define debugbuildsenabled 0
|
||||||
|
|
||||||
# Want to build a vanilla kernel build without any non-upstream patches?
|
# Want to build a vanilla kernel build without any non-upstream patches?
|
||||||
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
|
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
|
||||||
@ -630,9 +630,6 @@ Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
|||||||
Patch25058: net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
Patch25058: net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
||||||
Patch25061: gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
Patch25061: gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||||
|
|
||||||
#CVE-2014-0155 rhbz 1081589 1085016
|
|
||||||
Patch25060: KVM-ioapic-fix-assignment-of-ioapic-rtc_status-pending_eoi.patch
|
|
||||||
|
|
||||||
#rhbz 1048314
|
#rhbz 1048314
|
||||||
Patch25062: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
Patch25062: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||||
|
|
||||||
@ -1281,9 +1278,6 @@ ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
|||||||
ApplyPatch net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
ApplyPatch net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
||||||
ApplyPatch gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
ApplyPatch gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||||
|
|
||||||
#CVE-2014-0155 rhbz 1081589 1085016
|
|
||||||
ApplyPatch KVM-ioapic-fix-assignment-of-ioapic-rtc_status-pending_eoi.patch
|
|
||||||
|
|
||||||
#rhbz 1048314
|
#rhbz 1048314
|
||||||
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||||
|
|
||||||
@ -2072,6 +2066,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 15 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git1.1
|
||||||
|
- Linux v3.15-rc1-12-g55101e2d6ce1
|
||||||
|
- Reenable debugging options.
|
||||||
|
|
||||||
* Mon Apr 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git0.1
|
* Mon Apr 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git0.1
|
||||||
- Linux v3.15-rc1
|
- Linux v3.15-rc1
|
||||||
- Disable debugging options.
|
- Disable debugging options.
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
||||||
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
||||||
6e344ea5434bd203d95970ca30258570 patch-3.14-git13.xz
|
|
||||||
13e450bb569cfad7c246f0746a7f3217 patch-3.15-rc1.xz
|
13e450bb569cfad7c246f0746a7f3217 patch-3.15-rc1.xz
|
||||||
|
4976467d25e3ed20728a29cf175c05b5 patch-3.15-rc1-git1.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user