snapshot 2.6.38-rc2-git1
This commit is contained in:
parent
71f70cd13e
commit
a08b493398
13
kernel.spec
13
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 2
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
%define gitrev 1
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 2.6.%{upstream_sublevel}
|
||||
%endif
|
||||
@ -714,8 +714,6 @@ Patch12017: prevent-runtime-conntrack-changes.patch
|
||||
|
||||
Patch12018: neuter_intel_microcode_load.patch
|
||||
|
||||
Patch12030: tpm-fix-stall-on-boot.patch
|
||||
|
||||
Patch12101: apple_backlight.patch
|
||||
Patch12102: efifb_update.patch
|
||||
Patch12200: acpi_reboot.patch
|
||||
@ -1322,9 +1320,6 @@ ApplyPatch add-appleir-usb-driver.patch
|
||||
|
||||
ApplyPatch neuter_intel_microcode_load.patch
|
||||
|
||||
# try to fix stalls during boot (#530393)
|
||||
ApplyPatch tpm-fix-stall-on-boot.patch
|
||||
|
||||
# various fixes for Apple and EFI
|
||||
ApplyPatch apple_backlight.patch
|
||||
ApplyPatch efifb_update.patch
|
||||
@ -1958,6 +1953,12 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Mon Jan 24 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc2.git1.1
|
||||
- Linux 2.6.38-rc2-git1
|
||||
- [e5cce6c1] tpm: fix panic caused by "tpm: Autodetect itpm devices"
|
||||
may fix some boot issues people were having.
|
||||
- tpm-fix-stall-on-boot.patch: upstream.
|
||||
|
||||
* Sat Jan 22 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc2.git0.1
|
||||
- Linux 2.6.38-rc2
|
||||
- linux-2.6-serial-460800.patch, drivers/serial => drivers/tty/serial
|
||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
||||
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
||||
4651b1512e2fba1735713aca8f1007fc patch-2.6.38-rc2.bz2
|
||||
1edbfed39a74c24b542747f2b97f1e32 patch-2.6.38-rc2-git1.bz2
|
||||
|
@ -1,24 +0,0 @@
|
||||
Fix TPM timeouts on boot (#530393)
|
||||
|
||||
--- a/drivers/char/tpm/tpm.c
|
||||
+++ a/drivers/char/tpm/tpm.c
|
||||
@@ -354,12 +354,14 @@ unsigned long tpm_calc_ordinal_duration(struct tpm_chip *chip,
|
||||
tpm_protected_ordinal_duration[ordinal &
|
||||
TPM_PROTECTED_ORDINAL_MASK];
|
||||
|
||||
- if (duration_idx != TPM_UNDEFINED)
|
||||
+ if (duration_idx != TPM_UNDEFINED) {
|
||||
duration = chip->vendor.duration[duration_idx];
|
||||
- if (duration <= 0)
|
||||
+ /* if duration is 0, it's because chip->vendor.duration wasn't */
|
||||
+ /* filled yet, so we set the lowest timeout just to give enough */
|
||||
+ /* time to tpm_get_timeouts() succeed */
|
||||
+ return (duration <= 0 ? HZ : duration);
|
||||
+ } else
|
||||
return 2 * 60 * HZ;
|
||||
- else
|
||||
- return duration;
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(tpm_calc_ordinal_duration);
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user