kernel-5.14-60
* Mon Aug 30 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14-60] - arm64: use common CONFIG_MAX_ZONEORDER for arm kernel (Mark Salter) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
4594f2534f
commit
9e5bb46146
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 57
|
RHEL_RELEASE = 60
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -1,3 +1,6 @@
|
|||||||
|
https://gitlab.com/cki-project/kernel-ark/-/commit/12be5095f2feb2c686f6c9fb31de5513355fe31a
|
||||||
|
12be5095f2feb2c686f6c9fb31de5513355fe31a arm64: use common CONFIG_MAX_ZONEORDER for arm kernel
|
||||||
|
|
||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/4cee6f338b9edaeab1c45c6b2a8ecf80c8711186
|
https://gitlab.com/cki-project/kernel-ark/-/commit/4cee6f338b9edaeab1c45c6b2a8ecf80c8711186
|
||||||
4cee6f338b9edaeab1c45c6b2a8ecf80c8711186 Revert "IB/rxe: Mark Soft-RoCE Transport driver as tech-preview"
|
4cee6f338b9edaeab1c45c6b2a8ecf80c8711186 Revert "IB/rxe: Mark Soft-RoCE Transport driver as tech-preview"
|
||||||
|
|
||||||
|
@ -1733,6 +1733,7 @@ CONFIG_FIXED_PHY=y
|
|||||||
CONFIG_FM10K=m
|
CONFIG_FM10K=m
|
||||||
# CONFIG_FONTS is not set
|
# CONFIG_FONTS is not set
|
||||||
CONFIG_FONT_SUPPORT=y
|
CONFIG_FONT_SUPPORT=y
|
||||||
|
CONFIG_FORCE_MAX_ZONEORDER=13
|
||||||
CONFIG_FORTIFY_SOURCE=y
|
CONFIG_FORTIFY_SOURCE=y
|
||||||
# CONFIG_FPGA is not set
|
# CONFIG_FPGA is not set
|
||||||
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set
|
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set
|
||||||
|
@ -1717,6 +1717,7 @@ CONFIG_FIXED_PHY=y
|
|||||||
CONFIG_FM10K=m
|
CONFIG_FM10K=m
|
||||||
# CONFIG_FONTS is not set
|
# CONFIG_FONTS is not set
|
||||||
CONFIG_FONT_SUPPORT=y
|
CONFIG_FONT_SUPPORT=y
|
||||||
|
CONFIG_FORCE_MAX_ZONEORDER=13
|
||||||
CONFIG_FORTIFY_SOURCE=y
|
CONFIG_FORTIFY_SOURCE=y
|
||||||
# CONFIG_FPGA is not set
|
# CONFIG_FPGA is not set
|
||||||
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set
|
# CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER is not set
|
||||||
|
25
kernel.spec
25
kernel.spec
@ -78,9 +78,9 @@ Summary: The Linux kernel
|
|||||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||||
# to build the base kernel using the debug configuration. (Specifying
|
# to build the base kernel using the debug configuration. (Specifying
|
||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 1
|
||||||
|
|
||||||
%global distro_build 0.rc7.20210827git77dd11439b86.57
|
%global distro_build 60
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -124,13 +124,14 @@ Summary: The Linux kernel
|
|||||||
%define kversion 5.14
|
%define kversion 5.14
|
||||||
|
|
||||||
%define rpmversion 5.14.0
|
%define rpmversion 5.14.0
|
||||||
%define pkgrelease 0.rc7.20210827git77dd11439b86.57
|
%define patchversion 5.14
|
||||||
|
%define pkgrelease 60
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 14
|
%define patchlevel 14
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc7.20210827git77dd11439b86.57%{?buildid}%{?dist}
|
%define specrelease 60%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -671,7 +672,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.14-rc7-89-g77dd11439b86.tar.xz
|
Source0: linux-5.14.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -827,7 +828,7 @@ Source4002: gating.yaml
|
|||||||
|
|
||||||
%if !%{nopatches}
|
%if !%{nopatches}
|
||||||
|
|
||||||
Patch1: patch-%{rpmversion}-redhat.patch
|
Patch1: patch-%{patchversion}-redhat.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# empty final patch to facilitate testing of kernel patches
|
# empty final patch to facilitate testing of kernel patches
|
||||||
@ -1357,15 +1358,15 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.14-rc7-89-g77dd11439b86 -c
|
%setup -q -n kernel-5.14 -c
|
||||||
mv linux-5.14-rc7-89-g77dd11439b86 linux-%{KVERREL}
|
mv linux-5.14 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
|
|
||||||
%if !%{nopatches}
|
%if !%{nopatches}
|
||||||
|
|
||||||
ApplyOptionalPatch patch-%{rpmversion}-redhat.patch
|
ApplyOptionalPatch patch-%{patchversion}-redhat.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
ApplyOptionalPatch linux-kernel-test.patch
|
ApplyOptionalPatch linux-kernel-test.patch
|
||||||
@ -2957,6 +2958,12 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 30 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14-60]
|
||||||
|
- arm64: use common CONFIG_MAX_ZONEORDER for arm kernel (Mark Salter)
|
||||||
|
|
||||||
|
* Sat Aug 28 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14-0.rc7.20210828git64b4fc45bea6.58]
|
||||||
|
- Create Makefile.variables for a single point of configuration change (Justin M. Forbes)
|
||||||
|
|
||||||
* Fri Aug 27 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc7.20210827git77dd11439b86.57]
|
* Fri Aug 27 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc7.20210827git77dd11439b86.57]
|
||||||
- rpmspec: drop traceevent files instead of just excluding them from files list (Herton R. Krzesinski) [1967640]
|
- rpmspec: drop traceevent files instead of just excluding them from files list (Herton R. Krzesinski) [1967640]
|
||||||
- Revert "redhat/configs: Enable genet and brcmfmac wlan" (Íñigo Huguet)
|
- Revert "redhat/configs: Enable genet and brcmfmac wlan" (Íñigo Huguet)
|
||||||
|
@ -141,7 +141,7 @@ index 000000000000..effb81d04bfd
|
|||||||
+
|
+
|
||||||
+endmenu
|
+endmenu
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 80aa85170d6b..3b0fcfb382a3 100644
|
index 61741e9d9c6e..093ecf99677f 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||||
@ -187,7 +187,7 @@ index 2fb7012c3246..47718b4f2f75 100644
|
|||||||
The VM uses one page of physical memory for each page table.
|
The VM uses one page of physical memory for each page table.
|
||||||
For systems with a lot of processes, this can use a lot of
|
For systems with a lot of processes, this can use a lot of
|
||||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||||
index 62c3c1d2190f..121b5eb1e329 100644
|
index 62c3c1d2190f..9ef6bb1d5b0c 100644
|
||||||
--- a/arch/arm64/Kconfig
|
--- a/arch/arm64/Kconfig
|
||||||
+++ b/arch/arm64/Kconfig
|
+++ b/arch/arm64/Kconfig
|
||||||
@@ -915,7 +915,7 @@ endchoice
|
@@ -915,7 +915,7 @@ endchoice
|
||||||
@ -203,7 +203,7 @@ index 62c3c1d2190f..121b5eb1e329 100644
|
|||||||
config FORCE_MAX_ZONEORDER
|
config FORCE_MAX_ZONEORDER
|
||||||
int
|
int
|
||||||
default "14" if ARM64_64K_PAGES
|
default "14" if ARM64_64K_PAGES
|
||||||
+ default "13" if (ARCH_THUNDER && !ARM64_64K_PAGES && !RHEL_DIFFERENCES)
|
+ default "13" if (ARCH_THUNDER && !ARM64_64K_PAGES)
|
||||||
default "12" if ARM64_16K_PAGES
|
default "12" if ARM64_16K_PAGES
|
||||||
default "11"
|
default "11"
|
||||||
help
|
help
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.14-rc7-89-g77dd11439b86.tar.xz) = e538386555b64b82a04a6f93fb19d103415e0cb4b4ce47795404d89e7b6edd0fd40bb07cd53cd17cdcd8fccf939c5f7e4dd27be332fce49c286666efa1b21124
|
SHA512 (linux-5.14.tar.xz) = 88f9313c421ecb42ba75b22b30113b7801fa448d4cf53f86160d422c630c5bbd1c69736c714294c6fc2b17fdace6a786f98076bee960dedf6783d524fd6abb11
|
||||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc7.20210827git77dd11439b86.57.tar.bz2) = b2afa6962215f3c9774abab0c5d90805581002e8f1a2c3b3eae6ba32d6e65a198144d0673e5a823c1f0d10588a8dc1ee7243c0f0698bf21b64da1dab66a2af82
|
SHA512 (kernel-abi-stablelists-5.14.0-60.tar.bz2) = 9888fe44d4bf6395bac7a930e7063b66c65ac5483b17f7fa2408a52ce6cfb4f825aeb8115344eb3980334a1e1be87fdade434f8ebc21a883d5be55c2244c19cc
|
||||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc7.20210827git77dd11439b86.57.tar.bz2) = 67d673b15130a97dc5d9f2550aaa328a59df1d5a84d52589e0b74295ad7b4ac452efe48f960da771af128a995a7d0de1219fd9f4d3396737aeb82ffee75fbd69
|
SHA512 (kernel-kabi-dw-5.14.0-60.tar.bz2) = d231a72517da1f73bfe66888e67836bbaf580bbc038aceba698cfd126d23da697256b80f58267a2b3dcdfb39a731638dd485efa29ff9d67da1a15061fad896f2
|
||||||
|
Loading…
Reference in New Issue
Block a user