Linux 2.6.36-rc5-git4
Drop merged patches: fix-icebp-breakpoints.patch linux-2.6.35.4-virtio_console-fix-poll.patch
This commit is contained in:
parent
9e0d2f655e
commit
9e5584957c
@ -1,50 +0,0 @@
|
|||||||
From: Frederic Weisbecker <fweisbec@gmail.com>
|
|
||||||
|
|
||||||
https://bugzilla.kernel.org/show_bug.cgi?id=16315#c26
|
|
||||||
http://bugs.winehq.org/show_bug.cgi?id=23323
|
|
||||||
|
|
||||||
diff --git a/arch/x86/include/asm/hw_breakpoint.h b/arch/x86/include/asm/hw_breakpoint.h
|
|
||||||
index 528a11e..824ca07 100644
|
|
||||||
--- a/arch/x86/include/asm/hw_breakpoint.h
|
|
||||||
+++ b/arch/x86/include/asm/hw_breakpoint.h
|
|
||||||
@@ -20,7 +20,7 @@ struct arch_hw_breakpoint {
|
|
||||||
#include <linux/list.h>
|
|
||||||
|
|
||||||
/* Available HW breakpoint length encodings */
|
|
||||||
-#define X86_BREAKPOINT_LEN_X 0x00
|
|
||||||
+#define X86_BREAKPOINT_LEN_X 0x40
|
|
||||||
#define X86_BREAKPOINT_LEN_1 0x40
|
|
||||||
#define X86_BREAKPOINT_LEN_2 0x44
|
|
||||||
#define X86_BREAKPOINT_LEN_4 0x4c
|
|
||||||
diff --git a/arch/x86/kernel/hw_breakpoint.c b/arch/x86/kernel/hw_breakpoint.c
|
|
||||||
index a474ec3..71123b1 100644
|
|
||||||
--- a/arch/x86/kernel/hw_breakpoint.c
|
|
||||||
+++ b/arch/x86/kernel/hw_breakpoint.c
|
|
||||||
@@ -208,9 +208,6 @@ int arch_bp_generic_fields(int x86_len, int x86_type,
|
|
||||||
{
|
|
||||||
/* Len */
|
|
||||||
switch (x86_len) {
|
|
||||||
- case X86_BREAKPOINT_LEN_X:
|
|
||||||
- *gen_len = sizeof(long);
|
|
||||||
- break;
|
|
||||||
case X86_BREAKPOINT_LEN_1:
|
|
||||||
*gen_len = HW_BREAKPOINT_LEN_1;
|
|
||||||
break;
|
|
||||||
@@ -233,6 +230,7 @@ int arch_bp_generic_fields(int x86_len, int x86_type,
|
|
||||||
switch (x86_type) {
|
|
||||||
case X86_BREAKPOINT_EXECUTE:
|
|
||||||
*gen_type = HW_BREAKPOINT_X;
|
|
||||||
+ *gen_len = sizeof(long);
|
|
||||||
break;
|
|
||||||
case X86_BREAKPOINT_WRITE:
|
|
||||||
*gen_type = HW_BREAKPOINT_W;
|
|
||||||
@@ -316,9 +314,6 @@ int arch_validate_hwbkpt_settings(struct perf_event *bp)
|
|
||||||
ret = -EINVAL;
|
|
||||||
|
|
||||||
switch (info->len) {
|
|
||||||
- case X86_BREAKPOINT_LEN_X:
|
|
||||||
- align = sizeof(long) -1;
|
|
||||||
- break;
|
|
||||||
case X86_BREAKPOINT_LEN_1:
|
|
||||||
align = 0;
|
|
||||||
break;
|
|
15
kernel.spec
15
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 25
|
%global baserelease 26
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 5
|
%define rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 4
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -604,8 +604,6 @@ Patch30: linux-2.6-tracehook.patch
|
|||||||
Patch31: linux-2.6-utrace.patch
|
Patch31: linux-2.6-utrace.patch
|
||||||
Patch32: linux-2.6-utrace-ptrace.patch
|
Patch32: linux-2.6-utrace-ptrace.patch
|
||||||
|
|
||||||
Patch100: fix-icebp-breakpoints.patch
|
|
||||||
|
|
||||||
Patch150: linux-2.6.29-sparc-IOC_TYPECHECK.patch
|
Patch150: linux-2.6.29-sparc-IOC_TYPECHECK.patch
|
||||||
|
|
||||||
Patch160: linux-2.6-32bit-mmap-exec-randomization.patch
|
Patch160: linux-2.6-32bit-mmap-exec-randomization.patch
|
||||||
@ -648,7 +646,6 @@ Patch800: linux-2.6-crash-driver.patch
|
|||||||
|
|
||||||
# virt + ksm patches
|
# virt + ksm patches
|
||||||
Patch1555: fix_xen_guest_on_old_EC2.patch
|
Patch1555: fix_xen_guest_on_old_EC2.patch
|
||||||
Patch1556: linux-2.6.35.4-virtio_console-fix-poll.patch
|
|
||||||
|
|
||||||
# DRM
|
# DRM
|
||||||
Patch1801: drm-revert-drm-fbdev-rework-output-polling-to-be-back-in-core.patch
|
Patch1801: drm-revert-drm-fbdev-rework-output-polling-to-be-back-in-core.patch
|
||||||
@ -1141,7 +1138,6 @@ ApplyPatch linux-2.6-utrace-ptrace.patch
|
|||||||
|
|
||||||
# Architecture patches
|
# Architecture patches
|
||||||
# x86(-64)
|
# x86(-64)
|
||||||
ApplyPatch fix-icebp-breakpoints.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Intel IOMMU
|
# Intel IOMMU
|
||||||
@ -1251,7 +1247,6 @@ ApplyPatch linux-2.6-crash-driver.patch
|
|||||||
|
|
||||||
# Assorted Virt Fixes
|
# Assorted Virt Fixes
|
||||||
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
||||||
ApplyPatch linux-2.6.35.4-virtio_console-fix-poll.patch
|
|
||||||
|
|
||||||
#ApplyPatch drm-revert-drm-fbdev-rework-output-polling-to-be-back-in-core.patch
|
#ApplyPatch drm-revert-drm-fbdev-rework-output-polling-to-be-back-in-core.patch
|
||||||
#ApplyPatch revert-drm-kms-toggle-poll-around-switcheroo.patch
|
#ApplyPatch revert-drm-kms-toggle-poll-around-switcheroo.patch
|
||||||
@ -1922,6 +1917,12 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 23 2010 Chuck Ebbert <cebbert@redhat.com> 2.6.36-0.26.rc5.git4
|
||||||
|
- Linux 2.6.36-rc5-git4
|
||||||
|
- Drop merged patches:
|
||||||
|
fix-icebp-breakpoints.patch
|
||||||
|
linux-2.6.35.4-virtio_console-fix-poll.patch
|
||||||
|
|
||||||
* Thu Sep 23 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.25.rc5
|
* Thu Sep 23 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.25.rc5
|
||||||
- Add s390 vdso AFTER_LINK to Roland's linux-2.6-makefile-after_link.patch
|
- Add s390 vdso AFTER_LINK to Roland's linux-2.6-makefile-after_link.patch
|
||||||
|
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
Subject: virtio_console: Fix poll blocking even though there is data to read
|
|
||||||
From: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
|
|
||||||
I found this while working on a Linux agent for spice, the symptom I was
|
|
||||||
seeing was select blocking on the spice vdagent virtio serial port even
|
|
||||||
though there were messages queued up there.
|
|
||||||
|
|
||||||
virtio_console's port_fops_poll checks port->inbuf != NULL to determine if
|
|
||||||
read won't block. However if an application reads enough bytes from inbuf
|
|
||||||
through port_fops_read, to empty the current port->inbuf, port->inbuf
|
|
||||||
will be NULL even though there may be buffers left in the virtqueue.
|
|
||||||
|
|
||||||
This causes poll() to block even though there is data to be read, this patch
|
|
||||||
fixes this by using the alredy defined will_read_block utility function
|
|
||||||
instead of the port->inbuf != NULL check.
|
|
||||||
|
|
||||||
Signed-off-By: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
diff -up linux-2.6.35.x86_64/drivers/char/virtio_console.c~ linux-2.6.35.x86_64/drivers/char/virtio_console.c
|
|
||||||
--- linux-2.6.35.x86_64/drivers/char/virtio_console.c~ 2010-08-02 00:11:14.000000000 +0200
|
|
||||||
+++ linux-2.6.35.x86_64/drivers/char/virtio_console.c 2010-09-15 13:39:29.043505000 +0200
|
|
||||||
@@ -642,7 +642,7 @@ static unsigned int port_fops_poll(struc
|
|
||||||
poll_wait(filp, &port->waitqueue, wait);
|
|
||||||
|
|
||||||
ret = 0;
|
|
||||||
- if (port->inbuf)
|
|
||||||
+ if (!will_read_block(port))
|
|
||||||
ret |= POLLIN | POLLRDNORM;
|
|
||||||
if (!will_write_block(port))
|
|
||||||
ret |= POLLOUT;
|
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
||||||
eb356a379ec8093f7f4304520ce28de8 patch-2.6.36-rc5.bz2
|
eb356a379ec8093f7f4304520ce28de8 patch-2.6.36-rc5.bz2
|
||||||
|
754de7d199807e79c29ee98c8b5e0f12 patch-2.6.36-rc5-git4.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user