Add s390 vdso AFTER_LINK to Roland's linux-2.6-makefile-after_link.patch
This commit is contained in:
parent
6406b98a0e
commit
9e0d2f655e
@ -1923,6 +1923,9 @@ fi
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Sep 23 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.25.rc5
|
* Thu Sep 23 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.25.rc5
|
||||||
|
- Add s390 vdso AFTER_LINK to Roland's linux-2.6-makefile-after_link.patch
|
||||||
|
|
||||||
|
* Thu Sep 23 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
- Snipe ACPI patch from mjg59 to fix battery levels on some laptops.
|
- Snipe ACPI patch from mjg59 to fix battery levels on some laptops.
|
||||||
|
|
||||||
* Tue Sep 21 2010 Kyle McMartin <kyle@redhat.com>
|
* Tue Sep 21 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
|
@ -67,3 +67,32 @@ index 4a2afa1..12ad9f7 100644
|
|||||||
|
|
||||||
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
VDSO_LDFLAGS = -fPIC -shared $(call cc-ldoption, -Wl$(comma)--hash-style=sysv)
|
||||||
GCOV_PROFILE := n
|
GCOV_PROFILE := n
|
||||||
|
|
||||||
|
diff --git a/arch/s390/kernel/vdso32/Makefile b/arch/s390/kernel/vdso32/Makefile
|
||||||
|
index d13e875..28a3e1ad 100644
|
||||||
|
--- a/arch/s390/kernel/vdso32/Makefile
|
||||||
|
+++ b/arch/s390/kernel/vdso32/Makefile
|
||||||
|
@@ -40,7 +40,8 @@ $(obj-vdso32): %.o: %.S
|
||||||
|
|
||||||
|
# actual build commands
|
||||||
|
quiet_cmd_vdso32ld = VDSO32L $@
|
||||||
|
- cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
||||||
|
+ cmd_vdso32ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
||||||
|
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
||||||
|
quiet_cmd_vdso32as = VDSO32A $@
|
||||||
|
cmd_vdso32as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
|
diff --git a/arch/s390/kernel/vdso64/Makefile b/arch/s390/kernel/vdso64/Makefile
|
||||||
|
index 449352d..e90e656 100644
|
||||||
|
--- a/arch/s390/kernel/vdso64/Makefile
|
||||||
|
+++ b/arch/s390/kernel/vdso64/Makefile
|
||||||
|
@@ -40,7 +40,8 @@ $(obj-vdso64): %.o: %.S
|
||||||
|
|
||||||
|
# actual build commands
|
||||||
|
quiet_cmd_vdso64ld = VDSO64L $@
|
||||||
|
- cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@
|
||||||
|
+ cmd_vdso64ld = $(CC) $(c_flags) -Wl,-T $^ -o $@ \
|
||||||
|
+ $(if $(AFTER_LINK),; $(AFTER_LINK))
|
||||||
|
quiet_cmd_vdso64as = VDSO64A $@
|
||||||
|
cmd_vdso64as = $(CC) $(a_flags) -c -o $@ $<
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user