kernel-5.8.0-0.rc3.1
* Mon Jun 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc3.1] - v5.8-rc3 rebase - s390x-zfcpdump: Handle missing Module.symvers file (Don Zickus) - Updated changelog for the release based on 8be3a53e18e0 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Augusto Caringi <acaringi@redhat.com>
This commit is contained in:
parent
a6d5bdfa75
commit
9b53592daf
@ -67,5 +67,5 @@ index 953a2fae8b15..7ea07f7da582 100644
|
||||
for (i = 0; i < hest_tab->error_source_count; i++) {
|
||||
len = hest_esrc_len(hest_hdr);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -71,5 +71,5 @@ index e209081d644b..7484bcf59a1b 100644
|
||||
return ctx.rc;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -82,5 +82,5 @@ index 98c6b91be4a8..60055827dddc 100644
|
||||
|
||||
#define get_user(x, p) \
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -28,5 +28,5 @@ index b1e14beaac5f..b28779779058 100644
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -236,5 +236,5 @@ index 000000000000..8d1641710ed7
|
||||
+}
|
||||
+EXPORT_SYMBOL(mark_driver_unsupported);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
2 files changed, 96 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/drivers/firmware/efi/efi.c b/drivers/firmware/efi/efi.c
|
||||
index 7f1657b6c30d..078df3a48c7b 100644
|
||||
index 5114cae4ec97..93dcc37a9820 100644
|
||||
--- a/drivers/firmware/efi/efi.c
|
||||
+++ b/drivers/firmware/efi/efi.c
|
||||
@@ -31,6 +31,7 @@
|
||||
@ -26,7 +26,7 @@ index 7f1657b6c30d..078df3a48c7b 100644
|
||||
|
||||
#include <asm/early_ioremap.h>
|
||||
|
||||
@@ -826,40 +827,101 @@ int efi_mem_type(unsigned long phys_addr)
|
||||
@@ -827,40 +828,101 @@ int efi_mem_type(unsigned long phys_addr)
|
||||
}
|
||||
#endif
|
||||
|
||||
@ -160,7 +160,7 @@ index 7f1657b6c30d..078df3a48c7b 100644
|
||||
|
||||
static DEFINE_SPINLOCK(efi_mem_reserve_persistent_lock);
|
||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||
index 2c6495f72f79..b73b4bcaa32f 100644
|
||||
index bb35f3305e55..1d77c218b67e 100644
|
||||
--- a/include/linux/efi.h
|
||||
+++ b/include/linux/efi.h
|
||||
@@ -43,6 +43,8 @@
|
||||
@ -172,7 +172,7 @@ index 2c6495f72f79..b73b4bcaa32f 100644
|
||||
typedef unsigned long efi_status_t;
|
||||
typedef u8 efi_bool_t;
|
||||
typedef u16 efi_char16_t; /* UNICODE character */
|
||||
@@ -827,6 +829,7 @@ static inline bool efi_rt_services_supported(unsigned int mask)
|
||||
@@ -828,6 +830,7 @@ static inline bool efi_rt_services_supported(unsigned int mask)
|
||||
#endif
|
||||
|
||||
extern int efi_status_to_err(efi_status_t status);
|
||||
@ -181,5 +181,5 @@ index 2c6495f72f79..b73b4bcaa32f 100644
|
||||
/*
|
||||
* Variable Attributes
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index 659090edd357..da9f685531b4 100644
|
||||
index 2e0700a451e5..77e7e749d7e5 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -1133,6 +1133,7 @@ config XEN
|
||||
@ -28,5 +28,5 @@ index 659090edd357..da9f685531b4 100644
|
||||
default "11"
|
||||
help
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -130,7 +130,7 @@ Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
||||
2 files changed, 132 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
|
||||
index 043d93cdcaad..178813fea2ec 100644
|
||||
index 95c090a45b4b..bcc6d2df56c0 100644
|
||||
--- a/arch/x86/kernel/cpu/common.c
|
||||
+++ b/arch/x86/kernel/cpu/common.c
|
||||
@@ -1236,6 +1236,7 @@ static void __init early_identify_cpu(struct cpuinfo_x86 *c)
|
||||
@ -299,5 +299,5 @@ index a3767e74c758..a1b8cb9a2579 100644
|
||||
}
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -8,7 +8,7 @@ Subject: [PATCH] Drop that for now
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 9e33fdf83e11..642223f23b2e 100644
|
||||
index a3ec72fe1d8a..8dd82ad14236 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -496,7 +496,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
|
||||
@ -21,5 +21,5 @@ index 9e33fdf83e11..642223f23b2e 100644
|
||||
KBUILD_CPPFLAGS := -D__KERNEL__
|
||||
KBUILD_AFLAGS_KERNEL :=
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -54,5 +54,5 @@ index 5642eefb4ba1..01c8d750b9e0 100644
|
||||
err = rxe_cache_init();
|
||||
if (err) {
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -326,5 +326,5 @@ index 7b22366d0065..307a651b2755 100644
|
||||
|
||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -60,5 +60,5 @@ index 000000000000..733a26bd887a
|
||||
+
|
||||
+endmenu
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -40,5 +40,5 @@ index 9d9fc678c91d..84ad75a53c83 100644
|
||||
+ return ret;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -36,5 +36,5 @@ index 253fb9a7fc98..8c95b68d86d4 100644
|
||||
}
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -61,5 +61,5 @@ index 235b456698fc..d5a4a167ffa1 100644
|
||||
.has_cache_bars = false,
|
||||
.ectl.enable = false,
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -39,5 +39,5 @@ index 48a7abae02d2..2d826a14824a 100644
|
||||
|
||||
$(version_h): FORCE
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -109,5 +109,5 @@ index d48414e295a0..ba0e384412c9 100644
|
||||
PCI_ANY_ID, PCI_ANY_ID, },
|
||||
{PCI_VENDOR_ID_EMULEX, PCI_DEVICE_ID_LANCER_G7_FC,
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -77,5 +77,5 @@ index c0a4904413b5..1a0c362cddfb 100644
|
||||
obj-$(CONFIG_MODULES) += kmod.o
|
||||
obj-$(CONFIG_MULTIUSER) += groups.o
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -71,5 +71,5 @@ index 812bfc32ecb8..e09fec76c320 100644
|
||||
* Intersil/Techwell TW686[4589]-based video capture cards have an empty (zero)
|
||||
* class code. Fix it.
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -47,5 +47,5 @@ index a308e86a97f1..4d84f95a50ce 100644
|
||||
{ 0x9005, 0x028c, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 63 }, /* Adaptec PMC Series 7 (Denali) */
|
||||
{ 0x9005, 0x028d, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 64 }, /* Adaptec PMC Series 8 */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -48,5 +48,5 @@ index 8777faced51a..2e60d792005f 100644
|
||||
acpi_dev_get_resources(device, &resource_list,
|
||||
acpi_check_serial_bus_slave,
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -52,5 +52,5 @@ index a7586a4db142..c2a7e30e2143 100644
|
||||
|
||||
static int __init parse_acpi(char *arg)
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -79,5 +79,5 @@ index e2157ca387c8..534bc76e43da 100644
|
||||
|
||||
/**
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -92,5 +92,5 @@ index c79d83304e52..695efeea48f0 100644
|
||||
int pass);
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -85,5 +85,5 @@ index ea5bf5f4cbed..71c55cae27ac 100644
|
||||
tmp = ata_wait_register(ap, port_mmio + PORT_CMD,
|
||||
PORT_CMD_LIST_ON, PORT_CMD_LIST_ON, 1, 500);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -21,7 +21,7 @@ Signed-off-by: Jeremy Cline <jcline@redhat.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
||||
index a4a094bedcb2..659090edd357 100644
|
||||
index 66dc41fd49f2..2e0700a451e5 100644
|
||||
--- a/arch/arm64/Kconfig
|
||||
+++ b/arch/arm64/Kconfig
|
||||
@@ -861,7 +861,7 @@ endchoice
|
||||
@ -34,5 +34,5 @@ index a4a094bedcb2..659090edd357 100644
|
||||
For systems with 52-bit userspace VAs enabled, the kernel will attempt
|
||||
to maintain compatibility with older software by providing 48-bit VAs
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -27,5 +27,5 @@ index 2ac74904a3ce..f0094424f76a 100644
|
||||
The VM uses one page of physical memory for each page table.
|
||||
For systems with a lot of processes, this can use a lot of
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -77,5 +77,5 @@ index cefda145c3c9..96d9150423e0 100644
|
||||
status = "okay";
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -67,5 +67,5 @@ index 9b81cfbbc5c5..1ca08297939c 100644
|
||||
{ 0 }
|
||||
};
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -49,5 +49,5 @@ index 8f5546ec2d1f..772054412fab 100644
|
||||
if (err)
|
||||
return err;
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -118,5 +118,5 @@ index 534bc76e43da..e3bae852d92f 100644
|
||||
|
||||
/**
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -419,5 +419,5 @@ index 000000000000..b483f96ee1db
|
||||
+MODULE_DESCRIPTION("DRM driver for Xingbangda XBD599 MIPI DSI panel");
|
||||
+MODULE_LICENSE("GPL v2");
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -55,5 +55,5 @@ index aa67cb037e9d..52e009dc632b 100644
|
||||
/*
|
||||
* And I'm not entirely sure what vblk is about. The driver in
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -28,5 +28,5 @@ index d4a4045092df..ed808148b6a7 100644
|
||||
items:
|
||||
- const: radxa,rock
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -70,5 +70,5 @@ index 000000000000..b27bcf11198f
|
||||
+
|
||||
+...
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -31,5 +31,5 @@ index f999cca37a8a..9cbd2d6c7da4 100644
|
||||
goto out;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -107,10 +107,10 @@ index 000000000000..de0a3714a5d4
|
||||
+ }
|
||||
+}
|
||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||
index b73b4bcaa32f..bde09740a9b5 100644
|
||||
index 1d77c218b67e..f5fe3e01bc0e 100644
|
||||
--- a/include/linux/efi.h
|
||||
+++ b/include/linux/efi.h
|
||||
@@ -780,6 +780,14 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||
@@ -781,6 +781,14 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||
#define EFI_MEM_ATTR 10 /* Did firmware publish an EFI_MEMORY_ATTRIBUTES table? */
|
||||
#define EFI_MEM_NO_SOFT_RESERVE 11 /* Is the kernel configured to ignore soft reservations? */
|
||||
#define EFI_PRESERVE_BS_REGIONS 12 /* Are EFI boot-services memory segments available? */
|
||||
@ -125,7 +125,7 @@ index b73b4bcaa32f..bde09740a9b5 100644
|
||||
|
||||
#ifdef CONFIG_EFI
|
||||
/*
|
||||
@@ -791,6 +799,8 @@ static inline bool efi_enabled(int feature)
|
||||
@@ -792,6 +800,8 @@ static inline bool efi_enabled(int feature)
|
||||
}
|
||||
extern void efi_reboot(enum reboot_mode reboot_mode, const char *__unused);
|
||||
|
||||
@ -134,7 +134,7 @@ index b73b4bcaa32f..bde09740a9b5 100644
|
||||
bool __pure __efi_soft_reserve_enabled(void);
|
||||
|
||||
static inline bool __pure efi_soft_reserve_enabled(void)
|
||||
@@ -817,6 +827,8 @@ efi_capsule_pending(int *reset_type)
|
||||
@@ -818,6 +828,8 @@ efi_capsule_pending(int *reset_type)
|
||||
return false;
|
||||
}
|
||||
|
||||
@ -143,7 +143,7 @@ index b73b4bcaa32f..bde09740a9b5 100644
|
||||
static inline bool efi_soft_reserve_enabled(void)
|
||||
{
|
||||
return false;
|
||||
@@ -1088,12 +1100,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
|
||||
@@ -1089,12 +1101,6 @@ static inline bool efi_runtime_disabled(void) { return true; }
|
||||
extern void efi_call_virt_check_flags(unsigned long flags, const char *call);
|
||||
extern unsigned long efi_call_virt_save_flags(void);
|
||||
|
||||
@ -157,5 +157,5 @@ index b73b4bcaa32f..bde09740a9b5 100644
|
||||
|
||||
#ifdef CONFIG_RESET_ATTACK_MITIGATION
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -68,5 +68,5 @@ index e84ddf484010..d0501353a4b9 100644
|
||||
prompt "Kernel default lockdown mode"
|
||||
default LOCK_DOWN_KERNEL_FORCE_NONE
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -51,5 +51,5 @@ index 81d0414e2117..a3c5be79a9cc 100644
|
||||
};
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -39,5 +39,5 @@ index 4cbd49c87568..aa9baa923fd9 100644
|
||||
ice_wq = alloc_workqueue("%s", WQ_MEM_RECLAIM, 0, KBUILD_MODNAME);
|
||||
if (!ice_wq) {
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -39,5 +39,5 @@ index 3e4868a6498b..502f9a9a2806 100644
|
||||
|
||||
$(version_h): FORCE
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -94,5 +94,5 @@ index d43120eb1dc5..1920be30a378 100644
|
||||
+arch_initcall(iommu_quirks);
|
||||
+#endif
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -119,5 +119,5 @@ index e1b22fe0916c..894eda427214 100644
|
||||
rv = ipmi_register_driver();
|
||||
mutex_unlock(&ipmi_interfaces_mutex);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -210,5 +210,5 @@ index 000000000000..e0d3353802bb
|
||||
+
|
||||
+#endif /* _LINUX_RH_KABI_H */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -185,5 +185,5 @@ index d631d22089ba..c252221b2f4b 100644
|
||||
* if the commandline contains a ':', then that's the extended
|
||||
* syntax -- if not, it must be the classic syntax
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -39,5 +39,5 @@ index c252221b2f4b..df551fc9034c 100644
|
||||
|
||||
/*
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -89,5 +89,5 @@ index 9f1557b98468..d631d22089ba 100644
|
||||
break;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -49,5 +49,5 @@ index e3bae852d92f..8ab004b0f846 100644
|
||||
[ TAINT_RESERVED29 ] = { '?', '-', false },
|
||||
[ TAINT_RESERVED30 ] = { '?', '-', false },
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -43,5 +43,5 @@ index 00668335c2af..219f95ab56f8 100644
|
||||
/* Fusion */
|
||||
{PCI_DEVICE(PCI_VENDOR_ID_LSI_LOGIC, PCI_DEVICE_ID_LSI_PLASMA)},
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -67,5 +67,5 @@ index e362dc3d2028..0c3dfb8eef67 100644
|
||||
|
||||
debugfs_create_file("kmemleak", 0644, NULL, NULL, &kmemleak_fops);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -94,7 +94,7 @@ index 2e6670860d27..8c35a5db7d7e 100644
|
||||
|
||||
/* Exported symbols */
|
||||
diff --git a/kernel/module.c b/kernel/module.c
|
||||
index e8a198588f26..98b34eb6d14f 100644
|
||||
index 0c6573b98c36..4898faa4e8e1 100644
|
||||
--- a/kernel/module.c
|
||||
+++ b/kernel/module.c
|
||||
@@ -802,6 +802,7 @@ static struct module_attribute modinfo_##field = { \
|
||||
@ -147,5 +147,5 @@ index 6aea65c65745..ed3c4d8a1c7f 100644
|
||||
sprintf(fname, "%s.mod.c", mod->name);
|
||||
write_if_changed(&buf, fname);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -67,5 +67,5 @@ index 08fc4b381056..1305a2b72536 100644
|
||||
{ MPI2_MFGPAGE_VENDORID_LSI, MPI25_MFGPAGE_DEVID_SAS3004,
|
||||
PCI_ANY_ID, PCI_ANY_ID },
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -47,5 +47,5 @@ index 6a79cd0ebe2b..c17614cd6ed8 100644
|
||||
if (error) {
|
||||
dprintk(ioc, printk(MYIOC_s_ERR_FMT
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -54,5 +54,5 @@ index c17614cd6ed8..ca44a35ec411 100644
|
||||
};
|
||||
MODULE_DEVICE_TABLE(pci, mptsas_pci_table);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -47,5 +47,5 @@ index eabc4de5816c..c028f5944694 100644
|
||||
|
||||
out_mptspi_probe:
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -52,5 +52,5 @@ index c028f5944694..1f458e35effb 100644
|
||||
};
|
||||
MODULE_DEVICE_TABLE(pci, mptspi_pci_table);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -59,7 +59,7 @@ Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ac2c61c37a73..9e33fdf83e11 100644
|
||||
index a60c98519c37..a3ec72fe1d8a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1217,7 +1217,13 @@ endef
|
||||
@ -78,5 +78,5 @@ index ac2c61c37a73..9e33fdf83e11 100644
|
||||
|
||||
$(version_h): FORCE
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -75,5 +75,5 @@ index e92fad99338c..8dae589e7e50 100644
|
||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2271) },
|
||||
{ PCI_DEVICE(PCI_VENDOR_ID_QLOGIC, PCI_DEVICE_ID_QLOGIC_ISP2261) },
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -52,5 +52,5 @@ index 5dc697ce8b5d..15f4bedc3a78 100644
|
||||
};
|
||||
MODULE_DEVICE_TABLE(pci, qla4xxx_pci_tbl);
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -46,5 +46,5 @@ index 8d1641710ed7..4050b6dead75 100644
|
||||
EXPORT_SYMBOL(mark_hardware_unsupported);
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -197,5 +197,5 @@ index 87f2bd530df7..d551df994583 100644
|
||||
+
|
||||
#endif /* _LINUX_RH_KABI_H */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -43,5 +43,5 @@ index d551df994583..9a4fea93ad99 100644
|
||||
|
||||
/*
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -46,5 +46,5 @@ index 9a4fea93ad99..cdc636d3013d 100644
|
||||
/*
|
||||
* RH_KABI_SET_SIZE calculates and sets the size of the extended struct and
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -63,5 +63,5 @@ index 4debb7aaad48..b90601e8a657 100644
|
||||
* considered not to be part of the kABI whitelist and may be changed at
|
||||
* will. Note however that it's the responsibility of the developer
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -61,5 +61,5 @@ index b90601e8a657..ea9c136bf884 100644
|
||||
})
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -97,5 +97,5 @@ index cdc636d3013d..4debb7aaad48 100644
|
||||
* RHEL macros to extend structs.
|
||||
*
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -100,5 +100,5 @@ index e0d3353802bb..87f2bd530df7 100644
|
||||
+
|
||||
#endif /* _LINUX_RH_KABI_H */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -63,5 +63,5 @@ index 5853c9872dfe..fab9bc9889da 100644
|
||||
/* boot_command_line has been already set up in early.c */
|
||||
*cmdline_p = boot_command_line;
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -66,5 +66,5 @@ index cd157f11eb22..c5dc6cf57a71 100644
|
||||
PCI_DEVICE_SUB(PCI_VENDOR_ID_ADAPTEC2, 0x028f,
|
||||
PCI_VENDOR_ID_DELL, 0x1fe0)
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -99,5 +99,5 @@ index 0ce3e73edd42..8fe9a9911261 100644
|
||||
int security_perf_event_open(struct perf_event_attr *attr, int type)
|
||||
{
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -50,5 +50,5 @@ index 4e18ae5282a6..805341c0aaf3 100755
|
||||
# Use make KBUILD_ABS_SRCTREE=1 {tags|cscope}
|
||||
# to force full paths for a non-O= build
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -54,5 +54,5 @@ index c27289fd619a..f8a8d6b3c521 100644
|
||||
VMMDEVREQ_SIZEHACK = 0x7fffffff
|
||||
};
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -316,5 +316,5 @@ index f79d7abe27db..15125f6ec60d 100644
|
||||
struct vbg_ioctl_set_guest_caps {
|
||||
/** The header. */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -126,5 +126,5 @@ index aee5eff229f2..15b3cb618c6e 100644
|
||||
return ret;
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -119,5 +119,5 @@ index 9cec58a6a5ea..f79d7abe27db 100644
|
||||
|
||||
/** VBG_IOCTL_WAIT_FOR_EVENTS data structure. */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -43,5 +43,5 @@ index 6337b8d75d96..21f408120e3f 100644
|
||||
/** struct vmmdev_hypervisorinfo - Hypervisor info structure. */
|
||||
struct vmmdev_hypervisorinfo {
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -26,5 +26,5 @@ index ffd76b949276..e0e343d0ba93 100644
|
||||
}
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -99,5 +99,5 @@ index 77c3a9c8255d..dc745a033164 100644
|
||||
u32 requestor;
|
||||
/** Set on CANCEL_ALL_WAITEVENTS, protected by vbg_devevent_spinlock. */
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -57,5 +57,5 @@ index e677bb144835..6d31895c8e92 100644
|
||||
unwind_init();
|
||||
}
|
||||
--
|
||||
2.26.2
|
||||
2.25.4
|
||||
|
||||
|
@ -1854,6 +1854,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1444,6 +1444,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1846,6 +1846,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1436,6 +1436,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1893,6 +1893,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1886,6 +1886,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1845,6 +1845,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1838,6 +1838,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_ARMSTUB_DTB_LOADER=y
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1591,6 +1591,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
# CONFIG_EFI_CAPSULE_QUIRK_QUARK_CSH is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1582,6 +1582,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
# CONFIG_EFI_CAPSULE_QUIRK_QUARK_CSH is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1455,6 +1455,7 @@ CONFIG_EEPROM_EE1004=m
|
||||
CONFIG_EEPROM_IDT_89HPESX=m
|
||||
CONFIG_EEPROM_LEGACY=m
|
||||
CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1318,6 +1318,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1446,6 +1446,7 @@ CONFIG_EEPROM_EE1004=m
|
||||
CONFIG_EEPROM_IDT_89HPESX=m
|
||||
CONFIG_EEPROM_LEGACY=m
|
||||
CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1310,6 +1310,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1461,6 +1461,7 @@ CONFIG_EEPROM_EE1004=m
|
||||
CONFIG_EEPROM_IDT_89HPESX=m
|
||||
CONFIG_EEPROM_LEGACY=m
|
||||
CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1322,6 +1322,7 @@ CONFIG_EDAC_PND2=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1452,6 +1452,7 @@ CONFIG_EEPROM_EE1004=m
|
||||
CONFIG_EEPROM_IDT_89HPESX=m
|
||||
CONFIG_EEPROM_LEGACY=m
|
||||
CONFIG_EEPROM_MAX6875=m
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
CONFIG_EFI_PARTITION=y
|
||||
|
@ -1314,6 +1314,7 @@ CONFIG_EDAC_PND2=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1324,6 +1324,7 @@ CONFIG_EDAC_PND2=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1627,6 +1627,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
# CONFIG_EFI_CAPSULE_QUIRK_QUARK_CSH is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
@ -1419,6 +1419,7 @@ CONFIG_EEPROM_MAX6875=m
|
||||
# CONFIG_EFI_ARMSTUB_DTB_LOADER is not set
|
||||
# CONFIG_EFI_BOOTLOADER_CONTROL is not set
|
||||
# CONFIG_EFI_CAPSULE_LOADER is not set
|
||||
CONFIG_EFI_CUSTOM_SSDT_OVERLAYS=y
|
||||
# CONFIG_EFI_DISABLE_PCI_DMA is not set
|
||||
# CONFIG_EFI_FAKE_MEMMAP is not set
|
||||
CONFIG_EFI_GENERIC_STUB_INITRD_CMDLINE_LOADER=y
|
||||
|
Some files were not shown because too many files have changed in this diff Show More
Loading…
Reference in New Issue
Block a user