kernel-5.10.0-98
* Mon Dec 14 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.10.0-98] - Add missing '$' sign to (GIT) in redhat/Makefile (Augusto Caringi) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
39cafd6608
commit
952ed53b8d
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 97
|
||||
RHEL_RELEASE = 98
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,7 +1,6 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
|
||||
# shellcheck disable=SC1091
|
||||
. /etc/os-release
|
||||
|
||||
kernelver=$1 && shift
|
||||
@ -19,10 +18,7 @@ else
|
||||
debugid=""
|
||||
fi
|
||||
|
||||
# shellcheck will complain about bootprefix being referenced but not assigned,
|
||||
# but that is perfectly OK here.
|
||||
# shellcheck disable=SC2154
|
||||
cat > "$output" <<EOF
|
||||
cat >${output} <<EOF
|
||||
title ${NAME} (${kernelver}) ${VERSION}${debugname}
|
||||
version ${kernelver}${debugid}
|
||||
linux ${bootprefix}/vmlinuz-${kernelver}
|
||||
|
94
kernel.spec
Executable file → Normal file
94
kernel.spec
Executable file → Normal file
@ -56,7 +56,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc7.20201211git33dc9614dc20.97
|
||||
%global distro_build 98
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -97,13 +97,13 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.10.0
|
||||
%define pkgrelease 0.rc7.20201211git33dc9614dc20.97
|
||||
%define pkgrelease 98
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 10
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc7.20201211git33dc9614dc20.97%{?buildid}%{?dist}
|
||||
%define specrelease 98%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -193,7 +193,7 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||
# and 0 for rawhide (all kernels are debug kernels).
|
||||
# See also 'make debug' and 'make release'.
|
||||
%define debugbuildsenabled 0
|
||||
%define debugbuildsenabled 1
|
||||
|
||||
# The kernel tarball/base version
|
||||
%define kversion 5.10
|
||||
@ -590,7 +590,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-20201211git33dc9614dc20.tar.xz
|
||||
Source0: linux-5.10.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -740,7 +740,6 @@ Source4000: README.rst
|
||||
%if !%{nopatches}
|
||||
|
||||
Patch1: patch-%{rpmversion}-redhat.patch
|
||||
Patch2: revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
%endif
|
||||
|
||||
# empty final patch to facilitate testing of kernel patches
|
||||
@ -1235,8 +1234,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-20201211git33dc9614dc20 -c
|
||||
mv linux-20201211git33dc9614dc20 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.10 -c
|
||||
mv linux-5.10 linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1244,7 +1243,6 @@ cp -a %{SOURCE1} .
|
||||
%if !%{nopatches}
|
||||
|
||||
ApplyOptionalPatch patch-%{rpmversion}-redhat.patch
|
||||
ApplyOptionalPatch revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
%endif
|
||||
|
||||
ApplyOptionalPatch linux-kernel-test.patch
|
||||
@ -1273,7 +1271,10 @@ pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p -n \
|
||||
scripts/diffconfig \
|
||||
scripts/bloat-o-meter \
|
||||
scripts/jobserver-exec \
|
||||
tools \
|
||||
tools/perf/tests/attr.py \
|
||||
tools/perf/scripts/python/stat-cpi.py \
|
||||
tools/perf/scripts/python/sched-migration.py \
|
||||
tools/testing/selftests/drivers/net/mlxsw/sharedbuffer_configuration.py \
|
||||
Documentation \
|
||||
scripts/clang-tools
|
||||
|
||||
@ -1674,38 +1675,9 @@ BuildKernel() {
|
||||
cp -a --parents tools/include/tools/be_byteshift.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/tools/le_byteshift.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
# Files for 'make prepare' to succeed with kernel-devel.
|
||||
cp -a --parents tools/include/linux/compiler* $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/linux/types.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/build/Build.include $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/build/Build $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/build/fixdep.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/objtool/sync-check.sh $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/bpf/resolve_btfids $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
cp --parents security/selinux/include/policycap_names.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents security/selinux/include/policycap.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
cp -a --parents tools/include/asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/linux $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/uapi/asm $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/uapi/asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/uapi/linux $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/include/vdso $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/scripts/utilities.mak $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/lib/subcmd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/lib/*.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/objtool/*.[ch] $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/objtool/Build $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/lib/bpf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp --parents tools/lib/bpf/Build $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
if [ -f tools/objtool/objtool ]; then
|
||||
cp -a tools/objtool/objtool $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools/objtool/ || :
|
||||
fi
|
||||
if [ -f tools/objtool/fixdep ]; then
|
||||
cp -a tools/objtool/fixdep $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools/objtool/ || :
|
||||
fi
|
||||
if [ -d arch/$Arch/scripts ]; then
|
||||
cp -a arch/$Arch/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
|
||||
fi
|
||||
@ -1751,6 +1723,7 @@ BuildKernel() {
|
||||
cp -a --parents arch/x86/tools/relocs.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/tools/relocs_common.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/tools/relocs.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents tools/include/tools/le_byteshift.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/purgatory/purgatory.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/purgatory/stack.S $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/purgatory/setup-x86_64.S $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
@ -1758,18 +1731,7 @@ BuildKernel() {
|
||||
cp -a --parents arch/x86/boot/string.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/boot/string.c $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
cp -a --parents arch/x86/boot/ctype.h $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
|
||||
|
||||
cp -a --parents tools/arch/x86/include/asm $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/arch/x86/include/uapi/asm $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/objtool/arch/x86/lib $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/arch/x86/lib/ $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/arch/x86/tools/gen-insn-attr-x86.awk $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
cp -a --parents tools/objtool/arch/x86/ $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
|
||||
|
||||
%endif
|
||||
# Clean up intermediate tools files
|
||||
find $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools \( -iname "*.o" -o -iname "*.cmd" \) -exec rm -f {} +
|
||||
|
||||
# Make sure the Makefile and version.h have a matching timestamp so that
|
||||
# external modules can be built
|
||||
touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/generated/uapi/linux/version.h
|
||||
@ -2725,32 +2687,12 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Dec 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201211git33dc9614dc20.97]
|
||||
- Remove cp instruction already handled in instruction below. ("Paulo E. Castro")
|
||||
- Add all the dependencies gleaned from running `make prepare` on a bloated devel kernel. ("Paulo E. Castro")
|
||||
- Add tools to path mangling script. ("Paulo E. Castro")
|
||||
- Remove duplicate cp statement which is also not specific to x86. ("Paulo E. Castro")
|
||||
- Correct orc_types failure whilst running `make prepare` https://bugzilla.redhat.com/show_bug.cgi?id=1882854 ("Paulo E. Castro")
|
||||
- build_configs.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- genspec.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- ark-rebase-patches.sh: Fix for shellcheck (Ben Crocker)
|
||||
- ark-create-release.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- merge-subtrees.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- rh-dist-git.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- update_scripts.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- x86_rngd.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- parallel_xz.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- expand_srpm.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- create-tarball.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- generate_bls_conf.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- clone_tree.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- new_release.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- download_cross.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- create_distgit_changelog.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- generate_cross_report.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- run_kabi-dw.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- mod-blacklist.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
- scripts/configdiff.sh: Fix syntax flagged by shellcheck (Ben Crocker)
|
||||
* Mon Dec 14 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.10.0-98]
|
||||
- Add missing '$' sign to (GIT) in redhat/Makefile (Augusto Caringi)
|
||||
|
||||
* Sat Dec 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201212git7f376f1917d7.97]
|
||||
- Remove filterdiff and use native git instead (Don Zickus)
|
||||
- New configs in net/sched ("Justin M. Forbes")
|
||||
|
||||
* Fri Dec 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201211git33dc9614dc20.96]
|
||||
- redhat: explicitly disable CONFIG_IMA_APPRAISE_SIGNED_INIT (Bruno Meneguele)
|
||||
|
@ -1,5 +1,4 @@
|
||||
#! /bin/bash
|
||||
# shellcheck disable=SC2164
|
||||
|
||||
RpmDir=$1
|
||||
ModDir=$2
|
||||
@ -25,9 +24,9 @@ __EOF__
|
||||
|
||||
check_blacklist()
|
||||
{
|
||||
mod=$(find "$RpmDir/$ModDir" -name "$1")
|
||||
mod=$(find $RpmDir/$ModDir -name "$1")
|
||||
[ ! "$mod" ] && return 0
|
||||
if modinfo "$mod" | grep -q '^alias:\s\+net-'; then
|
||||
if modinfo $mod | grep -q '^alias:\s\+net-'; then
|
||||
mod="${1##*/}"
|
||||
mod="${mod%.ko*}"
|
||||
echo "$mod has an alias that allows auto-loading. Blacklisting."
|
||||
@ -38,7 +37,7 @@ check_blacklist()
|
||||
find_depends()
|
||||
{
|
||||
dep=$1
|
||||
depends=$(modinfo "$dep" | sed -n -e "/^depends/ s/^depends:[ \t]*//p")
|
||||
depends=`modinfo $dep | sed -n -e "/^depends/ s/^depends:[ \t]*//p"`
|
||||
[ -z "$depends" ] && exit
|
||||
for mod in ${depends//,/ }
|
||||
do
|
||||
@ -46,14 +45,14 @@ find_depends()
|
||||
[ -z "$match" ] && continue
|
||||
# check if the module we are looking at is in mod-* too.
|
||||
# if so we do not need to mark the dep as required.
|
||||
mod2=${dep##*/} # same as $(basename $dep), but faster
|
||||
mod2=${dep##*/} # same as `basename $dep`, but faster
|
||||
match2=$(grep "^$mod2" "$ListName")
|
||||
if [ -n "$match2" ]
|
||||
then
|
||||
#echo $mod2 >> notreq.list
|
||||
continue
|
||||
fi
|
||||
echo "$mod".ko >> req.list
|
||||
echo $mod.ko >> req.list
|
||||
done
|
||||
}
|
||||
|
||||
@ -61,11 +60,11 @@ foreachp()
|
||||
{
|
||||
P=$(nproc)
|
||||
bgcount=0
|
||||
while read -r mod; do
|
||||
while read mod; do
|
||||
$1 "$mod" &
|
||||
|
||||
bgcount=$((bgcount + 1))
|
||||
if [ $bgcount -eq "$P" ]; then
|
||||
if [ $bgcount -eq $P ]; then
|
||||
wait -n
|
||||
bgcount=$((bgcount - 1))
|
||||
fi
|
||||
@ -77,12 +76,12 @@ foreachp()
|
||||
# Destination was specified on the command line
|
||||
test -n "$4" && echo "$0: Override Destination $Dest has been specified."
|
||||
|
||||
pushd "$Dir"
|
||||
pushd $Dir
|
||||
|
||||
OverrideDir=$(basename "$List")
|
||||
OverrideDir=$(basename $List)
|
||||
OverrideDir=${OverrideDir%.*}
|
||||
OverrideDir=${OverrideDir#*-}
|
||||
mkdir -p "$OverrideDir"
|
||||
mkdir -p $OverrideDir
|
||||
|
||||
rm -rf modnames
|
||||
find . -name "*.ko" -type f > modnames
|
||||
@ -95,8 +94,7 @@ cp "$List" .
|
||||
|
||||
# This variable needs to be exported because it is used in sub-script
|
||||
# executed by xargs
|
||||
ListName=$(basename "$List")
|
||||
export ListName
|
||||
export ListName=$(basename "$List")
|
||||
|
||||
foreachp find_depends < modnames
|
||||
|
||||
@ -104,25 +102,25 @@ sort -u req.list > req2.list
|
||||
sort -u "$ListName" > modules2.list
|
||||
join -v 1 modules2.list req2.list > modules3.list
|
||||
|
||||
while IFS= read -r mod
|
||||
for mod in $(cat modules3.list)
|
||||
do
|
||||
# get the path for the module
|
||||
modpath=$(grep /"$mod" modnames)
|
||||
[ -z "$modpath" ] && continue
|
||||
echo "$modpath" >> dep.list
|
||||
done < modules3.list
|
||||
# get the path for the module
|
||||
modpath=`grep /$mod modnames`
|
||||
[ -z "$modpath" ] && continue
|
||||
echo $modpath >> dep.list
|
||||
done
|
||||
|
||||
sort -u dep.list > dep2.list
|
||||
|
||||
if [ -n "$Dest" ]; then
|
||||
# now move the modules into the $Dest directory
|
||||
while IFS= read -r mod
|
||||
do
|
||||
newpath=$(dirname "$mod" | sed -e "s/kernel\\//$Dest\//")
|
||||
mkdir -p "$newpath"
|
||||
mv "$mod" "$newpath"
|
||||
echo "$mod" | sed -e "s/kernel\\//$Dest\//" | sed -e "s|^.|${ModDir}|g" >> "$RpmDir"/"$ListName"
|
||||
done < dep2.list
|
||||
# now move the modules into the $Dest directory
|
||||
for mod in `cat dep2.list`
|
||||
do
|
||||
newpath=`dirname $mod | sed -e "s/kernel\\//$Dest\//"`
|
||||
mkdir -p $newpath
|
||||
mv $mod $newpath
|
||||
echo $mod | sed -e "s/kernel\\//$Dest\//" | sed -e "s|^.|${ModDir}|g" >> $RpmDir/$ListName
|
||||
done
|
||||
fi
|
||||
|
||||
popd
|
||||
@ -132,33 +130,31 @@ popd
|
||||
# target doesn't try to sign a non-existent file. This is kinda ugly, but
|
||||
# so are the modules-* packages.
|
||||
|
||||
while IFS= read -r mod
|
||||
for mod in `cat ${Dir}/dep2.list`
|
||||
do
|
||||
modfile=$(basename "$mod" | sed -e 's/.ko/.mod/')
|
||||
rm .tmp_versions/"$modfile"
|
||||
done < "$Dir"/dep2.list
|
||||
modfile=`basename $mod | sed -e 's/.ko/.mod/'`
|
||||
rm .tmp_versions/$modfile
|
||||
done
|
||||
|
||||
if [ -z "$Dest" ]; then
|
||||
sed -e "s|^.|${ModDir}|g" "$Dir"/dep2.list > "$RpmDir/$ListName"
|
||||
if [ ! -n "$Dest" ]; then
|
||||
sed -e "s|^.|${ModDir}|g" ${Dir}/dep2.list > $RpmDir/$ListName
|
||||
echo "./$RpmDir/$ListName created."
|
||||
[ -d "$RpmDir/etc/modprobe.d/" ] || mkdir -p "$RpmDir/etc/modprobe.d/"
|
||||
foreachp check_blacklist < "$List"
|
||||
foreachp check_blacklist < $List
|
||||
fi
|
||||
|
||||
# Many BIOS-es export a PNP-id which causes the floppy driver to autoload
|
||||
# even though most modern systems don't have a 3.5" floppy driver anymore
|
||||
# this replaces the old die_floppy_die.patch which removed the PNP-id from
|
||||
# the module
|
||||
|
||||
floppylist=("$RpmDir"/"$ModDir"/extra/drivers/block/floppy.ko*)
|
||||
if [[ -n ${floppylist[0]} && -f ${floppylist[0]} ]]; then
|
||||
blacklist "floppy"
|
||||
if [ -f $RpmDir/$ModDir/extra/drivers/block/floppy.ko* ]; then
|
||||
blacklist "floppy"
|
||||
fi
|
||||
|
||||
# avoid an empty kernel-extra package
|
||||
echo "$ModDir/$OverrideDir" >> "$RpmDir/$ListName"
|
||||
echo "$ModDir/$OverrideDir" >> $RpmDir/$ListName
|
||||
|
||||
pushd "$Dir"
|
||||
pushd $Dir
|
||||
rm modnames dep.list dep2.list req.list req2.list
|
||||
rm "$ListName" modules2.list modules3.list
|
||||
popd
|
||||
|
@ -23,4 +23,4 @@ test "$procgroup" = 1 && exec xargs -r xz
|
||||
# xz has some startup cost. If files are really small,
|
||||
# this cost might be significant. To combat this,
|
||||
# process several files (in sequence) by each xz process via -n 16:
|
||||
exec xargs -r -n 16 -P "$procgroup" xz
|
||||
exec xargs -r -n 16 -P $procgroup xz
|
||||
|
@ -202,7 +202,7 @@ index 000000000000..effb81d04bfd
|
||||
+
|
||||
+endmenu
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 9ec53d947628..43dc30764eda 100644
|
||||
index e30cf02da8b8..91c8dfc1f8a7 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -18,6 +18,10 @@ $(if $(filter __%, $(MAKECMDGOALS)), \
|
||||
@ -1859,7 +1859,7 @@ index 8f3772480582..b2ced7ed9d8e 100644
|
||||
{ 0x9005, 0x028c, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 63 }, /* Adaptec PMC Series 7 (Denali) */
|
||||
{ 0x9005, 0x028d, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 64 }, /* Adaptec PMC Series 8 */
|
||||
diff --git a/drivers/scsi/be2iscsi/be_main.c b/drivers/scsi/be2iscsi/be_main.c
|
||||
index 202ba925c494..094a9b551247 100644
|
||||
index 5c3513a4b450..0d59aca2cf58 100644
|
||||
--- a/drivers/scsi/be2iscsi/be_main.c
|
||||
+++ b/drivers/scsi/be2iscsi/be_main.c
|
||||
@@ -370,11 +370,13 @@ static int beiscsi_eh_device_reset(struct scsi_cmnd *sc)
|
||||
@ -2651,7 +2651,7 @@ index 39642626a707..17d55164b892 100644
|
||||
|
||||
#if defined(CONFIG_SECURITY) && defined(CONFIG_WATCH_QUEUE)
|
||||
diff --git a/kernel/Makefile b/kernel/Makefile
|
||||
index af601b9bda0e..eb29602a431b 100644
|
||||
index 6c9f19911be0..81a49119f668 100644
|
||||
--- a/kernel/Makefile
|
||||
+++ b/kernel/Makefile
|
||||
@@ -12,6 +12,8 @@ obj-y = fork.o exec_domain.o panic.o \
|
||||
|
@ -1,90 +0,0 @@
|
||||
From: akpm@linux-foundation.org
|
||||
To: mm-commits@vger.kernel.org, mkubecek@suse.cz, jrdr.linux@gmail.com,
|
||||
josef@toxicpanda.com, jmforbes@linuxtx.org, daniel@iogearbox.net,
|
||||
ast@kernel.org, alex.shi@linux.alibaba.com, akpm@linux-foundation.org
|
||||
Subject: +
|
||||
revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
added to -mm tree
|
||||
Message-ID: <20201208034157.9KFja%akpm@linux-foundation.org>
|
||||
User-Agent: s-nail v14.9.10
|
||||
|
||||
|
||||
The patch titled
|
||||
Subject: revert "mm/filemap: add static for function __add_to_page_cache_locked"
|
||||
has been added to the -mm tree. Its filename is
|
||||
revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
|
||||
This patch should soon appear at
|
||||
https://ozlabs.org/~akpm/mmots/broken-out/revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
and later at
|
||||
https://ozlabs.org/~akpm/mmotm/broken-out/revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
|
||||
Before you just go and hit "reply", please:
|
||||
a) Consider who else should be cc'ed
|
||||
b) Prefer to cc a suitable mailing list as well
|
||||
c) Ideally: find the original patch on the mailing list and do a
|
||||
reply-to-all to that, adding suitable additional cc's
|
||||
|
||||
*** Remember to use Documentation/process/submit-checklist.rst when testing your code ***
|
||||
|
||||
The -mm tree is included into linux-next and is updated
|
||||
there every 3-4 working days
|
||||
|
||||
------------------------------------------------------
|
||||
From: Andrew Morton <akpm@linux-foundation.org>
|
||||
Subject: revert "mm/filemap: add static for function __add_to_page_cache_locked"
|
||||
|
||||
Revert 3351b16af494 ("mm/filemap: add static for function
|
||||
__add_to_page_cache_locked") due to build issues with
|
||||
CONFIG_DEBUG_INFO_BTF=y.
|
||||
|
||||
Link: https://lkml.kernel.org/r/CAADnVQJ6tmzBXvtroBuEH6QA0H+q7yaSKxrVvVxhqr3KBZdEXg@mail.gmail.com
|
||||
Cc: Michal Kubecek <mkubecek@suse.cz>
|
||||
Cc: Justin Forbes <jmforbes@linuxtx.org>
|
||||
Cc: Alex Shi <alex.shi@linux.alibaba.com>
|
||||
Cc: Souptick Joarder <jrdr.linux@gmail.com>
|
||||
Cc: Alexei Starovoitov <ast@kernel.org>
|
||||
Cc: Daniel Borkmann <daniel@iogearbox.net>
|
||||
Cc: Josef Bacik <josef@toxicpanda.com>
|
||||
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
|
||||
---
|
||||
|
||||
mm/filemap.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/mm/filemap.c~revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked
|
||||
+++ a/mm/filemap.c
|
||||
@@ -827,7 +827,7 @@ int replace_page_cache_page(struct page
|
||||
}
|
||||
EXPORT_SYMBOL_GPL(replace_page_cache_page);
|
||||
|
||||
-static noinline int __add_to_page_cache_locked(struct page *page,
|
||||
+noinline int __add_to_page_cache_locked(struct page *page,
|
||||
struct address_space *mapping,
|
||||
pgoff_t offset, gfp_t gfp,
|
||||
void **shadowp)
|
||||
_
|
||||
|
||||
Patches currently in -mm which might be from akpm@linux-foundation.org are
|
||||
|
||||
revert-mm-filemap-add-static-for-function-__add_to_page_cache_locked.patch
|
||||
kthread_worker-document-cpu-hotplug-handling-fix.patch
|
||||
mm.patch
|
||||
mm-remove-the-unuseful-else-after-a-return-checkpatch-fixes.patch
|
||||
mm-prevent-gup_fast-from-racing-with-cow-during-fork-checkpatch-fixes.patch
|
||||
mm-swap_state-skip-meaningless-swap-cache-readahead-when-ra_infowin-==-0-fix.patch
|
||||
mm-vmallocc-__vmalloc_area_node-avoid-32-bit-overflow.patch
|
||||
mm-cma-improve-pr_debug-log-in-cma_release-fix.patch
|
||||
mm-vmstat-fix-proc-sys-vm-stat_refresh-generating-false-warnings-fix-2.patch
|
||||
lib-cmdline_kunit-add-a-new-test-suite-for-cmdline-api-fix.patch
|
||||
ilog2-improve-ilog2-for-constant-arguments-checkpatch-fixes.patch
|
||||
lib-test_bitmapc-add-for_each_set_clump-test-cases-checkpatch-fixes.patch
|
||||
checkpatch-fix-typo_spelling-check-for-words-with-apostrophe-fix.patch
|
||||
resource-fix-kernel-doc-markups-checkpatch-fixes.patch
|
||||
linux-next-rejects.patch
|
||||
kmap-stupid-hacks-to-make-it-compile.patch
|
||||
init-kconfig-dont-assume-scripts-lld-versionsh-is-executable.patch
|
||||
set_memory-allow-set_direct_map__noflush-for-multiple-pages-fix.patch
|
||||
arch-mm-wire-up-memfd_secret-system-call-were-relevant-fix.patch
|
||||
kernel-forkc-export-kernel_thread-to-modules.patch
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-20201211git33dc9614dc20.tar.xz) = 8ba0768cb918ff27ae82ee4c9631e23cc21c23815d2c9d9c7e162cb0970842efb40c5692b4c2da4ac0c7784143a970201c3e7298fbf1dd688b50b2e6f7ef2387
|
||||
SHA512 (kernel-abi-whitelists-5.10.0-0.rc7.20201211git33dc9614dc20.97.tar.bz2) = 81318457d22867a416cfa744f5a04c859af0a79c7046f66dcc7a1f4b74deb5a64e1e7b2ef1b80ecd72f8377123ba57d9878228efa5caf8b191d98b1d4bb8d11b
|
||||
SHA512 (kernel-kabi-dw-5.10.0-0.rc7.20201211git33dc9614dc20.97.tar.bz2) = 03f00c562085c0e6d6b3d8cd350e45bcb3301215572029520136af00a2c776dc8fe5354a6af9243cc4dbd414c39dd8ee93855dade3878eb49e8fa2fef57f310e
|
||||
SHA512 (linux-5.10.tar.xz) = c28d52bc0c1e2c99017ceeca0bf2e622427f3416e0692090b01f65e3b3a5bce0e3e52ce3cee15d71e84fcb965bd48bdfcccb818c0105035d712ebd07afde9452
|
||||
SHA512 (kernel-abi-whitelists-5.10.0-98.tar.bz2) = e3c85bb9cf256d1695035c1fc6197e85b9c74c021a67fd9c79e3422af6d0334e81aaf6b6c6857245bf4081f37a30638abe222c7ae9a94ec92eda02192a83aa90
|
||||
SHA512 (kernel-kabi-dw-5.10.0-98.tar.bz2) = 6e284faa972833261e5c9090f62efb1d3ed250d994e3e3e630e7d78b65a563799634738986f7640809557470c8edfc6250fc036b59763619f4e06a0767f7a772
|
||||
|
@ -1,12 +1,12 @@
|
||||
#!/bin/sh
|
||||
|
||||
if [ -z "$1" ]; then
|
||||
if [ -z $1 ]; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
TARGET="$1"
|
||||
TARGET=$1
|
||||
|
||||
for i in "$RPM_SOURCE_DIR"/*."$TARGET"; do
|
||||
for i in $RPM_SOURCE_DIR/*.$TARGET; do
|
||||
NEW=${i%.$TARGET}
|
||||
cp "$i" "$NEW"
|
||||
cp $i $NEW
|
||||
done
|
||||
|
Loading…
Reference in New Issue
Block a user