Linux v3.8-rc3-74-gb719f43
This commit is contained in:
parent
95c66487c9
commit
938506818d
@ -1,50 +0,0 @@
|
|||||||
From 690b1ad9d2032d6f2565d44f6564590d47835ae8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Zhang Rui <rui.zhang@intel.com>
|
|
||||||
Date: Thu, 29 Nov 2012 01:30:43 +0800
|
|
||||||
Subject: [PATCH 1/2] ACPI sony-laptop: do proper memcpy for ACPI_TYPE_INTEGER
|
|
||||||
acpi_object
|
|
||||||
|
|
||||||
the return value of __call_snc_method can either be
|
|
||||||
an ACPI_TYPE_BUFFER object or a ACPI_TYPE_INTEGER object.
|
|
||||||
do proper memcpy for ACPI_TYPE_INTEGER object.
|
|
||||||
|
|
||||||
https://bugzilla.kernel.org/show_bug.cgi?id=50111
|
|
||||||
|
|
||||||
Signed-off-by: Zhang Rui <rui.zhang@intel.com>
|
|
||||||
---
|
|
||||||
drivers/platform/x86/sony-laptop.c | 11 +++++------
|
|
||||||
1 file changed, 5 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/platform/x86/sony-laptop.c b/drivers/platform/x86/sony-laptop.c
|
|
||||||
index daaddec..92e0da2 100644
|
|
||||||
--- a/drivers/platform/x86/sony-laptop.c
|
|
||||||
+++ b/drivers/platform/x86/sony-laptop.c
|
|
||||||
@@ -792,20 +792,19 @@ static int sony_nc_buffer_call(acpi_handle handle, char *name, u64 *value,
|
|
||||||
if (!object)
|
|
||||||
return -EINVAL;
|
|
||||||
|
|
||||||
- if (object->type == ACPI_TYPE_BUFFER)
|
|
||||||
+ if (object->type == ACPI_TYPE_BUFFER) {
|
|
||||||
len = MIN(buflen, object->buffer.length);
|
|
||||||
-
|
|
||||||
- else if (object->type == ACPI_TYPE_INTEGER)
|
|
||||||
+ memcpy(buffer, object->buffer.pointer, len);
|
|
||||||
+ } else if (object->type == ACPI_TYPE_INTEGER) {
|
|
||||||
len = MIN(buflen, sizeof(object->integer.value));
|
|
||||||
-
|
|
||||||
- else {
|
|
||||||
+ memcpy(buffer, (void *)&object->integer.value, len);
|
|
||||||
+ } else {
|
|
||||||
pr_warn("Invalid acpi_object: expected 0x%x got 0x%x\n",
|
|
||||||
ACPI_TYPE_BUFFER, object->type);
|
|
||||||
kfree(object);
|
|
||||||
return -EINVAL;
|
|
||||||
}
|
|
||||||
|
|
||||||
- memcpy(buffer, object->buffer.pointer, len);
|
|
||||||
kfree(object);
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.9.5
|
|
||||||
|
|
12
kernel.spec
12
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 3
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 3
|
%define rcrev 3
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 0
|
%define gitrev 1
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -740,8 +740,6 @@ Patch21226: vt-Drop-K_OFF-for-VC_MUTE.patch
|
|||||||
#rhbz 883414
|
#rhbz 883414
|
||||||
Patch21236: mac80211-fix-ibss-scanning.patch
|
Patch21236: mac80211-fix-ibss-scanning.patch
|
||||||
|
|
||||||
#rhbz 873107
|
|
||||||
Patch21237: 0001-ACPI-sony-laptop-do-proper-memcpy-for-ACPI_TYPE_INTE.patch
|
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
@ -1429,9 +1427,6 @@ ApplyPatch vt-Drop-K_OFF-for-VC_MUTE.patch
|
|||||||
#rhbz 883414
|
#rhbz 883414
|
||||||
ApplyPatch mac80211-fix-ibss-scanning.patch
|
ApplyPatch mac80211-fix-ibss-scanning.patch
|
||||||
|
|
||||||
#rhbz 873107
|
|
||||||
ApplyPatch 0001-ACPI-sony-laptop-do-proper-memcpy-for-ACPI_TYPE_INTE.patch
|
|
||||||
|
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
@ -2301,6 +2296,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 14 2013 Justin M. Forbes <jforbes@redhat.com> - 3.8.0-0.rc3.git1.1
|
||||||
|
- Linux v3.8-rc3-74-gb719f43
|
||||||
|
|
||||||
* Fri Jan 11 2013 Josh Boyer <jwboyer@redhat.com>
|
* Fri Jan 11 2013 Josh Boyer <jwboyer@redhat.com>
|
||||||
- Update secure-boot patchset
|
- Update secure-boot patchset
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user