fix utsname for 3.0-rc1
This commit is contained in:
parent
b766b15a87
commit
911cdc530b
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -602,6 +602,8 @@ Patch00: patch-3.%{base_sublevel}-git%{gitrev}.bz2
|
||||
|
||||
Patch02: git-linus.diff
|
||||
|
||||
Patch03: linux-3.0-fix-uts-release.patch
|
||||
|
||||
# we also need compile fixes for -vanilla
|
||||
Patch04: linux-2.6-compile-fixes.patch
|
||||
|
||||
@ -1140,6 +1142,7 @@ done
|
||||
|
||||
ApplyOptionalPatch git-linus.diff
|
||||
|
||||
ApplyPatch linux-3.0-fix-uts-release.patch
|
||||
ApplyPatch linux-2.6-makefile-after_link.patch
|
||||
|
||||
#
|
||||
@ -1928,6 +1931,9 @@ fi
|
||||
# and build.
|
||||
|
||||
%changelog
|
||||
* Wed Jun 01 2011 Kyle McMartin <kmcmartin@redhat.com> 3.0-0.rc1.git0.2
|
||||
- Fix utsname for 3.0-rc1
|
||||
|
||||
* Mon May 30 2011 Kyle McMartin <kmcmartin@redhat.com> 3.0-0.rc1.git0.1
|
||||
- Linux 3.0-rc1 (won't build until module-init-tools gets an update.)
|
||||
|
||||
|
34
linux-3.0-fix-uts-release.patch
Normal file
34
linux-3.0-fix-uts-release.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index afb8e0d..e435bf5 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,6 +1,5 @@
|
||||
VERSION = 3
|
||||
PATCHLEVEL = 0
|
||||
-SUBLEVEL = 0
|
||||
EXTRAVERSION = -rc1
|
||||
NAME = Sneaky Weasel
|
||||
|
||||
@@ -378,9 +377,9 @@ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
||||
|
||||
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
||||
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|
||||
-KERNELVERSION = $(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
|
||||
+KERNELVERSION = $(VERSION).$(PATCHLEVEL)$(EXTRAVERSION)
|
||||
|
||||
-export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
|
||||
+export VERSION PATCHLEVEL KERNELRELEASE KERNELVERSION
|
||||
export ARCH SRCARCH CONFIG_SHELL HOSTCC HOSTCFLAGS CROSS_COMPILE AS LD CC
|
||||
export CPP AR NM STRIP OBJCOPY OBJDUMP
|
||||
export MAKE AWK GENKSYMS INSTALLKERNEL PERL UTS_MACHINE
|
||||
@@ -1005,8 +1004,8 @@ endef
|
||||
|
||||
define filechk_version.h
|
||||
(echo \#define LINUX_VERSION_CODE $(shell \
|
||||
- expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256 + $(SUBLEVEL)); \
|
||||
- echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
|
||||
+ expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256); \
|
||||
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8))';)
|
||||
endef
|
||||
|
||||
include/linux/version.h: $(srctree)/Makefile FORCE
|
Loading…
Reference in New Issue
Block a user