Linux 2.6.36-rc6-git3
This commit is contained in:
parent
1b522fd2e6
commit
8b178f558b
2
.gitignore
vendored
2
.gitignore
vendored
@ -4,4 +4,4 @@ clog
|
|||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
/patch-2.6.36-rc6.bz2
|
/patch-2.6.36-rc6.bz2
|
||||||
/patch-2.6.36-rc6-git2.bz2
|
/patch-2.6.36-rc6-git3.bz2
|
||||||
|
@ -1,105 +0,0 @@
|
|||||||
diff --git a/drivers/gpu/drm/i915/i915_dma.c b/drivers/gpu/drm/i915/i915_dma.c
|
|
||||||
index 9d67b48..c74e4e8 100644
|
|
||||||
--- a/drivers/gpu/drm/i915/i915_dma.c
|
|
||||||
+++ b/drivers/gpu/drm/i915/i915_dma.c
|
|
||||||
@@ -1787,9 +1787,9 @@ unsigned long i915_chipset_val(struct drm_i915_private *dev_priv)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- div_u64(diff, diff1);
|
|
||||||
+ diff = div_u64(diff, diff1);
|
|
||||||
ret = ((m * diff) + c);
|
|
||||||
- div_u64(ret, 10);
|
|
||||||
+ ret = div_u64(ret, 10);
|
|
||||||
|
|
||||||
dev_priv->last_count1 = total_count;
|
|
||||||
dev_priv->last_time1 = now;
|
|
||||||
@@ -1858,7 +1858,7 @@ void i915_update_gfx_val(struct drm_i915_private *dev_priv)
|
|
||||||
|
|
||||||
/* More magic constants... */
|
|
||||||
diff = diff * 1181;
|
|
||||||
- div_u64(diff, diffms * 10);
|
|
||||||
+ diff = div_u64(diff, diffms * 10);
|
|
||||||
dev_priv->gfx_power = diff;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/drivers/platform/x86/intel_ips.c b/drivers/platform/x86/intel_ips.c
|
|
||||||
index 9024480..bfa9c72 100644
|
|
||||||
--- a/drivers/platform/x86/intel_ips.c
|
|
||||||
+++ b/drivers/platform/x86/intel_ips.c
|
|
||||||
@@ -230,7 +230,7 @@
|
|
||||||
#define THM_TC2 0xac
|
|
||||||
#define THM_DTV 0xb0
|
|
||||||
#define THM_ITV 0xd8
|
|
||||||
-#define ITV_ME_SEQNO_MASK 0x000f0000 /* ME should update every ~200ms */
|
|
||||||
+#define ITV_ME_SEQNO_MASK 0x00ff0000 /* ME should update every ~200ms */
|
|
||||||
#define ITV_ME_SEQNO_SHIFT (16)
|
|
||||||
#define ITV_MCH_TEMP_MASK 0x0000ff00
|
|
||||||
#define ITV_MCH_TEMP_SHIFT (8)
|
|
||||||
@@ -940,7 +940,6 @@ static int ips_monitor(void *data)
|
|
||||||
kfree(mch_samples);
|
|
||||||
kfree(cpu_samples);
|
|
||||||
kfree(mchp_samples);
|
|
||||||
- kthread_stop(ips->adjust);
|
|
||||||
return -ENOMEM;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -948,7 +947,7 @@ static int ips_monitor(void *data)
|
|
||||||
ITV_ME_SEQNO_SHIFT;
|
|
||||||
seqno_timestamp = get_jiffies_64();
|
|
||||||
|
|
||||||
- old_cpu_power = thm_readl(THM_CEC) / 65535;
|
|
||||||
+ old_cpu_power = thm_readl(THM_CEC);
|
|
||||||
schedule_timeout_interruptible(msecs_to_jiffies(IPS_SAMPLE_PERIOD));
|
|
||||||
|
|
||||||
/* Collect an initial average */
|
|
||||||
@@ -1390,7 +1389,7 @@ static bool ips_get_i915_syms(struct ips_driver *ips)
|
|
||||||
return true;
|
|
||||||
|
|
||||||
out_put_busy:
|
|
||||||
- symbol_put(i915_gpu_turbo_disable);
|
|
||||||
+ symbol_put(i915_gpu_busy);
|
|
||||||
out_put_lower:
|
|
||||||
symbol_put(i915_gpu_lower);
|
|
||||||
out_put_raise:
|
|
||||||
@@ -1535,19 +1534,24 @@ static int ips_probe(struct pci_dev *dev, const struct pci_device_id *id)
|
|
||||||
ips_enable_cpu_turbo(ips);
|
|
||||||
ips->cpu_turbo_enabled = true;
|
|
||||||
|
|
||||||
- /* Set up the work queue and monitor/adjust threads */
|
|
||||||
- ips->monitor = kthread_run(ips_monitor, ips, "ips-monitor");
|
|
||||||
- if (IS_ERR(ips->monitor)) {
|
|
||||||
+ /* Create thermal adjust thread */
|
|
||||||
+ ips->adjust = kthread_create(ips_adjust, ips, "ips-adjust");
|
|
||||||
+ if (IS_ERR(ips->adjust)) {
|
|
||||||
dev_err(&dev->dev,
|
|
||||||
- "failed to create thermal monitor thread, aborting\n");
|
|
||||||
+ "failed to create thermal adjust thread, aborting\n");
|
|
||||||
ret = -ENOMEM;
|
|
||||||
goto error_free_irq;
|
|
||||||
+
|
|
||||||
}
|
|
||||||
|
|
||||||
- ips->adjust = kthread_create(ips_adjust, ips, "ips-adjust");
|
|
||||||
- if (IS_ERR(ips->adjust)) {
|
|
||||||
+ /*
|
|
||||||
+ * Set up the work queue and monitor thread. The monitor thread
|
|
||||||
+ * will wake up ips_adjust thread.
|
|
||||||
+ */
|
|
||||||
+ ips->monitor = kthread_run(ips_monitor, ips, "ips-monitor");
|
|
||||||
+ if (IS_ERR(ips->monitor)) {
|
|
||||||
dev_err(&dev->dev,
|
|
||||||
- "failed to create thermal adjust thread, aborting\n");
|
|
||||||
+ "failed to create thermal monitor thread, aborting\n");
|
|
||||||
ret = -ENOMEM;
|
|
||||||
goto error_thread_cleanup;
|
|
||||||
}
|
|
||||||
@@ -1566,7 +1570,7 @@ static int ips_probe(struct pci_dev *dev, const struct pci_device_id *id)
|
|
||||||
return ret;
|
|
||||||
|
|
||||||
error_thread_cleanup:
|
|
||||||
- kthread_stop(ips->monitor);
|
|
||||||
+ kthread_stop(ips->adjust);
|
|
||||||
error_free_irq:
|
|
||||||
free_irq(ips->dev->irq, ips);
|
|
||||||
error_unmap:
|
|
10
kernel.spec
10
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 32
|
%global baserelease 33
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 6
|
%define rcrev 6
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -725,8 +725,6 @@ Patch12224: pci-v2-4-4-PCI-allocate-bus-resources-from-the-top-down.patch
|
|||||||
Patch12300: btusb-macbookpro-7-1.patch
|
Patch12300: btusb-macbookpro-7-1.patch
|
||||||
Patch12301: btusb-macbookpro-6-2.patch
|
Patch12301: btusb-macbookpro-6-2.patch
|
||||||
|
|
||||||
Patch12310: fix-intel_ips-to-work-properly.patch
|
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
|
||||||
@ -1944,6 +1942,10 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 05 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.33.rc6.git3
|
||||||
|
- Linux 2.6.36-rc6-git3
|
||||||
|
- Drop intel_ips patches merged upstream.
|
||||||
|
|
||||||
* Sun Oct 03 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.32.rc6.git2
|
* Sun Oct 03 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.32.rc6.git2
|
||||||
- Enable printk.time by default for more useful logs.
|
- Enable printk.time by default for more useful logs.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
|
||||||
df4f4d64d812b6eea0079acb62e8ca83 patch-2.6.36-rc6.bz2
|
df4f4d64d812b6eea0079acb62e8ca83 patch-2.6.36-rc6.bz2
|
||||||
528777aa72e516033deb1dc4c005650f patch-2.6.36-rc6-git2.bz2
|
c99be287793f1b0b3eb7771443937359 patch-2.6.36-rc6-git3.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user