Fix ppc and i686 builds
This commit is contained in:
parent
4327623f9a
commit
89c1f1c04f
@ -11,4 +11,4 @@
|
|||||||
|
|
||||||
driverdirs="atm auxdisplay bcma bluetooth firewire fmc infiniband isdn leds media memstick mfd mmc mtd mwave nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
driverdirs="atm auxdisplay bcma bluetooth firewire fmc infiniband isdn leds media memstick mfd mmc mtd mwave nfc ntb pcmcia platform power ssb staging tty uio uwb w1"
|
||||||
|
|
||||||
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject hid-sensor-hub hid-sensor-magn-3d hid-sensor-incl-3d hid-sensor-gyro-3d hid-sensor-iio-common hid-sensor-accel-3d hid-sensor-trigger hid-sensor-als hid-sensor-rotation target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr parport_serial"
|
singlemods="ntb_netdev iscsi_ibft iscsi_boot_sysfs megaraid pmcraid qedi qla1280 9pnet_rdma rpcrdma nvmet-rdma nvme-rdma hid-picolcd hid-prodikeys hwa-hc hwpoison-inject hid-sensor-hub hid-sensor-magn-3d hid-sensor-incl-3d hid-sensor-gyro-3d hid-sensor-iio-common hid-sensor-accel-3d hid-sensor-trigger hid-sensor-als hid-sensor-rotation hid-sensor-temperature target_core_user sbp_target cxgbit iw_cxgb3 iw_cxgb4 cxgb3i cxgb3i cxgb3i_ddp cxgb4i chcr parport_serial"
|
||||||
|
@ -600,6 +600,9 @@ Patch667: CVE-2017-7645.patch
|
|||||||
# CVE-2017-7477 rhbz 1445207 1445208
|
# CVE-2017-7477 rhbz 1445207 1445208
|
||||||
Patch668: CVE-2017-7477.patch
|
Patch668: CVE-2017-7477.patch
|
||||||
|
|
||||||
|
# Fix build on PPC
|
||||||
|
Patch669: powerpc-fix-distclean-with-Makefile.postlink.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
44
powerpc-fix-distclean-with-Makefile.postlink.patch
Normal file
44
powerpc-fix-distclean-with-Makefile.postlink.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From patchwork Mon May 8 08:50:16 2017
|
||||||
|
Content-Type: text/plain; charset="utf-8"
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
Subject: powerpc: fix distclean with Makefile.postlink
|
||||||
|
From: =?utf-8?q?Horia_Geant=C4=83?= <horia.geanta@nxp.com>
|
||||||
|
X-Patchwork-Id: 9715899
|
||||||
|
Message-Id: <20170508085016.32601-1-horia.geanta@nxp.com>
|
||||||
|
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
|
||||||
|
Paul Mackerras <paulus@samba.org>, Michael Ellerman <mpe@ellerman.id.au>
|
||||||
|
Cc: Nicholas Piggin <npiggin@gmail.com>, Mircea Pop <mircea.pop@nxp.com>,
|
||||||
|
<linuxppc-dev@lists.ozlabs.org>, <linux-kernel@vger.kernel.org>
|
||||||
|
Date: Mon, 8 May 2017 11:50:16 +0300
|
||||||
|
|
||||||
|
Makefile.postlink always includes include/config/auto.conf, however
|
||||||
|
this file is not present in a clean kernel tree, causing make to fail:
|
||||||
|
|
||||||
|
arch/powerpc/Makefile.postlink:10: include/config/auto.conf: No such file or directory
|
||||||
|
make[1]: *** No rule to make target `include/config/auto.conf'. Stop.
|
||||||
|
make: *** [vmlinuxclean] Error 2
|
||||||
|
|
||||||
|
Change the inclusion such that file not being found does not trigger
|
||||||
|
an error.
|
||||||
|
|
||||||
|
Fixes: f188d0524d7e ("powerpc: Use the new post-link pass to check relocations")
|
||||||
|
Reported-by: Mircea Pop <mircea.pop@nxp.com>
|
||||||
|
Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
|
||||||
|
---
|
||||||
|
arch/powerpc/Makefile.postlink | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/arch/powerpc/Makefile.postlink b/arch/powerpc/Makefile.postlink
|
||||||
|
index 3c22d64b2de9..eccfcc88afae 100644
|
||||||
|
--- a/arch/powerpc/Makefile.postlink
|
||||||
|
+++ b/arch/powerpc/Makefile.postlink
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
PHONY := __archpost
|
||||||
|
__archpost:
|
||||||
|
|
||||||
|
-include include/config/auto.conf
|
||||||
|
+-include include/config/auto.conf
|
||||||
|
include scripts/Kbuild.include
|
||||||
|
|
||||||
|
quiet_cmd_relocs_check = CHKREL $@
|
Loading…
Reference in New Issue
Block a user