Linux v3.15-rc1-49-g10ec34fcb100
This commit is contained in:
parent
a21141dbca
commit
865dffb330
@ -0,0 +1,35 @@
|
|||||||
|
Bugzilla: N/A (Eric Paris reported via IRC)
|
||||||
|
Upstream-status: Sent for 3.15
|
||||||
|
|
||||||
|
From: Vincent Donnefort <vdonnefort@gmail.com>
|
||||||
|
|
||||||
|
This patch fixes kernel NULL pointer BUG introduced by the following commit:
|
||||||
|
b667cf488aa9476b0ab64acd91f2a96f188cfd21
|
||||||
|
gpio: ich: Add support for multiple register addresses.
|
||||||
|
|
||||||
|
Signed-off-by: Vincent Donnefort <vdonnefort@gmail.com>
|
||||||
|
|
||||||
|
diff --git a/drivers/gpio/gpio-ich.c b/drivers/gpio/gpio-ich.c
|
||||||
|
index e73c675..7030422 100644
|
||||||
|
--- a/drivers/gpio/gpio-ich.c
|
||||||
|
+++ b/drivers/gpio/gpio-ich.c
|
||||||
|
@@ -305,6 +305,8 @@ static struct ichx_desc ich6_desc = {
|
||||||
|
|
||||||
|
.ngpio = 50,
|
||||||
|
.have_blink = true,
|
||||||
|
+ .regs = ichx_regs,
|
||||||
|
+ .reglen = ichx_reglen,
|
||||||
|
};
|
||||||
|
|
||||||
|
/* Intel 3100 */
|
||||||
|
@@ -324,6 +326,8 @@ static struct ichx_desc i3100_desc = {
|
||||||
|
.uses_gpe0 = true,
|
||||||
|
|
||||||
|
.ngpio = 50,
|
||||||
|
+ .regs = ichx_regs,
|
||||||
|
+ .reglen = ichx_reglen,
|
||||||
|
};
|
||||||
|
|
||||||
|
/* ICH7 and ICH8-based */
|
||||||
|
--
|
||||||
|
1.8.3.2
|
27
kernel.spec
27
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 1
|
%define rcrev 1
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -627,17 +627,14 @@ Patch22000: weird-root-dentry-name-debug.patch
|
|||||||
|
|
||||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||||
|
|
||||||
Patch25058: net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
|
||||||
Patch25061: gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
|
||||||
|
|
||||||
#rhbz 1048314
|
#rhbz 1048314
|
||||||
Patch25062: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
Patch25048: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||||
|
|
||||||
#CVE-2014-2851 rhbz 1086730 1087420
|
|
||||||
Patch25059: net-ipv4-current-group_info-should-be-put-after-using.patch
|
|
||||||
|
|
||||||
#rhbz 1085582 1085697
|
#rhbz 1085582 1085697
|
||||||
Patch25063: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
Patch25049: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
||||||
|
|
||||||
|
Patch25061: gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||||
|
Patch25062: gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
@ -1275,18 +1272,15 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
|
|||||||
|
|
||||||
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||||
|
|
||||||
ApplyPatch net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
|
||||||
ApplyPatch gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
|
||||||
|
|
||||||
#rhbz 1048314
|
#rhbz 1048314
|
||||||
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
|
||||||
|
|
||||||
#CVE-2014-2851 rhbz 1086730 1087420
|
|
||||||
ApplyPatch net-ipv4-current-group_info-should-be-put-after-using.patch
|
|
||||||
|
|
||||||
#rhbz 1085582 1085697
|
#rhbz 1085582 1085697
|
||||||
ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
|
||||||
|
|
||||||
|
ApplyPatch gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||||
|
ApplyPatch gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2066,6 +2060,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 16 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git2.1
|
||||||
|
- Linux v3.15-rc1-49-g10ec34fcb100
|
||||||
|
|
||||||
* Tue Apr 15 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git1.1
|
* Tue Apr 15 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc1.git1.1
|
||||||
- Linux v3.15-rc1-12-g55101e2d6ce1
|
- Linux v3.15-rc1-12-g55101e2d6ce1
|
||||||
- Reenable debugging options.
|
- Reenable debugging options.
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From 54ae981b710324ddc190ed5eab97f265bdf402c5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
Date: Thu, 3 Apr 2014 11:39:15 -0400
|
|
||||||
Subject: [PATCH] net: cpts: Add includes for ETH_HLEN and VLAN_HLEN
|
|
||||||
definitions
|
|
||||||
|
|
||||||
If CONFIG_TI_CPTS is enabled, the ti_cpsw driver will fail to build with:
|
|
||||||
|
|
||||||
drivers/net/ethernet/ti/cpts.c: In function 'cpts_match':
|
|
||||||
drivers/net/ethernet/ti/cpts.c:266:12: error: 'ETH_HLEN' undeclared (first use in this function)
|
|
||||||
offset = ETH_HLEN + IPV4_HLEN(data) + UDP_HLEN;
|
|
||||||
^
|
|
||||||
drivers/net/ethernet/ti/cpts.c:266:12: note: each undeclared identifier is reported only once for each function it appears in
|
|
||||||
drivers/net/ethernet/ti/cpts.c:276:23: error: 'VLAN_HLEN' undeclared (first use in this function)
|
|
||||||
offset = ETH_HLEN + VLAN_HLEN;
|
|
||||||
^
|
|
||||||
|
|
||||||
Add includes of if_ether.h and if_vlan.h to bring in the appropriate defines.
|
|
||||||
|
|
||||||
Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|
||||||
---
|
|
||||||
drivers/net/ethernet/ti/cpts.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/net/ethernet/ti/cpts.c b/drivers/net/ethernet/ti/cpts.c
|
|
||||||
index a3bbf59eaafd..2a2f82ae0c1d 100644
|
|
||||||
--- a/drivers/net/ethernet/ti/cpts.c
|
|
||||||
+++ b/drivers/net/ethernet/ti/cpts.c
|
|
||||||
@@ -19,6 +19,8 @@
|
|
||||||
*/
|
|
||||||
#include <linux/err.h>
|
|
||||||
#include <linux/if.h>
|
|
||||||
+#include <linux/if_ether.h>
|
|
||||||
+#include <linux/if_vlan.h>
|
|
||||||
#include <linux/hrtimer.h>
|
|
||||||
#include <linux/module.h>
|
|
||||||
#include <linux/net_tstamp.h>
|
|
||||||
--
|
|
||||||
1.8.5.3
|
|
||||||
|
|
@ -1,64 +0,0 @@
|
|||||||
Bugzilla: 1087420
|
|
||||||
Upstream-status: Queued for 3.15 and stable
|
|
||||||
|
|
||||||
From b04c46190219a4f845e46a459e3102137b7f6cac Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Wang, Xiaoming" <xiaoming.wang@intel.com>
|
|
||||||
Date: Mon, 14 Apr 2014 12:30:45 -0400
|
|
||||||
Subject: net: ipv4: current group_info should be put after using.
|
|
||||||
|
|
||||||
Plug a group_info refcount leak in ping_init.
|
|
||||||
group_info is only needed during initialization and
|
|
||||||
the code failed to release the reference on exit.
|
|
||||||
While here move grabbing the reference to a place
|
|
||||||
where it is actually needed.
|
|
||||||
|
|
||||||
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
|
|
||||||
Signed-off-by: Zhang Dongxing <dongxing.zhang@intel.com>
|
|
||||||
Signed-off-by: xiaoming wang <xiaoming.wang@intel.com>
|
|
||||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
|
||||||
|
|
||||||
diff --git a/net/ipv4/ping.c b/net/ipv4/ping.c
|
|
||||||
index f4b19e5..8210964 100644
|
|
||||||
--- a/net/ipv4/ping.c
|
|
||||||
+++ b/net/ipv4/ping.c
|
|
||||||
@@ -252,26 +252,33 @@ int ping_init_sock(struct sock *sk)
|
|
||||||
{
|
|
||||||
struct net *net = sock_net(sk);
|
|
||||||
kgid_t group = current_egid();
|
|
||||||
- struct group_info *group_info = get_current_groups();
|
|
||||||
- int i, j, count = group_info->ngroups;
|
|
||||||
+ struct group_info *group_info;
|
|
||||||
+ int i, j, count;
|
|
||||||
kgid_t low, high;
|
|
||||||
+ int ret = 0;
|
|
||||||
|
|
||||||
inet_get_ping_group_range_net(net, &low, &high);
|
|
||||||
if (gid_lte(low, group) && gid_lte(group, high))
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
+ group_info = get_current_groups();
|
|
||||||
+ count = group_info->ngroups;
|
|
||||||
for (i = 0; i < group_info->nblocks; i++) {
|
|
||||||
int cp_count = min_t(int, NGROUPS_PER_BLOCK, count);
|
|
||||||
for (j = 0; j < cp_count; j++) {
|
|
||||||
kgid_t gid = group_info->blocks[i][j];
|
|
||||||
if (gid_lte(low, gid) && gid_lte(gid, high))
|
|
||||||
- return 0;
|
|
||||||
+ goto out_release_group;
|
|
||||||
}
|
|
||||||
|
|
||||||
count -= cp_count;
|
|
||||||
}
|
|
||||||
|
|
||||||
- return -EACCES;
|
|
||||||
+ ret = -EACCES;
|
|
||||||
+
|
|
||||||
+out_release_group:
|
|
||||||
+ put_group_info(group_info);
|
|
||||||
+ return ret;
|
|
||||||
}
|
|
||||||
EXPORT_SYMBOL_GPL(ping_init_sock);
|
|
||||||
|
|
||||||
--
|
|
||||||
cgit v0.10.1
|
|
||||||
|
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
||||||
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
||||||
13e450bb569cfad7c246f0746a7f3217 patch-3.15-rc1.xz
|
13e450bb569cfad7c246f0746a7f3217 patch-3.15-rc1.xz
|
||||||
4976467d25e3ed20728a29cf175c05b5 patch-3.15-rc1-git1.xz
|
9bbba81040ee55548742f24f12de8688 patch-3.15-rc1-git2.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user