Linux v3.14-12376-g4ba85265790b
This commit is contained in:
parent
2ed67326d8
commit
84c4ae5872
@ -154,6 +154,7 @@ CONFIG_EXTCON_PALMAS=m
|
||||
CONFIG_GPIO_PALMAS=y
|
||||
CONFIG_PINCTRL_PALMAS=y
|
||||
CONFIG_REGULATOR_PALMAS=y
|
||||
CONFIG_REGULATOR_PBIAS=m
|
||||
CONFIG_RTC_DRV_PALMAS=m
|
||||
|
||||
CONFIG_WL_TI=y
|
||||
@ -607,6 +608,7 @@ CONFIG_GPIO_XILINX=y
|
||||
CONFIG_I2C_XILINX=m
|
||||
CONFIG_SPI_XILINX=m
|
||||
CONFIG_MMC_SDHCI_OF_ARASAN=m
|
||||
CONFIG_I2C_CADENCE=m
|
||||
|
||||
# Multi function devices
|
||||
CONFIG_MFD_88PM800=m
|
||||
|
@ -4738,6 +4738,7 @@ CONFIG_DW_DMAC_PCI=m
|
||||
# CONFIG_DW_DMAC_BIG_ENDIAN_IO is not set
|
||||
# CONFIG_TIMB_DMA is not set
|
||||
# CONFIG_DMATEST is not set
|
||||
# CONFIG_FSL_EDMA is not set
|
||||
CONFIG_ASYNC_TX_DMA=y
|
||||
|
||||
CONFIG_UNUSED_SYMBOLS=y
|
||||
|
@ -220,6 +220,7 @@ CONFIG_TOPSTAR_LAPTOP=m
|
||||
CONFIG_ACPI_WMI=m
|
||||
CONFIG_ACER_WMI=m
|
||||
CONFIG_ACERHDF=m
|
||||
CONFIG_ALIENWARE_WMI=m
|
||||
CONFIG_ASUS_WMI=m
|
||||
CONFIG_ASUS_NB_WMI=m
|
||||
CONFIG_HP_WIRELESS=m
|
||||
|
11
kernel.spec
11
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 10
|
||||
%define gitrev 11
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -627,9 +627,6 @@ Patch22000: weird-root-dentry-name-debug.patch
|
||||
|
||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#Fixes module loading on ppc64le
|
||||
Patch25036: ppc64le_module_fix.patch
|
||||
|
||||
Patch25058: net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
||||
Patch25059: btrfs-fix-lockdep-warning-with-reclaim-lock-inversion.patch
|
||||
Patch25061: gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||
@ -1276,9 +1273,6 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
|
||||
|
||||
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
# Fixes module loading on ppc64le
|
||||
ApplyPatch ppc64le_module_fix.patch
|
||||
|
||||
ApplyPatch net-cpts-Add-includes-for-ETH_HLEN-and-VLAN_HLEN-def.patch
|
||||
ApplyPatch btrfs-fix-lockdep-warning-with-reclaim-lock-inversion.patch
|
||||
ApplyPatch gpio-ACPI-Dont-crash-on-NULL-chip-dev.patch
|
||||
@ -2068,6 +2062,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Thu Apr 10 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc0.git11.1
|
||||
- Linux v3.14-12376-g4ba85265790b
|
||||
|
||||
* Thu Apr 10 2014 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- Backported HID RMI driver for Haswell Dell XPS machines from Benjamin Tissoires (rhbz 1048314)
|
||||
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 414794ae6a59c38f6e5793ad50df97cba3dda4e3 Mon Sep 17 00:00:00 2001
|
||||
From: Tony Breeds <tony@bakeyournoodle.com>
|
||||
Date: Thu, 30 Jan 2014 19:58:55 +1100
|
||||
Subject: [PATCH] powerpc/le: Avoid creatng R_PPC64_TOCSAVE relocations for
|
||||
modules.
|
||||
|
||||
When building modules with a native le toolchain the linker will
|
||||
generate R_PPC64_TOCSAVE relocations when it's safe to omit saving r2 on
|
||||
a plt call. This isn't helpful in the conext of a kernel module and the
|
||||
kernel will fail to load those modules with an error like:
|
||||
nf_conntrack: Unknown ADD relocation: 109
|
||||
|
||||
This patch tells the linker to avoid createing R_PPC64_TOCSAVE
|
||||
relocations allowing modules to load.
|
||||
|
||||
Signed-off-by: Tony Breeds <tony@bakeyournoodle.com>
|
||||
---
|
||||
arch/powerpc/Makefile | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
|
||||
index 0f4344e..fff3945 100644
|
||||
--- a/arch/powerpc/Makefile
|
||||
+++ b/arch/powerpc/Makefile
|
||||
@@ -74,6 +74,9 @@ override CROSS32AS += -mlittle-endian
|
||||
LDEMULATION := lppc
|
||||
GNUTARGET := powerpcle
|
||||
MULTIPLEWORD := -mno-multiple
|
||||
+ifeq ($(call cc-option-yn,-mno-save-toc-indirect),y)
|
||||
+ KBUILD_CFLAGS_MODULE += -mno-save-toc-indirect
|
||||
+endif
|
||||
else
|
||||
ifeq ($(call cc-option-yn,-mbig-endian),y)
|
||||
override CC += -mbig-endian
|
||||
--
|
Loading…
Reference in New Issue
Block a user