Linux v4.16-rc5-60-g0aa3fdb8b3a6
This commit is contained in:
parent
86e3b7659f
commit
8225d2710e
2
gitrev
2
gitrev
@ -1 +1 @@
|
|||||||
fc6eabbbf8ef99efed778dd5afabc83c21dba585
|
0aa3fdb8b3a6df3c2e3b61dbfe079db9d30e03cd
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%global rcrev 5
|
%global rcrev 5
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 2
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 4.%{upstream_sublevel}.0
|
%define rpmversion 4.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -624,9 +624,6 @@ Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
|
|||||||
# rhbz 1509461
|
# rhbz 1509461
|
||||||
Patch503: v3-2-2-Input-synaptics---Lenovo-X1-Carbon-5-should-use-SMBUS-RMI.patch
|
Patch503: v3-2-2-Input-synaptics---Lenovo-X1-Carbon-5-should-use-SMBUS-RMI.patch
|
||||||
|
|
||||||
# rhbz 1554954
|
|
||||||
Patch504: mm-page_alloc-fix-boot-hang-in-memmap_init_zone.patch
|
|
||||||
|
|
||||||
# END OF PATCH DEFINITIONS
|
# END OF PATCH DEFINITIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1876,6 +1873,9 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 15 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-0.rc5.git2.1
|
||||||
|
- Linux v4.16-rc5-60-g0aa3fdb8b3a6
|
||||||
|
|
||||||
* Wed Mar 14 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-0.rc5.git1.2
|
* Wed Mar 14 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-0.rc5.git1.2
|
||||||
- Fix boot hang on aarch64
|
- Fix boot hang on aarch64
|
||||||
|
|
||||||
|
@ -1,58 +0,0 @@
|
|||||||
From patchwork Tue Mar 13 22:42:40 2018
|
|
||||||
Content-Type: text/plain; charset="utf-8"
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Transfer-Encoding: 7bit
|
|
||||||
Subject: mm/page_alloc: fix boot hang in memmap_init_zone
|
|
||||||
From: Daniel Vacek <neelx@redhat.com>
|
|
||||||
X-Patchwork-Id: 10281093
|
|
||||||
Message-Id: <20180313224240.25295-1-neelx@redhat.com>
|
|
||||||
To: linux-kernel@vger.kernel.org, linux-mm@kvack.org
|
|
||||||
Cc: Sudeep Holla <sudeep.holla@arm.com>,
|
|
||||||
Naresh Kamboju <naresh.kamboju@linaro.org>,
|
|
||||||
Daniel Vacek <neelx@redhat.com>, Andrew Morton <akpm@linux-foundation.org>,
|
|
||||||
Mel Gorman <mgorman@techsingularity.net>, Michal Hocko <mhocko@suse.com>,
|
|
||||||
Paul Burton <paul.burton@imgtec.com>,
|
|
||||||
Pavel Tatashin <pasha.tatashin@oracle.com>,
|
|
||||||
Vlastimil Babka <vbabka@suse.cz>, stable@vger.kernel.org
|
|
||||||
Date: Tue, 13 Mar 2018 23:42:40 +0100
|
|
||||||
|
|
||||||
On some architectures (reported on arm64) commit 864b75f9d6b01 ("mm/page_alloc: fix memmap_init_zone pageblock alignment")
|
|
||||||
causes a boot hang. This patch fixes the hang making sure the alignment
|
|
||||||
never steps back.
|
|
||||||
|
|
||||||
Link: http://lkml.kernel.org/r/0485727b2e82da7efbce5f6ba42524b429d0391a.1520011945.git.neelx@redhat.com
|
|
||||||
Fixes: 864b75f9d6b01 ("mm/page_alloc: fix memmap_init_zone pageblock alignment")
|
|
||||||
Signed-off-by: Daniel Vacek <neelx@redhat.com>
|
|
||||||
Tested-by: Sudeep Holla <sudeep.holla@arm.com>
|
|
||||||
Tested-by: Naresh Kamboju <naresh.kamboju@linaro.org>
|
|
||||||
Cc: Andrew Morton <akpm@linux-foundation.org>
|
|
||||||
Cc: Mel Gorman <mgorman@techsingularity.net>
|
|
||||||
Cc: Michal Hocko <mhocko@suse.com>
|
|
||||||
Cc: Paul Burton <paul.burton@imgtec.com>
|
|
||||||
Cc: Pavel Tatashin <pasha.tatashin@oracle.com>
|
|
||||||
Cc: Vlastimil Babka <vbabka@suse.cz>
|
|
||||||
Cc: <stable@vger.kernel.org>
|
|
||||||
---
|
|
||||||
mm/page_alloc.c | 7 ++++++-
|
|
||||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
|
|
||||||
index 3d974cb2a1a1..e033a6895c6f 100644
|
|
||||||
--- a/mm/page_alloc.c
|
|
||||||
+++ b/mm/page_alloc.c
|
|
||||||
@@ -5364,9 +5364,14 @@ void __meminit memmap_init_zone(unsigned long size, int nid, unsigned long zone,
|
|
||||||
* is not. move_freepages_block() can shift ahead of
|
|
||||||
* the valid region but still depends on correct page
|
|
||||||
* metadata.
|
|
||||||
+ * Also make sure we never step back.
|
|
||||||
*/
|
|
||||||
- pfn = (memblock_next_valid_pfn(pfn, end_pfn) &
|
|
||||||
+ unsigned long next_pfn;
|
|
||||||
+
|
|
||||||
+ next_pfn = (memblock_next_valid_pfn(pfn, end_pfn) &
|
|
||||||
~(pageblock_nr_pages-1)) - 1;
|
|
||||||
+ if (next_pfn > pfn)
|
|
||||||
+ pfn = next_pfn;
|
|
||||||
#endif
|
|
||||||
continue;
|
|
||||||
}
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-4.15.tar.xz) = c00d92659df815a53dcac7dde145b742b1f20867d380c07cb09ddb3295d6ff10f8931b21ef0b09d7156923a3957b39d74d87c883300173b2e20690d2b4ec35ea
|
SHA512 (linux-4.15.tar.xz) = c00d92659df815a53dcac7dde145b742b1f20867d380c07cb09ddb3295d6ff10f8931b21ef0b09d7156923a3957b39d74d87c883300173b2e20690d2b4ec35ea
|
||||||
SHA512 (patch-4.16-rc5.xz) = 0645901bf7e1fc9a2bff2b196fda356acf6a52d0f548bd14f478fea7f9110d6e20e609af659f49688fef72602b45cdf3f105ed13a79dcd547740a450d8ce8fff
|
SHA512 (patch-4.16-rc5.xz) = 0645901bf7e1fc9a2bff2b196fda356acf6a52d0f548bd14f478fea7f9110d6e20e609af659f49688fef72602b45cdf3f105ed13a79dcd547740a450d8ce8fff
|
||||||
SHA512 (patch-4.16-rc5-git1.xz) = 96d4fbe107142267b6f4ada225d70097aaf8897bb0393a514a98ddb8650a2d312e12e7c71e5f96a28c6c78847bebc1743f485de81cc60a684ef394e3e08e8e94
|
SHA512 (patch-4.16-rc5-git2.xz) = 303ecd87203ba6178f6e650a18d9c4dc5d0588f69511904f9540da0d4f30443db8b54af5ff8dbe95c64f51574c494ec672e1334cc2496805974a9a4cd5440938
|
||||||
|
Loading…
Reference in New Issue
Block a user