kernel-5.14.0-0.rc5.20210813gitf8e6dfc64f61.46
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.46] - pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
a7b4ddd630
commit
7a8626667d
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 44
|
RHEL_RELEASE = 46
|
||||||
|
|
||||||
#
|
#
|
||||||
# Early y+1 numbering
|
# Early y+1 numbering
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/989076bf390c0354bc3334037539bc0ae3c5133d
|
https://gitlab.com/cki-project/kernel-ark/-/commit/8d1041fe3e9bbffe2e339a032af8dc98780b1319
|
||||||
989076bf390c0354bc3334037539bc0ae3c5133d pinctrl: tigerlake: Fix GPIO mapping for newer version of software
|
8d1041fe3e9bbffe2e339a032af8dc98780b1319 pinctrl: tigerlake: Fix GPIO mapping for newer version of software
|
||||||
|
|
||||||
https://gitlab.com/cki-project/kernel-ark/-/commit/a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43
|
https://gitlab.com/cki-project/kernel-ark/-/commit/a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43
|
||||||
a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43 Revert "ice: mark driver as tech-preview"
|
a34f0f1fdb553a2d11a5220c9e417e3d9d96ee43 Revert "ice: mark driver as tech-preview"
|
||||||
|
22
kernel.spec
22
kernel.spec
@ -80,7 +80,7 @@ Summary: The Linux kernel
|
|||||||
# the --with-release option overrides this setting.)
|
# the --with-release option overrides this setting.)
|
||||||
%define debugbuildsenabled 0
|
%define debugbuildsenabled 0
|
||||||
|
|
||||||
%global distro_build 0.rc5.20210811git761c6d7ec820.44
|
%global distro_build 0.rc5.20210813gitf8e6dfc64f61.46
|
||||||
|
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%define secure_boot_arch x86_64
|
%define secure_boot_arch x86_64
|
||||||
@ -124,13 +124,13 @@ Summary: The Linux kernel
|
|||||||
%define kversion 5.14
|
%define kversion 5.14
|
||||||
|
|
||||||
%define rpmversion 5.14.0
|
%define rpmversion 5.14.0
|
||||||
%define pkgrelease 0.rc5.20210811git761c6d7ec820.44
|
%define pkgrelease 0.rc5.20210813gitf8e6dfc64f61.46
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 14
|
%define patchlevel 14
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc5.20210811git761c6d7ec820.44%{?buildid}%{?dist}
|
%define specrelease 0.rc5.20210813gitf8e6dfc64f61.46%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -671,7 +671,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.14-rc5-17-g761c6d7ec820.tar.xz
|
Source0: linux-5.14-rc5-184-gf8e6dfc64f61.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1357,8 +1357,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.14-rc5-17-g761c6d7ec820 -c
|
%setup -q -n kernel-5.14-rc5-184-gf8e6dfc64f61 -c
|
||||||
mv linux-5.14-rc5-17-g761c6d7ec820 linux-%{KVERREL}
|
mv linux-5.14-rc5-184-gf8e6dfc64f61 linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
@ -2647,7 +2647,7 @@ then\
|
|||||||
%{_sbindir}/weak-modules --add-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
|
%{_sbindir}/weak-modules --add-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
|
||||||
fi\
|
fi\
|
||||||
%endif\
|
%endif\
|
||||||
/bin/kernel-install add %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
|
/bin/kernel-install add -v %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
|
||||||
%{nil}
|
%{nil}
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -2952,12 +2952,12 @@ fi
|
|||||||
#
|
#
|
||||||
#
|
#
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Aug 11 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.14.0-0.rc5.20210811git761c6d7ec820.44]
|
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.46]
|
||||||
- update filters for Fedora (Justin M. Forbes)
|
|
||||||
|
|
||||||
* Wed Aug 11 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210811git761c6d7ec820.44]
|
|
||||||
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
|
- pinctrl: tigerlake: Fix GPIO mapping for newer version of software (Andy Shevchenko)
|
||||||
|
|
||||||
|
* Fri Aug 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210813gitf8e6dfc64f61.45]
|
||||||
|
- update filters for Fedora (Justin M. Forbes)
|
||||||
|
|
||||||
* Tue Aug 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210810git9a73fa375d58.42]
|
* Tue Aug 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.14.0-0.rc5.20210810git9a73fa375d58.42]
|
||||||
- redhat/configs/evaluate_configs: Update help output (Prarit Bhargava)
|
- redhat/configs/evaluate_configs: Update help output (Prarit Bhargava)
|
||||||
- redhat/configs: Double MAX_LOCKDEP_CHAINS (Justin M. Forbes)
|
- redhat/configs: Double MAX_LOCKDEP_CHAINS (Justin M. Forbes)
|
||||||
|
@ -2306,10 +2306,10 @@ index ab7eea01ab42..fff7c5f737fc 100644
|
|||||||
|
|
||||||
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
int rmi_register_transport_device(struct rmi_transport_dev *xport);
|
||||||
diff --git a/include/linux/security.h b/include/linux/security.h
|
diff --git a/include/linux/security.h b/include/linux/security.h
|
||||||
index 24eda04221e9..128837ea1fb2 100644
|
index 5b7288521300..f966f591c91e 100644
|
||||||
--- a/include/linux/security.h
|
--- a/include/linux/security.h
|
||||||
+++ b/include/linux/security.h
|
+++ b/include/linux/security.h
|
||||||
@@ -471,6 +471,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
|
@@ -472,6 +472,7 @@ int security_inode_notifysecctx(struct inode *inode, void *ctx, u32 ctxlen);
|
||||||
int security_inode_setsecctx(struct dentry *dentry, void *ctx, u32 ctxlen);
|
int security_inode_setsecctx(struct dentry *dentry, void *ctx, u32 ctxlen);
|
||||||
int security_inode_getsecctx(struct inode *inode, void **ctx, u32 *ctxlen);
|
int security_inode_getsecctx(struct inode *inode, void **ctx, u32 *ctxlen);
|
||||||
int security_locked_down(enum lockdown_reason what);
|
int security_locked_down(enum lockdown_reason what);
|
||||||
@ -2317,7 +2317,7 @@ index 24eda04221e9..128837ea1fb2 100644
|
|||||||
#else /* CONFIG_SECURITY */
|
#else /* CONFIG_SECURITY */
|
||||||
|
|
||||||
static inline int call_blocking_lsm_notifier(enum lsm_event event, void *data)
|
static inline int call_blocking_lsm_notifier(enum lsm_event event, void *data)
|
||||||
@@ -1347,6 +1348,10 @@ static inline int security_locked_down(enum lockdown_reason what)
|
@@ -1348,6 +1349,10 @@ static inline int security_locked_down(enum lockdown_reason what)
|
||||||
{
|
{
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
@ -2705,10 +2705,10 @@ index 87cbdc64d272..18555cf18da7 100644
|
|||||||
|
|
||||||
static int __init lockdown_lsm_init(void)
|
static int __init lockdown_lsm_init(void)
|
||||||
diff --git a/security/security.c b/security/security.c
|
diff --git a/security/security.c b/security/security.c
|
||||||
index 09533cbb7221..d36675494753 100644
|
index 9ffa9e9c5c55..36484cc9842d 100644
|
||||||
--- a/security/security.c
|
--- a/security/security.c
|
||||||
+++ b/security/security.c
|
+++ b/security/security.c
|
||||||
@@ -2598,6 +2598,12 @@ int security_locked_down(enum lockdown_reason what)
|
@@ -2599,6 +2599,12 @@ int security_locked_down(enum lockdown_reason what)
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL(security_locked_down);
|
EXPORT_SYMBOL(security_locked_down);
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.14-rc5-17-g761c6d7ec820.tar.xz) = 69197d57092ccc067c4f6ab56c991fdd85dce3f5fe1edd505ebe883571b610ce0de69390efd994e091cd48c94aa8feb821c0aab4264f1053b0a49eba7a952d44
|
SHA512 (linux-5.14-rc5-184-gf8e6dfc64f61.tar.xz) = 89c8951e84ec528f8c473cd0785d1202273f0d32b1837ec887fd2127319c45a38b6a9f929c09053b0aaa6767421609cda63e455dde313ce3cc725dde9bef9fa0
|
||||||
SHA512 (kernel-abi-stablelists-5.14.0-0.rc5.20210811git761c6d7ec820.44.tar.bz2) = 68d5e6016434eb832e1728fed1ddc8015fa4670d2ad3ebe6f5d6d4790f278ed323503428926f85b2f0a78378edeabc9dc88aff5214b3dbe68f5547f5d95eba57
|
SHA512 (kernel-abi-stablelists-5.14.0-0.rc5.20210813gitf8e6dfc64f61.46.tar.bz2) = f3fd4ae6d022a1be167ab37f17033a0abd1b453dfd441e5b6597f6b09a85c1c802a99d7580f3172a4494cf34b7a7cfc7f83f3b7e9399c0c192510211bf74b5a5
|
||||||
SHA512 (kernel-kabi-dw-5.14.0-0.rc5.20210811git761c6d7ec820.44.tar.bz2) = ad267dd4a3230cb2b159f9edaca46f87e445abdf016f39b01f55b4f0329134c1cba7811c67a739669a948efa6ecf14ce640a0b13cbacaf9a3d773ef21fbbf104
|
SHA512 (kernel-kabi-dw-5.14.0-0.rc5.20210813gitf8e6dfc64f61.46.tar.bz2) = 297dd8820a62e7eb9754a647d06d9aaff79aed97e842ae2817a9f1f1df51032c88d759d4f45f0788043ecdb22e403b1e4c4c5cd846db7ef4939a395a41a1c48f
|
||||||
|
Loading…
Reference in New Issue
Block a user