kernel-5.17-0.rc2.20220202git9f7fb8de5d9b.84
* Wed Feb 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc2.20220202git9f7fb8de5d9b.84] - mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long) - Workaround for gcc12 compile issues in ubcmd-util.h (Justin M. Forbes) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
b10cd81878
commit
79b7fc6dd1
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
||||
#
|
||||
# Use this spot to avoid future merge conflicts.
|
||||
# Do not trim this comment.
|
||||
RHEL_RELEASE = 83
|
||||
RHEL_RELEASE = 84
|
||||
|
||||
#
|
||||
# Early y+1 numbering
|
||||
|
@ -1,5 +1,8 @@
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/93296c8913585b0fef445615f3a13d8f42a85898
|
||||
93296c8913585b0fef445615f3a13d8f42a85898 Workaround for gcc12 compile issues in ubcmd-util.h
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/302bf21126cacae897f8a8fd5257cfdb2e8668a9
|
||||
302bf21126cacae897f8a8fd5257cfdb2e8668a9 mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/0a0a8b3fbe3d159111ab0117f62ad4d29ab194c6
|
||||
0a0a8b3fbe3d159111ab0117f62ad4d29ab194c6 Workaround for gcc12 compile issues in ubcmd-util.h
|
||||
|
||||
https://gitlab.com/cki-project/kernel-ark/-/commit/4f79b3c547b8e3dbc014058a8adffe0fe8cd5e4b
|
||||
4f79b3c547b8e3dbc014058a8adffe0fe8cd5e4b objtool: check: give big enough buffer for pv_ops
|
||||
|
31
kernel.spec
31
kernel.spec
@ -85,9 +85,9 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
|
||||
# to build the base kernel using the debug configuration. (Specifying
|
||||
# the --with-release option overrides this setting.)
|
||||
%define debugbuildsenabled 1
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%global distro_build 0.rc2.83
|
||||
%global distro_build 0.rc2.20220202git9f7fb8de5d9b.84
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -132,13 +132,13 @@ Summary: The Linux kernel
|
||||
|
||||
%define rpmversion 5.17.0
|
||||
%define patchversion 5.17
|
||||
%define pkgrelease 0.rc2.83
|
||||
%define pkgrelease 0.rc2.20220202git9f7fb8de5d9b.84
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 17
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc2.83%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc2.20220202git9f7fb8de5d9b.84%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -692,7 +692,7 @@ BuildRequires: lld
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-5.17-rc2.tar.xz
|
||||
Source0: linux-5.17-rc2-39-g9f7fb8de5d9b.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -1388,8 +1388,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-5.17-rc2 -c
|
||||
mv linux-5.17-rc2 linux-%{KVERREL}
|
||||
%setup -q -n kernel-5.17-rc2-39-g9f7fb8de5d9b -c
|
||||
mv linux-5.17-rc2-39-g9f7fb8de5d9b linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1960,12 +1960,11 @@ BuildKernel() {
|
||||
# Clean up intermediate tools files
|
||||
find $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/tools \( -iname "*.o" -o -iname "*.cmd" \) -exec rm -f {} +
|
||||
|
||||
# Make sure the Makefile and version.h have a matching timestamp so that
|
||||
# external modules can be built
|
||||
touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/generated/uapi/linux/version.h
|
||||
|
||||
# Copy .config to include/config/auto.conf so "make prepare" is unnecessary.
|
||||
cp $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/config/auto.conf
|
||||
# Make sure the Makefile, version.h, and auto.conf have a matching
|
||||
# timestamp so that external modules can be built
|
||||
touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile \
|
||||
$RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/generated/uapi/linux/version.h \
|
||||
$RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/config/auto.conf
|
||||
|
||||
%if %{with_debuginfo}
|
||||
eu-readelf -n vmlinux | grep "Build ID" | awk '{print $NF}' > vmlinux.id
|
||||
@ -3003,9 +3002,13 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Sun Jan 30 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc2.83]
|
||||
* Wed Feb 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc2.20220202git9f7fb8de5d9b.84]
|
||||
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
|
||||
- Workaround for gcc12 compile issues in ubcmd-util.h (Justin M. Forbes)
|
||||
|
||||
* Wed Feb 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc2.20220202git9f7fb8de5d9b.83]
|
||||
- spec: don't overwrite auto.conf with .config (Ondrej Mosnacek)
|
||||
|
||||
* Sat Jan 29 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc1.20220129git169387e2aa29.80]
|
||||
- New configs in drivers/crypto (Fedora Kernel Team)
|
||||
|
||||
|
@ -50,6 +50,7 @@
|
||||
include/linux/kernel.h | 19 ++
|
||||
include/linux/lsm_hook_defs.h | 2 +
|
||||
include/linux/lsm_hooks.h | 6 +
|
||||
include/linux/mmzone.h | 4 +-
|
||||
include/linux/module.h | 1 +
|
||||
include/linux/panic.h | 19 +-
|
||||
include/linux/pci.h | 16 ++
|
||||
@ -74,7 +75,7 @@
|
||||
security/security.c | 6 +
|
||||
tools/lib/subcmd/subcmd-util.h | 9 +-
|
||||
tools/objtool/check.c | 2 +-
|
||||
76 files changed, 1517 insertions(+), 194 deletions(-)
|
||||
77 files changed, 1518 insertions(+), 197 deletions(-)
|
||||
|
||||
diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
|
||||
index f5a27f067db9..f4dc42f2f82a 100644
|
||||
@ -2097,7 +2098,7 @@ index 47a1c8bddf86..e309d992e2ad 100644
|
||||
* disconnected while waiting for the lock to succeed. */
|
||||
usb_lock_device(hdev);
|
||||
diff --git a/fs/ext4/super.c b/fs/ext4/super.c
|
||||
index eee0d9ebfa6c..787d364f3b4a 100644
|
||||
index ce60b5026bde..95211f35dae8 100644
|
||||
--- a/fs/ext4/super.c
|
||||
+++ b/fs/ext4/super.c
|
||||
@@ -4760,6 +4760,7 @@ static int __ext4_fill_super(struct fs_context *fc, struct super_block *sb)
|
||||
@ -2264,6 +2265,23 @@ index 3bf5c658bc44..4701bc5ce2f5 100644
|
||||
* Security hooks for perf events
|
||||
*
|
||||
* @perf_event_open:
|
||||
diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
|
||||
index aed44e9b5d89..08517376c765 100644
|
||||
--- a/include/linux/mmzone.h
|
||||
+++ b/include/linux/mmzone.h
|
||||
@@ -1390,11 +1390,9 @@ static inline unsigned long *section_to_usemap(struct mem_section *ms)
|
||||
static inline struct mem_section *__nr_to_section(unsigned long nr)
|
||||
{
|
||||
#ifdef CONFIG_SPARSEMEM_EXTREME
|
||||
- if (!mem_section)
|
||||
+ if (!*mem_section || !mem_section[SECTION_NR_TO_ROOT(nr)])
|
||||
return NULL;
|
||||
#endif
|
||||
- if (!mem_section[SECTION_NR_TO_ROOT(nr)])
|
||||
- return NULL;
|
||||
return &mem_section[SECTION_NR_TO_ROOT(nr)][nr & SECTION_ROOT_MASK];
|
||||
}
|
||||
extern size_t mem_section_usage_size(void);
|
||||
diff --git a/include/linux/module.h b/include/linux/module.h
|
||||
index 1e135fd5c076..6ec4d001c1e2 100644
|
||||
--- a/include/linux/module.h
|
||||
@ -3210,34 +3228,3 @@ index c2d2ab9a2861..f5bed94e4558 100644
|
||||
struct reloc *rel;
|
||||
int idx;
|
||||
|
||||
From 102756c4df1ea2f55dd6a9de3f22f9304194d0e6 Mon Sep 17 00:00:00 2001
|
||||
From: "Justin M. Forbes" <jforbes@fedoraproject.org>
|
||||
Date: Mon, 31 Jan 2022 12:55:43 -0600
|
||||
Subject: [PATCH] Fix gcc 12 warning address of 'mem_section' will never be
|
||||
NULL
|
||||
|
||||
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
---
|
||||
include/linux/mmzone.h | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
|
||||
index aed44e9b5d89..9eeaa7e10771 100644
|
||||
--- a/include/linux/mmzone.h
|
||||
+++ b/include/linux/mmzone.h
|
||||
@@ -1390,11 +1390,9 @@ static inline unsigned long *section_to_usemap(struct mem_section *ms)
|
||||
static inline struct mem_section *__nr_to_section(unsigned long nr)
|
||||
{
|
||||
#ifdef CONFIG_SPARSEMEM_EXTREME
|
||||
- if (!mem_section)
|
||||
+ if (!mem_section || !mem_section[SECTION_NR_TO_ROOT(nr)])
|
||||
return NULL;
|
||||
#endif
|
||||
- if (!mem_section[SECTION_NR_TO_ROOT(nr)])
|
||||
- return NULL;
|
||||
return &mem_section[SECTION_NR_TO_ROOT(nr)][nr & SECTION_ROOT_MASK];
|
||||
}
|
||||
extern size_t mem_section_usage_size(void);
|
||||
--
|
||||
2.34.1
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.17-rc2.tar.xz) = b4b7d3aee7977fe934c5a313276b4ceba69f5660fdf2a40bbfee2a36500d49a2568e3c7cb2300019bd4fda89c4aed8ab8202a34b6dd440865cb83f711d2782dd
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc2.83.tar.bz2) = 0b3dad7604212950a3416327cac215bc8b5cba6ed3bc48ae28cdb04fff2bfaedb422e8d4be5bf9e18b56923caf606719885c3027b7c916835ba5f7ced265ab3a
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc2.83.tar.bz2) = 796787262bf18cf7510b1a4f6d37f4f6cfa2b390ab73007a337d82ec78710d23a516e308035d2f475ac1aa3aedc3ef9d9221299cc1bbd719421d36e8829729e2
|
||||
SHA512 (linux-5.17-rc2-39-g9f7fb8de5d9b.tar.xz) = a7c7944a8e7b534e9c6047cc6d2ff843e652ed5cfe2239eb20baa24e9d7c0d06af7a7903397e749bbfa6761e6bc0584a4267e2da044b123e426688d3378ec6ad
|
||||
SHA512 (kernel-abi-stablelists-5.17.0-0.rc2.20220202git9f7fb8de5d9b.84.tar.bz2) = da3476aaa105c25cda78679b677a948081ca45d98a553b8f714923ae1a614e29b88e635771e3594ac12ce75568e68e8077e9bdf91d142ee2ff1f88b4471d8928
|
||||
SHA512 (kernel-kabi-dw-5.17.0-0.rc2.20220202git9f7fb8de5d9b.84.tar.bz2) = dd5a78a760cfcc643b90540ae9143b99ce069a30b37f557c943b27a1db3c89fdce4947aae0296b9955fc71501473bd3248458145dffaa0c01d61d0ad124a8182
|
||||
|
Loading…
Reference in New Issue
Block a user