- Update AppleIR patch to work, and support the enter key on
newer remotes
This commit is contained in:
parent
aa63cbafd1
commit
78100db1fe
@ -1,11 +1,38 @@
|
|||||||
appleir usb driver from hadess
|
From e11e9e78799a7641fe0dc5289f35f2604a4b71a3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Bastien Nocera <hadess@hadess.net>
|
||||||
|
Date: Sun, 17 Jan 2010 00:40:15 +0000
|
||||||
|
Subject: [PATCH] Input: add appleir USB driver
|
||||||
|
|
||||||
|
This driver was originally written by James McKenzie, updated by
|
||||||
|
Greg Kroah-Hartman, further updated by myself, with suspend support
|
||||||
|
added.
|
||||||
|
|
||||||
|
More recent versions of the IR receiver are also supported through
|
||||||
|
a patch by Alex Karpenko. The patch also adds support for the 2nd
|
||||||
|
and 5th generation of the controller, and the menu key on newer
|
||||||
|
brushed metal remotes.
|
||||||
|
|
||||||
|
Tested on a MacbookAir1,1
|
||||||
|
|
||||||
|
Signed-off-by: Bastien Nocera <hadess@hadess.net>
|
||||||
---
|
---
|
||||||
|
Documentation/input/appleir.txt | 46 ++++
|
||||||
|
drivers/hid/hid-apple.c | 4 -
|
||||||
|
drivers/hid/hid-core.c | 7 +-
|
||||||
|
drivers/hid/hid-ids.h | 5 +-
|
||||||
|
drivers/input/misc/Kconfig | 13 +
|
||||||
|
drivers/input/misc/Makefile | 1 +
|
||||||
|
drivers/input/misc/appleir.c | 519 +++++++++++++++++++++++++++++++++++++++
|
||||||
|
7 files changed, 588 insertions(+), 7 deletions(-)
|
||||||
|
create mode 100644 Documentation/input/appleir.txt
|
||||||
|
create mode 100644 drivers/input/misc/appleir.c
|
||||||
|
|
||||||
diff --git a/Documentation/input/appleir.txt b/Documentation/input/appleir.txt
|
diff --git a/Documentation/input/appleir.txt b/Documentation/input/appleir.txt
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..0267a4b
|
index 0000000..db637fb
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/Documentation/input/appleir.txt
|
+++ b/Documentation/input/appleir.txt
|
||||||
@@ -0,0 +1,45 @@
|
@@ -0,0 +1,46 @@
|
||||||
+Apple IR receiver Driver (appleir)
|
+Apple IR receiver Driver (appleir)
|
||||||
+----------------------------------
|
+----------------------------------
|
||||||
+ Copyright (C) 2009 Bastien Nocera <hadess@hadess.net>
|
+ Copyright (C) 2009 Bastien Nocera <hadess@hadess.net>
|
||||||
@ -22,7 +49,8 @@ index 0000000..0267a4b
|
|||||||
+James McKenzie (original driver)
|
+James McKenzie (original driver)
|
||||||
+Alex Karpenko (05ac:8242 support)
|
+Alex Karpenko (05ac:8242 support)
|
||||||
+Greg Kroah-Hartman (cleanups and original submission)
|
+Greg Kroah-Hartman (cleanups and original submission)
|
||||||
+Bastien Nocera (further cleanups and suspend support)
|
+Bastien Nocera (further cleanups, brushed metal "enter"
|
||||||
|
+button support and suspend support)
|
||||||
+
|
+
|
||||||
+Supported hardware
|
+Supported hardware
|
||||||
+------------------
|
+------------------
|
||||||
@ -30,11 +58,11 @@ index 0000000..0267a4b
|
|||||||
+- All Apple laptops and desktops from 2005 onwards, except:
|
+- All Apple laptops and desktops from 2005 onwards, except:
|
||||||
+ - the unibody Macbook (2009)
|
+ - the unibody Macbook (2009)
|
||||||
+ - Mac Pro (all versions)
|
+ - Mac Pro (all versions)
|
||||||
+- Apple TV (all revisions)
|
+- Apple TV (all revisions prior to September 2010)
|
||||||
+
|
+
|
||||||
+The remote will only support the 6 buttons of the original remotes
|
+The remote will only support the 6 (old white) or 7 (brushed metal) buttons
|
||||||
+as sold by Apple. See the next section if you want to use other remotes
|
+of the remotes as sold by Apple. See the next section if you want to use
|
||||||
+or want to use lirc with the device instead of the kernel driver.
|
+other remotes or want to use lirc with the device instead of the kernel driver.
|
||||||
+
|
+
|
||||||
+Using lirc (native) instead of the kernel driver
|
+Using lirc (native) instead of the kernel driver
|
||||||
+------------------------------------------------
|
+------------------------------------------------
|
||||||
@ -67,7 +95,7 @@ index bba05d0..0059d5a 100644
|
|||||||
.driver_data = APPLE_MIGHTYMOUSE | APPLE_INVERT_HWHEEL },
|
.driver_data = APPLE_MIGHTYMOUSE | APPLE_INVERT_HWHEEL },
|
||||||
|
|
||||||
diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
|
diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
|
||||||
index 0c52899..712501e 100644
|
index baa25ad..abc5bd7 100644
|
||||||
--- a/drivers/hid/hid-core.c
|
--- a/drivers/hid/hid-core.c
|
||||||
+++ b/drivers/hid/hid-core.c
|
+++ b/drivers/hid/hid-core.c
|
||||||
@@ -1244,8 +1244,6 @@ static const struct hid_device_id hid_blacklist[] = {
|
@@ -1244,8 +1244,6 @@ static const struct hid_device_id hid_blacklist[] = {
|
||||||
@ -79,33 +107,40 @@ index 0c52899..712501e 100644
|
|||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MIGHTYMOUSE) },
|
{ HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MIGHTYMOUSE) },
|
||||||
{ HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICMOUSE) },
|
{ HID_BLUETOOTH_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_MAGICMOUSE) },
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_FOUNTAIN_ANSI) },
|
{ HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_FOUNTAIN_ANSI) },
|
||||||
@@ -1581,6 +1579,9 @@ static const struct hid_device_id hid_ignore_list[] = {
|
@@ -1577,6 +1575,11 @@ static const struct hid_device_id hid_ignore_list[] = {
|
||||||
|
{ HID_USB_DEVICE(USB_VENDOR_ID_AIPTEK, USB_DEVICE_ID_AIPTEK_24) },
|
||||||
|
{ HID_USB_DEVICE(USB_VENDOR_ID_AIRCABLE, USB_DEVICE_ID_AIRCABLE1) },
|
||||||
|
{ HID_USB_DEVICE(USB_VENDOR_ID_ALCOR, USB_DEVICE_ID_ALCOR_USBRS232) },
|
||||||
|
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL) },
|
||||||
|
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL2) },
|
||||||
|
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL3) },
|
||||||
|
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL4) },
|
||||||
|
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL5) },
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUS, USB_DEVICE_ID_ASUS_T91MT)},
|
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUS, USB_DEVICE_ID_ASUS_T91MT)},
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUSTEK, USB_DEVICE_ID_ASUSTEK_LCM)},
|
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUSTEK, USB_DEVICE_ID_ASUSTEK_LCM)},
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUSTEK, USB_DEVICE_ID_ASUSTEK_LCM2)},
|
{ HID_USB_DEVICE(USB_VENDOR_ID_ASUSTEK, USB_DEVICE_ID_ASUSTEK_LCM2)},
|
||||||
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL) },
|
|
||||||
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ATV_IRCONTROL) },
|
|
||||||
+ { HID_USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL4) },
|
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_AVERMEDIA, USB_DEVICE_ID_AVER_FM_MR800) },
|
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_BERKSHIRE, USB_DEVICE_ID_BERKSHIRE_PCWD) },
|
|
||||||
{ HID_USB_DEVICE(USB_VENDOR_ID_CIDC, 0x0103) },
|
|
||||||
diff --git a/drivers/hid/hid-ids.h b/drivers/hid/hid-ids.h
|
diff --git a/drivers/hid/hid-ids.h b/drivers/hid/hid-ids.h
|
||||||
index 85c6d13..4dc4c18 100644
|
index 11af537..360a5ca 100644
|
||||||
--- a/drivers/hid/hid-ids.h
|
--- a/drivers/hid/hid-ids.h
|
||||||
+++ b/drivers/hid/hid-ids.h
|
+++ b/drivers/hid/hid-ids.h
|
||||||
@@ -100,6 +100,7 @@
|
@@ -100,8 +100,11 @@
|
||||||
#define USB_DEVICE_ID_APPLE_ALU_WIRELESS_2009_JIS 0x023b
|
#define USB_DEVICE_ID_APPLE_ALU_WIRELESS_2009_JIS 0x023b
|
||||||
#define USB_DEVICE_ID_APPLE_FOUNTAIN_TP_ONLY 0x030a
|
#define USB_DEVICE_ID_APPLE_FOUNTAIN_TP_ONLY 0x030a
|
||||||
#define USB_DEVICE_ID_APPLE_GEYSER1_TP_ONLY 0x030b
|
#define USB_DEVICE_ID_APPLE_GEYSER1_TP_ONLY 0x030b
|
||||||
|
-#define USB_DEVICE_ID_APPLE_ATV_IRCONTROL 0x8241
|
||||||
+#define USB_DEVICE_ID_APPLE_IRCONTROL 0x8240
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL 0x8240
|
||||||
#define USB_DEVICE_ID_APPLE_ATV_IRCONTROL 0x8241
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL2 0x1440
|
||||||
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL3 0x8241
|
||||||
#define USB_DEVICE_ID_APPLE_IRCONTROL4 0x8242
|
#define USB_DEVICE_ID_APPLE_IRCONTROL4 0x8242
|
||||||
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL5 0x8243
|
||||||
|
|
||||||
|
#define USB_VENDOR_ID_ASUS 0x0486
|
||||||
|
#define USB_DEVICE_ID_ASUS_T91MT 0x0185
|
||||||
diff --git a/drivers/input/misc/Kconfig b/drivers/input/misc/Kconfig
|
diff --git a/drivers/input/misc/Kconfig b/drivers/input/misc/Kconfig
|
||||||
index b49e233..211adac 100644
|
index 60de906..2f2f2e7 100644
|
||||||
--- a/drivers/input/misc/Kconfig
|
--- a/drivers/input/misc/Kconfig
|
||||||
+++ b/drivers/input/misc/Kconfig
|
+++ b/drivers/input/misc/Kconfig
|
||||||
@@ -199,6 +199,19 @@ config INPUT_KEYSPAN_REMOTE
|
@@ -209,6 +209,19 @@ config INPUT_KEYSPAN_REMOTE
|
||||||
To compile this driver as a module, choose M here: the module will
|
To compile this driver as a module, choose M here: the module will
|
||||||
be called keyspan_remote.
|
be called keyspan_remote.
|
||||||
|
|
||||||
@ -117,7 +152,7 @@ index b49e233..211adac 100644
|
|||||||
+ Say Y here if you want to use a Apple infrared remote control. All
|
+ Say Y here if you want to use a Apple infrared remote control. All
|
||||||
+ the Apple computers from 2005 onwards include such a port, except
|
+ the Apple computers from 2005 onwards include such a port, except
|
||||||
+ the unibody Macbook (2009), and Mac Pros. This receiver is also
|
+ the unibody Macbook (2009), and Mac Pros. This receiver is also
|
||||||
+ used in the Apple TV set-top box.
|
+ used in the Apple TV set-top box prior to the 2010 model.
|
||||||
+
|
+
|
||||||
+ To compile this driver as a module, choose M here: the module will
|
+ To compile this driver as a module, choose M here: the module will
|
||||||
+ be called appleir.
|
+ be called appleir.
|
||||||
@ -126,10 +161,10 @@ index b49e233..211adac 100644
|
|||||||
tristate "Griffin PowerMate and Contour Jog support"
|
tristate "Griffin PowerMate and Contour Jog support"
|
||||||
depends on USB_ARCH_HAS_HCD
|
depends on USB_ARCH_HAS_HCD
|
||||||
diff --git a/drivers/input/misc/Makefile b/drivers/input/misc/Makefile
|
diff --git a/drivers/input/misc/Makefile b/drivers/input/misc/Makefile
|
||||||
index 19ccca7..b26e6ca 100644
|
index 1fe1f6c..d5ef2b9 100644
|
||||||
--- a/drivers/input/misc/Makefile
|
--- a/drivers/input/misc/Makefile
|
||||||
+++ b/drivers/input/misc/Makefile
|
+++ b/drivers/input/misc/Makefile
|
||||||
@@ -12,6 +12,7 @@ obj-$(CONFIG_INPUT_ADXL34X) += adxl34x.o
|
@@ -13,6 +13,7 @@ obj-$(CONFIG_INPUT_ADXL34X) += adxl34x.o
|
||||||
obj-$(CONFIG_INPUT_ADXL34X_I2C) += adxl34x-i2c.o
|
obj-$(CONFIG_INPUT_ADXL34X_I2C) += adxl34x-i2c.o
|
||||||
obj-$(CONFIG_INPUT_ADXL34X_SPI) += adxl34x-spi.o
|
obj-$(CONFIG_INPUT_ADXL34X_SPI) += adxl34x-spi.o
|
||||||
obj-$(CONFIG_INPUT_APANEL) += apanel.o
|
obj-$(CONFIG_INPUT_APANEL) += apanel.o
|
||||||
@ -139,10 +174,10 @@ index 19ccca7..b26e6ca 100644
|
|||||||
obj-$(CONFIG_INPUT_ATLAS_BTNS) += atlas_btns.o
|
obj-$(CONFIG_INPUT_ATLAS_BTNS) += atlas_btns.o
|
||||||
diff --git a/drivers/input/misc/appleir.c b/drivers/input/misc/appleir.c
|
diff --git a/drivers/input/misc/appleir.c b/drivers/input/misc/appleir.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..cff4df6
|
index 0000000..3817a3c
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/input/misc/appleir.c
|
+++ b/drivers/input/misc/appleir.c
|
||||||
@@ -0,0 +1,453 @@
|
@@ -0,0 +1,519 @@
|
||||||
+/*
|
+/*
|
||||||
+ * appleir: USB driver for the apple ir device
|
+ * appleir: USB driver for the apple ir device
|
||||||
+ *
|
+ *
|
||||||
@ -181,12 +216,14 @@ index 0000000..cff4df6
|
|||||||
+
|
+
|
||||||
+#define USB_VENDOR_ID_APPLE 0x05ac
|
+#define USB_VENDOR_ID_APPLE 0x05ac
|
||||||
+#define USB_DEVICE_ID_APPLE_IRCONTROL 0x8240
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL 0x8240
|
||||||
+#define USB_DEVICE_ID_APPLE_ATV_IRCONTROL 0x8241
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL2 0x1440
|
||||||
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL3 0x8241
|
||||||
+#define USB_DEVICE_ID_APPLE_IRCONTROL4 0x8242
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL4 0x8242
|
||||||
|
+#define USB_DEVICE_ID_APPLE_IRCONTROL5 0x8243
|
||||||
+
|
+
|
||||||
+#define URB_SIZE 32
|
+#define URB_SIZE 32
|
||||||
+
|
+
|
||||||
+#define MAX_KEYS 8
|
+#define MAX_KEYS 9
|
||||||
+#define MAX_KEYS_MASK (MAX_KEYS - 1)
|
+#define MAX_KEYS_MASK (MAX_KEYS - 1)
|
||||||
+
|
+
|
||||||
+#define dbginfo(dev, format, arg...) do { if (debug) dev_info(dev , format , ## arg); } while (0)
|
+#define dbginfo(dev, format, arg...) do { if (debug) dev_info(dev , format , ## arg); } while (0)
|
||||||
@ -226,6 +263,13 @@ index 0000000..cff4df6
|
|||||||
+/* 25 87 ee 47 02 menu */
|
+/* 25 87 ee 47 02 menu */
|
||||||
+/* 26 87 ee 47 ** for key repeat (** is the code of the key being held) */
|
+/* 26 87 ee 47 ** for key repeat (** is the code of the key being held) */
|
||||||
+
|
+
|
||||||
|
+/* Bastien Nocera's "new" remote */
|
||||||
|
+/* 25 87 ee 91 5f followed by
|
||||||
|
+ * 25 87 ee 91 05 gives you >"
|
||||||
|
+ *
|
||||||
|
+ * 25 87 ee 91 5c followed by
|
||||||
|
+ * 25 87 ee 91 05 gives you the middle button */
|
||||||
|
+
|
||||||
+static const unsigned short appleir_key_table[] = {
|
+static const unsigned short appleir_key_table[] = {
|
||||||
+ KEY_RESERVED,
|
+ KEY_RESERVED,
|
||||||
+ KEY_MENU,
|
+ KEY_MENU,
|
||||||
@ -234,6 +278,7 @@ index 0000000..cff4df6
|
|||||||
+ KEY_BACK,
|
+ KEY_BACK,
|
||||||
+ KEY_VOLUMEUP,
|
+ KEY_VOLUMEUP,
|
||||||
+ KEY_VOLUMEDOWN,
|
+ KEY_VOLUMEDOWN,
|
||||||
|
+ KEY_ENTER,
|
||||||
+ KEY_RESERVED,
|
+ KEY_RESERVED,
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
@ -247,6 +292,7 @@ index 0000000..cff4df6
|
|||||||
+ struct urb *urb;
|
+ struct urb *urb;
|
||||||
+ struct timer_list key_up_timer;
|
+ struct timer_list key_up_timer;
|
||||||
+ int current_key;
|
+ int current_key;
|
||||||
|
+ int prev_key_idx;
|
||||||
+ char phys[32];
|
+ char phys[32];
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
@ -259,8 +305,10 @@ index 0000000..cff4df6
|
|||||||
+
|
+
|
||||||
+static struct usb_device_id appleir_ids[] = {
|
+static struct usb_device_id appleir_ids[] = {
|
||||||
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL) },
|
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL) },
|
||||||
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_ATV_IRCONTROL) },
|
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL2) },
|
||||||
|
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL3) },
|
||||||
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL4) },
|
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL4) },
|
||||||
|
+ { USB_DEVICE(USB_VENDOR_ID_APPLE, USB_DEVICE_ID_APPLE_IRCONTROL5) },
|
||||||
+ {}
|
+ {}
|
||||||
+};
|
+};
|
||||||
+MODULE_DEVICE_TABLE(usb, appleir_ids);
|
+MODULE_DEVICE_TABLE(usb, appleir_ids);
|
||||||
@ -273,7 +321,43 @@ index 0000000..cff4df6
|
|||||||
+
|
+
|
||||||
+ for (i = 0; i < len; ++i)
|
+ for (i = 0; i < len; ++i)
|
||||||
+ printk(" %02x", data[i]);
|
+ printk(" %02x", data[i]);
|
||||||
+ printk("\n");
|
+ printk(" (should be command %d)\n", (data[4] >> 1) & MAX_KEYS_MASK);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static int get_key(int data)
|
||||||
|
+{
|
||||||
|
+ switch (data) {
|
||||||
|
+ case 0x02:
|
||||||
|
+ case 0x03:
|
||||||
|
+ /* menu */
|
||||||
|
+ return 1;
|
||||||
|
+ case 0x04:
|
||||||
|
+ case 0x05:
|
||||||
|
+ /* >" */
|
||||||
|
+ return 2;
|
||||||
|
+ case 0x06:
|
||||||
|
+ case 0x07:
|
||||||
|
+ /* >> */
|
||||||
|
+ return 3;
|
||||||
|
+ case 0x08:
|
||||||
|
+ case 0x09:
|
||||||
|
+ /* << */
|
||||||
|
+ return 4;
|
||||||
|
+ case 0x0a:
|
||||||
|
+ case 0x0b:
|
||||||
|
+ /* + */
|
||||||
|
+ return 5;
|
||||||
|
+ case 0x0c:
|
||||||
|
+ case 0x0d:
|
||||||
|
+ /* - */
|
||||||
|
+ return 6;
|
||||||
|
+ case 0x5c:
|
||||||
|
+ /* Middle button, on newer remotes,
|
||||||
|
+ * part of a 2 packet-command */
|
||||||
|
+ return -7;
|
||||||
|
+ default:
|
||||||
|
+ return -1;
|
||||||
|
+ }
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+static void key_up(struct appleir *appleir, int key)
|
+static void key_up(struct appleir *appleir, int key)
|
||||||
@ -318,20 +402,37 @@ index 0000000..cff4df6
|
|||||||
+ return;
|
+ return;
|
||||||
+
|
+
|
||||||
+ if (!memcmp(data, keydown, sizeof(keydown))) {
|
+ if (!memcmp(data, keydown, sizeof(keydown))) {
|
||||||
|
+ int index;
|
||||||
|
+
|
||||||
+ /* If we already have a key down, take it up before marking
|
+ /* If we already have a key down, take it up before marking
|
||||||
+ this one down */
|
+ this one down */
|
||||||
+ if (appleir->current_key)
|
+ if (appleir->current_key)
|
||||||
+ key_up(appleir, appleir->current_key);
|
+ key_up(appleir, appleir->current_key);
|
||||||
+ appleir->current_key = appleir->keymap[(data[4] >> 1) & MAX_KEYS_MASK];
|
|
||||||
+
|
+
|
||||||
+ key_down(appleir, appleir->current_key);
|
+ /* Handle dual packet commands */
|
||||||
+ /* Remote doesn't do key up, either pull them up, in the test
|
+ if (appleir->prev_key_idx > 0)
|
||||||
+ above, or here set a timer which pulls them up after 1/8 s */
|
+ index = appleir->prev_key_idx;
|
||||||
+ mod_timer(&appleir->key_up_timer, jiffies + HZ / 8);
|
+ else
|
||||||
|
+ index = get_key(data[4]);
|
||||||
+
|
+
|
||||||
+ return;
|
+ if (index > 0) {
|
||||||
|
+ appleir->current_key = appleir->keymap[index];
|
||||||
|
+
|
||||||
|
+ key_down(appleir, appleir->current_key);
|
||||||
|
+ /* Remote doesn't do key up, either pull them up, in the test
|
||||||
|
+ above, or here set a timer which pulls them up after 1/8 s */
|
||||||
|
+ mod_timer(&appleir->key_up_timer, jiffies + HZ / 8);
|
||||||
|
+ appleir->prev_key_idx = 0;
|
||||||
|
+ return;
|
||||||
|
+ } else if (index == -7) {
|
||||||
|
+ /* Remember key for next packet */
|
||||||
|
+ appleir->prev_key_idx = 0 - index;
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
|
+ appleir->prev_key_idx = 0;
|
||||||
|
+
|
||||||
+ if (!memcmp(data, keyrepeat, sizeof(keyrepeat))) {
|
+ if (!memcmp(data, keyrepeat, sizeof(keyrepeat))) {
|
||||||
+ key_down(appleir, appleir->current_key);
|
+ key_down(appleir, appleir->current_key);
|
||||||
+ /* Remote doesn't do key up, either pull them up, in the test
|
+ /* Remote doesn't do key up, either pull them up, in the test
|
||||||
@ -596,3 +697,6 @@ index 0000000..cff4df6
|
|||||||
+
|
+
|
||||||
+module_init(appleir_init);
|
+module_init(appleir_init);
|
||||||
+module_exit(appleir_exit);
|
+module_exit(appleir_exit);
|
||||||
|
--
|
||||||
|
1.7.2.2
|
||||||
|
|
||||||
|
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||||
# for example a 3 here will become 0.3
|
# for example a 3 here will become 0.3
|
||||||
#
|
#
|
||||||
%global baserelease 18
|
%global baserelease 19
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -1884,6 +1884,10 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 10 2010 Bastien Nocera <bnocera@redhat.com> - 2.6.36-0.19.rc3.git1
|
||||||
|
- Update AppleIR patch to work, and support the enter key on
|
||||||
|
newer remotes
|
||||||
|
|
||||||
* Wed Sep 08 2010 Kyle McMartin <kyle@redhat.com>
|
* Wed Sep 08 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
- Enable GPIO_SYSFS. (#631958)
|
- Enable GPIO_SYSFS. (#631958)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user