Add quirk for MSI keyboard backlight to avoid 10 sec boot delay (rhbz 907221)
This commit is contained in:
parent
4a5e3ac285
commit
774576ede9
45
HID-usbhid-quirk-for-MSI-GX680R-led-panel.patch
Normal file
45
HID-usbhid-quirk-for-MSI-GX680R-led-panel.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
From 565bd59e8f55b82eb49b58b0972ac41f4448ef06 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Josh Boyer <jwboyer@redhat.com>
|
||||||
|
Date: Fri, 15 Mar 2013 10:31:31 -0400
|
||||||
|
Subject: [PATCH] HID: usbhid: quirk for MSI GX680R led panel
|
||||||
|
|
||||||
|
This keyboard backlight device causes a 10 second delay to boot. Add it
|
||||||
|
to the quirk list with HID_QUIRK_NO_INIT_REPORTS.
|
||||||
|
|
||||||
|
This fixes Red Hat bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=907221
|
||||||
|
|
||||||
|
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||||
|
---
|
||||||
|
drivers/hid/hid-ids.h | 3 +++
|
||||||
|
drivers/hid/usbhid/hid-quirks.c | 1 +
|
||||||
|
2 files changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/drivers/hid/hid-ids.h b/drivers/hid/hid-ids.h
|
||||||
|
index d1063e9..c438877 100644
|
||||||
|
--- a/drivers/hid/hid-ids.h
|
||||||
|
+++ b/drivers/hid/hid-ids.h
|
||||||
|
@@ -590,6 +590,9 @@
|
||||||
|
#define USB_VENDOR_ID_MONTEREY 0x0566
|
||||||
|
#define USB_DEVICE_ID_GENIUS_KB29E 0x3004
|
||||||
|
|
||||||
|
+#define USB_VENDOR_ID_MSI 0x1770
|
||||||
|
+#define USB_DEVICE_ID_MSI_GX680R_LED_PANEL 0xff00
|
||||||
|
+
|
||||||
|
#define USB_VENDOR_ID_NATIONAL_SEMICONDUCTOR 0x0400
|
||||||
|
#define USB_DEVICE_ID_N_S_HARMONY 0xc359
|
||||||
|
|
||||||
|
diff --git a/drivers/hid/usbhid/hid-quirks.c b/drivers/hid/usbhid/hid-quirks.c
|
||||||
|
index e991d81..476c984 100644
|
||||||
|
--- a/drivers/hid/usbhid/hid-quirks.c
|
||||||
|
+++ b/drivers/hid/usbhid/hid-quirks.c
|
||||||
|
@@ -73,6 +73,7 @@ static const struct hid_blacklist {
|
||||||
|
{ USB_VENDOR_ID_FORMOSA, USB_DEVICE_ID_FORMOSA_IR_RECEIVER, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
|
{ USB_VENDOR_ID_FREESCALE, USB_DEVICE_ID_FREESCALE_MX28, HID_QUIRK_NOGET },
|
||||||
|
{ USB_VENDOR_ID_MGE, USB_DEVICE_ID_MGE_UPS, HID_QUIRK_NOGET },
|
||||||
|
+ { USB_VENDOR_ID_MSI, USB_DEVICE_ID_MSI_GX680R_LED_PANEL, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
|
{ USB_VENDOR_ID_NOVATEK, USB_DEVICE_ID_NOVATEK_MOUSE, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
|
{ USB_VENDOR_ID_PIXART, USB_DEVICE_ID_PIXART_OPTICAL_TOUCH_SCREEN, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
|
{ USB_VENDOR_ID_PIXART, USB_DEVICE_ID_PIXART_OPTICAL_TOUCH_SCREEN1, HID_QUIRK_NO_INIT_REPORTS },
|
||||||
|
--
|
||||||
|
1.8.1.2
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
|||||||
# For non-released -rc kernels, this will be appended after the rcX and
|
# For non-released -rc kernels, this will be appended after the rcX and
|
||||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||||
#
|
#
|
||||||
%global baserelease 1
|
%global baserelease 2
|
||||||
%global fedora_build %{baserelease}
|
%global fedora_build %{baserelease}
|
||||||
|
|
||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
@ -744,6 +744,9 @@ Patch21276: mac80211-Dont-restart-sta-timer-if-not-running.patch
|
|||||||
#rhbz 859282
|
#rhbz 859282
|
||||||
Patch21275: VMX-x86-handle-host-TSC-calibration-failure.patch
|
Patch21275: VMX-x86-handle-host-TSC-calibration-failure.patch
|
||||||
|
|
||||||
|
#rhbz 907221
|
||||||
|
Patch21277: HID-usbhid-quirk-for-MSI-GX680R-led-panel.patch
|
||||||
|
|
||||||
Patch22000: weird-root-dentry-name-debug.patch
|
Patch22000: weird-root-dentry-name-debug.patch
|
||||||
|
|
||||||
#selinux ptrace child permissions
|
#selinux ptrace child permissions
|
||||||
@ -1448,6 +1451,9 @@ ApplyPatch VMX-x86-handle-host-TSC-calibration-failure.patch
|
|||||||
#rhbz 920218
|
#rhbz 920218
|
||||||
ApplyPatch mac80211-Dont-restart-sta-timer-if-not-running.patch
|
ApplyPatch mac80211-Dont-restart-sta-timer-if-not-running.patch
|
||||||
|
|
||||||
|
#rhbz 907221
|
||||||
|
ApplyPatch HID-usbhid-quirk-for-MSI-GX680R-led-panel.patch
|
||||||
|
|
||||||
# END OF PATCH APPLICATIONS
|
# END OF PATCH APPLICATIONS
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -2289,6 +2295,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 26 2013 Josh Boyer <jwboyer@redhat.com>
|
||||||
|
- Add quirk for MSI keyboard backlight to avoid 10 sec boot delay (rhbz 907221)
|
||||||
|
|
||||||
* Mon Mar 25 2013 Justin M. Forbes <jforbes@redhat.com>
|
* Mon Mar 25 2013 Justin M. Forbes <jforbes@redhat.com>
|
||||||
- disable whci-hcd since it doesnt seem to have users (rhbz 919289)
|
- disable whci-hcd since it doesnt seem to have users (rhbz 919289)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user