Linux v3.19
This commit is contained in:
parent
c5c9c7b16e
commit
7681e91720
@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
|
|||||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index c8e17c05f916..63b4b479ed4a 100644
|
index b15036b1890c..0fbc68ed4ce9 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
||||||
|
24
kernel.spec
24
kernel.spec
@ -6,7 +6,7 @@ Summary: The Linux kernel
|
|||||||
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
# For a stable, released kernel, released_kernel should be 1. For rawhide
|
||||||
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
# and/or a kernel built from an rc or git snapshot, released_kernel should
|
||||||
# be 0.
|
# be 0.
|
||||||
%global released_kernel 0
|
%global released_kernel 1
|
||||||
|
|
||||||
%global aarch64patches 1
|
%global aarch64patches 1
|
||||||
|
|
||||||
@ -48,7 +48,7 @@ Summary: The Linux kernel
|
|||||||
# base_sublevel is the kernel version we're starting with and patching
|
# base_sublevel is the kernel version we're starting with and patching
|
||||||
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
|
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
|
||||||
# which yields a base_sublevel of 0.
|
# which yields a base_sublevel of 0.
|
||||||
%define base_sublevel 18
|
%define base_sublevel 19
|
||||||
|
|
||||||
## If this is a released kernel ##
|
## If this is a released kernel ##
|
||||||
%if 0%{?released_kernel}
|
%if 0%{?released_kernel}
|
||||||
@ -67,9 +67,9 @@ Summary: The Linux kernel
|
|||||||
# The next upstream release sublevel (base_sublevel+1)
|
# The next upstream release sublevel (base_sublevel+1)
|
||||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 7
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 0
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -615,6 +615,9 @@ Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
|||||||
#rhbz 1188638
|
#rhbz 1188638
|
||||||
Patch26132: nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
Patch26132: nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
||||||
|
|
||||||
|
#rhbz 1188074
|
||||||
|
Patch26133: ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
||||||
|
|
||||||
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
# git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
|
||||||
Patch30000: kernel-arm64.patch
|
Patch30000: kernel-arm64.patch
|
||||||
|
|
||||||
@ -1142,13 +1145,6 @@ cp -al vanilla-%{vanillaversion} linux-%{KVERREL}
|
|||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
|
|
||||||
#HACK for 3.19-rc6+patch-2.7.3 rbhz 1185928
|
|
||||||
# make the symlink for arm64 dt-bindings. sigh.
|
|
||||||
mkdir -p arch/arm64/boot/dts/include
|
|
||||||
pushd arch/arm64/boot/dts/include/
|
|
||||||
ln -s ../../../../../include/dt-bindings
|
|
||||||
popd
|
|
||||||
|
|
||||||
# released_kernel with possible stable updates
|
# released_kernel with possible stable updates
|
||||||
%if 0%{?stable_base}
|
%if 0%{?stable_base}
|
||||||
ApplyPatch %{stable_patch_00}
|
ApplyPatch %{stable_patch_00}
|
||||||
@ -1346,6 +1342,9 @@ ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
|||||||
#rhbz 1188638
|
#rhbz 1188638
|
||||||
ApplyPatch nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
ApplyPatch nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
||||||
|
|
||||||
|
#rhbz 1188074
|
||||||
|
ApplyPatch ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
||||||
|
|
||||||
%if 0%{?aarch64patches}
|
%if 0%{?aarch64patches}
|
||||||
ApplyPatch kernel-arm64.patch
|
ApplyPatch kernel-arm64.patch
|
||||||
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
%ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
|
||||||
@ -2212,6 +2211,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 09 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.19.0-1
|
||||||
|
- Linux v3.19
|
||||||
|
|
||||||
* Sat Feb 07 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.19.0-0.rc7.git3.1
|
* Sat Feb 07 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.19.0-0.rc7.git3.1
|
||||||
- Linux v3.19-rc7-189-g26cdd1f76a88
|
- Linux v3.19-rc7-189-g26cdd1f76a88
|
||||||
|
|
||||||
|
45
ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
Normal file
45
ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
From: John Stultz <john.stultz@linaro.org>
|
||||||
|
Date: Mon, 2 Feb 2015 10:57:56 -0800
|
||||||
|
Subject: [PATCH] ntp: Fixup adjtimex freq validation on 32bit systems
|
||||||
|
|
||||||
|
Additional validation of adjtimex freq values to avoid
|
||||||
|
potential multiplication overflows were added in commit
|
||||||
|
5e5aeb4367b (time: adjtimex: Validate the ADJ_FREQUENCY values)
|
||||||
|
|
||||||
|
Unfortunately the patch used LONG_MAX/MIN instead of
|
||||||
|
LLONG_MAX/MIN, which was fine on 64bit systems, but caused
|
||||||
|
false positives on 32bit systems resulting in most direct
|
||||||
|
frequency adjustments to fail w/ EINVAL.
|
||||||
|
|
||||||
|
ntpd only does driect frequency adjustments at startup,
|
||||||
|
so the issue was not easily observed there, but other sync
|
||||||
|
applications like ptpd and chrony were more effected by
|
||||||
|
the bug.
|
||||||
|
|
||||||
|
Cc: Sasha Levin <sasha.levin@oracle.com>
|
||||||
|
Reported-by: Josh Boyer <jwboyer@fedoraproject.org>
|
||||||
|
Reported-by: George Joseph <george.joseph@fairview5.com>
|
||||||
|
Signed-off-by: John Stultz <john.stultz@linaro.org>
|
||||||
|
---
|
||||||
|
kernel/time/ntp.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/kernel/time/ntp.c b/kernel/time/ntp.c
|
||||||
|
index 28bf91c60a0b..242774dd27a1 100644
|
||||||
|
--- a/kernel/time/ntp.c
|
||||||
|
+++ b/kernel/time/ntp.c
|
||||||
|
@@ -634,9 +634,9 @@ int ntp_validate_timex(struct timex *txc)
|
||||||
|
return -EPERM;
|
||||||
|
|
||||||
|
if (txc->modes & ADJ_FREQUENCY) {
|
||||||
|
- if (LONG_MIN / PPM_SCALE > txc->freq)
|
||||||
|
+ if (LLONG_MIN / PPM_SCALE > txc->freq)
|
||||||
|
return -EINVAL;
|
||||||
|
- if (LONG_MAX / PPM_SCALE < txc->freq)
|
||||||
|
+ if (LLONG_MAX / PPM_SCALE < txc->freq)
|
||||||
|
return -EINVAL;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
6
sources
6
sources
@ -1,4 +1,2 @@
|
|||||||
9e854df51ca3fef8bfe566dbd7b89241 linux-3.18.tar.xz
|
d3fc8316d4d4d04b65cbc2d70799e763 linux-3.19.tar.xz
|
||||||
813ccb96f0b379d656e57442c2587ca3 perf-man-3.18.tar.gz
|
15d8d2f97ce056488451a5bfb2944603 perf-man-3.19.tar.gz
|
||||||
1d522b72840cbf5269a1383da339690a patch-3.19-rc7.xz
|
|
||||||
5bf344d43b7b11b4b2d2ebddb239dcfd patch-3.19-rc7-git3.xz
|
|
||||||
|
Loading…
Reference in New Issue
Block a user