Linux v3.14-rc6-133-gc60f7d5
This commit is contained in:
parent
bd7199c301
commit
75649728de
@ -1,21 +0,0 @@
|
||||
@@ -, +, @@
|
||||
---
|
||||
drivers/net/wireless/iwlwifi/mvm/coex.c | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
--- a/drivers/net/wireless/iwlwifi/mvm/bt-coex.c
|
||||
+++ a/drivers/net/wireless/iwlwifi/mvm/bt-coex.c
|
||||
@@ -1119,8 +1119,11 @@ void iwl_mvm_bt_rssi_event(struct iwl_mvm *mvm, struct ieee80211_vif *vif,
|
||||
|
||||
lockdep_assert_held(&mvm->mutex);
|
||||
|
||||
- /* Rssi update while not associated ?! */
|
||||
- if (WARN_ON_ONCE(mvmvif->ap_sta_id == IWL_MVM_STATION_COUNT))
|
||||
+ /*
|
||||
+ * Rssi update while not associated - can happen since the statistics
|
||||
+ * are handled asynchronously
|
||||
+ */
|
||||
+ if (mvmvif->ap_sta_id == IWL_MVM_STATION_COUNT)
|
||||
return;
|
||||
|
||||
/* No BT - reports should be disabled */
|
||||
--
|
@ -1,32 +0,0 @@
|
||||
Bugzilla: 1074471
|
||||
Upstream-status: queued for 3.14
|
||||
|
||||
From c88507fbad8055297c1d1e21e599f46960cbee39 Mon Sep 17 00:00:00 2001
|
||||
From: Sabrina Dubroca <sd@queasysnail.net>
|
||||
Date: Thu, 06 Mar 2014 16:51:57 +0000
|
||||
Subject: ipv6: don't set DST_NOCOUNT for remotely added routes
|
||||
|
||||
DST_NOCOUNT should only be used if an authorized user adds routes
|
||||
locally. In case of routes which are added on behalf of router
|
||||
advertisments this flag must not get used as it allows an unlimited
|
||||
number of routes getting added remotely.
|
||||
|
||||
Signed-off-by: Sabrina Dubroca <sd@queasysnail.net>
|
||||
Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org>
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
---
|
||||
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
|
||||
index 11dac21..fba54a4 100644
|
||||
--- a/net/ipv6/route.c
|
||||
+++ b/net/ipv6/route.c
|
||||
@@ -1513,7 +1513,7 @@ int ip6_route_add(struct fib6_config *cfg)
|
||||
if (!table)
|
||||
goto out;
|
||||
|
||||
- rt = ip6_dst_alloc(net, NULL, DST_NOCOUNT, table);
|
||||
+ rt = ip6_dst_alloc(net, NULL, (cfg->fc_flags & RTF_ADDRCONF) ? 0 : DST_NOCOUNT, table);
|
||||
|
||||
if (!rt) {
|
||||
err = -ENOMEM;
|
||||
--
|
||||
cgit v0.9.2
|
17
kernel.spec
17
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 6
|
||||
# The git snapshot level
|
||||
%define gitrev 3
|
||||
%define gitrev 4
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -631,18 +631,12 @@ Patch22000: weird-root-dentry-name-debug.patch
|
||||
|
||||
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 1071998
|
||||
Patch25034: bug-1071998.patch
|
||||
|
||||
#rhbz 1051748
|
||||
Patch25035: Bluetooth-allocate-static-minor-for-vhci.patch
|
||||
|
||||
#Fixes module loading on ppc64le
|
||||
Patch25036: ppc64le_module_fix.patch
|
||||
|
||||
#CVE-2014-2309 rhbz 1074471 1075064
|
||||
Patch25037: ipv6-dont-set-DST_NOCOUNT-for-remotely-added-routes.patch
|
||||
|
||||
#rhbz 1046495
|
||||
Patch25044: iwlwifi-dvm-take-mutex-when-sending-SYNC-BT-config-command.patch
|
||||
|
||||
@ -1284,18 +1278,12 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
|
||||
|
||||
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
|
||||
|
||||
#rhbz 1071998
|
||||
ApplyPatch bug-1071998.patch
|
||||
|
||||
#rhbz 1051748
|
||||
ApplyPatch Bluetooth-allocate-static-minor-for-vhci.patch
|
||||
|
||||
# Fixes module loading on ppc64le
|
||||
ApplyPatch ppc64le_module_fix.patch
|
||||
|
||||
#CVE-2014-2309 rhbz 1074471 1075064
|
||||
ApplyPatch ipv6-dont-set-DST_NOCOUNT-for-remotely-added-routes.patch
|
||||
|
||||
#rhbz 1046495
|
||||
ApplyPatch iwlwifi-dvm-take-mutex-when-sending-SYNC-BT-config-command.patch
|
||||
|
||||
@ -2078,6 +2066,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Mar 14 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc6.git4.1
|
||||
- Linux v3.14-rc6-133-gc60f7d5
|
||||
|
||||
* Thu Mar 13 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc6.git3.1
|
||||
- Linux v3.14-rc6-41-gac9dc67
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
0ecbaf65c00374eb4a826c2f9f37606f linux-3.13.tar.xz
|
||||
732d1952898b28d5ccc264cad77b0619 perf-man-3.13.tar.gz
|
||||
cb06761a64fd9328add06577943e6b37 patch-3.14-rc6.xz
|
||||
0c424d82088c2ee440057fb79645fcf8 patch-3.14-rc6-git3.xz
|
||||
641f5c44f7793625b599e94810ecf4e5 patch-3.14-rc6-git4.xz
|
||||
|
Loading…
Reference in New Issue
Block a user