Linux 2.6.36-rc7 upstream
This commit is contained in:
parent
dd6df43713
commit
72c4be84a6
3
.gitignore
vendored
3
.gitignore
vendored
@ -3,5 +3,4 @@ patch-*.bz2
|
||||
clog
|
||||
*.rpm
|
||||
kernel-2.6.*/
|
||||
/patch-2.6.36-rc6.bz2
|
||||
/patch-2.6.36-rc6-git3.bz2
|
||||
/patch-2.6.36-rc7.bz2
|
||||
|
11
kernel.spec
11
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 34
|
||||
%global baserelease 35
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -82,9 +82,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%define rcrev 6
|
||||
%define rcrev 7
|
||||
# The git snapshot level
|
||||
%define gitrev 3
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 2.6.%{upstream_sublevel}
|
||||
%endif
|
||||
@ -682,7 +682,6 @@ Patch2912: linux-2.6-v4l-dvb-ir-core-update.patch
|
||||
Patch2917: hdpvr-ir-enable.patch
|
||||
|
||||
Patch3000: linux-2.6-rcu-sched-warning.patch
|
||||
Patch3010: linux-2.6-rcu-netpoll.patch
|
||||
|
||||
# fs fixes
|
||||
|
||||
@ -1296,7 +1295,6 @@ ApplyPatch hdpvr-ir-enable.patch
|
||||
|
||||
# silence another rcu_reference warning
|
||||
ApplyPatch linux-2.6-rcu-sched-warning.patch
|
||||
ApplyPatch linux-2.6-rcu-netpoll.patch
|
||||
|
||||
# Patches headed upstream
|
||||
ApplyPatch disable-i8042-check-on-apple-mac.patch
|
||||
@ -1942,6 +1940,9 @@ fi
|
||||
# || ||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 06 2010 Kyle McMartin <kyle@redhat.com> 2.6.36-0.35.rc7.git0
|
||||
- Linux 2.6.36-rc7 upstream.
|
||||
|
||||
* Wed Oct 06 2010 Dave Jones <davej@redhat.com>
|
||||
- Another day, another rcu_dereference warning. (#640673)
|
||||
|
||||
|
@ -1,16 +0,0 @@
|
||||
|
||||
diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
|
||||
index 9fbc54a..435c502 100644
|
||||
--- a/include/linux/rcupdate.h
|
||||
+++ b/include/linux/rcupdate.h
|
||||
@@ -454,7 +454,7 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
|
||||
* Makes rcu_dereference_check() do the dirty work.
|
||||
*/
|
||||
#define rcu_dereference_bh(p) \
|
||||
- rcu_dereference_check(p, rcu_read_lock_bh_held())
|
||||
+ rcu_dereference_check(p, rcu_read_lock_bh_held() || irqs_disabled())
|
||||
|
||||
/**
|
||||
* rcu_dereference_sched - fetch RCU-protected pointer, checking for RCU-sched
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user