update linux-2.6-silence-noise.patch and suck in gitrev 9
re-enable RONX modules, since it's been fixed to get along with dynamic ftrace.
This commit is contained in:
parent
5b032757ea
commit
6c1e38b718
@ -98,4 +98,4 @@ CONFIG_KDB_KEYBOARD=y
|
|||||||
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
||||||
CONFIG_TEST_LIST_SORT=y
|
CONFIG_TEST_LIST_SORT=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_SET_MODULE_RONX is not set
|
CONFIG_DEBUG_SET_MODULE_RONX
|
||||||
|
@ -98,4 +98,4 @@ CONFIG_KDB_KEYBOARD=y
|
|||||||
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
CONFIG_DEBUG_OBJECTS_PERCPU_COUNTER=y
|
||||||
CONFIG_TEST_LIST_SORT=y
|
CONFIG_TEST_LIST_SORT=y
|
||||||
|
|
||||||
# CONFIG_DEBUG_SET_MODULE_RONX is not set
|
CONFIG_DEBUG_SET_MODULE_RONX=y
|
||||||
|
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 4
|
%define gitrev 9
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
|
@ -1,15 +1,3 @@
|
|||||||
--- linux-2.6.26.noarch/drivers/base/power/main.c~ 2008-08-22 20:57:57.000000000 -0400
|
|
||||||
+++ linux-2.6.26.noarch/drivers/base/power/main.c 2008-08-22 20:58:05.000000000 -0400
|
|
||||||
@@ -69,9 +69,6 @@ void device_pm_unlock(void)
|
|
||||||
*/
|
|
||||||
void device_pm_add(struct device *dev)
|
|
||||||
{
|
|
||||||
- pr_debug("PM: Adding info for %s:%s\n",
|
|
||||||
- dev->bus ? dev->bus->name : "No Bus",
|
|
||||||
- kobject_name(&dev->kobj));
|
|
||||||
mutex_lock(&dpm_list_mtx);
|
|
||||||
if (dev->parent) {
|
|
||||||
if (dev->parent->power.status >= DPM_SUSPENDING)
|
|
||||||
From b4e96f34c17e5a79cd28774cc722bb33e7e02c6e Mon Sep 17 00:00:00 2001
|
From b4e96f34c17e5a79cd28774cc722bb33e7e02c6e Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Thu, 25 Sep 2008 16:23:33 -0400
|
Date: Thu, 25 Sep 2008 16:23:33 -0400
|
||||||
@ -64,3 +52,21 @@ Signed-off-by: Dave Jones <davej@redhat.com>
|
|||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
This was removed in revision 1.6 of linux-2.6-silence-noise.patch
|
||||||
|
in ye olde CVS tree. I have no idea why. Originally the pr_debug in
|
||||||
|
device_pm_remove was nuked as well, but that seems to have gotten lost in
|
||||||
|
the r1.634 of kernel.spec (2.6.26-rc2-git5.)
|
||||||
|
|
||||||
|
diff --git a/drivers/base/power/main.c b/drivers/base/power/main.c
|
||||||
|
index 2a52270..bacbdd2 100644
|
||||||
|
--- a/drivers/base/power/main.c
|
||||||
|
+++ b/drivers/base/power/main.c
|
||||||
|
@@ -87,8 +87,6 @@ void device_pm_unlock(void)
|
||||||
|
*/
|
||||||
|
void device_pm_add(struct device *dev)
|
||||||
|
{
|
||||||
|
- pr_debug("PM: Adding info for %s:%s\n",
|
||||||
|
- dev->bus ? dev->bus->name : "No Bus", dev_name(dev));
|
||||||
|
mutex_lock(&dpm_list_mtx);
|
||||||
|
if (dev->parent && dev->parent->power.in_suspend)
|
||||||
|
dev_warn(dev, "parent %s should not be sleeping\n",
|
||||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
c8ee37b4fdccdb651e0603d35350b434 linux-2.6.37.tar.bz2
|
||||||
b5f8b8a1e82bf1d52404e73421a21f4f patch-2.6.37-git4.bz2
|
b5f8b8a1e82bf1d52404e73421a21f4f patch-2.6.37-git4.bz2
|
||||||
|
58ad5016a3b3e12b6364b7cceed44a12 patch-2.6.37-git9.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user