Linux v4.10-11319-gc82be9d
This commit is contained in:
parent
d60ee93427
commit
69ffe69523
@ -1,62 +0,0 @@
|
||||
From 975dcf140bd307b431aff7b6d671155c796cfe5e Mon Sep 17 00:00:00 2001
|
||||
From: Laura Abbott <labbott@redhat.com>
|
||||
Date: Sat, 28 Jan 2017 16:13:49 +0100
|
||||
Subject: [PATCH] Work around for gcc7 and arm64
|
||||
|
||||
Originally proposed by Will Deacon <will.deacon@arm.com>
|
||||
|
||||
http://lists.infradead.org/pipermail/linux-arm-kernel/2016-October/462224.html
|
||||
|
||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
||||
---
|
||||
include/linux/log2.h | 13 ++-----------
|
||||
1 file changed, 2 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/include/linux/log2.h b/include/linux/log2.h
|
||||
index fd7ff3d91e6a..1ab22b79681e 100644
|
||||
--- a/include/linux/log2.h
|
||||
+++ b/include/linux/log2.h
|
||||
@@ -16,12 +16,6 @@
|
||||
#include <linux/bitops.h>
|
||||
|
||||
/*
|
||||
- * deal with unrepresentable constant logarithms
|
||||
- */
|
||||
-extern __attribute__((const, noreturn))
|
||||
-int ____ilog2_NaN(void);
|
||||
-
|
||||
-/*
|
||||
* non-constant log of base 2 calculators
|
||||
* - the arch may override these in asm/bitops.h if they can be implemented
|
||||
* more efficiently than using fls() and fls64()
|
||||
@@ -85,7 +79,7 @@ unsigned long __rounddown_pow_of_two(unsigned long n)
|
||||
#define ilog2(n) \
|
||||
( \
|
||||
__builtin_constant_p(n) ? ( \
|
||||
- (n) < 1 ? ____ilog2_NaN() : \
|
||||
+ (n) < 1 ? 0 : \
|
||||
(n) & (1ULL << 63) ? 63 : \
|
||||
(n) & (1ULL << 62) ? 62 : \
|
||||
(n) & (1ULL << 61) ? 61 : \
|
||||
@@ -149,9 +143,7 @@ unsigned long __rounddown_pow_of_two(unsigned long n)
|
||||
(n) & (1ULL << 3) ? 3 : \
|
||||
(n) & (1ULL << 2) ? 2 : \
|
||||
(n) & (1ULL << 1) ? 1 : \
|
||||
- (n) & (1ULL << 0) ? 0 : \
|
||||
- ____ilog2_NaN() \
|
||||
- ) : \
|
||||
+ 0 ) : \
|
||||
(sizeof(n) <= 4) ? \
|
||||
__ilog2_u32(n) : \
|
||||
__ilog2_u64(n) \
|
||||
@@ -194,7 +186,6 @@ unsigned long __rounddown_pow_of_two(unsigned long n)
|
||||
* @n: parameter
|
||||
*
|
||||
* The first few values calculated by this routine:
|
||||
- * ob2(0) = 0
|
||||
* ob2(1) = 0
|
||||
* ob2(2) = 1
|
||||
* ob2(3) = 2
|
||||
--
|
||||
2.11.0
|
||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
4977ab6e92e267afe9d8f78438c3db330ca8434c
|
||||
c82be9d2244aacea9851c86f4fb74694c99cd874
|
||||
|
10
kernel.spec
10
kernel.spec
@ -42,7 +42,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%global rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 8
|
||||
%define gitrev 9
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -497,9 +497,6 @@ Patch001: kbuild-AFTER_LINK.patch
|
||||
# ongoing complaint, full discussion delayed until ksummit/plumbers
|
||||
Patch002: 0001-iio-Use-event-header-from-kernel-tree.patch
|
||||
|
||||
# Still other instances of this bug floating around
|
||||
Patch003: 0001-Work-around-for-gcc7-and-arm64.patch
|
||||
|
||||
%if !%{nopatches}
|
||||
|
||||
# Git trees.
|
||||
@ -2166,6 +2163,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Mar 03 2017 Laura Abbott <labbott@fedoraproject.org> - 4.11.0-0.rc0.git9.1
|
||||
- Linux v4.10-11319-gc82be9d
|
||||
|
||||
* Thu Mar 02 2017 Laura Abbott <labbott@fedoraproject.org> - 4.11.0-0.rc0.git8.2
|
||||
- rebuilt
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-4.10.tar.xz) = c3690125a8402df638095bd98a613fcf1a257b81de7611c84711d315cd11e2634ab4636302b3742aedf1e3ba9ce0fea53fe8c7d48e37865d8ee5db3565220d90
|
||||
SHA512 (perf-man-4.10.tar.gz) = 2c830e06f47211d70a8330961487af73a8bc01073019475e6b6131d3bb8c95658b77ca0ae5f1b44371accf103658bc5a3a4366b3e017a4088a8fd408dd6867e8
|
||||
SHA512 (patch-4.10-git8.xz) = 30b9a9a06a4795cf208e16274bc4dd4731c1af758cb9510ab77a8347100712a56d20d9697f1dd1420c89d039110dadb8379b1dc3bbe0834207afba97291043a2
|
||||
SHA512 (patch-4.10-git9.xz) = 7e934f2001741547552ace9f4f81da423cc21607c27bcc8c73312a57d7ac29d1f2e191c6739380518cd11828a5b01a36fddb2a4eb5cc214773dff6024279c5cd
|
||||
|
Loading…
Reference in New Issue
Block a user