Linux v3.12-rc7-79-g4f794ee
- Set NR_CPUS=1024 on non-debug x86_64 builds (MAXSMP is set on debug)
This commit is contained in:
parent
105477709d
commit
69fef575e3
@ -3,9 +3,6 @@
|
||||
* net-flow_dissector-fail-on-evil-iph-ihl.patch (rhbz 1007939 1025647)
|
||||
- Should hit upstream and stable soon
|
||||
|
||||
* alps-Support-for-Dell-XT2-model.patch (rhbz 1023413)
|
||||
- http://article.gmane.org/gmane.linux.kernel.input/32484
|
||||
|
||||
* rt2800usb-slow-down-TX-status-polling.patch (rhbz 984696)
|
||||
- Still pending upstream. Fixes https://bugzilla.kernel.org/show_bug.cgi?id=62781
|
||||
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 7673be51f16e978a438bca8ac1bf9e939b7ed7a6 Mon Sep 17 00:00:00 2001
|
||||
From: Yunkang Tang <yunkang.tang@cn.alps.com>
|
||||
Date: Thu, 24 Oct 2013 13:39:08 +0800
|
||||
Subject: [PATCH] Support for Dell XT2 model
|
||||
|
||||
Signed-off-by: Yunkang Tang <yunkang.tang@cn.alps.com>
|
||||
---
|
||||
drivers/input/mouse/alps.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/drivers/input/mouse/alps.c b/drivers/input/mouse/alps.c
|
||||
index ca7a26f..24b3626 100644
|
||||
--- a/drivers/input/mouse/alps.c
|
||||
+++ b/drivers/input/mouse/alps.c
|
||||
@@ -103,6 +103,7 @@ static const struct alps_model_info alps_model_data[] = {
|
||||
/* Dell Latitude E5500, E6400, E6500, Precision M4400 */
|
||||
{ { 0x62, 0x02, 0x14 }, 0x00, ALPS_PROTO_V2, 0xcf, 0xcf,
|
||||
ALPS_PASS | ALPS_DUALPOINT | ALPS_PS2_INTERLEAVED },
|
||||
+ { { 0x73, 0x00, 0x14 }, 0x00, ALPS_PROTO_V2, 0xcf, 0xcf, ALPS_DUALPOINT }, /* Dell XT2 */
|
||||
{ { 0x73, 0x02, 0x50 }, 0x00, ALPS_PROTO_V2, 0xcf, 0xcf, ALPS_FOUR_BUTTONS }, /* Dell Vostro 1400 */
|
||||
{ { 0x52, 0x01, 0x14 }, 0x00, ALPS_PROTO_V2, 0xff, 0xff,
|
||||
ALPS_PASS | ALPS_DUALPOINT | ALPS_PS2_INTERLEAVED }, /* Toshiba Tecra A11-11L */
|
||||
--
|
||||
1.8.1.2
|
||||
|
@ -16,7 +16,8 @@ CONFIG_X86_64_ACPI_NUMA=y
|
||||
CONFIG_NUMA_BALANCING_DEFAULT_ENABLED=y
|
||||
CONFIG_NUMA_BALANCING=y
|
||||
|
||||
CONFIG_NR_CPUS=128
|
||||
# https://lists.fedoraproject.org/pipermail/kernel/2013-November/004601.html
|
||||
CONFIG_NR_CPUS=1024
|
||||
CONFIG_PHYSICAL_START=0x1000000
|
||||
CONFIG_PHYSICAL_ALIGN=0x1000000
|
||||
|
||||
|
12
kernel.spec
12
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 7
|
||||
# The git snapshot level
|
||||
%define gitrev 2
|
||||
%define gitrev 3
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -733,9 +733,6 @@ Patch25131: btrfs-relocate-csums-properly-with-prealloc-ext.patch
|
||||
#rhbz 984696
|
||||
Patch25132: rt2800usb-slow-down-TX-status-polling.patch
|
||||
|
||||
#rhbz 1023413
|
||||
Patch25133: alps-Support-for-Dell-XT2-model.patch
|
||||
|
||||
#CVE-2013-4348 rhbz 1007939 1025647
|
||||
Patch25139: net-flow_dissector-fail-on-evil-iph-ihl.patch
|
||||
|
||||
@ -1441,9 +1438,6 @@ ApplyPatch btrfs-relocate-csums-properly-with-prealloc-ext.patch
|
||||
#rhbz 984696
|
||||
ApplyPatch rt2800usb-slow-down-TX-status-polling.patch
|
||||
|
||||
#rhbz 1023413
|
||||
ApplyPatch alps-Support-for-Dell-XT2-model.patch
|
||||
|
||||
#CVE-2013-4348 rhbz 1007939 1025647
|
||||
ApplyPatch net-flow_dissector-fail-on-evil-iph-ihl.patch
|
||||
|
||||
@ -2250,6 +2244,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Nov 01 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.12.0-0.rc7.git3.1
|
||||
- Linux v3.12-rc7-79-g4f794ee
|
||||
- Set NR_CPUS=1024 on non-debug x86_64 builds (MAXSMP is set on debug)
|
||||
|
||||
* Fri Nov 01 2013 Josh Boyer <jwboyer@fedoraproject.org>
|
||||
- CVE-2013-4348 net: deadloop path in skb_flow_dissect (rhbz 1007939 1025647)
|
||||
|
||||
|
@ -7,28 +7,20 @@ Some systems, such as EFI-based Apple systems, won't necessarily have an
|
||||
i8042 to initialize. We shouldn't be printing an error message in this
|
||||
case, since not detecting the chip is the correct behavior.
|
||||
---
|
||||
drivers/input/serio/i8042.c | 4 +---
|
||||
1 files changed, 1 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/serio/i8042.c b/drivers/input/serio/i8042.c
|
||||
index 170f71e..4f3e632 100644
|
||||
index 52c9ebf..c374a96 100644
|
||||
--- a/drivers/input/serio/i8042.c
|
||||
+++ b/drivers/input/serio/i8042.c
|
||||
@@ -701,10 +701,8 @@ static int __devinit i8042_check_aux(void)
|
||||
|
||||
@@ -855,7 +855,6 @@ static int __init i8042_check_aux(void)
|
||||
static int i8042_controller_check(void)
|
||||
{
|
||||
- if (i8042_flush() == I8042_BUFFER_SIZE) {
|
||||
if (i8042_flush()) {
|
||||
- pr_err("No controller found\n");
|
||||
+ if (i8042_flush() == I8042_BUFFER_SIZE)
|
||||
return -ENODEV;
|
||||
- }
|
||||
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
1.6.0.1
|
||||
}
|
||||
|
||||
--
|
||||
|
||||
Socket fuzzers like sfuzz will trigger this printk a lot, even though it's
|
||||
ratelimited. It isn't particularly useful, so just remove it.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user