Linux v3.15-rc4-320-gafcf0a2d9289
This commit is contained in:
parent
5f24d860e4
commit
64f88b805e
@ -1,33 +0,0 @@
|
|||||||
From d1b9785eda70e7638927d294139c6d4796cb7ea6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
Date: Tue, 22 Apr 2014 11:08:16 +0200
|
|
||||||
Subject: [PATCH v3] synaptics: Add min/max quirk for ThinkPad Edge E431
|
|
||||||
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
|
||||||
---
|
|
||||||
drivers/input/mouse/synaptics.c | 8 ++++++++
|
|
||||||
1 file changed, 8 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c
|
|
||||||
index 7c9f509..93cc8fd 100644
|
|
||||||
--- a/drivers/input/mouse/synaptics.c
|
|
||||||
+++ b/drivers/input/mouse/synaptics.c
|
|
||||||
@@ -1566,6 +1566,14 @@ static const struct dmi_system_id min_max_dmi_table[] __initconst = {
|
|
||||||
.driver_data = (int []){1232, 5710, 1156, 4696},
|
|
||||||
},
|
|
||||||
{
|
|
||||||
+ /* Lenovo ThinkPad Edge E431 */
|
|
||||||
+ .matches = {
|
|
||||||
+ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
+ DMI_MATCH(DMI_PRODUCT_VERSION, "ThinkPad Edge E431"),
|
|
||||||
+ },
|
|
||||||
+ .driver_data = (int []){1024, 5022, 2508, 4832},
|
|
||||||
+ },
|
|
||||||
+ {
|
|
||||||
/* Lenovo ThinkPad T431s */
|
|
||||||
.matches = {
|
|
||||||
DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
11
kernel.spec
11
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 4
|
%define rcrev 4
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 4
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -626,9 +626,6 @@ Patch25064: 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
|
|||||||
#rhbz 1090161
|
#rhbz 1090161
|
||||||
Patch25072: HID-rmi-do-not-fetch-more-than-16-bytes-in-a-query.patch
|
Patch25072: HID-rmi-do-not-fetch-more-than-16-bytes-in-a-query.patch
|
||||||
|
|
||||||
#rhbz 1089689
|
|
||||||
Patch25065: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
|
|
||||||
|
|
||||||
#rhbz 1090746
|
#rhbz 1090746
|
||||||
Patch25067: ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
Patch25067: ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
||||||
|
|
||||||
@ -1344,9 +1341,6 @@ ApplyPatch gpio-ich-set-regs-and-reglen-for-i3100-and-ich6-chipset.patch
|
|||||||
#rhbz 1025603
|
#rhbz 1025603
|
||||||
ApplyPatch disable-libdw-unwind-on-non-x86.patch
|
ApplyPatch disable-libdw-unwind-on-non-x86.patch
|
||||||
|
|
||||||
#rhbz 1089689
|
|
||||||
ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
|
|
||||||
|
|
||||||
#rhbz 1090746
|
#rhbz 1090746
|
||||||
ApplyPatch ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
ApplyPatch ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
||||||
|
|
||||||
@ -2223,6 +2217,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 09 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc4.git4.1
|
||||||
|
- Linux v3.15-rc4-320-gafcf0a2d9289
|
||||||
|
|
||||||
* Thu May 08 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc4.git3.1
|
* Thu May 08 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc4.git3.1
|
||||||
- Linux v3.15-rc4-298-g9f1eb57dc706
|
- Linux v3.15-rc4-298-g9f1eb57dc706
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
||||||
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
||||||
19962a4eee9062e4b42b9e7884f2682f patch-3.15-rc4.xz
|
19962a4eee9062e4b42b9e7884f2682f patch-3.15-rc4.xz
|
||||||
270197d274e0fe4e20b018520560532a patch-3.15-rc4-git3.xz
|
2f4c17b8ab36db2d62a2284ccc79e406 patch-3.15-rc4-git4.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user