v3.6-9849-g2474542
This commit is contained in:
parent
7594423fc0
commit
5b5cc3df8e
12
kernel.spec
12
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 4
|
||||
%define gitrev 5
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -536,6 +536,7 @@ BuildRequires: sparse >= 0.4.1
|
||||
%endif
|
||||
%if %{with_perf}
|
||||
BuildRequires: elfutils-devel zlib-devel binutils-devel newt-devel python-devel perl(ExtUtils::Embed) bison
|
||||
BuildRequires: audit-libs-devel libunwind-devel
|
||||
%endif
|
||||
%if %{with_tools}
|
||||
BuildRequires: pciutils-devel gettext
|
||||
@ -752,6 +753,9 @@ Patch22066: virtio-scsi-Initialize-scatterlist-structure.patch
|
||||
#rhbz 846037
|
||||
Patch22067: selinux-Fix-sel_netnode_insert-suspicious-rcu-dereference.patch
|
||||
|
||||
#Perf build fix, should go away soon
|
||||
Patch22070: perf-build-fix.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1453,6 +1457,9 @@ ApplyPatch virtio-scsi-Initialize-scatterlist-structure.patch
|
||||
#rhbz 846037
|
||||
ApplyPatch selinux-Fix-sel_netnode_insert-suspicious-rcu-dereference.patch
|
||||
|
||||
#Perf build fix, should go away soon
|
||||
ApplyPatch perf-build-fix.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2306,6 +2313,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Wed Oct 10 2012 Justin M. Forbes <jforbes@redhat.com>
|
||||
- v3.6-9849-g2474542
|
||||
|
||||
* Tue Oct 09 2012 Justin M. Forbes <jforbes@redhat.com>
|
||||
- v3.6-9228-g547b1e8
|
||||
|
||||
|
68
perf-build-fix.patch
Normal file
68
perf-build-fix.patch
Normal file
@ -0,0 +1,68 @@
|
||||
Perf build fails with the new rbtree implementation:
|
||||
|
||||
../../lib/rbtree.c:24:36: fatal error: linux/rbtree_augmented.h: No such
|
||||
file or
|
||||
directory
|
||||
compilation terminated.
|
||||
make[2]: *** [util/rbtree.o] Error 1
|
||||
make[1]: *** [perf_install] Error 2
|
||||
make: *** [tools/perf_install] Error 2
|
||||
|
||||
Fix by updating the Makefile and adding a btree_augmented.h wrapper.
|
||||
|
||||
Reported-by: Borislav Petkov <borislav.petkov@amd.com>
|
||||
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
|
||||
---
|
||||
tools/perf/Makefile | 3 ++-
|
||||
tools/perf/util/include/linux/rbtree.h | 1 -
|
||||
tools/perf/util/include/linux/rbtree_augmented.h | 2 ++
|
||||
tools/perf/util/scripting-engines/trace-event-perl.c | 2 +-
|
||||
4 files changed, 5 insertions(+), 3 deletions(-)
|
||||
create mode 100644 tools/perf/util/include/linux/rbtree_augmented.h
|
||||
|
||||
diff --git a/tools/perf/Makefile b/tools/perf/Makefile
|
||||
index 86258c2..9546ff5 100644
|
||||
--- a/tools/perf/Makefile
|
||||
+++ b/tools/perf/Makefile
|
||||
@@ -268,6 +268,7 @@ LIB_H += util/include/linux/magic.h
|
||||
LIB_H += util/include/linux/poison.h
|
||||
LIB_H += util/include/linux/prefetch.h
|
||||
LIB_H += util/include/linux/rbtree.h
|
||||
+LIB_H += util/include/linux/rbtree_augmented.h
|
||||
LIB_H += util/include/linux/string.h
|
||||
LIB_H += util/include/linux/types.h
|
||||
LIB_H += util/include/linux/linkage.h
|
||||
@@ -906,7 +907,7 @@ $(OUTPUT)ui/browsers/map.o: ui/browsers/map.c $(OUTPUT)PERF-CFLAGS
|
||||
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DENABLE_SLFUTURE_CONST $<
|
||||
|
||||
$(OUTPUT)util/rbtree.o: ../../lib/rbtree.c $(OUTPUT)PERF-CFLAGS
|
||||
- $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -DETC_PERFCONFIG='"$(ETC_PERFCONFIG_SQ)"' $<
|
||||
+ $(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Wno-unused-parameter -DETC_PERFCONFIG='"$(ETC_PERFCONFIG_SQ)"' $<
|
||||
|
||||
$(OUTPUT)util/parse-events.o: util/parse-events.c $(OUTPUT)PERF-CFLAGS
|
||||
$(QUIET_CC)$(CC) -o $@ -c $(ALL_CFLAGS) -Wno-redundant-decls $<
|
||||
diff --git a/tools/perf/util/include/linux/rbtree.h b/tools/perf/util/include/linux/rbtree.h
|
||||
index 9bcdc84..2a030c5 100644
|
||||
--- a/tools/perf/util/include/linux/rbtree.h
|
||||
+++ b/tools/perf/util/include/linux/rbtree.h
|
||||
@@ -1,3 +1,2 @@
|
||||
#include <stdbool.h>
|
||||
-#include <stdbool.h>
|
||||
#include "../../../../include/linux/rbtree.h"
|
||||
diff --git a/tools/perf/util/include/linux/rbtree_augmented.h b/tools/perf/util/include/linux/rbtree_augmented.h
|
||||
new file mode 100644
|
||||
index 0000000..9d6fcdf
|
||||
--- /dev/null
|
||||
+++ b/tools/perf/util/include/linux/rbtree_augmented.h
|
||||
@@ -0,0 +1,2 @@
|
||||
+#include <stdbool.h>
|
||||
+#include "../../../../include/linux/rbtree_augmented.h"
|
||||
diff --git a/tools/perf/util/scripting-engines/trace-event-perl.c b/tools/perf/util/scripting-engines/trace-event-perl.c
|
||||
index f80605e..f53889d 100644
|
||||
--
|
||||
Markus
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
||||
Please read the FAQ at http://www.tux.org/lkml/
|
Loading…
Reference in New Issue
Block a user