kernel-5.18.0-0.rc5.20220505gita7391ad3572431a.43
* Mon May 02 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.18.0-0.rc5.39] - redhat/configs: Set GUP_TEST in debug kernel (Joel Savitz) Resolves: Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
1efd1ad096
commit
5b397b1aad
@ -12,7 +12,7 @@ RHEL_MINOR = 99
|
|||||||
#
|
#
|
||||||
# Use this spot to avoid future merge conflicts.
|
# Use this spot to avoid future merge conflicts.
|
||||||
# Do not trim this comment.
|
# Do not trim this comment.
|
||||||
RHEL_RELEASE = 42
|
RHEL_RELEASE = 43
|
||||||
|
|
||||||
#
|
#
|
||||||
# ZSTREAM
|
# ZSTREAM
|
||||||
|
10
kernel.spec
10
kernel.spec
@ -129,13 +129,13 @@ Summary: The Linux kernel
|
|||||||
|
|
||||||
%define rpmversion 5.18.0
|
%define rpmversion 5.18.0
|
||||||
%define patchversion 5.18
|
%define patchversion 5.18
|
||||||
%define pkgrelease 0.rc5.20220504git107c948d1d3e61d.42
|
%define pkgrelease 0.rc5.20220505gita7391ad3572431a.43
|
||||||
|
|
||||||
# This is needed to do merge window version magic
|
# This is needed to do merge window version magic
|
||||||
%define patchlevel 18
|
%define patchlevel 18
|
||||||
|
|
||||||
# allow pkg_release to have configurable %%{?dist} tag
|
# allow pkg_release to have configurable %%{?dist} tag
|
||||||
%define specrelease 0.rc5.20220504git107c948d1d3e61d.42%{?buildid}%{?dist}
|
%define specrelease 0.rc5.20220505gita7391ad3572431a.43%{?buildid}%{?dist}
|
||||||
|
|
||||||
%define pkg_release %{specrelease}
|
%define pkg_release %{specrelease}
|
||||||
|
|
||||||
@ -690,7 +690,7 @@ BuildRequires: lld
|
|||||||
# exact git commit you can run
|
# exact git commit you can run
|
||||||
#
|
#
|
||||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||||
Source0: linux-5.18-rc5-16-g107c948d1d3e61d.tar.xz
|
Source0: linux-5.18-rc5-28-ga7391ad3572431a.tar.xz
|
||||||
|
|
||||||
Source1: Makefile.rhelver
|
Source1: Makefile.rhelver
|
||||||
|
|
||||||
@ -1382,8 +1382,8 @@ ApplyOptionalPatch()
|
|||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
%setup -q -n kernel-5.18-rc5-16-g107c948d1d3e61d -c
|
%setup -q -n kernel-5.18-rc5-28-ga7391ad3572431a -c
|
||||||
mv linux-5.18-rc5-16-g107c948d1d3e61d linux-%{KVERREL}
|
mv linux-5.18-rc5-28-ga7391ad3572431a linux-%{KVERREL}
|
||||||
|
|
||||||
cd linux-%{KVERREL}
|
cd linux-%{KVERREL}
|
||||||
cp -a %{SOURCE1} .
|
cp -a %{SOURCE1} .
|
||||||
|
@ -614,7 +614,7 @@ index bbf7029e224b..cf7faa970dd6 100644
|
|||||||
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
|
dmi_decode_ipmi((const struct dmi_header *) dev->device_data);
|
||||||
|
|
||||||
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
|
diff --git a/drivers/char/ipmi/ipmi_msghandler.c b/drivers/char/ipmi/ipmi_msghandler.c
|
||||||
index c59265146e9c..caa8458edde2 100644
|
index f1827257ef0e..5a45c2cd3dc2 100644
|
||||||
--- a/drivers/char/ipmi/ipmi_msghandler.c
|
--- a/drivers/char/ipmi/ipmi_msghandler.c
|
||||||
+++ b/drivers/char/ipmi/ipmi_msghandler.c
|
+++ b/drivers/char/ipmi/ipmi_msghandler.c
|
||||||
@@ -35,6 +35,7 @@
|
@@ -35,6 +35,7 @@
|
||||||
@ -625,7 +625,7 @@ index c59265146e9c..caa8458edde2 100644
|
|||||||
#include <linux/delay.h>
|
#include <linux/delay.h>
|
||||||
|
|
||||||
#define IPMI_DRIVER_VERSION "39.2"
|
#define IPMI_DRIVER_VERSION "39.2"
|
||||||
@@ -5422,8 +5423,21 @@ static int __init ipmi_init_msghandler_mod(void)
|
@@ -5427,8 +5428,21 @@ static int __init ipmi_init_msghandler_mod(void)
|
||||||
{
|
{
|
||||||
int rv;
|
int rv;
|
||||||
|
|
||||||
@ -1348,7 +1348,7 @@ index 258d5fe3d395..f7298e3dc8f3 100644
|
|||||||
if (data->f01_container->dev.driver) {
|
if (data->f01_container->dev.driver) {
|
||||||
/* Driver already bound, so enable ATTN now. */
|
/* Driver already bound, so enable ATTN now. */
|
||||||
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
|
diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
|
||||||
index f2c45b85b9fc..cfeb6b3cd758 100644
|
index 857d4c2fd1a2..9353941f3a97 100644
|
||||||
--- a/drivers/iommu/iommu.c
|
--- a/drivers/iommu/iommu.c
|
||||||
+++ b/drivers/iommu/iommu.c
|
+++ b/drivers/iommu/iommu.c
|
||||||
@@ -7,6 +7,7 @@
|
@@ -7,6 +7,7 @@
|
||||||
@ -1359,7 +1359,7 @@ index f2c45b85b9fc..cfeb6b3cd758 100644
|
|||||||
#include <linux/dma-iommu.h>
|
#include <linux/dma-iommu.h>
|
||||||
#include <linux/kernel.h>
|
#include <linux/kernel.h>
|
||||||
#include <linux/bits.h>
|
#include <linux/bits.h>
|
||||||
@@ -2863,6 +2864,27 @@ u32 iommu_sva_get_pasid(struct iommu_sva *handle)
|
@@ -2870,6 +2871,27 @@ u32 iommu_sva_get_pasid(struct iommu_sva *handle)
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL_GPL(iommu_sva_get_pasid);
|
EXPORT_SYMBOL_GPL(iommu_sva_get_pasid);
|
||||||
|
|
||||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (linux-5.18-rc5-16-g107c948d1d3e61d.tar.xz) = ac09eb31dd846a4da181e4f880075595cf44c1f868341ed2eba41614c0ec0bc5ca05d9a479ad828996e709cd7dc37f38904d4b616c08a79778cd5e039cf14d35
|
SHA512 (linux-5.18-rc5-28-ga7391ad3572431a.tar.xz) = 941a570be6e7e26710dfc9008f72c7c1f18ccc0ce284c6f3e35287056c249c3071e50773d2b114c11476a2ff1407a5858b3ca077bbf4d96efe0b6da1b3893865
|
||||||
SHA512 (kernel-abi-stablelists-5.18.0-0.rc5.20220504git107c948d1d3e61d.42.tar.bz2) = e29614d9ce6a3faaa18ba1e2341076d0afeea99e412ab9b5fb961a7fdb2ce4a4d12aca6ed12401c2f58a684ec11ae3c5f1cd005623a5af60f6c326c542834f1c
|
SHA512 (kernel-abi-stablelists-5.18.0-0.rc5.20220505gita7391ad3572431a.43.tar.bz2) = 5b278bcb68c34c7a6b5206133b4b459073d8cd8d85623f398d81214e0b6e87f6917b8d21d81be674a6b638d03c4886a8c9561a91aee5a73e7d73c1399bad7c0f
|
||||||
SHA512 (kernel-kabi-dw-5.18.0-0.rc5.20220504git107c948d1d3e61d.42.tar.bz2) = 6b0c0a612f3e14431fd65e9236657de29085095ffc72973ffcd20d64a2be4859acbae6bdb3262dc7bef72ffe343a7eae21b6e606c83dd122427a141d396df441
|
SHA512 (kernel-kabi-dw-5.18.0-0.rc5.20220505gita7391ad3572431a.43.tar.bz2) = 27c7c184b59ca42825565eb0d01536150886ce4888b12c66db32237dde68edc16418eb9980251ef503a15913c50c9d96647065a0276682a845396db290972daf
|
||||||
|
Loading…
Reference in New Issue
Block a user