Linux 2.6.37-rc4-git3
This commit is contained in:
parent
254585788f
commit
5acda93677
2
.gitignore
vendored
2
.gitignore
vendored
@ -4,4 +4,4 @@ clog
|
|||||||
*.rpm
|
*.rpm
|
||||||
kernel-2.6.*/
|
kernel-2.6.*/
|
||||||
/patch-2.6.37-rc4.bz2
|
/patch-2.6.37-rc4.bz2
|
||||||
/patch-2.6.37-rc4-git1.bz2
|
/patch-2.6.37-rc4-git3.bz2
|
||||||
|
@ -3529,6 +3529,7 @@ CONFIG_CIFS_UPCALL=y
|
|||||||
CONFIG_CIFS_XATTR=y
|
CONFIG_CIFS_XATTR=y
|
||||||
CONFIG_CIFS_POSIX=y
|
CONFIG_CIFS_POSIX=y
|
||||||
CONFIG_CIFS_FSCACHE=y
|
CONFIG_CIFS_FSCACHE=y
|
||||||
|
CONFIG_CIFS_ACL=y
|
||||||
CONFIG_CIFS_WEAK_PW_HASH=y
|
CONFIG_CIFS_WEAK_PW_HASH=y
|
||||||
# CONFIG_CIFS_DEBUG2 is not set
|
# CONFIG_CIFS_DEBUG2 is not set
|
||||||
CONFIG_CIFS_DFS_UPCALL=y
|
CONFIG_CIFS_DFS_UPCALL=y
|
||||||
|
@ -437,3 +437,5 @@ CONFIG_PCH_PHUB=m
|
|||||||
CONFIG_VIDEO_VIA_CAMERA=m
|
CONFIG_VIDEO_VIA_CAMERA=m
|
||||||
|
|
||||||
CONFIG_JUMP_LABEL=y
|
CONFIG_JUMP_LABEL=y
|
||||||
|
|
||||||
|
CONFIG_HP_ILO=m
|
||||||
|
1612
drm-fixes.patch
1612
drm-fixes.patch
File diff suppressed because it is too large
Load Diff
44
drm-intel-edp-fixes.patch
Normal file
44
drm-intel-edp-fixes.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
|
||||||
|
index f737960..b1f8164 100644
|
||||||
|
--- a/drivers/gpu/drm/i915/i915_drv.c
|
||||||
|
+++ b/drivers/gpu/drm/i915/i915_drv.c
|
||||||
|
@@ -509,6 +509,8 @@ i915_pci_remove(struct pci_dev *pdev)
|
||||||
|
{
|
||||||
|
struct drm_device *dev = pci_get_drvdata(pdev);
|
||||||
|
|
||||||
|
+ pci_disable_device(pdev); /* core did previous enable */
|
||||||
|
+
|
||||||
|
drm_put_dev(dev);
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
index 300f64b..2e3db37 100644
|
||||||
|
--- a/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
+++ b/drivers/gpu/drm/i915/intel_dp.c
|
||||||
|
@@ -795,7 +795,8 @@ static bool ironlake_edp_panel_on (struct intel_dp *intel_dp)
|
||||||
|
{
|
||||||
|
struct drm_device *dev = intel_dp->base.base.dev;
|
||||||
|
struct drm_i915_private *dev_priv = dev->dev_private;
|
||||||
|
- u32 pp, idle_on_mask = PP_ON | PP_SEQUENCE_STATE_ON_IDLE;
|
||||||
|
+ u32 pp, idle_on = PP_ON | PP_SEQUENCE_STATE_ON_IDLE;
|
||||||
|
+ u32 idle_on_mask = PP_ON | PP_SEQUENCE_STATE_MASK;
|
||||||
|
|
||||||
|
if (I915_READ(PCH_PP_STATUS) & PP_ON)
|
||||||
|
return true;
|
||||||
|
@@ -816,7 +817,7 @@ static bool ironlake_edp_panel_on (struct intel_dp *intel_dp)
|
||||||
|
*/
|
||||||
|
msleep(300);
|
||||||
|
|
||||||
|
- if (wait_for((I915_READ(PCH_PP_STATUS) & idle_on_mask) == idle_on_mask,
|
||||||
|
+ if (wait_for((I915_READ(PCH_PP_STATUS) & idle_on_mask) == idle_on,
|
||||||
|
5000))
|
||||||
|
DRM_ERROR("panel on wait timed out: 0x%08x\n",
|
||||||
|
I915_READ(PCH_PP_STATUS));
|
||||||
|
@@ -922,6 +923,7 @@ static void intel_dp_prepare(struct drm_encoder *encoder)
|
||||||
|
|
||||||
|
if (is_edp(intel_dp)) {
|
||||||
|
ironlake_edp_backlight_off(dev);
|
||||||
|
+ ironlake_edp_panel_off(dev);
|
||||||
|
ironlake_edp_panel_on(intel_dp);
|
||||||
|
if (!is_pch_edp(intel_dp))
|
||||||
|
ironlake_edp_pll_on(encoder);
|
21
kernel.spec
21
kernel.spec
@ -84,7 +84,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 4
|
%define rcrev 4
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 1
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 2.6.%{upstream_sublevel}
|
%define rpmversion 2.6.%{upstream_sublevel}
|
||||||
%endif
|
%endif
|
||||||
@ -648,13 +648,14 @@ Patch1555: fix_xen_guest_on_old_EC2.patch
|
|||||||
# DRM
|
# DRM
|
||||||
|
|
||||||
# nouveau + drm fixes
|
# nouveau + drm fixes
|
||||||
Patch1801: drm-fixes.patch
|
|
||||||
Patch1810: drm-nouveau-updates.patch
|
Patch1810: drm-nouveau-updates.patch
|
||||||
Patch1819: drm-intel-big-hammer.patch
|
Patch1819: drm-intel-big-hammer.patch
|
||||||
# intel drm is all merged upstream
|
# intel drm is all merged upstream
|
||||||
Patch1824: drm-intel-next.patch
|
Patch1824: drm-intel-next.patch
|
||||||
# make sure the lvds comes back on lid open
|
# make sure the lvds comes back on lid open
|
||||||
Patch1825: drm-intel-make-lvds-work.patch
|
Patch1825: drm-intel-make-lvds-work.patch
|
||||||
|
Patch1826: drm-intel-edp-fixes.patch
|
||||||
|
|
||||||
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
Patch1900: linux-2.6-intel-iommu-igfx.patch
|
||||||
|
|
||||||
# linux1394 git patches
|
# linux1394 git patches
|
||||||
@ -700,10 +701,7 @@ Patch12205: runtime_pm_fixups.patch
|
|||||||
|
|
||||||
Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
Patch12303: dmar-disable-when-ricoh-multifunction.patch
|
||||||
|
|
||||||
Patch12400: tty-dont-allow-reopen-when-ldisc-is-changing.patch
|
|
||||||
Patch12401: debug-tty-print-dev-name.patch
|
Patch12401: debug-tty-print-dev-name.patch
|
||||||
Patch12402: tty-ldisc-fix-open-flag-handling.patch
|
|
||||||
Patch12403: tty-open-hangup-race-fixup.patch
|
|
||||||
|
|
||||||
Patch12410: mm-page-allocator-adjust-the-per-cpu-counter-threshold-when-memory-is-low.patch
|
Patch12410: mm-page-allocator-adjust-the-per-cpu-counter-threshold-when-memory-is-low.patch
|
||||||
Patch12411: mm-vmstat-use-a-single-setter-function-and-callback-for-adjusting-percpu-thresholds.patch
|
Patch12411: mm-vmstat-use-a-single-setter-function-and-callback-for-adjusting-percpu-thresholds.patch
|
||||||
@ -1246,7 +1244,6 @@ ApplyPatch linux-2.6-e1000-ich9-montevina.patch
|
|||||||
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
ApplyPatch fix_xen_guest_on_old_EC2.patch
|
||||||
|
|
||||||
# DRM core
|
# DRM core
|
||||||
ApplyPatch drm-fixes.patch
|
|
||||||
|
|
||||||
# Nouveau DRM
|
# Nouveau DRM
|
||||||
ApplyOptionalPatch drm-nouveau-updates.patch
|
ApplyOptionalPatch drm-nouveau-updates.patch
|
||||||
@ -1256,6 +1253,7 @@ ApplyOptionalPatch drm-intel-next.patch
|
|||||||
ApplyPatch drm-intel-big-hammer.patch
|
ApplyPatch drm-intel-big-hammer.patch
|
||||||
ApplyPatch drm-intel-make-lvds-work.patch
|
ApplyPatch drm-intel-make-lvds-work.patch
|
||||||
ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
ApplyPatch linux-2.6-intel-iommu-igfx.patch
|
||||||
|
ApplyPatch drm-intel-edp-fixes.patch
|
||||||
|
|
||||||
# linux1394 git patches
|
# linux1394 git patches
|
||||||
#ApplyPatch linux-2.6-firewire-git-update.patch
|
#ApplyPatch linux-2.6-firewire-git-update.patch
|
||||||
@ -1298,10 +1296,7 @@ ApplyPatch runtime_pm_fixups.patch
|
|||||||
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
ApplyPatch dmar-disable-when-ricoh-multifunction.patch
|
||||||
|
|
||||||
# rhbz#630464
|
# rhbz#630464
|
||||||
ApplyPatch tty-dont-allow-reopen-when-ldisc-is-changing.patch
|
|
||||||
ApplyPatch debug-tty-print-dev-name.patch
|
ApplyPatch debug-tty-print-dev-name.patch
|
||||||
ApplyPatch tty-ldisc-fix-open-flag-handling.patch
|
|
||||||
ApplyPatch tty-open-hangup-race-fixup.patch
|
|
||||||
|
|
||||||
# backport some fixes for kswapd from mmotm, rhbz#649694
|
# backport some fixes for kswapd from mmotm, rhbz#649694
|
||||||
ApplyPatch mm-page-allocator-adjust-the-per-cpu-counter-threshold-when-memory-is-low.patch
|
ApplyPatch mm-page-allocator-adjust-the-per-cpu-counter-threshold-when-memory-is-low.patch
|
||||||
@ -1919,6 +1914,14 @@ fi
|
|||||||
# || ||
|
# || ||
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 03 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
|
- Linux 2.6.37-rc4-git3
|
||||||
|
- Enable HP ILO on x86_64 for (#571329)
|
||||||
|
- Drop merged drm-fixes.patch, split out edp-fixes.
|
||||||
|
- tty-dont-allow-reopen-when-ldisc-is-changing.patch: upstream.
|
||||||
|
- tty-ldisc-fix-open-flag-handling.patch: upstream.
|
||||||
|
- Enable CIFS_ACL.
|
||||||
|
|
||||||
* Thu Dec 02 2010 Kyle McMartin <kyle@redhat.com>
|
* Thu Dec 02 2010 Kyle McMartin <kyle@redhat.com>
|
||||||
- Grab some of Mel's fixes from -mmotm to hopefully sort out #649694.
|
- Grab some of Mel's fixes from -mmotm to hopefully sort out #649694.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
61f3739a73afb6914cb007f37fb09b62 linux-2.6.36.tar.bz2
|
||||||
854ca0c7eca8930a71a6382a7dabbf65 patch-2.6.37-rc4.bz2
|
854ca0c7eca8930a71a6382a7dabbf65 patch-2.6.37-rc4.bz2
|
||||||
c3146fe28bb10e77d8388bc26e16483c patch-2.6.37-rc4-git1.bz2
|
e8f83da2932eb4ca1dda9b66c66f0980 patch-2.6.37-rc4-git3.bz2
|
||||||
|
@ -1,84 +0,0 @@
|
|||||||
From jirislaby@gmail.com Thu Nov 25 12:16:42 2010
|
|
||||||
From: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
Subject: [PATCH 1/1] TTY: don't allow reopen when ldisc is changing
|
|
||||||
Date: Thu, 25 Nov 2010 18:16:23 +0100
|
|
||||||
|
|
||||||
There are many WARNINGs like the following reported nowadays:
|
|
||||||
WARNING: at drivers/tty/tty_io.c:1331 tty_open+0x2a2/0x49a()
|
|
||||||
Hardware name: Latitude E6500
|
|
||||||
Modules linked in:
|
|
||||||
Pid: 1207, comm: plymouthd Not tainted 2.6.37-rc3-mmotm1123 #3
|
|
||||||
Call Trace:
|
|
||||||
[<ffffffff8103b189>] warn_slowpath_common+0x80/0x98
|
|
||||||
[<ffffffff8103b1b6>] warn_slowpath_null+0x15/0x17
|
|
||||||
[<ffffffff8128a3ab>] tty_open+0x2a2/0x49a
|
|
||||||
[<ffffffff810fd53f>] chrdev_open+0x11d/0x146
|
|
||||||
...
|
|
||||||
|
|
||||||
This means tty_reopen is called without TTY_LDISC set. For further
|
|
||||||
considerations, note tty_lock is held in tty_open. TTY_LDISC is cleared in:
|
|
||||||
1) __tty_hangup from tty_ldisc_hangup to tty_ldisc_enable. During this
|
|
||||||
section tty_lock is held.
|
|
||||||
|
|
||||||
2) tty_release via tty_ldisc_release till the end of tty existence. If
|
|
||||||
tty->count <= 1, tty_lock is taken, TTY_CLOSING bit set and then
|
|
||||||
tty_ldisc_release called. tty_reopen checks TTY_CLOSING before checking
|
|
||||||
TTY_LDISC.
|
|
||||||
|
|
||||||
3) tty_set_ldisc from tty_ldisc_halt to tty_ldisc_enable. We:
|
|
||||||
* take tty_lock, set TTY_LDISC_CHANGING, put tty_lock
|
|
||||||
* call tty_ldisc_halt (clear TTY_LDISC), tty_lock is _not_ held
|
|
||||||
* do some other work
|
|
||||||
* take tty_lock, call tty_ldisc_enable (set TTY_LDISC), put
|
|
||||||
tty_lock
|
|
||||||
|
|
||||||
So the only option I see is 3). The solution is to check
|
|
||||||
TTY_LDISC_CHANGING along with TTY_CLOSING in tty_reopen.
|
|
||||||
|
|
||||||
Nicely reproducible with two processes:
|
|
||||||
while (1) {
|
|
||||||
fd = open("/dev/ttyS1", O_RDWR);
|
|
||||||
if (fd < 0) {
|
|
||||||
warn("open");
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
close(fd);
|
|
||||||
}
|
|
||||||
--------
|
|
||||||
while (1) {
|
|
||||||
fd = open("/dev/ttyS1", O_RDWR);
|
|
||||||
ld1 = 0; ld2 = 2;
|
|
||||||
while (1) {
|
|
||||||
ioctl(fd, TIOCSETD, &ld1);
|
|
||||||
ioctl(fd, TIOCSETD, &ld2);
|
|
||||||
}
|
|
||||||
close(fd);
|
|
||||||
}
|
|
||||||
|
|
||||||
Signed-off-by: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
Reported-by: <Valdis.Kletnieks@vt.edu>
|
|
||||||
Cc: Kyle McMartin <kyle@mcmartin.ca>
|
|
||||||
Cc: Alan Cox <alan@lxorguk.ukuu.org.uk>
|
|
||||||
---
|
|
||||||
drivers/tty/tty_io.c | 3 ++-
|
|
||||||
1 files changed, 2 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/tty/tty_io.c b/drivers/tty/tty_io.c
|
|
||||||
index c05c5af..878f6d6 100644
|
|
||||||
--- a/drivers/tty/tty_io.c
|
|
||||||
+++ b/drivers/tty/tty_io.c
|
|
||||||
@@ -1310,7 +1310,8 @@ static int tty_reopen(struct tty_struct *tty)
|
|
||||||
{
|
|
||||||
struct tty_driver *driver = tty->driver;
|
|
||||||
|
|
||||||
- if (test_bit(TTY_CLOSING, &tty->flags))
|
|
||||||
+ if (test_bit(TTY_CLOSING, &tty->flags) ||
|
|
||||||
+ test_bit(TTY_LDISC_CHANGING, &tty->flags))
|
|
||||||
return -EIO;
|
|
||||||
|
|
||||||
if (driver->type == TTY_DRIVER_TYPE_PTY &&
|
|
||||||
--
|
|
||||||
1.7.3.1
|
|
||||||
|
|
||||||
|
|
||||||
|
|
@ -1,54 +0,0 @@
|
|||||||
From linux-kernel-owner@vger.kernel.org Wed Nov 24 18:28:11 2010
|
|
||||||
From: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
Subject: [PATCH 1/2] TTY: ldisc, fix open flag handling
|
|
||||||
Date: Thu, 25 Nov 2010 00:27:54 +0100
|
|
||||||
|
|
||||||
When a concrete ldisc open fails in tty_ldisc_open, we forget to clear
|
|
||||||
TTY_LDISC_OPEN. This causes a false warning on the next ldisc open:
|
|
||||||
WARNING: at drivers/char/tty_ldisc.c:445 tty_ldisc_open+0x26/0x38()
|
|
||||||
Hardware name: System Product Name
|
|
||||||
Modules linked in: ...
|
|
||||||
Pid: 5251, comm: a.out Tainted: G W 2.6.32-5-686 #1
|
|
||||||
Call Trace:
|
|
||||||
[<c1030321>] ? warn_slowpath_common+0x5e/0x8a
|
|
||||||
[<c1030357>] ? warn_slowpath_null+0xa/0xc
|
|
||||||
[<c119311c>] ? tty_ldisc_open+0x26/0x38
|
|
||||||
[<c11936c5>] ? tty_set_ldisc+0x218/0x304
|
|
||||||
...
|
|
||||||
|
|
||||||
So clear the bit when failing...
|
|
||||||
|
|
||||||
Introduced in c65c9bc3efa (tty: rewrite the ldisc locking) back in
|
|
||||||
2.6.31-rc1.
|
|
||||||
|
|
||||||
Signed-off-by: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
Cc: Alan Cox <alan@linux.intel.com>
|
|
||||||
Reported-by: Sergey Lapin <slapin@ossfans.org>
|
|
||||||
Tested-by: Sergey Lapin <slapin@ossfans.org>
|
|
||||||
---
|
|
||||||
drivers/tty/tty_ldisc.c | 2 ++
|
|
||||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/tty/tty_ldisc.c b/drivers/tty/tty_ldisc.c
|
|
||||||
index d8e96b0..4214d58 100644
|
|
||||||
--- a/drivers/tty/tty_ldisc.c
|
|
||||||
+++ b/drivers/tty/tty_ldisc.c
|
|
||||||
@@ -454,6 +454,8 @@ static int tty_ldisc_open(struct tty_struct *tty, struct tty_ldisc *ld)
|
|
||||||
/* BTM here locks versus a hangup event */
|
|
||||||
WARN_ON(!tty_locked());
|
|
||||||
ret = ld->ops->open(tty);
|
|
||||||
+ if (ret)
|
|
||||||
+ clear_bit(TTY_LDISC_OPEN, &tty->flags);
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
return 0;
|
|
||||||
--
|
|
||||||
1.7.3.1
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
|
|
||||||
the body of a message to majordomo@vger.kernel.org
|
|
||||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
|
||||||
Please read the FAQ at http://www.tux.org/lkml/
|
|
||||||
|
|
@ -1,76 +0,0 @@
|
|||||||
From 9e88e8b9915b5e067507a087437d80e6a133d612 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
Date: Sat, 27 Nov 2010 16:06:46 +0100
|
|
||||||
Subject: [PATCH 1/1] TTY: open/hangup race fixup
|
|
||||||
|
|
||||||
|
|
||||||
Signed-off-by: Jiri Slaby <jslaby@suse.cz>
|
|
||||||
---
|
|
||||||
drivers/tty/tty_io.c | 10 +++++++++-
|
|
||||||
include/linux/tty.h | 1 +
|
|
||||||
2 files changed, 10 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/drivers/tty/tty_io.c b/drivers/tty/tty_io.c
|
|
||||||
index 878f6d6..35480dd 100644
|
|
||||||
--- a/drivers/tty/tty_io.c
|
|
||||||
+++ b/drivers/tty/tty_io.c
|
|
||||||
@@ -559,6 +559,9 @@ void __tty_hangup(struct tty_struct *tty)
|
|
||||||
|
|
||||||
tty_lock();
|
|
||||||
|
|
||||||
+ /* some functions below drop BTM, so we need this bit */
|
|
||||||
+ set_bit(TTY_HUPPING, &tty->flags);
|
|
||||||
+
|
|
||||||
/* inuse_filps is protected by the single tty lock,
|
|
||||||
this really needs to change if we want to flush the
|
|
||||||
workqueue with the lock held */
|
|
||||||
@@ -578,6 +581,10 @@ void __tty_hangup(struct tty_struct *tty)
|
|
||||||
}
|
|
||||||
spin_unlock(&tty_files_lock);
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * it drops BTM and thus races with reopen
|
|
||||||
+ * we protect the race by TTY_HUPPING
|
|
||||||
+ */
|
|
||||||
tty_ldisc_hangup(tty);
|
|
||||||
|
|
||||||
read_lock(&tasklist_lock);
|
|
||||||
@@ -615,7 +622,6 @@ void __tty_hangup(struct tty_struct *tty)
|
|
||||||
tty->session = NULL;
|
|
||||||
tty->pgrp = NULL;
|
|
||||||
tty->ctrl_status = 0;
|
|
||||||
- set_bit(TTY_HUPPED, &tty->flags);
|
|
||||||
spin_unlock_irqrestore(&tty->ctrl_lock, flags);
|
|
||||||
|
|
||||||
/* Account for the p->signal references we killed */
|
|
||||||
@@ -641,6 +647,7 @@ void __tty_hangup(struct tty_struct *tty)
|
|
||||||
* can't yet guarantee all that.
|
|
||||||
*/
|
|
||||||
set_bit(TTY_HUPPED, &tty->flags);
|
|
||||||
+ clear_bit(TTY_HUPPING, &tty->flags);
|
|
||||||
tty_ldisc_enable(tty);
|
|
||||||
|
|
||||||
tty_unlock();
|
|
||||||
@@ -1311,6 +1318,7 @@ static int tty_reopen(struct tty_struct *tty)
|
|
||||||
struct tty_driver *driver = tty->driver;
|
|
||||||
|
|
||||||
if (test_bit(TTY_CLOSING, &tty->flags) ||
|
|
||||||
+ test_bit(TTY_HUPPING, &tty->flags) ||
|
|
||||||
test_bit(TTY_LDISC_CHANGING, &tty->flags))
|
|
||||||
return -EIO;
|
|
||||||
|
|
||||||
diff --git a/include/linux/tty.h b/include/linux/tty.h
|
|
||||||
index 032d79f..54e4eaa 100644
|
|
||||||
--- a/include/linux/tty.h
|
|
||||||
+++ b/include/linux/tty.h
|
|
||||||
@@ -366,6 +366,7 @@ struct tty_file_private {
|
|
||||||
#define TTY_HUPPED 18 /* Post driver->hangup() */
|
|
||||||
#define TTY_FLUSHING 19 /* Flushing to ldisc in progress */
|
|
||||||
#define TTY_FLUSHPENDING 20 /* Queued buffer flush pending */
|
|
||||||
+#define TTY_HUPPING 21 /* ->hangup() in progress */
|
|
||||||
|
|
||||||
#define TTY_WRITE_FLUSH(tty) tty_write_flush((tty))
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.3.1
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user