Linux v5.2-rc1-165-g54dee406374c
This commit is contained in:
parent
a87df2f1bb
commit
59ba0d757a
@ -1,34 +0,0 @@
|
||||
From a45c8a275e5e4120f4f657379ff7b805d37eac3c Mon Sep 17 00:00:00 2001
|
||||
From: Laura Abbott <labbott@redhat.com>
|
||||
Date: Wed, 15 May 2019 10:54:48 -0700
|
||||
Subject: [PATCH] arm64: vdso: Explicitly add build-id option
|
||||
To: Masahiro Yamada <yamada.masahiro@socionext.com>
|
||||
To: Will Deacon <will.deacon@arm.com>
|
||||
Cc: linux-kernel@vger.kernel.org
|
||||
Cc: linux-arm-kernel@lists.infradead.org
|
||||
|
||||
Commit 691efbedc60d ("arm64: vdso: use $(LD) instead of $(CC) to
|
||||
link VDSO") switched to using LD explicitly. The --build-id option
|
||||
needs to be passed explicitly, similar to x86. Add this option.
|
||||
|
||||
Fixes: 691efbedc60d ("arm64: vdso: use $(LD) instead of $(CC) to link VDSO")
|
||||
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
||||
---
|
||||
arch/arm64/kernel/vdso/Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/kernel/vdso/Makefile b/arch/arm64/kernel/vdso/Makefile
|
||||
index 744b9dbaba03..ca209103cd06 100644
|
||||
--- a/arch/arm64/kernel/vdso/Makefile
|
||||
+++ b/arch/arm64/kernel/vdso/Makefile
|
||||
@@ -13,6 +13,7 @@ targets := $(obj-vdso) vdso.so vdso.so.dbg
|
||||
obj-vdso := $(addprefix $(obj)/, $(obj-vdso))
|
||||
|
||||
ldflags-y := -shared -nostdlib -soname=linux-vdso.so.1 \
|
||||
+ $(call ld-option, --build-id) \
|
||||
$(call ld-option, --hash-style=sysv) -n -T
|
||||
|
||||
# Disable gcov profiling for VDSO code
|
||||
--
|
||||
2.21.0
|
||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
9c7db5004280767566e91a33445bf93aa479ef02
|
||||
54dee406374ce8adb352c48e175176247cb8db7c
|
||||
|
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%global rcrev 1
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 5.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -577,7 +577,6 @@ Patch508: KEYS-Make-use-of-platform-keyring-for-module-signature.patch
|
||||
Patch524: net-vhost_net-fix-possible-infinite-loop.patch
|
||||
|
||||
# build fix
|
||||
Patch525: 0001-arm64-vdso-Explicitly-add-build-id-option.patch
|
||||
Patch526: s390-mark-__cpacf_check_opcode-and-cpacf_query_func-as-__always_inline.patch
|
||||
Patch527: v2-powerpc-mm-mark-more-tlb-functions-as-__always_inline.patch
|
||||
|
||||
@ -1819,6 +1818,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Wed May 22 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.2.0-0.rc1.git2.1
|
||||
- Linux v5.2-rc1-165-g54dee406374c
|
||||
|
||||
* Tue May 21 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.2.0-0.rc1.git1.1
|
||||
- Linux v5.2-rc1-129-g9c7db5004280
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-5.1.tar.xz) = ae96f347badc95f1f3acf506c52b6cc23c0bd09ce8f4ce6705d4b4058b62593059bba1bc603c8d8b00a2f19131e7e56c31ac62b45883a346fa61d655e178f236
|
||||
SHA512 (patch-5.2-rc1.xz) = 771b53ee920488daf3e36bfa7a38d75b0ab165453d94137d289f4bab59da38251f7c94a63d2f5138bc226c3b4908a9153a3056f1aa19be5317cbe42d0ad4bd2a
|
||||
SHA512 (patch-5.2-rc1-git1.xz) = defa9c12a37761752d74b8ad235ae9322eddc54f9a36d8e5fe55138d4b759244e19875437be498075c537140eb0c25f41b8fdf5415973e8b06ea4c1237f946f7
|
||||
SHA512 (patch-5.2-rc1-git2.xz) = 2fe420c651894b772ef6cc6dfef1f173dd0c7034ce468bb2f1fb2e5accc29e58b25910710b74e63ac70e5f9b92015ff7c7d586c607be31770246f16f5c5e4b89
|
||||
|
Loading…
Reference in New Issue
Block a user