Linux v3.15-rc4-260-g38583f095c5a
This commit is contained in:
parent
94665dc3b5
commit
578819169f
@ -1,39 +0,0 @@
|
||||
Bugzilla: 696821
|
||||
Upstream-status: Sent http://marc.info/?l=linux-kernel&m=139835974112096&w=2
|
||||
|
||||
On 64-bit systems, O_LARGEFILE is automatically added to flags inside
|
||||
the open() syscall (also openat(), blkdev_open(), etc).
|
||||
Userspace therefore defines O_LARGEFILE to be 0 - you can use it,
|
||||
but it's a no-op. Everything should be O_LARGEFILE by default.
|
||||
|
||||
But: when fanotify does create_fd() it uses dentry_open(), which skips
|
||||
all that. And userspace can't set O_LARGEFILE in fanotify_init() because
|
||||
it's defined to 0. So if fanotify gets an event regarding a large file,
|
||||
the read() will just fail with -EOVERFLOW.
|
||||
|
||||
This patch adds O_LARGEFILE to fanotify_init()'s event_f_flags on 64-bit
|
||||
systems, using the same test as open()/openat()/etc.
|
||||
|
||||
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=696821
|
||||
|
||||
Acked-by: Eric Paris <eparis@redhat.com>
|
||||
Signed-off-by: Will Woods <wwoods@redhat.com>
|
||||
---
|
||||
fs/notify/fanotify/fanotify_user.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/fs/notify/fanotify/fanotify_user.c b/fs/notify/fanotify/fanotify_user.c
|
||||
index 4e565c8..732648b 100644
|
||||
--- a/fs/notify/fanotify/fanotify_user.c
|
||||
+++ b/fs/notify/fanotify/fanotify_user.c
|
||||
@@ -698,6 +698,8 @@ SYSCALL_DEFINE2(fanotify_init, unsigned int, flags, unsigned int, event_f_flags)
|
||||
}
|
||||
group->overflow_event = &oevent->fse;
|
||||
|
||||
+ if (force_o_largefile())
|
||||
+ event_f_flags |= O_LARGEFILE;
|
||||
group->fanotify_data.f_flags = event_f_flags;
|
||||
#ifdef CONFIG_FANOTIFY_ACCESS_PERMISSIONS
|
||||
spin_lock_init(&group->fanotify_data.access_lock);
|
||||
--
|
||||
1.9.0
|
11
kernel.spec
11
kernel.spec
@ -61,7 +61,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 4
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -632,9 +632,6 @@ Patch25065: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
|
||||
#rhbz 1090746
|
||||
Patch25067: ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
||||
|
||||
#rhbz 696821
|
||||
Patch25068: fanotify-fix-EOVERFLOW-on-64-bit.patch
|
||||
|
||||
#rhbz 983342 1093120
|
||||
Patch25069: 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
|
||||
|
||||
@ -1353,9 +1350,6 @@ ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
|
||||
#rhbz 1090746
|
||||
ApplyPatch ACPICA-Tables-Fix-bad-pointer-issue-in-acpi_tb_parse_root_table.patch
|
||||
|
||||
#rhbz 696821
|
||||
ApplyPatch fanotify-fix-EOVERFLOW-on-64-bit.patch
|
||||
|
||||
#rhbz 983342 1093120
|
||||
ApplyPatch 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
|
||||
|
||||
@ -2229,6 +2223,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Wed May 07 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc4.git2.1
|
||||
- Linux v3.15-rc4-260-g38583f095c5a
|
||||
|
||||
* Tue May 06 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.15.0-0.rc4.git1.1
|
||||
- Linux v3.15-rc4-202-g30321c7b658a
|
||||
- Reenable debugging options.
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
b621207b3f6ecbb67db18b13258f8ea8 linux-3.14.tar.xz
|
||||
d36baf2d62de5aa61f10a976d00d2d2a perf-man-3.14.tar.gz
|
||||
19962a4eee9062e4b42b9e7884f2682f patch-3.15-rc4.xz
|
||||
4b0ef9f7c4d9492c34d8263fa875c52f patch-3.15-rc4-git1.xz
|
||||
b742ac5036daebfca1dae650ac321aca patch-3.15-rc4-git2.xz
|
||||
|
Loading…
Reference in New Issue
Block a user