Linux v4.16-rc4-120-gce380619fab9
This commit is contained in:
parent
deb9c48b2d
commit
565f8f11d6
@ -1,109 +0,0 @@
|
||||
From patchwork Sun Feb 25 14:10:52 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [1/4] Bluetooth: hci_bcm: Make shutdown and device wake GPIO optional
|
||||
From: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
X-Patchwork-Id: 10240917
|
||||
Message-Id: <1519567855-26105-2-git-send-email-stefan.wahren@i2se.com>
|
||||
To: Loic Poulain <loic.poulain@gmail.com>,
|
||||
=?UTF-8?q?Fr=C3=A9d=C3=A9ric=20Danis?= <frederic.danis.oss@gmail.com>,
|
||||
Marcel Holtmann <marcel@holtmann.org>,
|
||||
Johan Hedberg <johan.hedberg@gmail.com>, Eric Anholt <eric@anholt.net>,
|
||||
Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
||||
Florian Fainelli <f.fainelli@gmail.com>,
|
||||
Phil Elwell <phil@raspberrypi.org>,
|
||||
linux-bluetooth@vger.kernel.org, Lukas Wunner <lukas@wunner.de>,
|
||||
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
||||
Date: Sun, 25 Feb 2018 15:10:52 +0100
|
||||
|
||||
According to the devicetree binding the shutdown and device wake
|
||||
GPIOs are optional. Since commit 3e81a4ca51a1 ("Bluetooth: hci_bcm:
|
||||
Mandate presence of shutdown and device wake GPIO") this driver
|
||||
won't probe anymore on Raspberry Pi 3 and Zero W (no device wake GPIO
|
||||
connected). So fix this regression by reverting this commit partially.
|
||||
|
||||
Cc: Lukas Wunner <lukas@wunner.de>
|
||||
Fixes: 3e81a4ca51a1 ("Bluetooth: hci_bcm: Mandate presence of shutdown and device wake GPIO")
|
||||
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
---
|
||||
drivers/bluetooth/hci_bcm.c | 8 +++++---
|
||||
1 file changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/bluetooth/hci_bcm.c b/drivers/bluetooth/hci_bcm.c
|
||||
index 0438a64..f8728eb 100644
|
||||
--- a/drivers/bluetooth/hci_bcm.c
|
||||
+++ b/drivers/bluetooth/hci_bcm.c
|
||||
@@ -922,12 +922,14 @@ static int bcm_get_resources(struct bcm_device *dev)
|
||||
|
||||
dev->clk = devm_clk_get(dev->dev, NULL);
|
||||
|
||||
- dev->device_wakeup = devm_gpiod_get(dev->dev, "device-wakeup",
|
||||
- GPIOD_OUT_LOW);
|
||||
+ dev->device_wakeup = devm_gpiod_get_optional(dev->dev,
|
||||
+ "device-wakeup",
|
||||
+ GPIOD_OUT_LOW);
|
||||
if (IS_ERR(dev->device_wakeup))
|
||||
return PTR_ERR(dev->device_wakeup);
|
||||
|
||||
- dev->shutdown = devm_gpiod_get(dev->dev, "shutdown", GPIOD_OUT_LOW);
|
||||
+ dev->shutdown = devm_gpiod_get_optional(dev->dev, "shutdown",
|
||||
+ GPIOD_OUT_LOW);
|
||||
if (IS_ERR(dev->shutdown))
|
||||
return PTR_ERR(dev->shutdown);
|
||||
|
||||
From patchwork Sun Feb 25 14:10:53 2018
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: [2/4] ARM: dts: bcm283x: Apply pull settings to Zero W relevant groups
|
||||
From: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
X-Patchwork-Id: 10240919
|
||||
Message-Id: <1519567855-26105-3-git-send-email-stefan.wahren@i2se.com>
|
||||
To: Loic Poulain <loic.poulain@gmail.com>,
|
||||
=?UTF-8?q?Fr=C3=A9d=C3=A9ric=20Danis?= <frederic.danis.oss@gmail.com>,
|
||||
Marcel Holtmann <marcel@holtmann.org>,
|
||||
Johan Hedberg <johan.hedberg@gmail.com>, Eric Anholt <eric@anholt.net>,
|
||||
Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
||||
Florian Fainelli <f.fainelli@gmail.com>,
|
||||
Phil Elwell <phil@raspberrypi.org>,
|
||||
linux-bluetooth@vger.kernel.org, Lukas Wunner <lukas@wunner.de>,
|
||||
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
||||
Date: Sun, 25 Feb 2018 15:10:53 +0100
|
||||
|
||||
Instead of keeping the firmware's pull settings, we better apply
|
||||
them via the devicetree pin control. Start with the RPi Zero W relevant
|
||||
first to keep the effort low.
|
||||
|
||||
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
---
|
||||
arch/arm/boot/dts/bcm283x.dtsi | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/bcm283x.dtsi b/arch/arm/boot/dts/bcm283x.dtsi
|
||||
index 8d9a0df..1a50b67 100644
|
||||
--- a/arch/arm/boot/dts/bcm283x.dtsi
|
||||
+++ b/arch/arm/boot/dts/bcm283x.dtsi
|
||||
@@ -223,6 +223,7 @@
|
||||
gpclk2_gpio43: gpclk2_gpio43 {
|
||||
brcm,pins = <43>;
|
||||
brcm,function = <BCM2835_FSEL_ALT0>;
|
||||
+ brcm,pull = <BCM2835_PUD_OFF>;
|
||||
};
|
||||
|
||||
i2c0_gpio0: i2c0_gpio0 {
|
||||
@@ -335,10 +336,12 @@
|
||||
uart0_ctsrts_gpio30: uart0_ctsrts_gpio30 {
|
||||
brcm,pins = <30 31>;
|
||||
brcm,function = <BCM2835_FSEL_ALT3>;
|
||||
+ brcm,pull = <BCM2835_PUD_UP BCM2835_PUD_OFF>;
|
||||
};
|
||||
uart0_gpio32: uart0_gpio32 {
|
||||
brcm,pins = <32 33>;
|
||||
brcm,function = <BCM2835_FSEL_ALT3>;
|
||||
+ brcm,pull = <BCM2835_PUD_OFF BCM2835_PUD_UP>;
|
||||
};
|
||||
uart0_gpio36: uart0_gpio36 {
|
||||
brcm,pins = <36 37>;
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
5d60e057d127538113d8945ea87d916fccee93fe
|
||||
ce380619fab99036f5e745c7a865b21c59f005f6
|
||||
|
11
kernel.spec
11
kernel.spec
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%global rcrev 4
|
||||
# The git snapshot level
|
||||
%define gitrev 0
|
||||
%define gitrev 1
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 4.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -124,7 +124,7 @@ Summary: The Linux kernel
|
||||
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
|
||||
# and 0 for rawhide (all kernels are debug kernels).
|
||||
# See also 'make debug' and 'make release'.
|
||||
%define debugbuildsenabled 1
|
||||
%define debugbuildsenabled 0
|
||||
|
||||
%if %{with_verbose}
|
||||
%define make_opts V=1
|
||||
@ -606,9 +606,6 @@ Patch316: mmc-sdhci-iproc-Disable-preset-values-for-BCM2835.patch
|
||||
# https://www.spinics.net/lists/arm-kernel/msg633945.html
|
||||
Patch317: bcm2835-hwrng-Handle-deferred-clock-properly.patch
|
||||
|
||||
# https://www.spinics.net/lists/linux-bluetooth/msg74414.html
|
||||
Patch318: bcm2835-fix-bluetooth.patch
|
||||
|
||||
# 400 - IBM (ppc/s390x) patches
|
||||
|
||||
# 500 - Temp fixes/CVEs etc
|
||||
@ -1874,6 +1871,10 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Tue Mar 06 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-0.rc4.git1.1
|
||||
- Linux v4.16-rc4-120-gce380619fab9
|
||||
- Re-enable debugging options.
|
||||
|
||||
* Mon Mar 05 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-0.rc4.git0.1
|
||||
- Linux v4.16-rc4
|
||||
- Disable debugging options.
|
||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
||||
SHA512 (linux-4.15.tar.xz) = c00d92659df815a53dcac7dde145b742b1f20867d380c07cb09ddb3295d6ff10f8931b21ef0b09d7156923a3957b39d74d87c883300173b2e20690d2b4ec35ea
|
||||
SHA512 (patch-4.16-rc4.xz) = ac11f79a16a3f48a858206986589fcfe5d6e8c88fffcc690782b708a31f0a4c3ff267c3c09dd1bbe7f467b5555f7d4bb9cf0b2e568eea6fd35ac015972c96254
|
||||
SHA512 (patch-4.16-rc4-git1.xz) = cefbec1b2784fbe21ca568ef17fb2d926c8df451df6567e1cc3f6e97130dbbd54a1d1d71dd032cbf318cf043ac21aa8fcdc699139117d71f7b69984318d4f36b
|
||||
|
Loading…
Reference in New Issue
Block a user