Add bluetooth support for BCM20102A0 21e3 (rhbz 770233)
This commit is contained in:
parent
c679b871a8
commit
54daf00b3e
42
Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch
Normal file
42
Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From c0190925dacd976a67044f4382d4effbed568dce Mon Sep 17 00:00:00 2001
|
||||
From: Jesse Sung <jesse.sung@canonical.com>
|
||||
Date: Thu, 22 Dec 2011 10:48:47 +0800
|
||||
Subject: [PATCH] Bluetooth: Add support for BCM20702A0 [0a5c:21e3]
|
||||
|
||||
Add another vendor specific ID for BCM20702A0.
|
||||
|
||||
output of usb-devices:
|
||||
T: Bus=06 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 4 Spd=12 MxCh= 0
|
||||
D: Ver= 2.00 Cls=ff(vend.) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
|
||||
P: Vendor=0a5c ProdID=21e3 Rev=01.12
|
||||
S: Manufacturer=Broadcom Corp
|
||||
S: Product=BCM20702A0
|
||||
S: SerialNumber=9439E5CBF66C
|
||||
C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=0mA
|
||||
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
|
||||
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
|
||||
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
|
||||
I: If#= 3 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=01 Driver=(none)
|
||||
|
||||
Signed-off-by: Wen-chien Jesse Sung <jesse.sung@canonical.com>
|
||||
Acked-by: Marcel Holtmann <marcel@holtmann.org>
|
||||
Signed-off-by: Gustavo F. Padovan <padovan@profusion.mobi>
|
||||
---
|
||||
drivers/bluetooth/btusb.c | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
|
||||
index a67c6db..fbfba80 100644
|
||||
--- a/drivers/bluetooth/btusb.c
|
||||
+++ b/drivers/bluetooth/btusb.c
|
||||
@@ -101,6 +101,7 @@ static struct usb_device_id btusb_table[] = {
|
||||
{ USB_DEVICE(0x0c10, 0x0000) },
|
||||
|
||||
/* Broadcom BCM20702A0 */
|
||||
+ { USB_DEVICE(0x0a5c, 0x21e3) },
|
||||
{ USB_DEVICE(0x413c, 0x8197) },
|
||||
|
||||
{ } /* Terminating entry */
|
||||
--
|
||||
1.7.6.2
|
||||
|
1
TODO
1
TODO
@ -8,6 +8,7 @@
|
||||
|
||||
**** Queued for 3.3 ***********************************************************************************
|
||||
drm-edid-try-harder-to-fix-up-broken-headers.patch
|
||||
Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch
|
||||
|
||||
**** Other stuff that should go upstream (in decreasing likelyhood) ************************************
|
||||
|
||||
|
11
kernel.spec
11
kernel.spec
@ -54,7 +54,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -748,6 +748,9 @@ Patch21030: alps.patch
|
||||
#rhbz 717735
|
||||
Patch21045: nfs-client-freezer.patch
|
||||
|
||||
#rhbz 770233
|
||||
Patch21065: Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch
|
||||
|
||||
# compat-wireless patches
|
||||
Patch50000: compat-wireless-config-fixups.patch
|
||||
Patch50001: compat-wireless-integrated-build.patch
|
||||
@ -1448,6 +1451,9 @@ ApplyPatch alps.patch
|
||||
#rhbz 717735
|
||||
ApplyPatch nfs-client-freezer.patch
|
||||
|
||||
#rhbz 770233
|
||||
ApplyPatch Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch
|
||||
|
||||
# END OF PATCH APPLICATIONS
|
||||
|
||||
%endif
|
||||
@ -2280,6 +2286,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Jan 03 2012 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add bluetooth support for BCM20102A0 21e3 (rhbz 770233)
|
||||
|
||||
* Tue Jan 03 2012 John W. Linville <linville@redhat.com>
|
||||
- Re-enable CONFIG_RT2800PCI_RT53XX in compat-wireless build (rhbz #720594)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user