Linux v5.2-rc6
This commit is contained in:
parent
6acb9747bd
commit
53459f7b69
@ -1,54 +0,0 @@
|
||||
From c8f57936ab21a1430ae2209fa874e842d13552d3 Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Cline <jcline@redhat.com>
|
||||
Date: Tue, 11 Jun 2019 14:59:23 +0000
|
||||
Subject: [PATCH] Revert "Bluetooth: Align minimum encryption key size for LE
|
||||
and BR/EDR connections"
|
||||
|
||||
This reverts commit d5bb334a8e171b262e48f378bd2096c0ea458265.
|
||||
|
||||
This patch broke a number of older bluetooth devices and while an RFC
|
||||
that fixes this patch has been posted upstream, it has not been merged
|
||||
and there are still a few folks reporting problems.
|
||||
|
||||
Signed-off-by: Jeremy Cline <jcline@redhat.com>
|
||||
---
|
||||
include/net/bluetooth/hci_core.h | 3 ---
|
||||
net/bluetooth/hci_conn.c | 8 --------
|
||||
2 files changed, 11 deletions(-)
|
||||
|
||||
diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h
|
||||
index 05b1b96f4d9e..094e61e07030 100644
|
||||
--- a/include/net/bluetooth/hci_core.h
|
||||
+++ b/include/net/bluetooth/hci_core.h
|
||||
@@ -190,9 +190,6 @@ struct adv_info {
|
||||
|
||||
#define HCI_MAX_SHORT_NAME_LENGTH 10
|
||||
|
||||
-/* Min encryption key size to match with SMP */
|
||||
-#define HCI_MIN_ENC_KEY_SIZE 7
|
||||
-
|
||||
/* Default LE RPA expiry time, 15 minutes */
|
||||
#define HCI_DEFAULT_RPA_TIMEOUT (15 * 60)
|
||||
|
||||
diff --git a/net/bluetooth/hci_conn.c b/net/bluetooth/hci_conn.c
|
||||
index 3cf0764d5793..bd4978ce8c45 100644
|
||||
--- a/net/bluetooth/hci_conn.c
|
||||
+++ b/net/bluetooth/hci_conn.c
|
||||
@@ -1276,14 +1276,6 @@ int hci_conn_check_link_mode(struct hci_conn *conn)
|
||||
!test_bit(HCI_CONN_ENCRYPT, &conn->flags))
|
||||
return 0;
|
||||
|
||||
- /* The minimum encryption key size needs to be enforced by the
|
||||
- * host stack before establishing any L2CAP connections. The
|
||||
- * specification in theory allows a minimum of 1, but to align
|
||||
- * BR/EDR and LE transports, a minimum of 7 is chosen.
|
||||
- */
|
||||
- if (conn->enc_key_size < HCI_MIN_ENC_KEY_SIZE)
|
||||
- return 0;
|
||||
-
|
||||
return 1;
|
||||
}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
2
gitrev
2
gitrev
@ -1 +1 @@
|
||||
4ae004a9bca8bef118c2b4e76ee31c7df4514f18
|
||||
4b972a01a7da614b4796475f933094751a295a2f
|
||||
|
10
kernel.spec
10
kernel.spec
@ -69,9 +69,9 @@ Summary: The Linux kernel
|
||||
# The next upstream release sublevel (base_sublevel+1)
|
||||
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
|
||||
# The rc snapshot level
|
||||
%global rcrev 5
|
||||
%global rcrev 6
|
||||
# The git snapshot level
|
||||
%define gitrev 4
|
||||
%define gitrev 0
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 5.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -590,9 +590,6 @@ Patch530: crypto-ghash-fix-unaligned-memory-access-in-ghash_setkey.patch
|
||||
# Fix for new Logitech wireless keyboard support in 5.2, submitted upstream
|
||||
Patch534: 0001-HID-logitech-dj-Fix-forwarding-of-very-long-HID-repo.patch
|
||||
|
||||
# Fix for broken bluetooth, reverted in upstream stable, not yet in Torvald's tree
|
||||
Patch535: Revert-Bluetooth-Align-minimum-encryption-key-size.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1831,6 +1828,9 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Mon Jun 24 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.2.0-0.rc6.git0.1
|
||||
- Linux v5.2-rc6
|
||||
|
||||
* Mon Jun 24 2019 Justin M. Forbes <jforbes@fedoraproject.org>
|
||||
- Disable debugging options.
|
||||
|
||||
|
4
sources
4
sources
@ -1,4 +1,2 @@
|
||||
SHA512 (linux-5.1.tar.xz) = ae96f347badc95f1f3acf506c52b6cc23c0bd09ce8f4ce6705d4b4058b62593059bba1bc603c8d8b00a2f19131e7e56c31ac62b45883a346fa61d655e178f236
|
||||
SHA512 (patch-5.2-rc5.xz) = ee7caea50dccd299182da1453ca2a6f3f4947d544da81703e00b7f63e7c99d19975d4a34261282bbce36a8cf08060a60e51c095189a3aa43fdc34b67b05004c7
|
||||
SHA512 (patch-5.2-rc5-git3.xz) = 4fd8ac2caeb6e281ba9694a068c168486dba9e77b0b3b19fb6c8b4067e5ca0a878d9270c26ddcd82cceed5e7f3d7050ddec0e98b0fe0177ba9f7f5703349c76f
|
||||
SHA512 (patch-5.2-rc5-git4.xz) = 39411def747b14e670a71f83ac822ec7721dfe68a87e976882c0e2419c10d783b7b862010a7c273ba6631b43714a865dcd98d1b9886fecd7e935dc3aa0c1b136
|
||||
SHA512 (patch-5.2-rc6.xz) = 61b4c645477810a417fff019fa4c92f58a7914945d653b3c3eba67b467680eea6aea42895d63fc37af4b25dd0c9f30c73778ec02a8e16d1dfa3b38ee5eec7554
|
||||
|
Loading…
Reference in New Issue
Block a user