Linux v3.16-10013-gc309bfa9b481
- Temporarily don't apply crash driver patch
This commit is contained in:
parent
3f7b3ae795
commit
531b0ea5a0
@ -1,111 +0,0 @@
|
|||||||
From: Stephen Warren <swarren@xxxxxxxxxx>
|
|
||||||
|
|
||||||
When tegra-drm.ko is built as a module, these MODULE_DEVICE_TABLEs allow
|
|
||||||
the module to be auto-loaded since the module will match the devices
|
|
||||||
instantiated from device tree.
|
|
||||||
|
|
||||||
(Notes for stable: in 3.14+, just git rm any conflicting file, since they
|
|
||||||
are added in later kernels. For 3.13 and below, manual merging will be
|
|
||||||
needed)
|
|
||||||
|
|
||||||
Cc: <stable@xxxxxxxxxxxxxxx>
|
|
||||||
Signed-off-by: Stephen Warren <swarren@xxxxxxxxxx>
|
|
||||||
---
|
|
||||||
v2: Remove change to drm.c, since the match table there isn't used for
|
|
||||||
probing.
|
|
||||||
---
|
|
||||||
drivers/gpu/drm/tegra/dc.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/dpaux.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/dsi.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/gr2d.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/gr3d.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/hdmi.c | 1 +
|
|
||||||
drivers/gpu/drm/tegra/sor.c | 1 +
|
|
||||||
7 files changed, 7 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/dc.c b/drivers/gpu/drm/tegra/dc.c
|
|
||||||
index ef40381f3909..48c3bc460eef 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/dc.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/dc.c
|
|
||||||
@@ -1303,6 +1303,7 @@ static const struct of_device_id tegra_dc_of_match[] = {
|
|
||||||
/* sentinel */
|
|
||||||
}
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_dc_of_match);
|
|
||||||
|
|
||||||
static int tegra_dc_parse_dt(struct tegra_dc *dc)
|
|
||||||
{
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/dpaux.c b/drivers/gpu/drm/tegra/dpaux.c
|
|
||||||
index 3f132e356e9c..708f783ead47 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/dpaux.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/dpaux.c
|
|
||||||
@@ -382,6 +382,7 @@ static const struct of_device_id tegra_dpaux_of_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra124-dpaux", },
|
|
||||||
{ },
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_dpaux_of_match);
|
|
||||||
|
|
||||||
struct platform_driver tegra_dpaux_driver = {
|
|
||||||
.driver = {
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/dsi.c b/drivers/gpu/drm/tegra/dsi.c
|
|
||||||
index bd56f2affa78..97c409f10456 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/dsi.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/dsi.c
|
|
||||||
@@ -982,6 +982,7 @@ static const struct of_device_id tegra_dsi_of_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra114-dsi", },
|
|
||||||
{ },
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_dsi_of_match);
|
|
||||||
|
|
||||||
struct platform_driver tegra_dsi_driver = {
|
|
||||||
.driver = {
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/gr2d.c b/drivers/gpu/drm/tegra/gr2d.c
|
|
||||||
index 7c53941f2a9e..02cd3e37a6ec 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/gr2d.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/gr2d.c
|
|
||||||
@@ -121,6 +121,7 @@ static const struct of_device_id gr2d_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra20-gr2d" },
|
|
||||||
{ },
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, gr2d_match);
|
|
||||||
|
|
||||||
static const u32 gr2d_addr_regs[] = {
|
|
||||||
GR2D_UA_BASE_ADDR,
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/gr3d.c b/drivers/gpu/drm/tegra/gr3d.c
|
|
||||||
index 30f5ba9bd6d0..2bea2b2d204e 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/gr3d.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/gr3d.c
|
|
||||||
@@ -130,6 +130,7 @@ static const struct of_device_id tegra_gr3d_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra20-gr3d" },
|
|
||||||
{ }
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_gr3d_match);
|
|
||||||
|
|
||||||
static const u32 gr3d_addr_regs[] = {
|
|
||||||
GR3D_IDX_ATTRIBUTE( 0),
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/hdmi.c b/drivers/gpu/drm/tegra/hdmi.c
|
|
||||||
index a0b8d8539d07..84ea0c8b47f7 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/hdmi.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/hdmi.c
|
|
||||||
@@ -1370,6 +1370,7 @@ static const struct of_device_id tegra_hdmi_of_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra20-hdmi", .data = &tegra20_hdmi_config },
|
|
||||||
{ },
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_hdmi_of_match);
|
|
||||||
|
|
||||||
static int tegra_hdmi_probe(struct platform_device *pdev)
|
|
||||||
{
|
|
||||||
diff --git a/drivers/gpu/drm/tegra/sor.c b/drivers/gpu/drm/tegra/sor.c
|
|
||||||
index 27c979b50111..061a5c501124 100644
|
|
||||||
--- a/drivers/gpu/drm/tegra/sor.c
|
|
||||||
+++ b/drivers/gpu/drm/tegra/sor.c
|
|
||||||
@@ -1455,6 +1455,7 @@ static const struct of_device_id tegra_sor_of_match[] = {
|
|
||||||
{ .compatible = "nvidia,tegra124-sor", },
|
|
||||||
{ },
|
|
||||||
};
|
|
||||||
+MODULE_DEVICE_TABLE(of, tegra_sor_of_match);
|
|
||||||
|
|
||||||
struct platform_driver tegra_sor_driver = {
|
|
||||||
.driver = {
|
|
||||||
--
|
|
||||||
1.8.1.5
|
|
@ -143,6 +143,9 @@ CONFIG_I2C_MUX_PINCTRL=m
|
|||||||
CONFIG_I2C_MUX_PCA9541=m
|
CONFIG_I2C_MUX_PCA9541=m
|
||||||
CONFIG_I2C_MUX_PCA954x=m
|
CONFIG_I2C_MUX_PCA954x=m
|
||||||
|
|
||||||
|
# bus
|
||||||
|
# CONFIG_ARM_CCN is not set
|
||||||
|
|
||||||
# Sensors
|
# Sensors
|
||||||
CONFIG_SENSORS_IIO_HWMON=m
|
CONFIG_SENSORS_IIO_HWMON=m
|
||||||
CONFIG_IIO_SYSFS_TRIGGER=m
|
CONFIG_IIO_SYSFS_TRIGGER=m
|
||||||
|
@ -68,6 +68,7 @@ CONFIG_SND_KIRKWOOD_SOC_ARMADA370_DB=m
|
|||||||
CONFIG_USB_EHCI_HCD_ORION=m
|
CONFIG_USB_EHCI_HCD_ORION=m
|
||||||
CONFIG_MMC_SDHCI_PXAV3=m
|
CONFIG_MMC_SDHCI_PXAV3=m
|
||||||
CONFIG_MVPP2=m
|
CONFIG_MVPP2=m
|
||||||
|
# CONFIG_ARM_MVEBU_V7_CPUIDLE is not set
|
||||||
# CONFIG_CACHE_FEROCEON_L2 is not set
|
# CONFIG_CACHE_FEROCEON_L2 is not set
|
||||||
# CONFIG_CACHE_FEROCEON_L2_WRITETHROUGH is not set
|
# CONFIG_CACHE_FEROCEON_L2_WRITETHROUGH is not set
|
||||||
|
|
||||||
@ -216,6 +217,7 @@ CONFIG_PWM_TIECAP=m
|
|||||||
CONFIG_PWM_TIEHRPWM=m
|
CONFIG_PWM_TIEHRPWM=m
|
||||||
CONFIG_PWM_TWL=m
|
CONFIG_PWM_TWL=m
|
||||||
CONFIG_PWM_TWL_LED=m
|
CONFIG_PWM_TWL_LED=m
|
||||||
|
CONFIG_PWM_ROCKCHIP=m
|
||||||
|
|
||||||
CONFIG_CRYPTO_DEV_OMAP_SHAM=m
|
CONFIG_CRYPTO_DEV_OMAP_SHAM=m
|
||||||
CONFIG_CRYPTO_DEV_OMAP_AES=m
|
CONFIG_CRYPTO_DEV_OMAP_AES=m
|
||||||
@ -383,6 +385,7 @@ CONFIG_USB_EHCI_MSM=m
|
|||||||
CONFIG_MXC_IRQ_PRIOR=y
|
CONFIG_MXC_IRQ_PRIOR=y
|
||||||
# CONFIG_MXC_DEBUG_BOARD is not set
|
# CONFIG_MXC_DEBUG_BOARD is not set
|
||||||
CONFIG_SOC_IMX50=y
|
CONFIG_SOC_IMX50=y
|
||||||
|
# CONFIG_SOC_IMX51 is not set
|
||||||
CONFIG_SOC_IMX53=y
|
CONFIG_SOC_IMX53=y
|
||||||
CONFIG_SOC_IMX6Q=y
|
CONFIG_SOC_IMX6Q=y
|
||||||
CONFIG_SOC_IMX6SL=y
|
CONFIG_SOC_IMX6SL=y
|
||||||
|
@ -68,6 +68,9 @@ CONFIG_ARCH_VEXPRESS_CORTEX_A5_A9_ERRATA=y
|
|||||||
# CONFIG_ARCH_U8500 is not set
|
# CONFIG_ARCH_U8500 is not set
|
||||||
# CONFIG_ARCH_VEXPRESS_SPC is not set
|
# CONFIG_ARCH_VEXPRESS_SPC is not set
|
||||||
# CONFIG_ARCH_WM8850 is not set
|
# CONFIG_ARCH_WM8850 is not set
|
||||||
|
# CONFIG_ARCH_HISI is not set
|
||||||
|
# CONFIG_ARCH_MEDIATEK is not set
|
||||||
|
# CONFIG_ARCH_S5PV210 is not set
|
||||||
|
|
||||||
# errata
|
# errata
|
||||||
# v5/v6
|
# v5/v6
|
||||||
@ -162,6 +165,7 @@ CONFIG_MACH_SUN4I=y
|
|||||||
CONFIG_MACH_SUN5I=y
|
CONFIG_MACH_SUN5I=y
|
||||||
CONFIG_MACH_SUN6I=y
|
CONFIG_MACH_SUN6I=y
|
||||||
CONFIG_MACH_SUN7I=y
|
CONFIG_MACH_SUN7I=y
|
||||||
|
# CONFIG_MACH_SUN8I is not set
|
||||||
CONFIG_PINCTRL_SUNXI=y
|
CONFIG_PINCTRL_SUNXI=y
|
||||||
CONFIG_SUNXI_WATCHDOG=m
|
CONFIG_SUNXI_WATCHDOG=m
|
||||||
CONFIG_MDIO_SUN4I=m
|
CONFIG_MDIO_SUN4I=m
|
||||||
@ -391,6 +395,7 @@ CONFIG_GENERIC_PINCONF=y
|
|||||||
# CONFIG_PINCTRL_BCM281XX is not set
|
# CONFIG_PINCTRL_BCM281XX is not set
|
||||||
# CONFIG_PINCTRL_APQ8064 is not set
|
# CONFIG_PINCTRL_APQ8064 is not set
|
||||||
# CONFIG_PINCTRL_IPQ8064 is not set
|
# CONFIG_PINCTRL_IPQ8064 is not set
|
||||||
|
# CONFIG_PINCTRL_MSM8960 is not set
|
||||||
|
|
||||||
# GPIO
|
# GPIO
|
||||||
# CONFIG_GPIO_EM is not set
|
# CONFIG_GPIO_EM is not set
|
||||||
@ -402,6 +407,7 @@ CONFIG_GPIO_MC33880=m
|
|||||||
CONFIG_GPIO_TPS65910=y
|
CONFIG_GPIO_TPS65910=y
|
||||||
CONFIG_GPIO_TPS65912=m
|
CONFIG_GPIO_TPS65912=m
|
||||||
# CONFIG_GPIO_ZEVIO is not set
|
# CONFIG_GPIO_ZEVIO is not set
|
||||||
|
# CONFIG_GPIO_ZYNQ is not set
|
||||||
CONFIG_LEDS_GPIO=m
|
CONFIG_LEDS_GPIO=m
|
||||||
CONFIG_MDIO_BUS_MUX=m
|
CONFIG_MDIO_BUS_MUX=m
|
||||||
CONFIG_MDIO_BUS_MUX_GPIO=m
|
CONFIG_MDIO_BUS_MUX_GPIO=m
|
||||||
@ -754,6 +760,7 @@ CONFIG_BPF_JIT=y
|
|||||||
# HW Enabled in armv7 not lpae
|
# HW Enabled in armv7 not lpae
|
||||||
# CONFIG_DRM_TILCDC is not set
|
# CONFIG_DRM_TILCDC is not set
|
||||||
# CONFIG_DRM_IMX is not set
|
# CONFIG_DRM_IMX is not set
|
||||||
|
# CONFIG_DRM_STI is not set
|
||||||
# CONFIG_AHCI_IMX is not set
|
# CONFIG_AHCI_IMX is not set
|
||||||
# CONFIG_IMX_THERMAL is not set
|
# CONFIG_IMX_THERMAL is not set
|
||||||
# CONFIG_TI_DAC7512 is not set
|
# CONFIG_TI_DAC7512 is not set
|
||||||
|
@ -2158,6 +2158,7 @@ CONFIG_TABLET_USB_GTCO=m
|
|||||||
CONFIG_TABLET_USB_HANWANG=m
|
CONFIG_TABLET_USB_HANWANG=m
|
||||||
CONFIG_TABLET_USB_KBTAB=m
|
CONFIG_TABLET_USB_KBTAB=m
|
||||||
CONFIG_TABLET_USB_WACOM=m
|
CONFIG_TABLET_USB_WACOM=m
|
||||||
|
CONFIG_TABLET_SERIAL_WACOM4=m
|
||||||
|
|
||||||
CONFIG_INPUT_POWERMATE=m
|
CONFIG_INPUT_POWERMATE=m
|
||||||
CONFIG_INPUT_YEALINK=m
|
CONFIG_INPUT_YEALINK=m
|
||||||
@ -2220,6 +2221,7 @@ CONFIG_KEYBOARD_ATKBD=y
|
|||||||
# CONFIG_KEYBOARD_TCA6416 is not set
|
# CONFIG_KEYBOARD_TCA6416 is not set
|
||||||
# CONFIG_KEYBOARD_TCA8418 is not set
|
# CONFIG_KEYBOARD_TCA8418 is not set
|
||||||
# CONFIG_KEYBOARD_OMAP4 is not set
|
# CONFIG_KEYBOARD_OMAP4 is not set
|
||||||
|
# CONFIG_KEYBOARD_CAP1106 is not set
|
||||||
CONFIG_INPUT_MOUSE=y
|
CONFIG_INPUT_MOUSE=y
|
||||||
CONFIG_MOUSE_PS2=y
|
CONFIG_MOUSE_PS2=y
|
||||||
# CONFIG_MOUSE_PS2_TOUCHKIT is not set
|
# CONFIG_MOUSE_PS2_TOUCHKIT is not set
|
||||||
@ -2961,6 +2963,7 @@ CONFIG_RTC_DRV_DS1343=m
|
|||||||
CONFIG_RTC_DRV_DS1305=m
|
CONFIG_RTC_DRV_DS1305=m
|
||||||
CONFIG_RTC_DRV_M41T94=m
|
CONFIG_RTC_DRV_M41T94=m
|
||||||
CONFIG_RTC_DRV_M41T93=m
|
CONFIG_RTC_DRV_M41T93=m
|
||||||
|
CONFIG_RTC_DRV_PCF85063=m
|
||||||
# CONFIG_RTC_DRV_HID_SENSOR_TIME is not set
|
# CONFIG_RTC_DRV_HID_SENSOR_TIME is not set
|
||||||
# CONFIG_RTC_DRV_MOXART is not set
|
# CONFIG_RTC_DRV_MOXART is not set
|
||||||
# CONFIG_RTC_DRV_ISL12057 is not set
|
# CONFIG_RTC_DRV_ISL12057 is not set
|
||||||
@ -3746,6 +3749,7 @@ CONFIG_HID_ROCCAT_KOVAPLUS=m
|
|||||||
CONFIG_HID_HOLTEK=m
|
CONFIG_HID_HOLTEK=m
|
||||||
CONFIG_HOLTEK_FF=y
|
CONFIG_HOLTEK_FF=y
|
||||||
CONFIG_HID_HUION=m
|
CONFIG_HID_HUION=m
|
||||||
|
CONFIG_HID_GT683R=m
|
||||||
CONFIG_HID_SPEEDLINK=m
|
CONFIG_HID_SPEEDLINK=m
|
||||||
CONFIG_HID_WIIMOTE=m
|
CONFIG_HID_WIIMOTE=m
|
||||||
CONFIG_HID_WIIMOTE_EXT=y
|
CONFIG_HID_WIIMOTE_EXT=y
|
||||||
@ -3986,6 +3990,8 @@ CONFIG_USB_PHY=y
|
|||||||
# CONFIG_GENERIC_PHY is not set
|
# CONFIG_GENERIC_PHY is not set
|
||||||
# CONFIG_PHY_EXYNOS_MIPI_VIDEO is not set
|
# CONFIG_PHY_EXYNOS_MIPI_VIDEO is not set
|
||||||
# CONFIG_PHY_EXYNOS_DP_VIDEO is not set
|
# CONFIG_PHY_EXYNOS_DP_VIDEO is not set
|
||||||
|
# CONFIG_PHY_ST_SPEAR1310_MIPHY is not set
|
||||||
|
# CONFIG_PHY_ST_SPEAR1340_MIPHY is not set
|
||||||
# CONFIG_AM335X_PHY_USB is not set
|
# CONFIG_AM335X_PHY_USB is not set
|
||||||
# CONFIG_SAMSUNG_USBPHY is not set
|
# CONFIG_SAMSUNG_USBPHY is not set
|
||||||
# CONFIG_SAMSUNG_USB2PHY is not set
|
# CONFIG_SAMSUNG_USB2PHY is not set
|
||||||
@ -4122,6 +4128,7 @@ CONFIG_MFD_VIPERBOARD=m
|
|||||||
# CONFIG_MFD_MC13XXX_SPI is not set
|
# CONFIG_MFD_MC13XXX_SPI is not set
|
||||||
# CONFIG_MFD_DA9052_SPI is not set
|
# CONFIG_MFD_DA9052_SPI is not set
|
||||||
# CONFIG_EZX_PCAP is not set
|
# CONFIG_EZX_PCAP is not set
|
||||||
|
# CONFIG_INTEL_SOC_PMIC is not set
|
||||||
|
|
||||||
|
|
||||||
#
|
#
|
||||||
|
@ -481,6 +481,8 @@ CONFIG_MODULE_SIG_SHA256=y
|
|||||||
CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE=y
|
CONFIG_EFI_SECURE_BOOT_SIG_ENFORCE=y
|
||||||
CONFIG_EFI_SIGNATURE_LIST_PARSER=y
|
CONFIG_EFI_SIGNATURE_LIST_PARSER=y
|
||||||
|
|
||||||
|
# CONFIG_KEXEC_VERIFY_SIG is not set
|
||||||
|
|
||||||
CONFIG_MODULE_SIG_UEFI=y
|
CONFIG_MODULE_SIG_UEFI=y
|
||||||
|
|
||||||
CONFIG_VMXNET3=m
|
CONFIG_VMXNET3=m
|
||||||
|
19
kernel.spec
19
kernel.spec
@ -8,7 +8,7 @@ Summary: The Linux kernel
|
|||||||
# be 0.
|
# be 0.
|
||||||
%global released_kernel 0
|
%global released_kernel 0
|
||||||
|
|
||||||
%global aarch64patches 1
|
%global aarch64patches 0
|
||||||
|
|
||||||
# Sign modules on x86. Make sure the config files match this setting if more
|
# Sign modules on x86. Make sure the config files match this setting if more
|
||||||
# architectures are added.
|
# architectures are added.
|
||||||
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -565,7 +565,7 @@ Patch600: 0001-lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
|||||||
#rhbz 917708
|
#rhbz 917708
|
||||||
Patch700: Revert-userns-Allow-unprivileged-users-to-create-use.patch
|
Patch700: Revert-userns-Allow-unprivileged-users-to-create-use.patch
|
||||||
|
|
||||||
Patch800: crash-driver.patch
|
# atch800: crash-driver.patch
|
||||||
|
|
||||||
# crypto/
|
# crypto/
|
||||||
|
|
||||||
@ -604,8 +604,6 @@ Patch15000: nowatchdog-on-virt.patch
|
|||||||
Patch21020: arm-tegra-usb-no-reset-linux33.patch
|
Patch21020: arm-tegra-usb-no-reset-linux33.patch
|
||||||
Patch21021: arm-beagle.patch
|
Patch21021: arm-beagle.patch
|
||||||
Patch21022: arm-imx6-utilite.patch
|
Patch21022: arm-imx6-utilite.patch
|
||||||
# http://www.spinics.net/lists/linux-tegra/msg17948.html
|
|
||||||
Patch21023: arm-tegra-drmdetection.patch
|
|
||||||
|
|
||||||
#rhbz 754518
|
#rhbz 754518
|
||||||
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
|
||||||
@ -635,8 +633,6 @@ Patch26005: eeepc-wmi-Add-no-backlight-quirk-for-Asus-H87I-PLUS-.patch
|
|||||||
Patch26013: acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
|
Patch26013: acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
|
||||||
Patch26014: acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
|
Patch26014: acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
|
||||||
|
|
||||||
Patch25109: revert-input-wacom-testing-result-shows-get_report-is-unnecessary.patch
|
|
||||||
|
|
||||||
#rhbz 1021036, submitted upstream
|
#rhbz 1021036, submitted upstream
|
||||||
Patch25110: 0001-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
Patch25110: 0001-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
||||||
|
|
||||||
@ -1238,7 +1234,6 @@ ApplyPatch 0001-lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
|
|||||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
ApplyPatch arm-beagle.patch
|
ApplyPatch arm-beagle.patch
|
||||||
ApplyPatch arm-imx6-utilite.patch
|
ApplyPatch arm-imx6-utilite.patch
|
||||||
ApplyPatch arm-tegra-drmdetection.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# bugfixes to drivers and filesystems
|
# bugfixes to drivers and filesystems
|
||||||
@ -1300,7 +1295,7 @@ ApplyPatch silence-fbcon-logo.patch
|
|||||||
ApplyPatch Revert-userns-Allow-unprivileged-users-to-create-use.patch
|
ApplyPatch Revert-userns-Allow-unprivileged-users-to-create-use.patch
|
||||||
|
|
||||||
# /dev/crash driver.
|
# /dev/crash driver.
|
||||||
ApplyPatch crash-driver.patch
|
# pplyPatch crash-driver.patch
|
||||||
|
|
||||||
# crypto/
|
# crypto/
|
||||||
|
|
||||||
@ -1360,8 +1355,6 @@ ApplyPatch eeepc-wmi-Add-no-backlight-quirk-for-Asus-H87I-PLUS-.patch
|
|||||||
ApplyPatch acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
|
ApplyPatch acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
|
||||||
ApplyPatch acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
|
ApplyPatch acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
|
||||||
|
|
||||||
ApplyPatch revert-input-wacom-testing-result-shows-get_report-is-unnecessary.patch
|
|
||||||
|
|
||||||
#rhbz 1021036, submitted upstream
|
#rhbz 1021036, submitted upstream
|
||||||
ApplyPatch 0001-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
ApplyPatch 0001-ideapad-laptop-Change-Lenovo-Yoga-2-series-rfkill-ha.patch
|
||||||
|
|
||||||
@ -2247,6 +2240,10 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Aug 09 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.17.0-0.rc0.git3.1
|
||||||
|
- Linux v3.16-10013-gc309bfa9b481
|
||||||
|
- Temporarily don't apply crash driver patch
|
||||||
|
|
||||||
* Thu Aug 07 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.17.0-0.rc0.git2.1
|
* Thu Aug 07 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.17.0-0.rc0.git2.1
|
||||||
- Linux v3.16-7503-g33caee39925b
|
- Linux v3.16-7503-g33caee39925b
|
||||||
|
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
Bugzilla: N/A
|
|
||||||
Upstream-status: Sent upstream
|
|
||||||
|
|
||||||
This reverts commit 1b2faaf7e219fc2905d75afcd4c815e5d39eda80.
|
|
||||||
|
|
||||||
The Intuos4 series presents a bug in which it hangs if it receives
|
|
||||||
a set feature command while switching to the enhanced mode.
|
|
||||||
This bug is triggered when plugging an Intuos 4 while having
|
|
||||||
a gnome user session up and running.
|
|
||||||
|
|
||||||
Signed-off-by: Benjamin Tissoires <benjamin.tissoires@xxxxxxxxxx>
|
|
||||||
---
|
|
||||||
|
|
||||||
Hi Aris,
|
|
||||||
|
|
||||||
actually, you bisected the bug, so can I consider that I have your signed-off-by?
|
|
||||||
|
|
||||||
Cheers,
|
|
||||||
Benjamin
|
|
||||||
|
|
||||||
drivers/input/tablet/wacom_sys.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/drivers/input/tablet/wacom_sys.c b/drivers/input/tablet/wacom_sys.c
|
|
||||||
index 7087b33..319a3ff 100644
|
|
||||||
--- a/drivers/input/tablet/wacom_sys.c
|
|
||||||
+++ b/drivers/input/tablet/wacom_sys.c
|
|
||||||
@@ -536,6 +536,9 @@ static int wacom_set_device_mode(struct usb_interface *intf, int report_id, int
|
|
||||||
|
|
||||||
error = wacom_set_report(intf, WAC_HID_FEATURE_REPORT,
|
|
||||||
report_id, rep_data, length, 1);
|
|
||||||
+ if (error >= 0)
|
|
||||||
+ error = wacom_get_report(intf, WAC_HID_FEATURE_REPORT,
|
|
||||||
+ report_id, rep_data, length, 1);
|
|
||||||
} while ((error < 0 || rep_data[1] != mode) && limit++ < WAC_MSG_RETRIES);
|
|
||||||
|
|
||||||
kfree(rep_data);
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
5c569ed649a0c9711879f333e90c5386 linux-3.16.tar.xz
|
5c569ed649a0c9711879f333e90c5386 linux-3.16.tar.xz
|
||||||
49868ce6467b35cd9ffea1120d129462 perf-man-3.16.tar.gz
|
49868ce6467b35cd9ffea1120d129462 perf-man-3.16.tar.gz
|
||||||
817f313f183e084650d605c4b178df38 patch-3.16-git2.xz
|
bf53e84f3e00b9f1fc6e3ca350bd8b12 patch-3.16-git3.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user