Linux v3.10-9289-g9903883
This commit is contained in:
parent
73e4f49352
commit
5265f6cee2
@ -621,6 +621,7 @@ CONFIG_DM_MULTIPATH_ST=m
|
||||
CONFIG_DM_RAID=m
|
||||
CONFIG_DM_FLAKEY=m
|
||||
CONFIG_DM_VERITY=m
|
||||
CONFIG_DM_SWITCH=m
|
||||
|
||||
#
|
||||
# Fusion MPT device support
|
||||
|
@ -447,6 +447,7 @@ CONFIG_NFC_MICROREAD_MEI=m
|
||||
# CONFIG_X86_INTEL_LPSS is not set
|
||||
|
||||
# CONFIG_INTEL_POWERCLAMP is not set
|
||||
CONFIG_X86_PKG_TEMP_THERMAL=m
|
||||
|
||||
CONFIG_VMWARE_VMCI=m
|
||||
CONFIG_VMWARE_VMCI_VSOCKETS=m
|
||||
|
10
kernel.spec
10
kernel.spec
@ -62,7 +62,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be appended after the rcX and
|
||||
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
|
||||
#
|
||||
%global baserelease 3
|
||||
%global baserelease 1
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 0
|
||||
# The git snapshot level
|
||||
%define gitrev 6
|
||||
%define gitrev 7
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -722,8 +722,6 @@ Patch15000: nowatchdog-on-virt.patch
|
||||
Patch21001: arm-lpae-ax88796.patch
|
||||
Patch21002: drm-exynos-fix-multiple-definition-build-error.patch
|
||||
|
||||
Patch21003: v2-thermal-cpu_cooling-fix-stub-function.patch
|
||||
|
||||
# ARM omap
|
||||
Patch21004: arm-omap-load-tfp410.patch
|
||||
|
||||
@ -1325,7 +1323,6 @@ ApplyPatch debug-bad-pte-modules.patch
|
||||
ApplyPatch arm-lpae-ax88796.patch
|
||||
ApplyPatch drm-exynos-fix-multiple-definition-build-error.patch
|
||||
ApplyPatch arm-omap-load-tfp410.patch
|
||||
ApplyPatch v2-thermal-cpu_cooling-fix-stub-function.patch
|
||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||
#ApplyPatch arm-wandboard-quad.patch
|
||||
#
|
||||
@ -2264,6 +2261,9 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Fri Jul 12 2013 Justin M. Forbes <jforbes@redhat.com> - 3.11.0-0.rc0.git7.1
|
||||
- Linux v3.10-9289-g9903883
|
||||
|
||||
* Fri Jul 12 2013 Dave Jones <davej@redhat.com> - 3.11.0-0.rc0.git6.4
|
||||
- Disable LATENCYTOP/SCHEDSTATS in non-debug builds.
|
||||
|
||||
|
1
sources
1
sources
@ -1,3 +1,4 @@
|
||||
4f25cd5bec5f8d5a7d935b3f2ccb8481 linux-3.10.tar.xz
|
||||
bafe9ce838f3bc7e98307fdbb21e714b patch-3.10-git3.xz
|
||||
a60aff8b30dcfe4942586d4115582dbd patch-3.10-git6.xz
|
||||
e3d424be689787fecacd0580601a1695 patch-3.10-git7.xz
|
||||
|
@ -1,22 +0,0 @@
|
||||
diff --git a/include/linux/cpu_cooling.h b/include/linux/cpu_cooling.h
|
||||
index 282e270..a5d52ee 100644
|
||||
--- a/include/linux/cpu_cooling.h
|
||||
+++ b/include/linux/cpu_cooling.h
|
||||
@@ -41,7 +41,7 @@ cpufreq_cooling_register(const struct cpumask *clip_cpus);
|
||||
*/
|
||||
void cpufreq_cooling_unregister(struct thermal_cooling_device *cdev);
|
||||
|
||||
-unsigned long cpufreq_cooling_get_level(unsigned int, unsigned int);
|
||||
+unsigned long cpufreq_cooling_get_level(unsigned int cpu, unsigned int freq);
|
||||
#else /* !CONFIG_CPU_THERMAL */
|
||||
static inline struct thermal_cooling_device *
|
||||
cpufreq_cooling_register(const struct cpumask *clip_cpus)
|
||||
@@ -54,7 +54,7 @@ void cpufreq_cooling_unregister(struct thermal_cooling_device *cdev)
|
||||
return;
|
||||
}
|
||||
static inline
|
||||
-unsigned long cpufreq_cooling_get_level(unsigned int, unsigned int)
|
||||
+unsigned long cpufreq_cooling_get_level(unsigned int cpu, unsigned int freq)
|
||||
{
|
||||
return THERMAL_CSTATE_INVALID;
|
||||
}
|
Loading…
Reference in New Issue
Block a user