Linux v3.12-rc3-186-gc31eeac
- Enable options for Intel Low Power Subsystem Support
This commit is contained in:
parent
c1a9286ef7
commit
51a9efc4b6
@ -1,6 +1,5 @@
|
||||
CONFIG_KUSER_HELPERS=y
|
||||
# CONFIG_ASYMMETRIC_KEY_TYPE is not set
|
||||
# CONFIG_COMMON_CLK_DEBUG is not set
|
||||
CONFIG_COMMON_CLK=y
|
||||
CONFIG_EARLY_PRINTK=y
|
||||
CONFIG_FB_SSD1307=m
|
||||
@ -78,7 +77,6 @@ CONFIG_GPIOLIB=y
|
||||
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
|
||||
CONFIG_MDIO_GPIO=m
|
||||
CONFIG_POWER_RESET_GPIO=y
|
||||
CONFIG_RFKILL_GPIO=m
|
||||
|
||||
# MFD
|
||||
CONFIG_MFD_CORE=m
|
||||
@ -96,7 +94,4 @@ CONFIG_SMC911X=m
|
||||
# CONFIG_I2C_NOMADIK is not set
|
||||
# CONFIG_IRQ_DOMAIN_DEBUG is not set
|
||||
# CONFIG_LEDS_RENESAS_TPU is not set
|
||||
# CONFIG_MMC_SDHCI_PXAV2 is not set
|
||||
# CONFIG_MMC_SDHCI_PXAV3 is not set
|
||||
# CONFIG_COMMON_CLK_SI5351 is not set
|
||||
# CONFIG_LOCK_STAT is not set
|
||||
|
@ -145,6 +145,9 @@ CONFIG_MMC_RICOH_MMC=y
|
||||
CONFIG_MMC_USHC=m
|
||||
CONFIG_MMC_REALTEK_PCI=m
|
||||
CONFIG_MMC_VUB300=m
|
||||
# CONFIG_MMC_SDHCI_PXAV2 is not set
|
||||
# CONFIG_MMC_SDHCI_PXAV3 is not set
|
||||
|
||||
|
||||
CONFIG_CB710_CORE=m
|
||||
# CONFIG_CB710_DEBUG is not set
|
||||
@ -191,6 +194,9 @@ CONFIG_BINFMT_MISC=m
|
||||
# Device Drivers
|
||||
#
|
||||
|
||||
# CONFIG_COMMON_CLK_DEBUG is not set
|
||||
# CONFIG_COMMON_CLK_SI5351 is not set
|
||||
|
||||
#
|
||||
# Generic Driver Options
|
||||
#
|
||||
@ -1235,6 +1241,7 @@ CONFIG_L2TP_ETH=m
|
||||
# CONFIG_CAIF is not set
|
||||
|
||||
CONFIG_RFKILL=m
|
||||
CONFIG_RFKILL_GPIO=m
|
||||
CONFIG_RFKILL_INPUT=y
|
||||
|
||||
CONFIG_ETHERNET=y
|
||||
@ -2556,6 +2563,8 @@ CONFIG_W83697UG_WDT=m
|
||||
CONFIG_HW_RANDOM=y
|
||||
CONFIG_HW_RANDOM_TIMERIOMEM=m
|
||||
CONFIG_HW_RANDOM_TPM=m
|
||||
# CONFIG_HW_RANDOM_ATMEL is not set
|
||||
# CONFIG_HW_RANDOM_EXYNOS is not set
|
||||
# CONFIG_NVRAM is not set
|
||||
# CONFIG_RTC is not set
|
||||
# CONFIG_RTC_DEBUG is not set
|
||||
@ -4604,6 +4613,9 @@ CONFIG_OPTIMIZE_INLINING=y
|
||||
|
||||
# CONFIG_GPIOLIB is not set
|
||||
# CONFIG_PINCTRL is not set
|
||||
# CONFIG_DEBUG_PINCTRL is not set
|
||||
# CONFIG_PINMUX is not set
|
||||
# CONFIG_PINCONF is not set
|
||||
|
||||
CONFIG_NET_DSA=m
|
||||
CONFIG_NET_DSA_MV88E6060=m
|
||||
|
@ -331,8 +331,6 @@ CONFIG_I2C_MPC=m
|
||||
# CONFIG_IMA is not set
|
||||
# CONFIG_TCG_TPM is not set
|
||||
|
||||
CONFIG_RFKILL_GPIO=m
|
||||
|
||||
# CONFIG_CRYPTO_DEV_FSL_CAAM is not set
|
||||
# CONFIG_CRYPTO_SHA1_PPC is not set
|
||||
|
||||
|
@ -230,3 +230,4 @@ CONFIG_BACKLIGHT_PWM=m
|
||||
# CONFIG_OF_VIDEOMODE is not set
|
||||
|
||||
# CONFIG_MLX5_INFINIBAND is not set
|
||||
# CONFIG_PINCTRL_SINGLE is not set
|
||||
|
@ -147,6 +147,8 @@ CONFIG_I2C_PIIX4=m
|
||||
CONFIG_I2C_SIS96X=m
|
||||
CONFIG_I2C_VIA=m
|
||||
CONFIG_I2C_VIAPRO=m
|
||||
CONFIG_I2C_DESIGNWARE_CORE=m
|
||||
CONFIG_I2C_DESIGNWARE_PLATFORM=m
|
||||
|
||||
#rhbz 997149
|
||||
# CONFIG_DELL_RBU is not set
|
||||
@ -434,7 +436,9 @@ CONFIG_NFC_MICROREAD_MEI=m
|
||||
# Maybe enable in debug kernels?
|
||||
# CONFIG_DEBUG_NMI_SELFTEST is not set
|
||||
|
||||
# CONFIG_X86_INTEL_LPSS is not set
|
||||
CONFIG_X86_INTEL_LPSS=y
|
||||
CONFIG_PINCTRL=y
|
||||
CONFIG_PINCTRL_BAYTRAIL=y
|
||||
|
||||
# CONFIG_INTEL_POWERCLAMP is not set
|
||||
CONFIG_X86_PKG_TEMP_THERMAL=m
|
||||
|
12
kernel.spec
12
kernel.spec
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
||||
# The rc snapshot level
|
||||
%define rcrev 3
|
||||
# The git snapshot level
|
||||
%define gitrev 1
|
||||
%define gitrev 2
|
||||
# Set rpm version accordingly
|
||||
%define rpmversion 3.%{upstream_sublevel}.0
|
||||
%endif
|
||||
@ -735,9 +735,6 @@ Patch25107: ntp-Make-periodic-RTC-update-more-reliable.patch
|
||||
#rhbz 1010431
|
||||
Patch25108: Revert-rt2x00pci-Use-PCI-MSIs-whenever-possible.patch
|
||||
|
||||
#rhbz 1008323
|
||||
Patch25109: skge-fix-invalid-value-passed-to-pci_unmap_sigle.patch
|
||||
|
||||
#rhbz 902012
|
||||
Patch25114: elevator-Fix-a-race-in-elevator-switching-and-md.patch
|
||||
Patch25115: elevator-acquire-q-sysfs_lock-in-elevator_change.patch
|
||||
@ -1441,9 +1438,6 @@ ApplyPatch ntp-Make-periodic-RTC-update-more-reliable.patch
|
||||
#rhbz 1010431
|
||||
ApplyPatch Revert-rt2x00pci-Use-PCI-MSIs-whenever-possible.patch
|
||||
|
||||
#rhbz 1008323
|
||||
ApplyPatch skge-fix-invalid-value-passed-to-pci_unmap_sigle.patch
|
||||
|
||||
#rhbz 902012
|
||||
ApplyPatch elevator-Fix-a-race-in-elevator-switching-and-md.patch
|
||||
ApplyPatch elevator-acquire-q-sysfs_lock-in-elevator_change.patch
|
||||
@ -2255,6 +2249,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Wed Oct 02 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.12.0-0.rc3.git2.1
|
||||
- Linux v3.12-rc3-186-gc31eeac
|
||||
- Enable options for Intel Low Power Subsystem Support
|
||||
|
||||
* Tue Oct 01 2013 Josh Boyer <jwboyer@fedoraproject.org> - 3.12.0-0.rc3.git1.1
|
||||
- Linux v3.12-rc3-65-gf927318
|
||||
- Reenable debugging options.
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 3361dc9538832a2a9150a8c722374ca844bf8dc8 Mon Sep 17 00:00:00 2001
|
||||
From: Mikulas Patocka <mpatocka@redhat.com>
|
||||
Date: Fri, 20 Sep 2013 17:53:22 +0000
|
||||
Subject: skge: fix invalid value passed to pci_unmap_sigle
|
||||
|
||||
In my patch c194992cbe71c20bb3623a566af8d11b0bfaa721 ("skge: fix
|
||||
broken driver") I didn't fix the skge bug correctly. The value of the
|
||||
new mapping (not old) was passed to pci_unmap_single.
|
||||
|
||||
If we enable CONFIG_DMA_API_DEBUG, it results in this warning:
|
||||
WARNING: CPU: 0 PID: 0 at lib/dma-debug.c:986 check_sync+0x4c4/0x580()
|
||||
skge 0000:02:07.0: DMA-API: device driver tries to sync DMA memory it has
|
||||
not allocated [device address=0x000000023a0096c0] [size=1536 bytes]
|
||||
|
||||
This patch makes the skge driver pass the correct value to
|
||||
pci_unmap_single and fixes the warning. It copies the old descriptor to
|
||||
on-stack variable "ee" and unmaps it if mapping of the new descriptor
|
||||
succeeded.
|
||||
|
||||
This patch should be backported to 3.11-stable.
|
||||
|
||||
Signed-off-by: Mikulas Patocka <mpatocka@redhat.com>
|
||||
Reported-by: Francois Romieu <romieu@fr.zoreil.com>
|
||||
Tested-by: Mikulas Patocka <mpatocka@redhat.com>
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
---
|
||||
diff --git a/drivers/net/ethernet/marvell/skge.c b/drivers/net/ethernet/marvell/skge.c
|
||||
index 1a9c4f6..ecc7f7b 100644
|
||||
--- a/drivers/net/ethernet/marvell/skge.c
|
||||
+++ b/drivers/net/ethernet/marvell/skge.c
|
||||
@@ -3086,13 +3086,16 @@ static struct sk_buff *skge_rx_get(struct net_device *dev,
|
||||
PCI_DMA_FROMDEVICE);
|
||||
skge_rx_reuse(e, skge->rx_buf_size);
|
||||
} else {
|
||||
+ struct skge_element ee;
|
||||
struct sk_buff *nskb;
|
||||
|
||||
nskb = netdev_alloc_skb_ip_align(dev, skge->rx_buf_size);
|
||||
if (!nskb)
|
||||
goto resubmit;
|
||||
|
||||
- skb = e->skb;
|
||||
+ ee = *e;
|
||||
+
|
||||
+ skb = ee.skb;
|
||||
prefetch(skb->data);
|
||||
|
||||
if (skge_rx_setup(skge, e, nskb, skge->rx_buf_size) < 0) {
|
||||
@@ -3101,8 +3104,8 @@ static struct sk_buff *skge_rx_get(struct net_device *dev,
|
||||
}
|
||||
|
||||
pci_unmap_single(skge->hw->pdev,
|
||||
- dma_unmap_addr(e, mapaddr),
|
||||
- dma_unmap_len(e, maplen),
|
||||
+ dma_unmap_addr(&ee, mapaddr),
|
||||
+ dma_unmap_len(&ee, maplen),
|
||||
PCI_DMA_FROMDEVICE);
|
||||
}
|
||||
|
||||
--
|
||||
cgit v0.9.2
|
Loading…
Reference in New Issue
Block a user