Fix build against rawhide glibc and add BR for gettext
This commit is contained in:
parent
69fc02b694
commit
5106c63573
35
fix-perf-build.patch
Normal file
35
fix-perf-build.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 602d6a279939ec30fc7f3ae9d10e3640854f77b2 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@redhat.com>
|
||||
Date: Thu, 18 Aug 2011 07:24:25 -0400
|
||||
Subject: [PATCH] Fix perf build against newer glibc
|
||||
|
||||
Upstream glibc commit 295e904 added a definition for __attribute_const__ to
|
||||
cdefs.h. This causes the following error when building perf:
|
||||
|
||||
util/include/linux/compiler.h:8:0: error: "__attribute_const__" redefined [-Werror]
|
||||
/usr/include/sys/cdefs.h:226:0: note: this is the location of the previous definition
|
||||
|
||||
Wrap __attribute_const__ in #ifndef as we do for __always_inline.
|
||||
|
||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||
---
|
||||
tools/perf/util/include/linux/compiler.h | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/tools/perf/util/include/linux/compiler.h b/tools/perf/util/include/linux/compiler.h
|
||||
index 791f9dd..547628e 100644
|
||||
--- a/tools/perf/util/include/linux/compiler.h
|
||||
+++ b/tools/perf/util/include/linux/compiler.h
|
||||
@@ -5,7 +5,9 @@
|
||||
#define __always_inline inline
|
||||
#endif
|
||||
#define __user
|
||||
+#ifndef __attribute_const__
|
||||
#define __attribute_const__
|
||||
+#endif
|
||||
|
||||
#define __used __attribute__((__unused__))
|
||||
|
||||
--
|
||||
1.7.6
|
||||
|
11
kernel.spec
11
kernel.spec
@ -51,7 +51,7 @@ Summary: The Linux kernel
|
||||
# For non-released -rc kernels, this will be prepended with "0.", so
|
||||
# for example a 3 here will become 0.3
|
||||
#
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
%global fedora_build %{baserelease}
|
||||
|
||||
# base_sublevel is the kernel version we're starting with and patching
|
||||
@ -535,7 +535,7 @@ BuildRequires: xmlto, asciidoc
|
||||
BuildRequires: sparse >= 0.4.1
|
||||
%endif
|
||||
%if %{with_tools}
|
||||
BuildRequires: elfutils-devel zlib-devel binutils-devel newt-devel python-devel perl(ExtUtils::Embed) pciutils-devel
|
||||
BuildRequires: elfutils-devel zlib-devel binutils-devel newt-devel python-devel perl(ExtUtils::Embed) pciutils-devel gettext
|
||||
%endif
|
||||
BuildConflicts: rhbuildsys(DiskFree) < 500Mb
|
||||
|
||||
@ -718,6 +718,7 @@ Patch12024: epoll-fix-spurious-lockdep-warnings.patch
|
||||
Patch12025: rcu-avoid-just-onlined-cpu-resched.patch
|
||||
Patch12026: block-stray-block-put-after-teardown.patch
|
||||
Patch12027: usb-add-quirk-for-logitech-webcams.patch
|
||||
Patch12028: fix-perf-build.patch
|
||||
|
||||
|
||||
# Runtime power management
|
||||
@ -1335,6 +1336,8 @@ ApplyPatch rcu-avoid-just-onlined-cpu-resched.patch
|
||||
ApplyPatch block-stray-block-put-after-teardown.patch
|
||||
ApplyPatch usb-add-quirk-for-logitech-webcams.patch
|
||||
|
||||
ApplyPatch fix-perf-build.patch
|
||||
|
||||
# Runtime PM
|
||||
#ApplyPatch linux-2.6-usb-pci-autosuspend.patch
|
||||
### Broken by implicit notify support & ACPICA rebase
|
||||
@ -2059,6 +2062,10 @@ fi
|
||||
# ||----w |
|
||||
# || ||
|
||||
%changelog
|
||||
* Thu Aug 18 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add patch to fix perf build against rawhide glibc
|
||||
- Add BR for gettext for cpupower translations
|
||||
|
||||
* Wed Aug 17 2011 Josh Boyer <jwboyer@redhat.com>
|
||||
- Linux 3.1-rc2-git4
|
||||
- Create the kernel-tools subpackages based on a start by davej
|
||||
|
Loading…
Reference in New Issue
Block a user