Linux v3.9-2154-gec25e24
This commit is contained in:
parent
4cec579113
commit
4894d6ca88
@ -1,190 +0,0 @@
|
|||||||
From 54a419668b0f27b7982807fb2376d237e0a0ce05 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alan Stern <stern@rowland.harvard.edu>
|
|
||||||
Date: Tue, 12 Mar 2013 10:44:39 +0000
|
|
||||||
Subject: USB: EHCI: split ehci-omap out to a separate driver
|
|
||||||
|
|
||||||
This patch (as1645) converts ehci-omap over to the new "ehci-hcd is a
|
|
||||||
library" approach, so that it can coexist peacefully with other EHCI
|
|
||||||
platform drivers and can make use of the private area allocated at
|
|
||||||
the end of struct ehci_hcd.
|
|
||||||
|
|
||||||
Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
|
|
||||||
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
||||||
---
|
|
||||||
diff --git a/drivers/usb/host/Kconfig b/drivers/usb/host/Kconfig
|
|
||||||
index c59a112..62f4e9a 100644
|
|
||||||
--- a/drivers/usb/host/Kconfig
|
|
||||||
+++ b/drivers/usb/host/Kconfig
|
|
||||||
@@ -155,7 +155,7 @@ config USB_EHCI_MXC
|
|
||||||
Variation of ARC USB block used in some Freescale chips.
|
|
||||||
|
|
||||||
config USB_EHCI_HCD_OMAP
|
|
||||||
- bool "EHCI support for OMAP3 and later chips"
|
|
||||||
+ tristate "EHCI support for OMAP3 and later chips"
|
|
||||||
depends on USB_EHCI_HCD && ARCH_OMAP
|
|
||||||
default y
|
|
||||||
---help---
|
|
||||||
diff --git a/drivers/usb/host/Makefile b/drivers/usb/host/Makefile
|
|
||||||
index 001fbff..56de410 100644
|
|
||||||
--- a/drivers/usb/host/Makefile
|
|
||||||
+++ b/drivers/usb/host/Makefile
|
|
||||||
@@ -27,6 +27,7 @@ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
|
|
||||||
obj-$(CONFIG_USB_EHCI_PCI) += ehci-pci.o
|
|
||||||
obj-$(CONFIG_USB_EHCI_HCD_PLATFORM) += ehci-platform.o
|
|
||||||
obj-$(CONFIG_USB_EHCI_MXC) += ehci-mxc.o
|
|
||||||
+obj-$(CONFIG_USB_EHCI_HCD_OMAP) += ehci-omap.o
|
|
||||||
|
|
||||||
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
|
|
||||||
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
|
|
||||||
diff --git a/drivers/usb/host/ehci-hcd.c b/drivers/usb/host/ehci-hcd.c
|
|
||||||
index b416a3f..303b022 100644
|
|
||||||
--- a/drivers/usb/host/ehci-hcd.c
|
|
||||||
+++ b/drivers/usb/host/ehci-hcd.c
|
|
||||||
@@ -1252,11 +1252,6 @@ MODULE_LICENSE ("GPL");
|
|
||||||
#define PLATFORM_DRIVER ehci_hcd_sh_driver
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifdef CONFIG_USB_EHCI_HCD_OMAP
|
|
||||||
-#include "ehci-omap.c"
|
|
||||||
-#define PLATFORM_DRIVER ehci_hcd_omap_driver
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#ifdef CONFIG_PPC_PS3
|
|
||||||
#include "ehci-ps3.c"
|
|
||||||
#define PS3_SYSTEM_BUS_DRIVER ps3_ehci_driver
|
|
||||||
@@ -1346,6 +1341,7 @@ MODULE_LICENSE ("GPL");
|
|
||||||
!IS_ENABLED(CONFIG_USB_EHCI_HCD_PLATFORM) && \
|
|
||||||
!IS_ENABLED(CONFIG_USB_CHIPIDEA_HOST) && \
|
|
||||||
!IS_ENABLED(CONFIG_USB_EHCI_MXC) && \
|
|
||||||
+ !IS_ENABLED(CONFIG_USB_EHCI_HCD_OMAP) && \
|
|
||||||
!defined(PLATFORM_DRIVER) && \
|
|
||||||
!defined(PS3_SYSTEM_BUS_DRIVER) && \
|
|
||||||
!defined(OF_PLATFORM_DRIVER) && \
|
|
||||||
diff --git a/drivers/usb/host/ehci-omap.c b/drivers/usb/host/ehci-omap.c
|
|
||||||
index 0555ee4..fa66757 100644
|
|
||||||
--- a/drivers/usb/host/ehci-omap.c
|
|
||||||
+++ b/drivers/usb/host/ehci-omap.c
|
|
||||||
@@ -36,6 +36,9 @@
|
|
||||||
* - convert to use hwmod and runtime PM
|
|
||||||
*/
|
|
||||||
|
|
||||||
+#include <linux/kernel.h>
|
|
||||||
+#include <linux/module.h>
|
|
||||||
+#include <linux/io.h>
|
|
||||||
#include <linux/platform_device.h>
|
|
||||||
#include <linux/slab.h>
|
|
||||||
#include <linux/usb/ulpi.h>
|
|
||||||
@@ -43,6 +46,10 @@
|
|
||||||
#include <linux/pm_runtime.h>
|
|
||||||
#include <linux/gpio.h>
|
|
||||||
#include <linux/clk.h>
|
|
||||||
+#include <linux/usb.h>
|
|
||||||
+#include <linux/usb/hcd.h>
|
|
||||||
+
|
|
||||||
+#include "ehci.h"
|
|
||||||
|
|
||||||
#include <linux/platform_data/usb-omap.h>
|
|
||||||
|
|
||||||
@@ -57,9 +64,11 @@
|
|
||||||
#define EHCI_INSNREG05_ULPI_EXTREGADD_SHIFT 8
|
|
||||||
#define EHCI_INSNREG05_ULPI_WRDATA_SHIFT 0
|
|
||||||
|
|
||||||
-/*-------------------------------------------------------------------------*/
|
|
||||||
+#define DRIVER_DESC "OMAP-EHCI Host Controller driver"
|
|
||||||
|
|
||||||
-static const struct hc_driver ehci_omap_hc_driver;
|
|
||||||
+static const char hcd_name[] = "ehci-omap";
|
|
||||||
+
|
|
||||||
+/*-------------------------------------------------------------------------*/
|
|
||||||
|
|
||||||
|
|
||||||
static inline void ehci_write(void __iomem *base, u32 reg, u32 val)
|
|
||||||
@@ -166,6 +175,12 @@ static void disable_put_regulator(
|
|
||||||
/* configure so an HC device and id are always provided */
|
|
||||||
/* always called with process context; sleeping is OK */
|
|
||||||
|
|
||||||
+static struct hc_driver __read_mostly ehci_omap_hc_driver;
|
|
||||||
+
|
|
||||||
+static const struct ehci_driver_overrides ehci_omap_overrides __initdata = {
|
|
||||||
+ .reset = omap_ehci_init,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
/**
|
|
||||||
* ehci_hcd_omap_probe - initialize TI-based HCDs
|
|
||||||
*
|
|
||||||
@@ -315,56 +330,33 @@ static struct platform_driver ehci_hcd_omap_driver = {
|
|
||||||
/*.suspend = ehci_hcd_omap_suspend, */
|
|
||||||
/*.resume = ehci_hcd_omap_resume, */
|
|
||||||
.driver = {
|
|
||||||
- .name = "ehci-omap",
|
|
||||||
+ .name = hcd_name,
|
|
||||||
}
|
|
||||||
};
|
|
||||||
|
|
||||||
/*-------------------------------------------------------------------------*/
|
|
||||||
|
|
||||||
-static const struct hc_driver ehci_omap_hc_driver = {
|
|
||||||
- .description = hcd_name,
|
|
||||||
- .product_desc = "OMAP-EHCI Host Controller",
|
|
||||||
- .hcd_priv_size = sizeof(struct ehci_hcd),
|
|
||||||
-
|
|
||||||
- /*
|
|
||||||
- * generic hardware linkage
|
|
||||||
- */
|
|
||||||
- .irq = ehci_irq,
|
|
||||||
- .flags = HCD_MEMORY | HCD_USB2,
|
|
||||||
-
|
|
||||||
- /*
|
|
||||||
- * basic lifecycle operations
|
|
||||||
- */
|
|
||||||
- .reset = omap_ehci_init,
|
|
||||||
- .start = ehci_run,
|
|
||||||
- .stop = ehci_stop,
|
|
||||||
- .shutdown = ehci_shutdown,
|
|
||||||
-
|
|
||||||
- /*
|
|
||||||
- * managing i/o requests and associated device resources
|
|
||||||
- */
|
|
||||||
- .urb_enqueue = ehci_urb_enqueue,
|
|
||||||
- .urb_dequeue = ehci_urb_dequeue,
|
|
||||||
- .endpoint_disable = ehci_endpoint_disable,
|
|
||||||
- .endpoint_reset = ehci_endpoint_reset,
|
|
||||||
+static int __init ehci_omap_init(void)
|
|
||||||
+{
|
|
||||||
+ if (usb_disabled())
|
|
||||||
+ return -ENODEV;
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * scheduling support
|
|
||||||
- */
|
|
||||||
- .get_frame_number = ehci_get_frame,
|
|
||||||
+ pr_info("%s: " DRIVER_DESC "\n", hcd_name);
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * root hub support
|
|
||||||
- */
|
|
||||||
- .hub_status_data = ehci_hub_status_data,
|
|
||||||
- .hub_control = ehci_hub_control,
|
|
||||||
- .bus_suspend = ehci_bus_suspend,
|
|
||||||
- .bus_resume = ehci_bus_resume,
|
|
||||||
+ ehci_init_driver(&ehci_omap_hc_driver, &ehci_omap_overrides);
|
|
||||||
+ return platform_driver_register(&ehci_hcd_omap_driver);
|
|
||||||
+}
|
|
||||||
+module_init(ehci_omap_init);
|
|
||||||
|
|
||||||
- .clear_tt_buffer_complete = ehci_clear_tt_buffer_complete,
|
|
||||||
-};
|
|
||||||
+static void __exit ehci_omap_cleanup(void)
|
|
||||||
+{
|
|
||||||
+ platform_driver_unregister(&ehci_hcd_omap_driver);
|
|
||||||
+}
|
|
||||||
+module_exit(ehci_omap_cleanup);
|
|
||||||
|
|
||||||
MODULE_ALIAS("platform:ehci-omap");
|
|
||||||
MODULE_AUTHOR("Texas Instruments, Inc.");
|
|
||||||
MODULE_AUTHOR("Felipe Balbi <felipe.balbi@nokia.com>");
|
|
||||||
|
|
||||||
+MODULE_DESCRIPTION(DRIVER_DESC);
|
|
||||||
+MODULE_LICENSE("GPL");
|
|
||||||
--
|
|
||||||
cgit v0.9.1
|
|
@ -180,6 +180,7 @@ CONFIG_SMC91X=m
|
|||||||
CONFIG_SMC911X=m
|
CONFIG_SMC911X=m
|
||||||
CONFIG_SMSC911X=m
|
CONFIG_SMSC911X=m
|
||||||
CONFIG_USB_ISP1760_HCD=m
|
CONFIG_USB_ISP1760_HCD=m
|
||||||
|
# CONFIG_USB_EHCI_HCD_ORION is not set
|
||||||
|
|
||||||
# Multifunction Devices
|
# Multifunction Devices
|
||||||
CONFIG_MFD_SYSCON=y
|
CONFIG_MFD_SYSCON=y
|
||||||
|
@ -2130,6 +2130,7 @@ CONFIG_N_HDLC=m
|
|||||||
CONFIG_N_GSM=m
|
CONFIG_N_GSM=m
|
||||||
# CONFIG_TRACE_SINK is not set
|
# CONFIG_TRACE_SINK is not set
|
||||||
# CONFIG_STALDRV is not set
|
# CONFIG_STALDRV is not set
|
||||||
|
# CONFIG_DUMMY_IRQ is not set
|
||||||
# CONFIG_IBM_ASM is not set
|
# CONFIG_IBM_ASM is not set
|
||||||
CONFIG_TIFM_CORE=m
|
CONFIG_TIFM_CORE=m
|
||||||
CONFIG_TIFM_7XX1=m
|
CONFIG_TIFM_7XX1=m
|
||||||
@ -2411,6 +2412,7 @@ CONFIG_W1_MASTER_DS1WM=m
|
|||||||
CONFIG_W1_SLAVE_THERM=m
|
CONFIG_W1_SLAVE_THERM=m
|
||||||
CONFIG_W1_SLAVE_SMEM=m
|
CONFIG_W1_SLAVE_SMEM=m
|
||||||
CONFIG_W1_SLAVE_DS2408=m
|
CONFIG_W1_SLAVE_DS2408=m
|
||||||
|
# CONFIG_W1_SLAVE_DS2408_READBACK is not set
|
||||||
CONFIG_W1_SLAVE_DS2413=m
|
CONFIG_W1_SLAVE_DS2413=m
|
||||||
CONFIG_W1_SLAVE_DS2423=m
|
CONFIG_W1_SLAVE_DS2423=m
|
||||||
CONFIG_W1_SLAVE_DS2431=m
|
CONFIG_W1_SLAVE_DS2431=m
|
||||||
@ -3146,6 +3148,7 @@ CONFIG_USB_SUPPORT=y
|
|||||||
# Deprecated.
|
# Deprecated.
|
||||||
# CONFIG_USB_DEVICEFS is not set
|
# CONFIG_USB_DEVICEFS is not set
|
||||||
|
|
||||||
|
CONFIG_USB_DEFAULT_PERSIST=y
|
||||||
# CONFIG_USB_DYNAMIC_MINORS is not set
|
# CONFIG_USB_DYNAMIC_MINORS is not set
|
||||||
CONFIG_USB_SUSPEND=y
|
CONFIG_USB_SUSPEND=y
|
||||||
|
|
||||||
@ -3453,6 +3456,7 @@ CONFIG_USB_SERIAL_MCT_U232=m
|
|||||||
CONFIG_USB_SERIAL_MOS7720=m
|
CONFIG_USB_SERIAL_MOS7720=m
|
||||||
CONFIG_USB_SERIAL_MOS7715_PARPORT=y
|
CONFIG_USB_SERIAL_MOS7715_PARPORT=y
|
||||||
# CONFIG_USB_SERIAL_ZIO is not set
|
# CONFIG_USB_SERIAL_ZIO is not set
|
||||||
|
# CONFIG_USB_SERIAL_WISHBONE is not set
|
||||||
# CONFIG_USB_SERIAL_ZTE is not set
|
# CONFIG_USB_SERIAL_ZTE is not set
|
||||||
CONFIG_USB_SERIAL_MOS7840=m
|
CONFIG_USB_SERIAL_MOS7840=m
|
||||||
CONFIG_USB_SERIAL_MOTOROLA=m
|
CONFIG_USB_SERIAL_MOTOROLA=m
|
||||||
@ -3495,9 +3499,16 @@ CONFIG_USB_ADUTUX=m
|
|||||||
CONFIG_USB_SEVSEG=m
|
CONFIG_USB_SEVSEG=m
|
||||||
CONFIG_USB_ALI_M5632=y
|
CONFIG_USB_ALI_M5632=y
|
||||||
CONFIG_USB_APPLEDISPLAY=m
|
CONFIG_USB_APPLEDISPLAY=m
|
||||||
|
|
||||||
|
# Physical Layer USB driver
|
||||||
|
CONFIG_USB_PHY=y
|
||||||
|
|
||||||
# CONFIG_OMAP_USB2 is not set
|
# CONFIG_OMAP_USB2 is not set
|
||||||
# CONFIG_OMAP_USB3 is not set
|
# CONFIG_OMAP_USB3 is not set
|
||||||
# CONFIG_OMAP_CONTROL_USB is not set
|
# CONFIG_OMAP_CONTROL_USB is not set
|
||||||
|
# CONFIG_SAMSUNG_USBPHY is not set
|
||||||
|
# CONFIG_SAMSUNG_USB2PHY is not set
|
||||||
|
# CONFIG_SAMSUNG_USB3PHY is not set
|
||||||
CONFIG_USB_RCAR_PHY=m
|
CONFIG_USB_RCAR_PHY=m
|
||||||
CONFIG_USB_ATM=m
|
CONFIG_USB_ATM=m
|
||||||
CONFIG_USB_CXACRU=m
|
CONFIG_USB_CXACRU=m
|
||||||
@ -3545,6 +3556,8 @@ CONFIG_USB_UEAGLEATM=m
|
|||||||
CONFIG_USB_XUSBATM=m
|
CONFIG_USB_XUSBATM=m
|
||||||
CONFIG_USB_ZERO=m
|
CONFIG_USB_ZERO=m
|
||||||
|
|
||||||
|
# CONFIG_USB_DWC2 is not set
|
||||||
|
|
||||||
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
|
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
|
||||||
|
|
||||||
# CONFIG_USB_ISP1301 is not set
|
# CONFIG_USB_ISP1301 is not set
|
||||||
@ -4006,6 +4019,8 @@ CONFIG_AUDITSYSCALL=y
|
|||||||
# http://lists.fedoraproject.org/pipermail/kernel/2013-February/004125.html
|
# http://lists.fedoraproject.org/pipermail/kernel/2013-February/004125.html
|
||||||
CONFIG_AUDIT_LOGINUID_IMMUTABLE=y
|
CONFIG_AUDIT_LOGINUID_IMMUTABLE=y
|
||||||
|
|
||||||
|
# CONFIG_SSBI is not set
|
||||||
|
|
||||||
#
|
#
|
||||||
# Cryptographic options
|
# Cryptographic options
|
||||||
#
|
#
|
||||||
|
@ -95,7 +95,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 2
|
%define gitrev 3
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -708,7 +708,6 @@ Patch21001: arm-of-dma.patch
|
|||||||
Patch21002: arm-lpae-ax88796.patch
|
Patch21002: arm-lpae-ax88796.patch
|
||||||
|
|
||||||
# ARM omap
|
# ARM omap
|
||||||
Patch21003: arm-omap-ehci-fix.patch
|
|
||||||
|
|
||||||
# ARM tegra
|
# ARM tegra
|
||||||
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
Patch21005: arm-tegra-usb-no-reset-linux33.patch
|
||||||
@ -1313,7 +1312,6 @@ ApplyPatch debug-bad-pte-modules.patch
|
|||||||
ApplyPatch arm-export-read_current_timer.patch
|
ApplyPatch arm-export-read_current_timer.patch
|
||||||
ApplyPatch arm-of-dma.patch
|
ApplyPatch arm-of-dma.patch
|
||||||
ApplyPatch arm-lpae-ax88796.patch
|
ApplyPatch arm-lpae-ax88796.patch
|
||||||
ApplyPatch arm-omap-ehci-fix.patch
|
|
||||||
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
|
||||||
ApplyPatch arm-tegra-fixclk.patch
|
ApplyPatch arm-tegra-fixclk.patch
|
||||||
|
|
||||||
@ -2292,6 +2290,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 29 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git3.1
|
||||||
|
- Linux v3.9-2154-gec25e24
|
||||||
|
|
||||||
* Mon Apr 29 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git2.1
|
* Mon Apr 29 2013 Josh Boyer <jwboyer@redhat.com> - 3.10.0-0.rc0.git2.1
|
||||||
- Linux v3.9-332-g92ddcf4
|
- Linux v3.9-332-g92ddcf4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user